Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
lanserver 637 tcp lanserver Chris Larsson Chris Larsson
lanserver 637 udp lanserver Chris Larsson Chris Larsson
islc 1637 tcp ISP shared local data control
islc 1637 udp ISP shared local data control
pptp 1723 tcp pptp Ken Crocker Ken Crocker 2021-09-21 RFC 2637
pptp 1723 udp pptp Ken Crocker Ken Crocker 2021-09-21 RFC 2637
imdocsvc 2637 tcp Import Document Service Zia Bhatti Zia Bhatti
imdocsvc 2637 udp Import Document Service Zia Bhatti Zia Bhatti
scservp 3637 tcp Customer Service Port Jonathan A. Zdziarski Jonathan A. Zdziarski 2002-11
scservp 3637 udp Customer Service Port Jonathan A. Zdziarski Jonathan A. Zdziarski 2002-11
cssc 5637 tcp Symantec CSSC Amol P Tambe Amol P Tambe 2011-02-02
5637 udp Reserved
metaedit-se 6370 tcp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
metaedit-se 6370 udp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
6371-6378 Unassigned
redis 6379 tcp An advanced key-value cache and store Salvatore Sanfilippo Itamar Haber 2015-04-23
6379 udp Reserved
6637-6639 Unassigned
32637-32766 Unassigned
38473-38637 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Amol P Tambe amol_tambe&symantec.com 2011-02-02
Chris Larsson clarsson&vnet.ibm.com
Itamar Haber Salvatore Sanfilippo itamar&redislabs.com 2015-04-23
Jonathan A. Zdziarski johathan&networkdweebs.com 2002-11
Ken Crocker kcrocker&microsoft.com
Salvatore Sanfilippo antirez&gmail.com 2015-04-23
Steven Kelly stevek&metacase.com 2007-11-12
Zia Bhatti zia&netright.com