Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
daytime 13 tcp Daytime Jon Postel Jon Postel RFC 867
daytime 13 udp Daytime Jon Postel Jon Postel RFC 867
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
bootps 67 udp Bootstrap Protocol Server
namp 167 tcp NAMP Marty Schoffstahl Marty Schoffstahl
namp 167 udp NAMP Marty Schoffstahl Marty Schoffstahl
td-service 267 tcp Tobit David Service Layer
td-service 267 udp Tobit David Service Layer
mortgageware 367 tcp MortgageWare Ole Hellevik Ole Hellevik
mortgageware 367 udp MortgageWare Ole Hellevik Ole Hellevik
mylex-mapd 467 tcp mylex-mapd Gary Lewis Gary Lewis
mylex-mapd 467 udp mylex-mapd Gary Lewis Gary Lewis
banyan-rpc 567 tcp banyan-rpc Tom Lemaire Tom Lemaire
banyan-rpc 567 udp banyan-rpc Tom Lemaire Tom Lemaire
idxp 603 tcp IDXP RFC 4767
idxp 603 udp IDXP RFC 4767
disclose 667 tcp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
disclose 667 udp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
vacdsm-sws 670 tcp VACDSM-SWS
vacdsm-sws 670 udp VACDSM-SWS
vacdsm-app 671 tcp VACDSM-APP
vacdsm-app 671 udp VACDSM-APP
vpps-qua 672 tcp VPPS-QUA
vpps-qua 672 udp VPPS-QUA
cimplex 673 tcp CIMPLEX Ulysses G. Smith Jr. Ulysses G. Smith Jr.
cimplex 673 udp CIMPLEX Ulysses G. Smith Jr. Ulysses G. Smith Jr.
acap 674 tcp ACAP Chris Newman Chris Newman 2010-10-15
acap 674 udp ACAP Chris Newman Chris Newman 2010-10-15
dctp 675 tcp DCTP Andre Kramer Andre Kramer
dctp 675 udp DCTP Andre Kramer Andre Kramer
vpps-via 676 tcp VPPS Via Ulysses G. Smith Jr. Ulysses G. Smith Jr.
vpps-via 676 udp VPPS Via Ulysses G. Smith Jr. Ulysses G. Smith Jr.
vpp 677 tcp Virtual Presence Protocol Klaus Wolf Klaus Wolf
vpp 677 udp Virtual Presence Protocol Klaus Wolf Klaus Wolf
ggf-ncp 678 tcp GNU Generation Foundation NCP Noah Paul Noah Paul
ggf-ncp 678 udp GNU Generation Foundation NCP Noah Paul Noah Paul
mrm 679 tcp MRM Liming Wei Liming Wei
mrm 679 udp MRM Liming Wei Liming Wei
phonebook 767 tcp phone Josyula R. Rao Josyula R. Rao
phonebook 767 udp phone Josyula R. Rao Josyula R. Rao
6a44 1027 udp IPv6 Behind NAT44 CPEs IESG IETF Chair 2012-08-02 RFC 6751
instl-boots 1067 tcp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 tcp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
instl-boots 1067 udp Installation Bootstrap Proto. Serv.

IANA assigned this well-formed service name as a replacement for "instl_boots".
instl_boots 1067 udp Installation Bootstrap Proto. Serv. This entry is an alias to "instl-boots". This entry is now historic, not usable for use with many common service discovery mechanisms.
sacred 1118 tcp SACRED RFC 3767
sacred 1118 udp SACRED RFC 3767
cisco-ipsla 1167 tcp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 udp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 sctp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
epc 1267 tcp eTrust Policy Compliance Aaron Stein Aaron Stein
epc 1267 udp eTrust Policy Compliance Aaron Stein Aaron Stein
dcs 1367 tcp DCS Stefan Siebert Stefan Siebert
dcs 1367 udp DCS Stefan Siebert Stefan Siebert
csdmbase 1467 tcp CSDMBASE
csdmbase 1467 udp CSDMBASE
jlicelmd 1567 tcp jlicelmd Christian Schormann Christian Schormann
jlicelmd 1567 udp jlicelmd Christian Schormann Christian Schormann
netview-aix-7 1667 tcp netview-aix-7
netview-aix-7 1667 udp netview-aix-7
netview-aix-10 1670 tcp netview-aix-10
netview-aix-10 1670 udp netview-aix-10
netview-aix-11 1671 tcp netview-aix-11
netview-aix-11 1671 udp netview-aix-11
netview-aix-12 1672 tcp netview-aix-12 Martha Crisson Martha Crisson
netview-aix-12 1672 udp netview-aix-12 Martha Crisson Martha Crisson
proshare-mc-1 1673 tcp Intel Proshare Multicast
proshare-mc-1 1673 udp Intel Proshare Multicast
proshare-mc-2 1674 tcp Intel Proshare Multicast Mark Lewis Mark Lewis
proshare-mc-2 1674 udp Intel Proshare Multicast Mark Lewis Mark Lewis
pdp 1675 tcp Pacific Data Products Gary Morton Gary Morton
pdp 1675 udp Pacific Data Products Gary Morton Gary Morton
netcomm1 1676 tcp netcomm1
netcomm2 1676 udp netcomm2 Bulent Kasman Bulent Kasman
groupwise 1677 tcp groupwise Brent Bradshaw Brent Bradshaw
groupwise 1677 udp groupwise Brent Bradshaw Brent Bradshaw
prolink 1678 tcp prolink Brian Abramson Brian Abramson
prolink 1678 udp prolink Brian Abramson Brian Abramson
darcorp-lm 1679 tcp darcorp-lm DARcorp DARcorp
darcorp-lm 1679 udp darcorp-lm DARcorp DARcorp
cft-6 1767 tcp cft-6 Martine Marchand Martine Marchand
cft-6 1767 udp cft-6 Martine Marchand Martine Marchand
udrive 1867 tcp UDRIVE Robby Walker Robby Walker
udrive 1867 udp UDRIVE Robby Walker Robby Walker
sns-quote 1967 tcp SNS Quote Robert Ellman Robert Ellman
sns-quote 1967 udp SNS Quote Robert Ellman Robert Ellman
dlswpn 2067 tcp Data Link Switch Write Port Number Amir Peless Amir Peless
dlswpn 2067 udp Data Link Switch Write Port Number Amir Peless Amir Peless
raw-serial 2167 tcp Raw Async Serial Link Benjamin Green Benjamin Green
raw-serial 2167 udp Raw Async Serial Link Benjamin Green Benjamin Green
ontobroker 2267 tcp OntoBroker Dr. Michael Erdmann Dr. Michael Erdmann 2004-12
ontobroker 2267 udp OntoBroker Dr. Michael Erdmann Dr. Michael Erdmann 2004-12
service-ctrl 2367 tcp Service Control Humberto Sanchez Humberto Sanchez
service-ctrl 2367 udp Service Control Humberto Sanchez Humberto Sanchez
high-criteria 2467 tcp High Criteria Konstantin Iavid Konstantin Iavid
high-criteria 2467 udp High Criteria Konstantin Iavid Konstantin Iavid
clp 2567 tcp Cisco Line Protocol Susan Hinrichs Susan Hinrichs
clp 2567 udp Cisco Line Protocol Susan Hinrichs Susan Hinrichs
alarm-clock-s 2667 tcp Alarm Clock Server
alarm-clock-s 2667 udp Alarm Clock Server

Contact Information

Name Organization Contact URI Last Updated
Aaron Stein aaron.stein&ca.com
Amir Peless amirp&radware.co.il
Andre Kramer Andre.Kramer&ansa.co.uk
Benjamin Green ben&lh.co.nz
Bill Croft Croft&sumex-aim.stanford.edu
Brent Bradshaw bbradshaw&novell.com
Brian Abramson brianab&soul.tv.tek.com
Bulent Kasman BKasman&symantec.com
Chris Newman chris.newman&oracle.com 2017-01-26
Christian Schormann 100410.3063&compuserve.com
DARcorp&aol.com
Dr. Michael Erdmann erdmann&ontoprise.de 2004-12
Emmanuel Tychon etychon&cisco.com 2006-03
Gary Lewis GaryL&hq.mylex.com
Gary Morton mortong&pacdata.com
Humberto Sanchez Humberto_Sanchez&hp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Dixon jim&lambda.com
Jon Postel postel&isi.edu
Josyula R. Rao jrrao&watson.ibm.com
Klaus Wolf wolf&cobrow.com
Konstantin Iavid kiavid&highcriteria.com
Liming Wei lwei&cisco.com
Mark Lewis Mark_Lewis&ccm.jf.intel.com
Martha Crisson CRISSON&ralvm12.vnet.ibm.com
Martine Marchand tel:+16-1-46-59-24-84
Marty Schoffstahl schoff&nisc.nyser.net
Noah Paul noahp&altavista.net
Ole Hellevik oleh&interlinq.com
Robby Walker webmaster&cd-lab.com
Robert Ellman rellman&calicotech.com
Stefan Siebert ssiebert&dcs.de
Susan Hinrichs shinrich&cisco.com
Tom Lemaire toml&banyan.com
Ulysses G. Smith Jr. ugsmith&cesi.com