Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| tftp | 69 | tcp | Trivial File Transfer | David Clark | David Clark | ||||||
| tftp | 69 | udp | Trivial File Transfer | David Clark | David Clark | ||||||
| send | 169 | tcp | SEND | William Oldwin | William Oldwin | 2019-04-22 | |||||
| send | 169 | udp | SEND | William Oldwin | William Oldwin | 2019-04-22 | |||||
| manet | 269 | tcp | MANET Protocols | RFC 5498 | |||||||
| manet | 269 | udp | MANET Protocols | RFC 5498 | |||||||
| rpc2portmap | 369 | tcp | rpc2portmap | ||||||||
| rpc2portmap | 369 | udp | rpc2portmap | ||||||||
| rcp | 469 | tcp | Radio Control Protocol | Jim Jennings | Jim Jennings | ||||||
| rcp | 469 | udp | Radio Control Protocol | Jim Jennings | Jim Jennings | ||||||
| ms-rome | 569 | tcp | microsoft rome | Rudolph Balaz | Rudolph Balaz | ||||||
| ms-rome | 569 | udp | microsoft rome | Rudolph Balaz | Rudolph Balaz | ||||||
| meregister | 669 | tcp | MeRegister | Armin Sawusch | Armin Sawusch | ||||||
| meregister | 669 | udp | MeRegister | Armin Sawusch | Armin Sawusch | ||||||
| vatp | 690 | tcp | Velneo Application Transfer Protocol | Velneo | David Gutiérrez | 2015-02-03 | |||||
| vatp | 690 | udp | Velneo Application Transfer Protocol | Velneo | David Gutiérrez | 2015-02-03 | |||||
| msexch-routing | 691 | tcp | MS Exchange Routing | David Lemson | David Lemson | ||||||
| msexch-routing | 691 | udp | MS Exchange Routing | David Lemson | David Lemson | ||||||
| hyperwave-isp | 692 | tcp | Hyperwave-ISP | Gerald Mesaric | Gerald Mesaric | ||||||
| hyperwave-isp | 692 | udp | Hyperwave-ISP | Gerald Mesaric | Gerald Mesaric | ||||||
| connendp | 693 | tcp | almanid Connection Endpoint | Ronny Bremer | Ronny Bremer | ||||||
| connendp | 693 | udp | almanid Connection Endpoint | Ronny Bremer | Ronny Bremer | ||||||
| ha-cluster | 694 | tcp | ha-cluster | Alan Robertson | Alan Robertson | ||||||
| ha-cluster | 694 | udp | ha-cluster | Alan Robertson | Alan Robertson | ||||||
| ieee-mms-ssl | 695 | tcp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| ieee-mms-ssl | 695 | udp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| rushd | 696 | tcp | RUSHD | Greg Ercolano | Greg Ercolano | ||||||
| rushd | 696 | udp | RUSHD | Greg Ercolano | Greg Ercolano | ||||||
| uuidgen | 697 | tcp | UUIDGEN | James Falkner | James Falkner | ||||||
| uuidgen | 697 | udp | UUIDGEN | James Falkner | James Falkner | ||||||
| olsr | 698 | tcp | OLSR | Thomas Clausen | Thomas Clausen | ||||||
| olsr | 698 | udp | OLSR | Thomas Clausen | Thomas Clausen | ||||||
| accessnetwork | 699 | tcp | Access Network | Yingchun Xu | Yingchun Xu | ||||||
| accessnetwork | 699 | udp | Access Network | Yingchun Xu | Yingchun Xu | ||||||
| vid | 769 | tcp | |||||||||
| vid | 769 | udp | |||||||||
| rift-lies | 914 | udp | Routing in Fat Trees Link Information Element | IESG | IETF Chair | 2023-02-17 | 2024-06-07 | RFC 9692 | |||
| rift-ties | 915 | udp | Routing in Fat Trees Topology Information Element | IESG | IETF Chair | 2023-02-17 | 2024-06-07 | RFC 9692 | |||
| exp1 | 1021 | tcp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | udp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | sctp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | dccp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | tcp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | udp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | sctp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | dccp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| cognex-insight | 1069 | tcp | COGNEX-INSIGHT | Steve Olson | Steve Olson | ||||||
| cognex-insight | 1069 | udp | COGNEX-INSIGHT | Steve Olson | Steve Olson | ||||||
| ltp-deepspace | 1113 | dccp | Licklider Transmission Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 7107696 | ||||
| tripwire | 1169 | tcp | TRIPWIRE | Ed Metcalf; Albert Holt | Ed Metcalf; Albert Holt | ||||||
| tripwire | 1169 | udp | TRIPWIRE | Ed Metcalf; Albert Holt | Ed Metcalf; Albert Holt | ||||||
| watilapp | 1269 | tcp | WATiLaPP | Frederic Weymann | Frederic Weymann | ||||||
| watilapp | 1269 | udp | WATiLaPP | Frederic Weymann | Frederic Weymann | ||||||
| gv-us | 1369 | tcp | GlobalView to Unix Shell | ||||||||
| gv-us | 1369 | udp | GlobalView to Unix Shell | ||||||||
| aal-lm | 1469 | tcp | Active Analysis Limited License Manager | David Snocken | David Snocken | ||||||
| aal-lm | 1469 | udp | Active Analysis Limited License Manager | David Snocken | David Snocken | ||||||
| ets | 1569 | tcp | ets | Carstein Seeberg | Carstein Seeberg | ||||||
| ets | 1569 | udp | ets | Carstein Seeberg | Carstein Seeberg | ||||||
| netview-aix-9 | 1669 | tcp | netview-aix-9 | ||||||||
| netview-aix-9 | 1669 | udp | netview-aix-9 | ||||||||
| ng-umds | 1690 | tcp | ng-umds | Louis E. Simard | Louis E. Simard | ||||||
| ng-umds | 1690 | udp | ng-umds | Louis E. Simard | Louis E. Simard | ||||||
| empire-empuma | 1691 | tcp | empire-empuma | Bobby Krupczak | Bobby Krupczak | ||||||
| empire-empuma | 1691 | udp | empire-empuma | Bobby Krupczak | Bobby Krupczak | ||||||
| sstsys-lm | 1692 | tcp | sstsys-lm | Yih-Wu Wang | Yih-Wu Wang | ||||||
| sstsys-lm | 1692 | udp | sstsys-lm | Yih-Wu Wang | Yih-Wu Wang | ||||||
| rrirtr | 1693 | tcp | rrirtr | ||||||||
| rrirtr | 1693 | udp | rrirtr | ||||||||
| rrimwm | 1694 | tcp | rrimwm | ||||||||
| rrimwm | 1694 | udp | rrimwm | ||||||||
| rrilwm | 1695 | tcp | rrilwm | ||||||||
| rrilwm | 1695 | udp | rrilwm | ||||||||
| rrifmm | 1696 | tcp | rrifmm | ||||||||
| rrifmm | 1696 | udp | rrifmm | ||||||||
| rrisat | 1697 | tcp | rrisat | Allen Briggs | Allen Briggs | ||||||
| rrisat | 1697 | udp | rrisat | Allen Briggs | Allen Briggs | ||||||
| rsvp-encap-1 | 1698 | tcp | RSVP-ENCAPSULATION-1 | ||||||||
| rsvp-encap-1 | 1698 | udp | RSVP-ENCAPSULATION-1 | ||||||||
| rsvp-encap-2 | 1699 | tcp | RSVP-ENCAPSULATION-2 | Bob Braden | Bob Braden | ||||||
| rsvp-encap-2 | 1699 | udp | RSVP-ENCAPSULATION-2 | Bob Braden | Bob Braden | ||||||
| bmc-net-adm | 1769 | tcp | bmc-net-adm | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-net-adm | 1769 | udp | bmc-net-adm | Portnoy Boxman | Portnoy Boxman | ||||||
| transact | 1869 | tcp | TransAct | TransAct Futures Development Team | TransAct Futures Development Team | ||||||
| transact | 1869 | udp | TransAct | TransAct Futures Development Team | TransAct Futures Development Team | ||||||
| lipsinc1 | 1969 | tcp | LIPSinc 1 | Robert Armington | Robert Armington | ||||||
| lipsinc1 | 1969 | udp | LIPSinc 1 | Robert Armington | Robert Armington | ||||||
| event-port | 2069 | tcp | HTTP Event Port | Larry Emlich | Larry Emlich | ||||||
| event-port | 2069 | udp | HTTP Event Port | Larry Emlich | Larry Emlich | ||||||
| brain | 2169 | tcp | Backbone for Academic Information Notification (BRAIN) | Archishmat Gore | Archishmat Gore | 2004-11 | |||||
| brain | 2169 | udp | Backbone for Academic Information Notification (BRAIN) | Archishmat Gore | Archishmat Gore | 2004-11 | |||||
| mikey | 2269 | tcp | MIKEY | Karl Norrman | Karl Norrman | 2004-12 | |||||
| mikey | 2269 | udp | MIKEY | Karl Norrman | Karl Norrman | 2004-12 | |||||
| bif-p2p | 2369 | tcp | Blockchain Identifier InFrastructure P2P | Li Zhiping | Zhang Bo | 2023-06-29 | |||||
| bif-p2p | 2369 | udp | Blockchain Identifier InFrastructure P2P | Li Zhiping | Zhang Bo | 2023-03-06 | |||||
| mti-tcs-comm | 2469 | tcp | MTI-TCS-COMM | Mario Bonin | Mario Bonin | ||||||
| mti-tcs-comm | 2469 | udp | MTI-TCS-COMM | Mario Bonin | Mario Bonin | ||||||
| sonuscallsig | 2569 | tcp | Sonus Call Signal | Mark Garti | Mark Garti | ||||||
| sonuscallsig | 2569 | udp | Sonus Call Signal | Mark Garti | Mark Garti | ||||||
| toad | 2669 | tcp | TOAD | Michael Marking | Michael Marking |