Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| netrjs-4 | 74 | tcp | Remote Job Service | Bob Braden | Bob Braden | ||||||
| netrjs-4 | 74 | udp | Remote Job Service | Bob Braden | Bob Braden | ||||||
| mailq | 174 | tcp | MAILQ | Rayan Zachariassen | Rayan Zachariassen | ||||||
| mailq | 174 | udp | MAILQ | Rayan Zachariassen | Rayan Zachariassen | ||||||
| legent-2 | 374 | tcp | Legent Corporation | Keith Boyce | Keith Boyce | ||||||
| legent-2 | 374 | udp | Legent Corporation | Keith Boyce | Keith Boyce | ||||||
| tn-tl-w1 | 474 | tcp | tn-tl-w1 | ||||||||
| tn-tl-w2 | 474 | udp | tn-tl-w2 | Ed Kress | Ed Kress | ||||||
| ftp-agent | 574 | tcp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| ftp-agent | 574 | udp | FTP Software Agent System | Michael S. Greenberg | Michael S. Greenberg | ||||||
| acap | 674 | tcp | ACAP | Chris Newman | Chris Newman | 2010-10-15 | |||||
| acap | 674 | udp | ACAP | Chris Newman | Chris Newman | 2010-10-15 | |||||
| 732-740 | Unassigned | ||||||||||
| netgw | 741 | tcp | netGW | Oliver Korfmacher | Oliver Korfmacher | ||||||
| netgw | 741 | udp | netGW | Oliver Korfmacher | Oliver Korfmacher | ||||||
| netrcs | 742 | tcp | Network based Rev. Cont. Sys. | Gordon C. Galligher | Gordon C. Galligher | ||||||
| netrcs | 742 | udp | Network based Rev. Cont. Sys. | Gordon C. Galligher | Gordon C. Galligher | ||||||
| 743 | Unassigned | ||||||||||
| flexlm | 744 | tcp | Flexible License Manager | Matt Christiano | Matt Christiano | ||||||
| flexlm | 744 | udp | Flexible License Manager | Matt Christiano | Matt Christiano | ||||||
| 745-746 | Unassigned | ||||||||||
| fujitsu-dev | 747 | tcp | Fujitsu Device Control | ||||||||
| fujitsu-dev | 747 | udp | Fujitsu Device Control | ||||||||
| ris-cm | 748 | tcp | Russell Info Sci Calendar Manager | ||||||||
| ris-cm | 748 | udp | Russell Info Sci Calendar Manager | ||||||||
| kerberos-adm | 749 | tcp | kerberos administration | ||||||||
| kerberos-adm | 749 | udp | kerberos administration | ||||||||
| rpasswd | 774 | tcp | |||||||||
| acmaint-dbd | 774 | udp | IANA assigned this well-formed service name as a replacement for "acmaint_dbd". | ||||||||
| acmaint_dbd | 774 | udp | This entry is an alias to "acmaint-dbd". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||||||
| 874-885 | Unassigned | ||||||||||
| warmspotMgmt | 1074 | tcp | Warmspot Management Protocol | Robert C. Henningsgard | Robert C. Henningsgard | ||||||
| warmspotMgmt | 1074 | udp | Warmspot Management Protocol | Robert C. Henningsgard | Robert C. Henningsgard | ||||||
| fnet-remote-ui | 1174 | tcp | FlashNet Remote Admin | Terry Smyth | Terry Smyth | 2004-11 | |||||
| fnet-remote-ui | 1174 | udp | FlashNet Remote Admin | Terry Smyth | Terry Smyth | 2004-11 | |||||
| t1distproc | 1274 | tcp | t1distproc | Julian Biddle | Julian Biddle | ||||||
| t1distproc | 1274 | udp | t1distproc | Julian Biddle | Julian Biddle | ||||||
| molly | 1374 | tcp | EPI Software Systems | Jim Vlcek | Jim Vlcek | ||||||
| molly | 1374 | udp | EPI Software Systems | Jim Vlcek | Jim Vlcek | ||||||
| telefinder | 1474 | tcp | Telefinder | Jim White | Jim White | ||||||
| telefinder | 1474 | udp | Telefinder | Jim White | Jim White | ||||||
| mvel-lm | 1574 | tcp | mvel-lm | David Bisset | David Bisset | ||||||
| mvel-lm | 1574 | udp | mvel-lm | David Bisset | David Bisset | ||||||
| proshare-mc-2 | 1674 | tcp | Intel Proshare Multicast | Mark Lewis | Mark Lewis | ||||||
| proshare-mc-2 | 1674 | udp | Intel Proshare Multicast | Mark Lewis | Mark Lewis | ||||||
| encore | 1740 | tcp | encore | Stuart Button | Stuart Button | ||||||
| encore | 1740 | udp | encore | Stuart Button | Stuart Button | ||||||
| cisco-net-mgmt | 1741 | tcp | cisco-net-mgmt | John McCormack | John McCormack | ||||||
| cisco-net-mgmt | 1741 | udp | cisco-net-mgmt | John McCormack | John McCormack | ||||||
| 3Com-nsd | 1742 | tcp | 3Com-nsd | Nitza Steinberg | Nitza Steinberg | ||||||
| 3Com-nsd | 1742 | udp | 3Com-nsd | Nitza Steinberg | Nitza Steinberg | ||||||
| cinegrfx-lm | 1743 | tcp | Cinema Graphics License Manager | Rodney Iwashina | Rodney Iwashina | ||||||
| cinegrfx-lm | 1743 | udp | Cinema Graphics License Manager | Rodney Iwashina | Rodney Iwashina | ||||||
| ncpm-ft | 1744 | tcp | ncpm-ft | Ken Hearn | Ken Hearn | ||||||
| ncpm-ft | 1744 | udp | ncpm-ft | Ken Hearn | Ken Hearn | ||||||
| remote-winsock | 1745 | tcp | remote-winsock | Avi Nathan | Avi Nathan | ||||||
| remote-winsock | 1745 | udp | remote-winsock | Avi Nathan | Avi Nathan | ||||||
| ftrapid-1 | 1746 | tcp | ftrapid-1 | ||||||||
| ftrapid-1 | 1746 | udp | ftrapid-1 | ||||||||
| ftrapid-2 | 1747 | tcp | ftrapid-2 | Richard J. Williams | Richard J. Williams | ||||||
| ftrapid-2 | 1747 | udp | ftrapid-2 | Richard J. Williams | Richard J. Williams | ||||||
| oracle-em1 | 1748 | tcp | oracle-em1 | Bob Purvy | Bob Purvy | ||||||
| oracle-em1 | 1748 | udp | oracle-em1 | Bob Purvy | Bob Purvy | ||||||
| aspen-services | 1749 | tcp | aspen-services | Mark B. Hurst | Mark B. Hurst | ||||||
| aspen-services | 1749 | udp | aspen-services | Mark B. Hurst | Mark B. Hurst | ||||||
| global-dtserv | 1774 | tcp | global-dtserv | Nicholas Davies | Nicholas Davies | ||||||
| global-dtserv | 1774 | udp | global-dtserv | Nicholas Davies | Nicholas Davies | ||||||
| fjswapsnp | 1874 | tcp | Fjswapsnp | Y. Ohiwa | Y. Ohiwa | ||||||
| fjswapsnp | 1874 | udp | Fjswapsnp | Y. Ohiwa | Y. Ohiwa | ||||||
| drp | 1974 | tcp | DRP | Richard Alan Johnson | Richard Alan Johnson | ||||||
| drp | 1974 | udp | DRP | Richard Alan Johnson | Richard Alan Johnson | ||||||
| vrtl-vmf-sa | 2074 | tcp | Vertel VMF SA | Alan Akahoshi | Alan Akahoshi | ||||||
| vrtl-vmf-sa | 2074 | udp | Vertel VMF SA | Alan Akahoshi | Alan Akahoshi | ||||||
| msfw-array | 2174 | tcp | MS Firewall Intra Array | Itai Greenberg | Itai Greenberg | 2004-11 | |||||
| msfw-array | 2174 | udp | MS Firewall Intra Array | Itai Greenberg | Itai Greenberg | 2004-11 | |||||
| amt | 2268 | tcp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| amt | 2268 | udp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| pcttunnell | 2274 | tcp | PCTTunneller | ProControl Technology AB | ProControl Technology AB | 2004-12 | |||||
| pcttunnell | 2274 | udp | PCTTunneller | ProControl Technology AB | ProControl Technology AB | 2004-12 | |||||
| hydra | 2374 | tcp | Hydra RPC | Jacob Feisley | Jacob Feisley | 2009-01-21 | |||||
| 2374 | udp | Reserved | |||||||||
| vitalanalysis | 2474 | tcp | Vital Analysis | Srinivas Reddy | Srinivas Reddy | ||||||
| vitalanalysis | 2474 | udp | Vital Analysis | Srinivas Reddy | Srinivas Reddy | ||||||
| blockade-bpsp | 2574 | tcp | Blockade BPSP | VP - Research & Development | VP - Research & Development | ||||||
| blockade-bpsp | 2574 | udp | Blockade BPSP | VP - Research & Development | VP - Research & Development | ||||||
| ewnn | 2674 | tcp | ewnn | Yasunari Yamashita | Yasunari Yamashita | ||||||
| ewnn | 2674 | udp | ewnn | Yasunari Yamashita | Yasunari Yamashita | ||||||
| alarm | 2740 | tcp | Alarm | Uriy Makasjuk | Uriy Makasjuk | ||||||
| alarm | 2740 | udp | Alarm | Uriy Makasjuk | Uriy Makasjuk | ||||||
| tsb | 2741 | tcp | TSB | ||||||||
| tsb | 2741 | udp | TSB | ||||||||
| tsb2 | 2742 | tcp | TSB2 | Ashish Chatterjee | Ashish Chatterjee | ||||||
| tsb2 | 2742 | udp | TSB2 | Ashish Chatterjee | Ashish Chatterjee | ||||||
| murx | 2743 | tcp | murx | Thomas Kuiper | Thomas Kuiper | ||||||
| murx | 2743 | udp | murx | Thomas Kuiper | Thomas Kuiper | ||||||
| honyaku | 2744 | tcp | honyaku | Yasunari Yamashita | Yasunari Yamashita | ||||||
| honyaku | 2744 | udp | honyaku | Yasunari Yamashita | Yasunari Yamashita | ||||||
| urbisnet | 2745 | tcp | URBISNET | Urbis.Net Ltd | Urbis.Net Ltd | ||||||
| urbisnet | 2745 | udp | URBISNET | Urbis.Net Ltd | Urbis.Net Ltd | ||||||
| cpudpencap | 2746 | tcp | CPUDPENCAP | Tamir Zegman | Tamir Zegman |