Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 87 | tcp | any private terminal link | Jon Postel | Jon Postel | |||||||
| 87 | udp | any private terminal link | Jon Postel | Jon Postel | |||||||
| aci | 187 | tcp | Application Communication Interface | Rick Carlos | Rick Carlos | ||||||
| aci | 187 | udp | Application Communication Interface | Rick Carlos | Rick Carlos | ||||||
| pt-tls | 271 | tcp | IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) | IESG | IETF Chair | 2012-07-31 | RFC 6876 | ||||
| k-block | 287 | tcp | K-BLOCK | Simon P Jackson | Simon P Jackson | ||||||
| k-block | 287 | udp | K-BLOCK | Simon P Jackson | Simon P Jackson | ||||||
| tacacss | 300 | tcp | TLS Secure Login Host Protocol (TACACSS) | IESG | IETF Chair | 2025-07-15 | RFC 9887 | ||||
| aurp | 387 | tcp | Appletalk Update-Based Routing Pro. | Chris Ranch | Chris Ranch | ||||||
| aurp | 387 | udp | Appletalk Update-Based Routing Pro. | Chris Ranch | Chris Ranch | ||||||
| saft | 487 | tcp | saft Simple Asynchronous File Transfer | Ulli Horlacher | Ulli Horlacher | ||||||
| saft | 487 | udp | saft Simple Asynchronous File Transfer | Ulli Horlacher | Ulli Horlacher | ||||||
| submission | 587 | tcp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| submission | 587 | udp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| asipregistry | 687 | tcp | asipregistry | Erik Sea | Erik Sea | ||||||
| asipregistry | 687 | udp | asipregistry | Erik Sea | Erik Sea | ||||||
| 787 | Unassigned | 2002-10-08 | |||||||||
| 863-872 | Unassigned | ||||||||||
| rsync | 873 | tcp | rsync | Andrew Tridgell | Andrew Tridgell | ||||||
| rsync | 873 | udp | rsync | Andrew Tridgell | Andrew Tridgell | ||||||
| 874-885 | Unassigned | ||||||||||
| iclcnet-svinfo | 887 | tcp | ICL coNETion server info IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo". |
Bob Lyon | Bob Lyon | ||||||
| iclcnet_svinfo | 887 | tcp | ICL coNETion server info | Bob Lyon | Bob Lyon | This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| iclcnet-svinfo | 887 | udp | ICL coNETion server info IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo". |
Bob Lyon | Bob Lyon | ||||||
| iclcnet_svinfo | 887 | udp | ICL coNETion server info | Bob Lyon | Bob Lyon | This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| mtqp | 1038 | tcp | Message Tracking Query Protocol | RFC 3887 | |||||||
| mtqp | 1038 | udp | Message Tracking Query Protocol | RFC 3887 | |||||||
| cplscrambler-in | 1087 | tcp | CPL Scrambler Internal | ||||||||
| cplscrambler-in | 1087 | udp | CPL Scrambler Internal | ||||||||
| alias | 1187 | tcp | Alias Service | Paul Tokarchuk | Paul Tokarchuk | 2004-11 | |||||
| alias | 1187 | udp | Alias Service | Paul Tokarchuk | Paul Tokarchuk | 2004-11 | |||||
| routematch | 1287 | tcp | RouteMatch Com | Jeff Jones | Jeff Jones | 2005-11 | |||||
| routematch | 1287 | udp | RouteMatch Com | Jeff Jones | Jeff Jones | 2005-11 | |||||
| cadsi-lm | 1387 | tcp | Computer Aided Design Software Inc LM | Sulistio Muljadi | Sulistio Muljadi | ||||||
| cadsi-lm | 1387 | udp | Computer Aided Design Software Inc LM | Sulistio Muljadi | Sulistio Muljadi | ||||||
| localinfosrvr | 1487 | tcp | LocalInfoSrvr | Brian Matthews | Brian Matthews | ||||||
| localinfosrvr | 1487 | udp | LocalInfoSrvr | Brian Matthews | Brian Matthews | ||||||
| pra-elmd | 1587 | tcp | pra_elmd IANA assigned this well-formed service name as a replacement for "pra_elmd". |
Dennis Mastin | Dennis Mastin | ||||||
| pra_elmd | 1587 | tcp | pra_elmd | Dennis Mastin | Dennis Mastin | This entry is an alias to "pra-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| pra-elmd | 1587 | udp | pra_elmd IANA assigned this well-formed service name as a replacement for "pra_elmd". |
Dennis Mastin | Dennis Mastin | ||||||
| pra_elmd | 1587 | udp | pra_elmd | Dennis Mastin | Dennis Mastin | This entry is an alias to "pra-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| nsjtp-ctrl | 1687 | tcp | nsjtp-ctrl | ||||||||
| nsjtp-ctrl | 1687 | udp | nsjtp-ctrl | ||||||||
| funk-license | 1787 | tcp | funk-license | Cimarron Boozer; Eric Wilde | Cimarron Boozer; Eric Wilde | ||||||
| funk-license | 1787 | udp | funk-license | Cimarron Boozer; Eric Wilde | Cimarron Boozer; Eric Wilde | ||||||
| sunscalar-dns | 1870 | tcp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| sunscalar-dns | 1870 | udp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| canocentral0 | 1871 | tcp | Cano Central 0 | ||||||||
| canocentral0 | 1871 | udp | Cano Central 0 | ||||||||
| canocentral1 | 1872 | tcp | Cano Central 1 | Mark McNamara | Mark McNamara | ||||||
| canocentral1 | 1872 | udp | Cano Central 1 | Mark McNamara | Mark McNamara | ||||||
| fjmpjps | 1873 | tcp | Fjmpjps | ||||||||
| fjmpjps | 1873 | udp | Fjmpjps | ||||||||
| fjswapsnp | 1874 | tcp | Fjswapsnp | Y. Ohiwa | Y. Ohiwa | ||||||
| fjswapsnp | 1874 | udp | Fjswapsnp | Y. Ohiwa | Y. Ohiwa | ||||||
| westell-stats | 1875 | tcp | westell stats | Thomas McCabe | Thomas McCabe | ||||||
| westell-stats | 1875 | udp | westell stats | Thomas McCabe | Thomas McCabe | ||||||
| ewcappsrv | 1876 | tcp | ewcappsrv | Howard Yin | Howard Yin | ||||||
| ewcappsrv | 1876 | udp | ewcappsrv | Howard Yin | Howard Yin | ||||||
| hp-webqosdb | 1877 | tcp | hp-webqosdb | Kim Scott | Kim Scott | ||||||
| hp-webqosdb | 1877 | udp | hp-webqosdb | Kim Scott | Kim Scott | ||||||
| drmsmc | 1878 | tcp | drmsmc | Katsuhiko Abe | Katsuhiko Abe | ||||||
| drmsmc | 1878 | udp | drmsmc | Katsuhiko Abe | Katsuhiko Abe | ||||||
| nettgain-nms | 1879 | tcp | NettGain NMS | Dr. Yair Shapira | Dr. Yair Shapira | ||||||
| nettgain-nms | 1879 | udp | NettGain NMS | Dr. Yair Shapira | Dr. Yair Shapira | ||||||
| filex-lport | 1887 | tcp | FileX Listening Port | Megan Woods | Megan Woods | ||||||
| filex-lport | 1887 | udp | FileX Listening Port | Megan Woods | Megan Woods | ||||||
| tr-rsrb-p1 | 1987 | tcp | cisco RSRB Priority 1 port | ||||||||
| tr-rsrb-p1 | 1987 | udp | cisco RSRB Priority 1 port | ||||||||
| eli | 2087 | tcp | ELI - Event Logging Integration | Maya Zimerman | Maya Zimerman | ||||||
| eli | 2087 | udp | ELI - Event Logging Integration | Maya Zimerman | Maya Zimerman | ||||||
| tdmoip | 2142 | tcp | TDM OVER IP | Yaakov Stein | Yaakov Stein | 2016-09-21 | RFC 5087 | ||||
| tdmoip | 2142 | udp | TDM OVER IP | Yaakov Stein | Yaakov Stein | 2016-09-21 | RFC 5087 | ||||
| ssmc | 2187 | tcp | Sepehr System Management Control | ||||||||
| ssmd | 2187 | udp | Sepehr System Management Data | Shahriar Pourazin | Shahriar Pourazin | 2008-12-02 | |||||
| dna | 2287 | tcp | DNA | Tung Nguyen | Tung Nguyen | ||||||
| dna | 2287 | udp | DNA | Tung Nguyen | Tung Nguyen | ||||||
| vsamredirector | 2387 | tcp | VSAM Redirector | Ingo Franzki | Ingo Franzki | ||||||
| vsamredirector | 2387 | udp | VSAM Redirector | Ingo Franzki | Ingo Franzki | ||||||
| iec-104 | 2404 | tcp | IEC 60870-5-104 process control over IP | Walter K. Eichelburg | Walter K. Eichelburg | ||||||
| iec-104 | 2404 | udp | IEC 60870-5-104 process control over IP | Walter K. Eichelburg | Walter K. Eichelburg | ||||||
| pns | 2487 | tcp | Policy Notice Service | Akiyoshi Ochi | Akiyoshi Ochi | ||||||
| pns | 2487 | udp | Policy Notice Service | Akiyoshi Ochi | Akiyoshi Ochi | ||||||
| masc | 2587 | tcp | MASC | Pavlin Ivanov Radoslavov | Pavlin Ivanov Radoslavov | ||||||
| masc | 2587 | udp | MASC | Pavlin Ivanov Radoslavov | Pavlin Ivanov Radoslavov | ||||||
| pq-lic-mgmt | 2687 | tcp | pq-lic-mgmt | Bob Sledge | Bob Sledge | ||||||
| pq-lic-mgmt | 2687 | udp | pq-lic-mgmt | Bob Sledge | Bob Sledge | ||||||
| piccolo | 2787 | tcp | piccolo - Cornerstone Software | Dave Bellivea | Dave Bellivea | ||||||
| piccolo | 2787 | udp | piccolo - Cornerstone Software | Dave Bellivea | Dave Bellivea | ||||||
| daishi | 2870 | tcp | daishi | Patrick Chipman | Patrick Chipman | ||||||
| daishi | 2870 | udp | daishi | Patrick Chipman | Patrick Chipman | ||||||
| msi-selectplay | 2871 | tcp | MSI Select Play | Paul Fonte | Paul Fonte | ||||||
| msi-selectplay | 2871 | udp | MSI Select Play | Paul Fonte | Paul Fonte | ||||||
| radix | 2872 | tcp | RADIX | Stein Roger Skaflotten | Stein Roger Skaflotten | 2011-07-06 | |||||
| radix | 2872 | udp | RADIX | Stein Roger Skaflotten | Stein Roger Skaflotten | 2011-07-06 | |||||
| psrt | 2873 | tcp | PubSub Realtime Telemetry Protocol | Altertech | Serhij Symonenko | 2021-11-12 | |||||
| psrt | 2873 | udp | PubSub Realtime Telemetry Protocol | Altertech | Serhij Symonenko | 2021-11-12 | |||||
| dxmessagebase1 | 2874 | tcp | DX Message Base Transport Protocol | ||||||||
| dxmessagebase1 | 2874 | udp | DX Message Base Transport Protocol | ||||||||
| dxmessagebase2 | 2875 | tcp | DX Message Base Transport Protocol | G.E. Ozz Nixon Jr. | G.E. Ozz Nixon Jr. | 2009-01-13 |