Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
mit-dov 91 tcp MIT Dover Spooler Eliot Moss Eliot Moss
mit-dov 91 udp MIT Dover Spooler Eliot Moss Eliot Moss
prospero 191 tcp Prospero Directory Service B. Clifford Neuman B. Clifford Neuman
prospero 191 udp Prospero Directory Service B. Clifford Neuman B. Clifford Neuman
914c-g 211 tcp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 tcp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
914c-g 211 udp Texas Instruments 914C/G Terminal

IANA assigned this well-formed service name as a replacement for "914c/g".
Bill Harrell Bill Harrell
914c/g 211 udp Texas Instruments 914C/G Terminal Bill Harrell Bill Harrell This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms.
synotics-relay 391 tcp SynOptics SNMP Relay Port
synotics-relay 391 udp SynOptics SNMP Relay Port
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
go-login 491 tcp go-login Troy Morrison Troy Morrison
go-login 491 udp go-login Troy Morrison Troy Morrison
dhcpv6-client 546 udp DHCPv6 Client IESG IETF Chair 2018-05-21 RFC 9915
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
http-alt 591 tcp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
http-alt 591 udp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
msexch-routing 691 tcp MS Exchange Routing David Lemson David Lemson
msexch-routing 691 udp MS Exchange Routing David Lemson David Lemson
pana 716 udp PANA Messages RFC 5191
kink 910 tcp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
kink 910 udp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
xact-backup 911 tcp xact-backup Bill Carroll Bill Carroll
xact-backup 911 udp xact-backup Bill Carroll Bill Carroll
apex-mesh 912 tcp APEX relay-relay service
apex-mesh 912 udp APEX relay-relay service
apex-edge 913 tcp APEX endpoint-relay service RFC 3340
apex-edge 913 udp APEX endpoint-relay service RFC 3340
914 tcp Reserved
rift-lies 914 udp Routing in Fat Trees Link Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
915 tcp Reserved
rift-ties 915 udp Routing in Fat Trees Topology Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
916-952 Unassigned
nas 991 tcp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
nas 991 udp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
ff-sm 1091 tcp FF System Management Fieldbus Foundation Fieldbus Foundation
ff-sm 1091 udp FF System Management Fieldbus Foundation Fieldbus Foundation
gpfs 1191 tcp General Parallel File System Dave Craft Dave Craft 2004-11
gpfs 1191 udp General Parallel File System Dave Craft Dave Craft 2004-11
seagulllms 1291 tcp SEAGULLLMS Lee Breisacher Lee Breisacher
seagulllms 1291 udp SEAGULLLMS Lee Breisacher Lee Breisacher
iclpv-sas 1391 tcp Storage Access Server
iclpv-sas 1391 udp Storage Access Server
1491 Unassigned 2009-08-05 Unauthorized Use Known on port 1491
ncpm-pm 1591 tcp ncpm-pm Ted Power Ted Power
ncpm-pm 1591 udp ncpm-pm Ted Power Ted Power
empire-empuma 1691 tcp empire-empuma Bobby Krupczak Bobby Krupczak
empire-empuma 1691 udp empire-empuma Bobby Krupczak Bobby Krupczak
ea1 1791 tcp EA1 Kirk MacLean Kirk MacLean
ea1 1791 udp EA1 Kirk MacLean Kirk MacLean
childkey-notif 1891 tcp ChildKey Notification
childkey-notif 1891 udp ChildKey Notification
ultrabac 1910 tcp UltraBac Software communications port Paul Bunn Paul Bunn
ultrabac 1910 udp UltraBac Software communications port Paul Bunn Paul Bunn
mtp 1911 tcp Starlight Networks Multimedia Transport Protocol Bruce Lieberman Bruce Lieberman
mtp 1911 udp Starlight Networks Multimedia Transport Protocol Bruce Lieberman Bruce Lieberman
rhp-iibp 1912 tcp rhp-iibp George Nachman; Tom Lake George Nachman; Tom Lake
rhp-iibp 1912 udp rhp-iibp George Nachman; Tom Lake George Nachman; Tom Lake
armadp 1913 tcp armadp Kevin Welton Kevin Welton
armadp 1913 udp armadp Kevin Welton Kevin Welton
elm-momentum 1914 tcp Elm-Momentum Willie Wu Willie Wu
elm-momentum 1914 udp Elm-Momentum Willie Wu Willie Wu
facelink 1915 tcp FACELINK J.H. Hermans J.H. Hermans
facelink 1915 udp FACELINK J.H. Hermans J.H. Hermans
persona 1916 tcp Persoft Persona Tom Spidell Tom Spidell
persona 1916 udp Persoft Persona Tom Spidell Tom Spidell
noagent 1917 tcp nOAgent Martin Bestmann Martin Bestmann
noagent 1917 udp nOAgent Martin Bestmann Martin Bestmann
can-nds 1918 tcp IBM Tivole Directory Service - NDS
can-nds 1918 udp IBM Tivole Directory Service - NDS
can-dch 1919 tcp IBM Tivoli Directory Service - DCH
can-dch 1919 udp IBM Tivoli Directory Service - DCH
stun-p2 1991 tcp cisco STUN Priority 2 port
stun-p2 1991 udp cisco STUN Priority 2 port
prp 2091 tcp PRP Amir Peless Amir Peless
prp 2091 udp PRP Amir Peless Amir Peless
tvbus 2191 tcp TvBus Messaging Brian W. Beach Brian W. Beach 2003-01
tvbus 2191 udp TvBus Messaging Brian W. Beach Brian W. Beach 2003-01
eapsp 2291 tcp EPSON Advanced Printer Share Protocol SEIKO EPSON SEIKO EPSON 2006-06
eapsp 2291 udp EPSON Advanced Printer Share Protocol SEIKO EPSON SEIKO EPSON 2006-06
3com-net-mgmt 2391 tcp 3COM Net Management Prathibha Nagvar Prathibha Nagvar
3com-net-mgmt 2391 udp 3COM Net Management Prathibha Nagvar Prathibha Nagvar
conclave-cpp 2491 tcp Conclave CPP Larry Lipstone Larry Lipstone
conclave-cpp 2491 udp Conclave CPP Larry Lipstone Larry Lipstone
maytagshuffle 2591 tcp Maytag Shuffle Ken Ksiazek Ken Ksiazek
maytagshuffle 2591 udp Maytag Shuffle Ken Ksiazek Ken Ksiazek
itinternet 2691 tcp ITInternet ISM Server Ron Ehli Ron Ehli
itinternet 2691 udp ITInternet ISM Server Ron Ehli Ron Ehli
mtport-regist 2791 tcp MT Port Registrator Maxim Tseitlin Maxim Tseitlin
mtport-regist 2791 udp MT Port Registrator Maxim Tseitlin Maxim Tseitlin
cinegrfx-elmd 2891 tcp CINEGRFX-ELMD License Manager Greg Ercolano Greg Ercolano
cinegrfx-elmd 2891 udp CINEGRFX-ELMD License Manager Greg Ercolano Greg Ercolano
tdaccess 2910 tcp TDAccess Tom Haapanen Tom Haapanen
tdaccess 2910 udp TDAccess Tom Haapanen Tom Haapanen
blockade 2911 tcp Blockade VP - Research & Development VP - Research & Development

Contact Information

Name Organization Contact URI Last Updated
Amir Peless amirp&radware.co.il
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bill Carroll billc&xactlabs.com
Bill Harrell
VP - Research & Development development&blockade.com
Bobby Krupczak rdk&empiretech.com
Brian W. Beach brian&tivo.com 2003-01
Bruce Lieberman brucel&iserver.starlight.com
Clay Maeckel clay&claris.com 2023-09-12
Dave Craft gpfs&ibm.com 2004-11
David Lemson dlemson&microsoft.com
Eliot Moss EBM&xx.lcs.mit.edu
Fieldbus Foundation dave.glanzer&fieldbus.org 2002-10
George Nachman
Greg Ercolano erco&cinegrfx.com
Heiko Schlichting heiko.schlichting&fu-berlin.de 2022-06-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J.H. Hermans j.h.hermans&hiscom.nl
Ken Ksiazek kksiazek&maytag.com
Kevin Welton Kevin.Welton&armltd.co.uk
Kirk MacLean kmaclean&ea.com
Larry Lipstone lrl&interdyn.com
Lee Breisacher lbreisacher&seagullsw.com
Martin Bestmann martin&datawatch.de
Maxim Tseitlin mtseitlin&iname.com
Paul Bunn iana&ultrabac.com
Prathibha Nagvar
Ron Ehli ron&itinternet.net
SEIKO EPSON APD.admin&exc.epson.co.jp 2006-06
Ted Power tedp&hpinpcb.cup.hp.com
Tom Haapanen tomh&metrics.com
Tom Lake tlake&m-ware.com
Tom Spidell spidell&persoft.com
Troy Morrison troy&graphon.com
Vera Heinau vera.heinau&fu-berlin.de 2022-06-07
Willie Wu willie&mds.com