Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
objcall 94 tcp Tivoli Object Dispatcher Tom Bereiter Tom Bereiter
objcall 94 udp Tivoli Object Dispatcher Tom Bereiter Tom Bereiter
irc 194 tcp Internet Relay Chat Protocol Jarkko Oikarinen Jarkko Oikarinen
irc 194 udp Internet Relay Chat Protocol Jarkko Oikarinen Jarkko Oikarinen
embl-ndt 394 tcp EMBL Nucleic Data Transfer Peter Gad Peter Gad
embl-ndt 394 udp EMBL Nucleic Data Transfer Peter Gad Peter Gad
pov-ray 494 tcp POV-Ray POV-Team Co-ordinator POV-Team Co-ordinator
pov-ray 494 udp POV-Ray POV-Team Co-ordinator POV-Team Co-ordinator
tpip 594 tcp TPIP Brad Spear Brad Spear
tpip 594 udp TPIP Brad Spear Brad Spear
ha-cluster 694 tcp ha-cluster Alan Robertson Alan Robertson
ha-cluster 694 udp ha-cluster Alan Robertson Alan Robertson
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
994 tcp Reserved 2011-08-31 (previous contact was Christopher Allen)
994 udp Reserved
rootd 1094 tcp ROOTD Fons Rademakers Fons Rademakers
rootd 1094 udp ROOTD Fons Rademakers Fons Rademakers
openvpn 1194 tcp OpenVPN James Yonan James Yonan 2004-11
openvpn 1194 udp OpenVPN James Yonan James Yonan 2004-11
cmmdriver 1294 tcp CMMdriver Lutz Karras Lutz Karras
cmmdriver 1294 udp CMMdriver Lutz Karras Lutz Karras
iclpv-nlc 1394 tcp Network Log Client
iclpv-nlc 1394 udp Network Log Client
ica 1494 tcp ica John Richardson John Richardson
ica 1494 udp ica John Richardson John Richardson
sixtrak 1594 tcp sixtrak Red Lion Controls Denis Aull 2014-09-22
sixtrak 1594 udp sixtrak Red Lion Controls Denis Aull 2014-09-22
rrimwm 1694 tcp rrimwm
rrimwm 1694 udp rrimwm
cera-bcm 1794 tcp cera-bcm Leo Moesgaard Leo Moesgaard
cera-bcm 1794 udp cera-bcm Leo Moesgaard Leo Moesgaard
o2server-port 1894 tcp O2Server Port Tim Howard Tim Howard
o2server-port 1894 udp O2Server Port Tim Howard Tim Howard
jvclient 1940 tcp JetVision Client Port Stephen Tsun Stephen Tsun
jvclient 1940 udp JetVision Client Port Stephen Tsun Stephen Tsun
dic-aida 1941 tcp DIC-Aida Frans S.C. Witte Frans S.C. Witte
dic-aida 1941 udp DIC-Aida Frans S.C. Witte Frans S.C. Witte
res 1942 tcp Real Enterprise Service Bob Janssen Bob Janssen
res 1942 udp Real Enterprise Service Bob Janssen Bob Janssen
beeyond-media 1943 tcp Beeyond Media Bob Deblier Bob Deblier
beeyond-media 1943 udp Beeyond Media Bob Deblier Bob Deblier
close-combat 1944 tcp close-combat David Hua David Hua
close-combat 1944 udp close-combat David Hua David Hua
dialogic-elmd 1945 tcp dialogic-elmd Roger Kay Roger Kay
dialogic-elmd 1945 udp dialogic-elmd Roger Kay Roger Kay
tekpls 1946 tcp tekpls Brian Abramson Brian Abramson
tekpls 1946 udp tekpls Brian Abramson Brian Abramson
sentinelsrm 1947 tcp SentinelSRM Michael Zunke Michael Zunke 2010-07-23 Unauthorized Use Known on port 1947
sentinelsrm 1947 udp SentinelSRM Michael Zunke Michael Zunke 2010-07-23 Unauthorized Use Known on port 1947
eye2eye 1948 tcp eye2eye Trevor Bell Trevor Bell
eye2eye 1948 udp eye2eye Trevor Bell Trevor Bell
ismaeasdaqlive 1949 tcp ISMA Easdaq Live Stephen Dunne Stephen Dunne
ismaeasdaqlive 1949 udp ISMA Easdaq Live Stephen Dunne Stephen Dunne
stun-port 1994 tcp cisco serial tunnel port
stun-port 1994 udp cisco serial tunnel port
nbx-au 2094 tcp NBX AU
nbx-au 2094 udp NBX AU
2194-2196 Unassigned Unauthorized Use Known on ports 2194-2196
konshus-lm 2294 tcp Konshus License Manager (FLEX) Francois Painchaud Francois Painchaud
konshus-lm 2294 udp Konshus License Manager (FLEX) Francois Painchaud Francois Painchaud
ms-olap2 2394 tcp MS OLAP 2 Mosha Pasumansky Mosha Pasumansky
ms-olap2 2394 udp MS OLAP 2 Mosha Pasumansky Mosha Pasumansky
bmc-ar 2494 tcp BMC AR Portnoy Boxman Portnoy Boxman
bmc-ar 2494 udp BMC AR Portnoy Boxman Portnoy Boxman
dts 2594 tcp Data Base Server Andreas Roene Andreas Roene
dts 2594 udp Data Base Server Andreas Roene Andreas Roene
pwrsevent 2694 tcp pwrsevent Yoshinobu Nakamura Yoshinobu Nakamura
pwrsevent 2694 udp pwrsevent Yoshinobu Nakamura Yoshinobu Nakamura
urp 2794 tcp Uniform Resource Platform Liu Hongyan Han Yingying 2024-11-26
urp 2794 udp Uniform Resource Platform Liu Hongyan Han Yingying 2024-11-26
abacus-remote 2894 tcp ABACUS-REMOTE Mike Bello Mike Bello
abacus-remote 2894 udp ABACUS-REMOTE Mike Bello Mike Bello
sm-pas-3 2940 tcp SM-PAS-3
sm-pas-3 2940 udp SM-PAS-3
sm-pas-4 2941 tcp SM-PAS-4
sm-pas-4 2941 udp SM-PAS-4
sm-pas-5 2942 tcp SM-PAS-5 Tom Haapanen Tom Haapanen
sm-pas-5 2942 udp SM-PAS-5 Tom Haapanen Tom Haapanen
ttnrepository 2943 tcp TTNRepository Robert Orr Robert Orr
ttnrepository 2943 udp TTNRepository Robert Orr Robert Orr
megaco-h248 2944 tcp Megaco H-248 Tom Taylor Tom Taylor
megaco-h248 2944 udp Megaco H-248 Tom Taylor Tom Taylor
megaco-h248 2944 sctp Megaco-H.248 text Tom Taylor Tom Taylor 2006-09
h248-binary 2945 tcp H248 Binary Tom Taylor Tom Taylor
h248-binary 2945 udp H248 Binary Tom Taylor Tom Taylor
h248-binary 2945 sctp Megaco/H.248 binary Tom Taylor Tom Taylor 2006-09
fjsvmpor 2946 tcp FJSVmpor Naoki Hayashi Naoki Hayashi
fjsvmpor 2946 udp FJSVmpor Naoki Hayashi Naoki Hayashi
gpsd 2947 tcp GPS Daemon request/response protocol Eric S. Raymond Eric S. Raymond 2010-04-19
gpsd 2947 udp GPS Daemon request/response protocol Eric S. Raymond Eric S. Raymond 2010-04-19
wap-push 2948 tcp WAP PUSH
wap-push 2948 udp WAP PUSH
wap-pushsecure 2949 tcp WAP PUSH SECURE WAP Forum WAP Forum
wap-pushsecure 2949 udp WAP PUSH SECURE WAP Forum WAP Forum
veritas-vis2 2994 tcp VERITAS VIS2 Dinkar Chivaluri Dinkar Chivaluri
veritas-vis2 2994 udp VERITAS VIS2 Dinkar Chivaluri Dinkar Chivaluri
rapidmq-reg 3094 tcp Jiiva RapidMQ Registry Mark Ericksen Mark Ericksen
rapidmq-reg 3094 udp Jiiva RapidMQ Registry Mark Ericksen Mark Ericksen
magbind 3194 tcp Rockstorm MAG protocol Jens Nilsson Jens Nilsson
magbind 3194 udp Rockstorm MAG protocol Jens Nilsson Jens Nilsson

Contact Information

Name Organization Contact URI Last Updated
Alan Robertson alanr&unix.sh
Andreas Roene andreas.roene&seolizer.de 2025-07-17
Bob Deblier bob&virtualunlimited.com
Bob Janssen bob&res.nl
Brad Spear spear&platinum.com
Brian Abramson brianab&vnd.tek.com
Christopher Allen ChristopherA&consensus.com
David Hua davhua&microsoft.com
Denis Aull Red Lion Controls Engineering&RedLion.net 2014-05-21
Dinkar Chivaluri dinkar&veritas.com
Eric S. Raymond esr&thyrsus.com 2010-04-19
Fons Rademakers Fons.Rademakers&cern.ch
Francois Painchaud fpainchaud&konshus.com
Frans S.C. Witte fscwitte&dicgroep.nl
Han Yingying hanyingying&caict.ac.cn 2024-11-26
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Yonan jim&yonan.net 2004-11
Jarkko Oikarinen jto&tolsun.oulu.fi
Jens Nilsson jens&rockstorm.se
John Richardson Citrix Systems
Leo Moesgaard leo_moesgaard&dk.ibm.com
Liu Hongyan liuhongyan&caict.ac.cn 2024-11-26
Lutz Karras karras&zeiss.de
Mark Ericksen mark&jiiva.com
Michael Zunke Michael.Zunke&ealaddin.com 2010-07-23
Mike Bello mbello&zarak.com
Mosha Pasumansky moshap&microsoft.com
Naoki Hayashi ha&fjh.se.fujitsu.co.jp
Peter Gad peter&bmc.uu.se
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
POV-Team Co-ordinator iana-port.remove-spamguard&povray.org
Red Lion Controls Engineering&RedLion.net 2014-05-21
Robert Orr rorr&teltone.com
Roger Kay r.kay&nz.dialogic.com
Stephen Dunne sdun&isma.co.uk
Stephen Tsun stsun&jetstream.com
Tim Howard timothygh&hotmail.com
Tom Bereiter
Tom Haapanen tomh&metrics.com
Tom Taylor taylor&nortelnetworks.com
Tom Taylor taylor&nortel.com 2006-09
Trevor Bell Trevor&iguana.iosoftware.com
WAP Forum wap-feedback&mail.wapforum.org
pg&uplanet.com
Yoshinobu Nakamura nakamura&np.lps.cs.fujitsu.co.jp