Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
831 tcp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
831 udp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
832 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
832 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
ftps 990 tcp ftp protocol, control, over TLS/SSL Christopher Allen Christopher Allen
ftps 990 udp ftp protocol, control, over TLS/SSL Christopher Allen Christopher Allen
stun-p1 1990 tcp cisco STUN Priority 1 port
stun-p1 1990 udp cisco STUN Priority 1 port
boscap 2990 tcp BOSCAP Dirk Hillbrecht Dirk Hillbrecht
boscap 2990 udp BOSCAP Dirk Hillbrecht Dirk Hillbrecht
bv-is 3990 tcp BindView-IS
bv-is 3990 udp BindView-IS
busycal 4990 tcp BusySync Calendar Synch. Protocol David Riggle David Riggle 2008-01-07 Defined TXT keys: Proprietary
busycal 4990 udp BusySync Calendar Synch. Protocol David Riggle David Riggle 2008-01-07 Defined TXT keys: Proprietary
wbem-exp-https 5990 tcp WBEM Export HTTPS Denise Eckstein Denise Eckstein 2004-11
wbem-exp-https 5990 udp WBEM Export HTTPS Denise Eckstein Denise Eckstein 2004-11
grasp 7017 tcp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
grasp 7017 udp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
http-wmap 8990 tcp webmail HTTP service Chris Newman Chris Newman 2007-12-03
http-wmap 8990 udp webmail HTTP service Chris Newman Chris Newman 2007-12-03
iua 9900 tcp IUA Lyndon Ong Lyndon Ong
iua 9900 udp IUA Lyndon Ong Lyndon Ong
iua 9900 sctp IUA Lyndon Ong Lyndon Ong
enrp 9901 udp enrp server channel
enrp-sctp 9901 sctp enrp server channel RFC 5353
enrp-sctp-tls 9902 sctp enrp/tls server channel RFC 5353
9903 tcp Reserved
multicast-ping 9903 udp Multicast Ping Protocol 2011-12-09 RFC 6450
9904-9908 Unassigned
domaintime 9909 tcp domaintime Jeffry Dwight Jeffry Dwight
domaintime 9909 udp domaintime Jeffry Dwight Jeffry Dwight
osm-appsrvr 9990 tcp OSM Applet Server Vinay Gupta Vinay Gupta 2003-08
osm-appsrvr 9990 udp OSM Applet Server Vinay Gupta Vinay Gupta 2003-08
rmiaux 10990 tcp Auxiliary RMI Port Eugen Bacic Eugen Bacic
rmiaux 10990 udp Auxiliary RMI Port Eugen Bacic Eugen Bacic
16951-16990 Unassigned
netconf-beep NETCONF over BEEP RFC 4744; RFC 9900
netconfsoapbeep NETCONF for SOAP over BEEP RFC 4743; RFC 9900
netconfsoaphttp NETCONF for SOAP over HTTPS RFC 4743; RFC 9900

Contact Information

Name Organization Contact URI Last Updated
Chris Newman chris.newman&oracle.com 2017-01-26
Christopher Allen ChristopherA&consensus.com
David Riggle dave&busymac.com 2008-01-07
Denise Eckstein denise.eckstein&hp.com 2004-11
Dirk Hillbrecht dirk&hillbrecht.de
Eugen Bacic eugen&texar.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeffry Dwight jeffryd&greyware.com
Lyndon Ong Lyong&ciena.com
Vinay Gupta vinay.gupta&hp.com 2003-08