Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| asip-webadmin | 311 | tcp | AppleShare IP WebAdmin | Ann Huang | Ann Huang | ||||||
| asip-webadmin | 311 | udp | AppleShare IP WebAdmin | Ann Huang | Ann Huang | ||||||
| openvms-sysipc | 557 | tcp | openvms-sysipc | Alan Potter | Alan Potter | ||||||
| openvms-sysipc | 557 | udp | openvms-sysipc | Alan Potter | Alan Potter | ||||||
| asipregistry | 687 | tcp | asipregistry | Erik Sea | Erik Sea | ||||||
| asipregistry | 687 | udp | asipregistry | Erik Sea | Erik Sea | ||||||
| XSIP-network | 1354 | tcp | Five Across XSIP Network | Glenn Reid | Glenn Reid | ||||||
| XSIP-network | 1354 | udp | Five Across XSIP Network | Glenn Reid | Glenn Reid | ||||||
| rgtp | 1431 | tcp | Reverse Gossip Transport | Ian Jackson | Ian Jackson | ||||||
| rgtp | 1431 | udp | Reverse Gossip Transport | Ian Jackson | Ian Jackson | ||||||
| ovsessionmgr | 2389 | tcp | OpenView Session Mgr | Eric Pulsipher | Eric Pulsipher | ||||||
| ovsessionmgr | 2389 | udp | OpenView Session Mgr | Eric Pulsipher | Eric Pulsipher | ||||||
| ovwdb | 2447 | tcp | OpenView NNM daemon | Eric Pulsipher | Eric Pulsipher | ||||||
| ovwdb | 2447 | udp | OpenView NNM daemon | Eric Pulsipher | Eric Pulsipher | ||||||
| ovtopmd | 2532 | tcp | OVTOPMD | Eric Pulsipher | Eric Pulsipher | ||||||
| ovtopmd | 2532 | udp | OVTOPMD | Eric Pulsipher | Eric Pulsipher | ||||||
| vpsipport | 2649 | tcp | VPSIPPORT | Joon Radley | Joon Radley | ||||||
| vpsipport | 2649 | udp | VPSIPPORT | Joon Radley | Joon Radley | ||||||
| esip | 2950 | tcp | ESIP | David Stephenson | David Stephenson | ||||||
| esip | 2950 | udp | ESIP | David Stephenson | David Stephenson | ||||||
| ovalarmsrv-cmd | 2954 | tcp | OVALARMSRV-CMD | Eric Pulsipher | Eric Pulsipher | ||||||
| ovalarmsrv-cmd | 2954 | udp | OVALARMSRV-CMD | Eric Pulsipher | Eric Pulsipher | ||||||
| rsip | 4555 | tcp | RSIP Port | RFC 3103 | |||||||
| rsip | 4555 | udp | RSIP Port | RFC 3103 | |||||||
| sds | 5059 | tcp | SIP Directory Services | Arthur Wilton | Arthur Wilton | 2006-03 | |||||
| sds | 5059 | udp | SIP Directory Services | Arthur Wilton | Arthur Wilton | 2006-03 | |||||
| sip | 5060 | tcp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sip | 5060 | udp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sip | 5060 | sctp | SIP | RFC 4168 | |||||||
| sips | 5061 | tcp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | udp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | sctp | SIP-TLS | RFC 4168 | |||||||
| tinymessage | 5104 | udp | TinyMessage | Josip Medved | Josip Medved | 2010-10-20 | |||||
| sipuri | Session Initiation Protocol Uniform Resource Identifier | Jae Woo Lee | Jae Woo Lee | Defined TXT keys: Defined in URL specification |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Alan Potter | potter&movies.enet.dec.com | |
| Ann Huang | annhuang&apple.com | |
| Arthur Wilton | art&awilton.com | 2006-03 |
| David Stephenson | david_stephenson&hp.com | |
| Eric Pulsipher | eric_pulsipher&hp.com | |
| Eric Pulsipher | eric_pulsipher&fc.hp.com | |
| Erik Sea | sea&apple.com | |
| Glenn Reid | port-reg&fiveacross.com | 2004-11 |
| Ian Jackson | iwj&cam-orl.co.uk | |
| Jae Woo Lee | jae&cs.columbia.edu | |
| Joon Radley | jradley&csir.co.za | |
| Josip Medved | jmedved&jmedved.com | 2010-10-20 |