Multimedia Internet KEYing (MIKEY) Payload Name Spaces

Created

  • 2004-05-21

Last Updated

  • 2019-02-15

Available Formats


Common Header Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
version RFC 3830
data type RFC 3830
Next payload RFC 3830
PRF func RFC 3830
CS ID map type RFC 3830

Version

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Version Reference
0x01 RFC 3830

Data Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Data Type Reference
0 Pre-shared RFC 3830
1 PSK ver msg RFC 3830
2 Public key RFC 3830
3 PK ver msg RFC 3830
4 D-H init RFC 3830
5 D-H resp RFC 3830
6 Error RFC 3830
7 DHHMAC init RFC 4650
8 DHHMAC resp RFC 4650
9 RSA-R I_MSG RFC 4738
10 RSA-R R_MSG RFC 4738
11 REQUEST_INIT_PSK RFC 6043
12 REQUEST_INIT_PK RFC 6043
13 REQUEST_RESP RFC 6043
14 TRANSFER_INIT RFC 6043
15 TRANSFER_RESP RFC 6043
16 RESOLVE_INIT_PSK RFC 6043
17 RESOLVE_INIT_PK RFC 6043
18 RESOLVE_RESP RFC 6043
19 REQUEST_KEY_PSK RFC 6267
20 REQUEST_KEY_PKE RFC 6267
21 REQUEST_KEY_RESP RFC 6267
22 I_MESSAGE_1 RFC 6267
23 R_MESSAGE_1 RFC 6267
24 I_MESSAGE_2 RFC 6267
25 R_MESSAGE_2 RFC 6267
26 SAKKE msg RFC 6509
27-240 Unassigned
241-255 Reserved for Private Use

Next Payload

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Next Payload Section in Document Reference
0 Last payload RFC 3830
1 KEMAC 6.2 RFC 3830
2 PKE 6.3 RFC 3830
3 DH 6.4 RFC 3830
4 SIGN 6.5 RFC 3830
5 T 6.6 RFC 3830
6 ID 6.7 RFC 3830
7 CERT 6.7 RFC 3830
8 CHASH 6.8 RFC 3830
9 V 6.9 RFC 3830
10 SP 6.10 RFC 3830
11 RAND 6.11 RFC 3830
12 ERR 6.12 RFC 3830
13 TR 6.4 RFC 6043
14 IDR 6.6 RFC 6043
15 RANDR 6.8 RFC 6043
16 TP 6.10 RFC 6043
17 TICKET 6.10 RFC 6043
18-19 Unassigned
20 Key data 6.13 RFC 3830
21 General Ext. 6.15 RFC 3830
22 IBAKE 6.1 RFC 6267
23 ESK 6.1 RFC 6267
24 SK 6.1 RFC 6267
25 ECCPT 6.1 RFC 6267
26 SAKKE 4.2 RFC 6509
27-240 Unassigned
241-255 Reserved for Private Use

PRF Func

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value PRF Func Section in Document Reference
0 MIKEY-1 4.1.3 RFC 3830
1 PRF-HMAC-SHA-256 6.1 RFC 6043
2-111 Unassigned
112-127 Reserved for Private Use

CS ID Map Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value CS ID Map Type Reference
0 SRTP-ID RFC 3830
1 Empty map RFC 4563
2 GENERIC-ID RFC 6043
3-240 Unassigned
241-255 Reserved for Private Use RFC 3830

Key Data Transport Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
Encr Alg RFC 3830
MAC Alg RFC 3830

Encr Alg

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Encr Alg Section in Document Reference
0 NULL 4.2.3 RFC 3830
1 AES-CM-128 4.2.3 RFC 3830
2 AES-KW-128 4.2.3 RFC 3830
3 AES-CM-256 6.2 RFC 6043
4-240 Unassigned
241-255 Reserved for Private Use

MAC alg

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value MAC Alg Section in Document Reference
0 NULL 4.2.4 RFC 3830
1 HMAC-SHA-1-160 4.2.4 RFC 3830
2 HMAC-SHA-256-256 6.2 RFC 6043
3-240 Unassigned
241-255 Reserved for Private Use

Envelope Data Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
C Envelope Key Cache Indicator RFC 3830

C Envelope Key Cache Indicator

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Cache Type Reference
0 No cache RFC 3830
1 Cache RFC 3830
2 Cache for CSB RFC 3830
3 Unassigned

DH Data Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
DH-Group RFC 3830

DH-Group

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value DH-Group Comments DH Value length (bits) Reference
0 OAKLEY 5 Mandatory 1536 RFC 3830
1 OAKLEY 1 768 RFC 3830
2 OAKLEY 2 1024 RFC 3830
3-240 Unassigned
241-255 Reserved for Private Use

Signature Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
S Type RFC 3830

S Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value S Type Reference
0 RSA/PKCS#1/1.5 RFC 3830
1 RSA/PSS RFC 3830
2 ECCSI RFC 6509
3-15 Unassigned

Timestamp Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
TS Type RFC 3830

TS Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value TS Type Reference
0 NTP-UTC RFC 3830
1 NTP RFC 3830
2 COUNTER RFC 3830
3 NTP-UTC-32 RFC 6043
4-240 Unassigned
241-255 Reserved for Private Use

ID Payload and Certificate Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
ID Type RFC 3830
Cert Type RFC 3830

ID Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value ID Type Reference
0 NAI RFC 3830
1 URI RFC 3830
2 Byte string RFC 6043
3-240 Unassigned
241-255 Reserved for Private Use

Cert Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Cert Type Reference
0 X.509v3 RFC 3830
1 X.509v3 URL RFC 3830
2 X.509v3 Sign RFC 3830
3 X.509v3 Encr RFC 3830
4-240 Unassigned
241-255 Reserved for Private Use

Cert Hash Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
Hash func RFC 3830

Hash Func

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Hash Func Reference
0 SHA-1 RFC 3830
1 MD5 RFC 3830
2 SHA-256 RFC 6043
3-240 Unassigned
241-255 Reserved for Private Use

Security Policy Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
Prot Type RFC 3830

Prot Type

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Prot Type Reference
0 SRTP RFC 3830
1 TESLA RFC 4442
2-240 Unassigned
241-255 Reserved for Private Use

MIKEY Security Protocol Parameters

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

SRTP Type Meaning Reference
0 Encryption algorithm RFC 3830
1 Session Encr. key length RFC 3830
2 Authentication algorithm RFC 3830
3 Session Auth. key length RFC 3830
4 Session Salt key length RFC 3830
5 SRTP Pseudo Random Function RFC 3830
6 Key derivation rate RFC 3830
7 SRTP encryption off/on RFC 3830
8 SRTCP encryption off/on RFC 3830
9 sender's FEC order RFC 3830
10 SRTP authentication off/on RFC 3830
11 Authentication tag length RFC 3830
12 SRTP prefix length RFC 3830
13 ROC transmission rate RFC 4771
14 SRTP Auth. algorithm RFC 4771
15 SRTCP Auth. algorithm RFC 4771
16 SRTP Session Auth. key len RFC 4771
17 SRTCP Session Auth. key len RFC 4771
18 SRTP Authentication tag len RFC 4771
19 SRTCP Authentication tag len RFC 4771
20 AEAD authentication tag length RFC 7714
21-240 Unassigned
241-255 Reserved

Encryption algorithm (Value 0)

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value SRTP encr alg Reference
0 NULL RFC 3830
1 AES-CM RFC 3830
2 AES-F8 RFC 3830
3 SEED-CTR RFC 5748
4 SEED-CCM RFC 5748
5 SEED-GCM RFC 5748
6 AES-GCM RFC 7714
7 ARIA-CTR RFC 8269
8 ARIA-GCM RFC 8269
9-240 Unassigned
241-255 Reserved for Private Use

Authentication algorithm (Value 2)

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value SRTP auth alg Reference
0 NULL RFC 3830
1 HMAC-SHA-1 RFC 3830
2 RCCm1 RFC 4771
3 RCCm2 RFC 4771
4 RCCm3 RFC 4771
5-240 Unassigned
241-255 Reserved for Private Use

SRTP Pseudo Random Function (Value 5)

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value SRTP PRF Reference
0 AES-CM RFC 3830
1 SEED-CTR RFC 5748
2 ARIA-CTR RFC 8269
3-240 Unassigned
241-255 Reserved for Private Use

sender's FEC order (Value 9)

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value FEC order Reference
0 FEC-SRTP RFC 3830
1-240 Unassigned
241-255 Reserved for Private Use

Error Payload Name Spaces

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
Error No RFC 3830

Error No

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Error No Reference
0 Auth failure RFC 3830
1 Invalid TS RFC 3830
2 Invalid PRF RFC 3830
3 Invalid MAC RFC 3830
4 Invalid EA RFC 3830
5 Invalid HA RFC 3830
6 Invalid DH RFC 3830
7 Invalid ID RFC 3830
8 Invalid Cert RFC 3830
9 Invalid SP RFC 3830
10 Invalid SPpar RFC 3830
11 Invalid DT RFC 3830
12 Unspecified error RFC 3830
13 Unsupported message type RFC 4738
14 Invalid TICKET RFC 6043
15 Invalid TPpar RFC 6043
16-240 Unassigned
241-255 Reserved for Private Use

Key Data Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
Type RFC 3830
KV Type RFC 3830

Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Type Reference
0 TGK RFC 3830
1 TGK+SALT RFC 3830
2 TEK RFC 3830
3 TEK+SALT RFC 3830
4 GTGK RFC 6043
5 GTGK+SALT RFC 6043
6 MPK RFC 6043
7 K_PR RFC 6267
8-15 Unassigned

KV Type

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value KV Reference
0 Null RFC 3830
1 SPI RFC 3830
2 Interval RFC 3830
3-15 Unassigned

General Extensions Payload Field Names

Registration Procedure(s)

  • IETF Review or IESG Approval

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Field Name Reference
Type RFC 3830

Type

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 3830: MIKEY: Multimedia Internet KEYing
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Type Reference
0 Vendor ID RFC 3830
1 SDP IDs RFC 3830
2 TESLA I-Key RFC 4442
3 Key ID RFC 4563
4 CSB_ID RFC 4738
5 OMA BCAST RFC 4909
6 SAKKE-to-self 3GPP TS 33.180, Section E.5; Tim Woodward
7 3GPP key parameters 3GPP TS 33.180, Section E.6; Tim Woodward
8-240 Unassigned
241-255 Reserved for Private Use

Key ID Types (Value 3)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 4563: The Key ID Information Type for the General Extension Payload in Multimedia Internet KEYing (MIKEY)
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value Key ID Type Comment Reference
0 MBMS Key Domain ID ID of the group key domain RFC 4563
1 MBMS Service Key ID ID of the group key RFC 4563
2 MBMS Transport Key ID ID of the group traffic key RFC 4563
3-240 Unassigned
241-255 Reserved for Private Use

OMA BCAST Data Subtype (Value 5)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 4909: Multimedia Internet KEYing (MIKEY) General Extension Payload for Open Mobile Alliance BCAST LTKM/STKM Transport
  • RFC 6309: IANA Rules for MIKEY (Multimedia Internet KEYing)

Available Formats

Value OMA BCAST Types Comment Reference
0 Reserved RFC 4909
1 LTKM RFC 4909
2 STKM RFC 4909
3 LTKM Reporting RFC 5410
4 Parental Control RFC 5410
5-191 Unassigned
192-255 Reserved for Private Use

TS Role

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6043: MIKEY-TICKET: Ticket-Based Modes of Key Distribution in Multimedia Internet KEYing (MIKEY)

Available Formats

Value TS Role Reference
0 Reserved RFC 6043
1 Time of issue (TRi) RFC 6043
2 Start of validity period (TRs) RFC 6043
3 End of validity period (TRe) RFC 6043
4 Rekeying interval (TRr) RFC 6043
5-239 Unassigned
240-254 Reserved for Private Use RFC 6043
255 Reserved RFC 6043

ID Role

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6043: MIKEY-TICKET: Ticket-Based Modes of Key Distribution in Multimedia Internet KEYing (MIKEY)

Available Formats

Value ID Role Reference
0 Reserved RFC 6043
1 Initiator (IDRi) RFC 6043
2 Responder (IDRr) RFC 6043
3 KMS (IDRkms) RFC 6043
4 Pre-Shared Key (IDRpsk) RFC 6043
5 Application (IDRapp) RFC 6043
6 Initiator's KMS (IDRkmsi) RFC 6509
7 Responder's KMS (IDRkmsr) RFC 6509
8 Hashed Initiator (IDRuidi) 3GPP TS 33.180, Section E.6.7; Tim Woodward
9 Hashed Responder (IDRuidr) 3GPP TS 33.180, Section E.6.7; Tim Woodward
10-239 Unassigned
240-254 Reserved for Private Use RFC 6043
255 Reserved RFC 6043

RAND Role

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6043: MIKEY-TICKET: Ticket-Based Modes of Key Distribution in Multimedia Internet KEYing (MIKEY)

Available Formats

Value RAND Role Reference
0 Reserved RFC 6043
1 Initiator (RANDRi) RFC 6043
2 Responder (RANDRr) RFC 6043
3 KMS (RANDRkms) RFC 6043
4-239 Unassigned
240-254 Reserved for Private Use RFC 6043
255 Reserved RFC 6043

Ticket Type

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6043: MIKEY-TICKET: Ticket-Based Modes of Key Distribution in Multimedia Internet KEYing (MIKEY)

Available Formats

Value Ticket Type Reference
0 Reserved RFC 6043
1 MIKEY base ticket RFC 6043
2 3GPP base ticket RFC 6043
3-61439 Unassigned
61440-65534 Reserved for Private Use RFC 6043
65535 Reserved RFC 6043

ECC Curve

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6267: MIKEY-IBAKE: Identity-Based Authenticated Key Exchange (IBAKE) Mode of Key Distribution in Multimedia Internet KEYing (MIKEY)

Available Formats

Value ECC curve Reference
0 Reserved RFC 6267
1 ECPRGF192Random / P-192 / secp192r1 RFC 6267
2 EC2NGF163Random / B-163 / sect163r2 RFC 6267
3 EC2NGF163Koblitz / K-163 / sect163k1 RFC 6267
4 EC2NGF163Random2 / none / sect163r1 RFC 6267
5 ECPRGF224Random / P-224 / secp224r1 RFC 6267
6 EC2NGF233Random / B-233 / sect233r1 RFC 6267
7 EC2NGF233Koblitz / K-233 / sect233k1 RFC 6267
8 ECPRGF256Random / P-256 / secp256r1 RFC 6267
9 EC2NGF283Random / B-283 / sect283r1 RFC 6267
10 EC2NGF283Koblitz / K-283 / sect283k1 RFC 6267
11 ECPRGF384Random / P-384 / secp384r1 RFC 6267
12 EC2NGF409Random / B-409 / sect409r1 RFC 6267
13 EC2NGF409Koblitz / K-409 / sect409k1 RFC 6267
14 ECPRGF521Random / P-521 / secp521r1 RFC 6267
15 EC2NGF571Random / B-571 / sect571r1 RFC 6267
16 EC2NGF571Koblitz / K-571 / sect571k1 RFC 6267
17-239 Unassigned
240-254 Private Use RFC 6267
255 Reserved RFC 6267

SK sub-payload

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6267: MIKEY-IBAKE: Identity-Based Authenticated Key Exchange (IBAKE) Mode of Key Distribution in Multimedia Internet KEYing (MIKEY)

Available Formats

Value Type Reference
0 Reserved RFC 6267
1 Secret Key (SK) RFC 6267
2-15 Unassigned

SAKKE params

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6509: MIKEY-SAKKE: Sakai-Kasahara Key Encryption in Multimedia Internet KEYing (MIKEY)

Available Formats

Value SAKKE params Reference
0 Reserved RFC 6509
1 Parameter Set 1 RFC 6509
2-239 Unassigned
240-254 Reserved for Private Use RFC 6509
255 Reserved RFC 6509

ID Scheme

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Daniel Migault

Reference

  • RFC 6509: MIKEY-SAKKE: Sakai-Kasahara Key Encryption in Multimedia Internet KEYing (MIKEY)

Available Formats

Value ID Scheme Reference
0 Reserved RFC 6509
1 tel URI with monthly keys RFC 6509
2 3GPP MCX hashed UID 3GPP TS 33.180, Sections E.1.2 and F.2.1; Tim Woodward
3-239 Unassigned
240-254 Reserved for Private Use RFC 6509
255 Reserved RFC 6509

Contact Information

Name Contact URI Last Updated
Tim Woodward tim.woodward&motorolasolutions.com 2019-02-15