Multiprotocol Label Switching (MPLS) Label Switched Paths (LSPs) Ping Parameters
Created
- 2006-01-12
Last Updated
- 2026-04-30
Available Formats
Message Types
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-191 | Standards Action | |
| 192-247 | RFC Required | |
| 248-251 | Experimental Use | Reserved, not to be assigned |
| 252-255 | Private Use | Reserved, not to be assigned |
| Value | Meaning | Reference |
|---|---|---|
| 0 | Reserved | RFC 9041 |
| 1 | MPLS Echo Request | RFC 8029 |
| 2 | MPLS Echo Reply | RFC 8029 |
| 3 | MPLS Proxy Ping Request | RFC 7555 |
| 4 | MPLS Proxy Ping Reply | RFC 7555 |
| 5 | MPLS Relayed Echo Reply | RFC 7743 |
| 6-247 | Unassigned | |
| 248-251 | Reserved for Experimental Use | RFC 9041 |
| 252-255 | Reserved for Private Use | RFC 8029 |
Reply Modes
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-191 | Standards Action | |
| 192-247 | RFC Required | |
| 248-251 | Experimental Use | Reserved, not to be assigned |
| 252-255 | Private Use | Reserved, not to be assigned |
| Value | Meaning | Reference |
|---|---|---|
| 0 | Reserved | RFC 9041 |
| 1 | Do not reply | RFC 8029 |
| 2 | Reply via an IPv4/IPv6 UDP packet | RFC 8029 |
| 3 | Reply via an IPv4/IPv6 UDP packet with Router Alert (DEPRECATED) | RFC 8029; RFC 9570 |
| 4 | Reply via application-level control channel | RFC 8029 |
| 5 | Reply via Specified Path | RFC 7110 |
| 6-247 | Unassigned | |
| 248-251 | Reserved for Experimental Use | RFC 9041 |
| 252-255 | Reserved for Private Use | RFC 8029 |
Return Codes
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-191 | Standards Action | |
| 192-247 | RFC Required | |
| 248-251 | Experimental Use | Reserved, not to be assigned |
| 252-255 | Private Use | Reserved, not to be assigned |
| Value | Meaning | Reference |
|---|---|---|
| 0 | No Return Code | RFC 8029 |
| 1 | Malformed echo request received | RFC 8029 |
| 2 | One or more of the TLVs was not understood | RFC 8029 |
| 3 | Replying router is an egress for the FEC at stack-depth <RSC> | RFC 8029 |
| 4 | Replying router has no mapping for the FEC at stack-depth <RSC> | RFC 8029 |
| 5 | Downstream Mapping Mismatch (See [1]) | RFC 8029 |
| 6 | Upstream Interface Index Unknown (See [1]) | RFC 8029 |
| 7 | Reserved | RFC 8029 |
| 8 | Label switched at stack-depth <RSC> | RFC 8029 |
| 9 | Label switched but no MPLS forwarding at stack-depth <RSC> | RFC 8029 |
| 10 | Mapping for this FEC is not the given label at stack-depth <RSC> | RFC 8029 |
| 11 | No label entry at stack-depth <RSC> | RFC 8029 |
| 12 | Protocol not associated with interface at FEC stack-depth <RSC> | RFC 8029 |
| 13 | Premature termination of ping due to label stack shrinking to a single label | RFC 8029 |
| 14 | See DDMAP TLV for meaning of Return Code and Return Subcode (See [2]) | RFC 8029 |
| 15 | Label switched with FEC change | RFC 8029 |
| 16 | Proxy Ping not authorized | RFC 7555 |
| 17 | Proxy Ping parameters need to be modified | RFC 7555 |
| 18 | MPLS Echo Request could not be sent | RFC 7555 |
| 19 | Replying router has FEC mapping for topmost FEC | RFC 7555 |
| 20 | One or more TLVs not returned due to MTU size | RFC 7743 |
| 21 | OAM Problem/Unsupported BFD Version | RFC 7759 |
| 22 | OAM Problem/Unsupported BFD Encapsulation format | RFC 7759 |
| 23 | OAM Problem/Unsupported BFD Authentication Type | RFC 7759 |
| 24 | OAM Problem/Mismatch of BFD Authentication Key ID | RFC 7759 |
| 25 | OAM Problem/Unsupported Timestamp Format | RFC 7759 |
| 26 | OAM Problem/Unsupported Delay Mode | RFC 7759 |
| 27 | OAM Problem/Unsupported Loss Mode | RFC 7759 |
| 28 | OAM Problem/Delay variation unsupported | RFC 7759 |
| 29 | OAM Problem/Dyadic mode unsupported | RFC 7759 |
| 30 | OAM Problem/Loopback mode unsupported | RFC 7759 |
| 31 | OAM Problem/Combined mode unsupported | RFC 7759 |
| 32 | OAM Problem/Fault management signaling unsupported | RFC 7759 |
| 33 | OAM Problem/Unable to create fault management association | RFC 7759 |
| 34 | OAM Problem/PM Configuration Error | RFC 7759 |
| 35 | Mapping for this FEC is not associated with the incoming interface | RFC 8287, Section 7.4 |
| 36 | Replying router is an egress for the address in the Egress TLV for the FEC at stack depth <RSC> | RFC 9655 |
| 37 | Replying router is egress for the FEC at the stack depth. In addition, the BUM packets are dropped on the ES corresponding to the ESI received in EVPN Ethernet Auto-Discovery sub-TLV because of the Split Horizon Group filtering. | RFC 9489 |
| 38 | Replying router is egress for the FEC at the stack depth. In addition, the BUM packets are forwarded because there is no ES corresponding to the ESI received in EVPN Ethernet Auto-Discovery sub-TLV. | RFC 9489 |
| 39-191 | Unassigned | |
| 192 | Inappropriate Target FEC Stack sub-TLV present | RFC 9612 |
| 193 | Failed to establish the BFD session. The specified reverse path was not found. | RFC 9612 |
| 194-247 | Unassigned | |
| 248-251 | Reserved for Experimental Use | RFC 9041 |
| 252-255 | Reserved for Private Use | RFC 8029 |
TLVs
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16383 | Standards Action | This range is for TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 16384-31739 | RFC Required | This range is for TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31740-31743 | Experimental Use | Reserved, not to be assigned. This range is for TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | First Come First Served | This range is for TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 32768-49161 | Standards Action | This range is for TLVs that can be silently dropped if not recognized. |
| 49162-64507 | RFC Required | This range is for TLVs that can be silently dropped if not recognized. |
| 64508-64511 | Experimental Use | Reserved, not to be assigned. This range is for TLVs that can be silently dropped if not recognized. |
| 64512-65535 | First Come First Served | This range is for TLVs that can be silently dropped if not recognized. |
| Type | TLV Name | Reference | Sub-TLV Registry |
|---|---|---|---|
| 0 | Reserved | RFC 9041 | |
| 1 | Target FEC Stack | RFC 8029 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-1-16-21 |
| 2 | Downstream Mapping (DEPRECATED) | RFC 8029 | No Sub-TLVs |
| 3 | Pad | RFC 8029 | No Sub-TLVs |
| 4 | LSR Capability | RFC 8611 | No Sub-TLVs |
| 5 | Vendor Enterprise Number | RFC 8029 | No Sub-TLVs |
| 6 | Detailed Interface and Label Stack | RFC 8611 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-6 |
| 7 | Interface and Label Stack | RFC 8029 | No Sub-TLVs |
| 8 | Unassigned | ||
| 9 | Errored TLVs | RFC 8029 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-9 |
| 10 | Reply TOS Byte | RFC 8029 | No Sub-TLVs |
| 11 | P2MP Responder Identifier | RFC 6425 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-11 |
| 12 | Echo Jitter | RFC 6425 | No Sub-TLVs |
| 13 | Source ID | RFC 6426 | No Sub-TLVs |
| 14 | Destination ID | RFC 6426 | No Sub-TLVs |
| 15 | BFD Discriminator | RFC 5884 | No Sub-TLVs |
| 16 | Reverse-path Target FEC Stack | RFC 6426 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-1-16-21 |
| 17-19 | Unassigned | ||
| 20 | Downstream Detailed Mapping | RFC 8029 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-20 |
| 21 | Reply Path | RFC 7110 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-1-16-21 |
| 22 | Reply TC | RFC 7110 | No Sub-TLVs |
| 23 | Proxy Echo Parameters | RFC 7555 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-23 |
| 24 | Reply-to Address | RFC 7555 | No Sub-TLVs |
| 25 | Upstream Neighbor Address | RFC 7555 | No Sub-TLVs |
| 26 | Downstream Neighbor Address | RFC 7555 | No Sub-TLVs |
| 27 | MPLS OAM Functions | RFC 7759 | https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-27 |
| 28 | EGRESS TLV (DEPRECATED) | RFC 9655 | No Sub-TLVs |
| 29-16383 | Unassigned | ||
| 16384 | BFD Reverse Path | RFC 9612 | Only non-multicast sub-TLVs (already defined or to be defined in the future) in the "Sub-TLVs for TLV Types 1, 16, and 21" registry at https://www.iana.org/assignments/mpls-lsp-ping-parameters/mpls-lsp-ping-parameters.xml#sub-tlv-1-16-21 are permitted to be used in this field. Other sub-TLVs MUST NOT be used. |
| 16385-31739 | Unassigned | ||
| 31740-31743 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | Unassigned | ||
| 32768 | Relay Node Address Stack TLV | RFC 7743 | No Sub-TLVs |
| 32769 | Time To Live | RFC 7394 | No Sub-TLVs |
| 32770 | Reply Mode Order TLV | RFC 7737 | No Sub-TLVs |
| 32771 | Egress TLV | RFC 9655 | No Sub-TLVs |
| 32772-64507 | Unassigned | ||
| 64508-64511 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for TLVs that can be silently dropped if not recognized. |
| 64512-65535 | Unassigned |
Sub-TLVs for TLV Types 1, 16, and 21
Reference
- RFC 6425: Detecting Data-Plane Failures in Point-to-Multipoint MPLS - Extensions to LSP Ping
- RFC 6426: MPLS On-Demand Connectivity Verification and Route Tracing
- RFC 7110: Return Path Specified Label Switched Path (LSP) Ping
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16383 | Standards Action | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 16384-31739 | RFC Required | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31740-31743 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | First Come First Served | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 32768-49161 | Standards Action | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 49162-64507 | RFC Required | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64508-64511 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | First Come First Served | This range is for sub-TLVs that can be silently dropped if not recognized. |
| Sub-Type | Sub-TLV Name | Reference | Comment |
|---|---|---|---|
| 0 | Reserved | RFC 9041 | |
| 1 | LDP IPv4 prefix | RFC 8029 | |
| 2 | LDP IPv6 prefix | RFC 8029 | |
| 3 | RSVP IPv4 LSP | RFC 8029 | |
| 4 | RSVP IPv6 LSP | RFC 8029 | |
| 5 | Unassigned | ||
| 6 | VPN IPv4 prefix | RFC 8029 | |
| 7 | VPN IPv6 prefix | RFC 8029 | |
| 8 | L2 VPN endpoint | RFC 8029 | |
| 9 | "FEC 128" Pseudowire - IPv4 | RFC 8029 | DEPRECATED |
| 10 | "FEC 128" Pseudowire - IPv4 | RFC 8029 | |
| 11 | "FEC 129" Pseudowire - IPv4 | RFC 8029 | |
| 12 | BGP labeled IPv4 prefix | RFC 8029 | |
| 13 | BGP labeled IPv6 prefix | RFC 8029 | |
| 14 | Generic IPv4 prefix | RFC 8029 | |
| 15 | Generic IPv6 prefix | RFC 8029 | |
| 16 | Nil FEC | RFC 8029 | |
| 17 | RSVP P2MP IPv4 Session | RFC 6425 | |
| 18 | RSVP P2MP IPv6 Session | RFC 6425 | |
| 19 | Multicast P2MP LDP FEC Stack | RFC 6425 | |
| 20 | Multicast MP2MP LDP FEC Stack | RFC 6425 | |
| 21 | Unassigned | ||
| 22 | Static LSP | RFC 6426 | |
| 23 | Static Pseudowire | RFC 6426 | |
| 24 | "FEC 128" Pseudowire - IPv6 | RFC 8029 | |
| 25 | "FEC 129" Pseudowire - IPv6 | RFC 8029 | |
| 26 | IPv4 RSVP Tunnel | RFC 7110 | |
| 27 | IPv6 RSVP Tunnel | RFC 7110 | |
| 28 | Static Tunnel | RFC 7110 | |
| 29 | HSMP-upstream LDP FEC Stack | RFC 7140 | |
| 30 | HSMP-downstream LDP FEC Stack | RFC 7140 | |
| 31 | MT LDP IPv4 prefix | RFC 7307 | |
| 32 | MT LDP IPv6 prefix | RFC 7307 | |
| 33 | Entropy label FEC | RFC 8012 | |
| 34 | IPv4 IGP-Prefix Segment ID | RFC 8287, Section 5.1; RFC 8690 | |
| 35 | IPv6 IGP-Prefix Segment ID | RFC 8287, Section 5.2; RFC 8690 | |
| 36 | IGP-Adjacency Segment ID | RFC 8287, Section 5.3; RFC 8690 | |
| 37 | P2MP Pseudowire sub-TLV | RFC 8339 | |
| 38 | PeerAdj SID | RFC 9703 | |
| 39 | PeerNode SID | RFC 9703 | |
| 40 | PeerSet SID | RFC 9703 | |
| 41 | SR MPLS P2MP Policy Tree Instance | RFC 9961 | |
| 42 | EVPN MAC/IP | RFC 9489 | |
| 43 | EVPN Inclusive Multicast | RFC 9489 | |
| 44 | EVPN Ethernet Auto-Discovery | RFC 9489 | |
| 45 | EVPN IP Prefix | RFC 9489 | |
| 46 | SID only, in the form of MPLS label | RFC 9716, Section 4.1 | |
| 47 | IPv4 Node Address with an optional SID for SR-MPLS | RFC 9716, Section 4.2 | |
| 48 | IPv6 Node Address with an optional SID for SR-MPLS | RFC 9716, Section 4.3 | |
| 49 | SR Policy Associated PSID - IPv4 | RFC 9884, Section 3.1 | |
| 50 | SR Candidate Path Associated PSID - IPv4 | RFC 9884, Section 3.2 | |
| 51 | SR Segment List Associated PSID - IPv4 | RFC 9884, Section 3.3 | |
| 52 | SR Policy Associated PSID - IPv6 | RFC 9884, Section 3.4 | |
| 53 | SR Candidate Path Associated PSID - IPv6 | RFC 9884, Section 3.5 | |
| 54 | SR Segment List Associated PSID - IPv6 | RFC 9884, Section 3.6 | |
| 55-31739 | Unassigned | ||
| 31740-31743 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744 | IPv4 BGP Classful Transport | RFC 9832 | |
| 31745 | IPv6 BGP Classful Transport | RFC 9832 | |
| 31746-64507 | Unassigned | ||
| 64508-64511 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | Unassigned |
Sub-TLVs for TLV Type 6
Reference
- RFC 8611: Label Switched Path (LSP) Ping and Traceroute Multipath Support for Link Aggregation Group (LAG) Interfaces
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16383 | Standards Action | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 16384-31739 | RFC Required | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31740-31743 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | First Come First Served | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 32768-49161 | Standards Action | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 49162-64507 | RFC Required | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64508-64511 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | First Come First Served | This range is for sub-TLVs that can be silently dropped if not recognized. |
| Sub-Type | Sub-TLV Name | Reference | Comment |
|---|---|---|---|
| 0 | Reserved | RFC 8611; RFC 9041 | |
| 1 | Incoming Label Stack | RFC 8611 | |
| 2 | Incoming Interface Index | RFC 8611 | |
| 3-31739 | Unassigned | ||
| 31740-31743 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-64507 | Unassigned | ||
| 64508-64511 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | Unassigned |
Sub-TLVs for TLV Type 9
Registration Procedure(s)
- None
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
Available Formats
| Sub-Type | Sub-TLV Name | Reference | Comment |
|---|---|---|---|
| Any value | TLV Not Understood | RFC 8029 | The entire errored TLV is returned |
Sub-TLVs for TLV Type 11
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16383 | Standards Action | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 16384-31739 | RFC Required | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31740-31743 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | First Come First Served | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 32768-49161 | Standards Action | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 49162-64507 | RFC Required | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64508-64511 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | First Come First Served | This range is for sub-TLVs that can be silently dropped if not recognized. |
| Sub-Type | Sub-TLV Name | Reference | Comment |
|---|---|---|---|
| 0 | Reserved | RFC 9041 | |
| 1 | IPv4 Egress Address P2MP Responder | RFC 6425 | |
| 2 | IPv6 Egress Address P2MP Responder | RFC 6425 | |
| 3 | IPv4 Node Address P2MP Responder | RFC 6425 | |
| 4 | IPv6 Node Address P2MP Responder | RFC 6425 | |
| 5-31739 | Unassigned | ||
| 31740-31743 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-64507 | Unassigned | ||
| 64508-64511 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | Unassigned |
Sub-TLVs for TLV Type 20
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16383 | Standards Action | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 16384-31739 | RFC Required | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31740-31743 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | First Come First Served | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 32768-49161 | Standards Action | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 49162-64507 | RFC Required | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64508-64511 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | First Come First Served | This range is for sub-TLVs that can be silently dropped if not recognized. |
| Sub-Type | Sub-TLV Name | Reference | Comment |
|---|---|---|---|
| 0 | Reserved | RFC 9041 | |
| 1 | Multipath data | RFC 8029 | |
| 2 | Label stack | RFC 8029 | |
| 3 | FEC stack change | RFC 8029 | |
| 4 | Local Interface Index | RFC 8611 | |
| 5 | Remote Interface Index | RFC 8611 | |
| 6-31739 | Unassigned | ||
| 31740-31743 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-64507 | Unassigned | ||
| 64508-64511 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | Unassigned |
Sub-TLVs for TLV Type 23
Reference
- RFC 7555: Proxy MPLS Echo Request
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16383 | Standards Action | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 16384-31739 | RFC Required | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31740-31743 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | First Come First Served | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 32768-49161 | Standards Action | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 49162-64507 | RFC Required | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64508-64511 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | First Come First Served | This range is for sub-TLVs that can be silently dropped if not recognized. |
| Sub-Type | Sub-TLV Name | Reference | Comment |
|---|---|---|---|
| 0 | Reserved | RFC 7555 | |
| 1 | Next Hop | RFC 7555 | |
| 2-31739 | Unassigned | ||
| 31740-31743 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-64507 | Unassigned | ||
| 64508-64511 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | Unassigned |
Sub-TLVs for TLV Type 27
Reference
- RFC 7759: Configuration of Proactive Operations, Administration, and Maintenance (OAM) Functions for MPLS-Based Transport Networks Using Label Switched Path (LSP) Ping
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 9041: Updating the MPLS Label Switched Paths (LSPs) Ping Parameters IANA Registry
Available Formats
| Range | Registration Procedures | Note |
|---|---|---|
| 0-16383 | Standards Action | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 16384-31739 | RFC Required | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31740-31743 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-32767 | First Come First Served | This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 32768-49161 | Standards Action | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 49162-64507 | RFC Required | This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64508-64511 | Experimental Use | Reserved, not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | First Come First Served | This range is for sub-TLVs that can be silently dropped if not recognized. |
| Sub-Type | Sub-TLV Name | Reference | Comment |
|---|---|---|---|
| 0 | Reserved | RFC 7759 | |
| 1-99 | Unassigned | ||
| 100 | BFD Configuration | RFC 7759 | |
| 101 | BFD Local Discriminator | RFC 7759 | |
| 102 | BFD Negotiation Timer Parameters | RFC 7759 | |
| 103 | BFD Authentication | RFC 7759 | |
| 104 | Traffic Class | RFC 7759 | |
| 105-199 | Unassigned | ||
| 200 | Performance Monitoring | RFC 7759 | |
| 201 | PM Loss Measurement | RFC 7759 | |
| 202 | PM Delay Measurement | RFC 7759 | |
| 203-299 | Unassigned | ||
| 300 | Fault Management Signal | RFC 7759 | |
| 301-399 | Unassigned | ||
| 400 | Source MEP-ID | RFC 7759 | |
| 401-31739 | Unassigned | ||
| 31740-31743 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that require an error message if not recognized. RFC 9041, Section 3.1 |
| 31744-64507 | Unassigned | ||
| 64508-64511 | Reserved for Experimental Use | RFC 9041 | Not to be assigned. This range is for sub-TLVs that can be silently dropped if not recognized. |
| 64512-65535 | Unassigned |
Measurement Timestamp Type
Reference
- RFC 6374: Packet Loss and Delay Measurement for MPLS Networks
- RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry
Note
Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.
Loss/Delay Measurement Control Code: Query Codes
Reference
- RFC 6374: Packet Loss and Delay Measurement for MPLS Networks
- RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry
Note
Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.
Loss/Delay Measurement Control Code: Response Codes
Reference
- RFC 6374: Packet Loss and Delay Measurement for MPLS Networks
- RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry
Note
Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.
MPLS Loss/Delay Measurement TLV Object
Reference
- RFC 6374: Packet Loss and Delay Measurement for MPLS Networks
- RFC 7214: Moving Generic Associated Channel (G-ACh) IANA Registries to a New Registry
Note
Moved to Generic Associated Channel (G-ACh) Parameters
per RFC 7214.
Global Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 6425: Detecting Data-Plane Failures in Point-to-Multipoint MPLS - Extensions to LSP Ping
Available Formats
| Bit number | Name | Reference |
|---|---|---|
| 15 | V Flag | RFC 8029 |
| 14 | T Flag | RFC 6425 |
| 13 | Validate Reverse Path | RFC 6426; RFC Errata 4012 |
| 12-0 | Unassigned | RFC 8029 |
Downstream Detailed Mapping Address Type Registry
Registration Procedure(s)
- Standards Action
Reference
- RFC 6426: MPLS On-Demand Connectivity Verification and Route Tracing
- RFC 7555: Proxy MPLS Echo Request
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
Note
When a code point is assigned that is not also assigned in the Next Hop Address Type Registry, the code point there must be marked "Reserved".
Available Formats
Next Hop Address Type Registry
Registration Procedure(s)
- Standards Action
Reference
- RFC 7555: Proxy MPLS Echo Request
Note
When a code point is assigned that is not also assigned in the Downstream Mapping Address Type Registry, the code point there must be marked "Reserved".
Available Formats
| Type | Type of Next Hop | Address Length | IF Length | Reference |
|---|---|---|---|---|
| 0 | Unassigned | |||
| 1 | IPv4 Numbered | 4 | 4 | RFC 8029 |
| 2 | IPv4 Unnumbered | 4 | 4 | RFC 8029 |
| 3 | IPv6 Numbered | 16 | 16 | RFC 8029 |
| 4 | IPv6 Unnumbered | 16 | 4 | RFC 8029 |
| 5 | Reserved | RFC 6426; RFC 7555 | ||
| 6 | IPv4 Protocol Adj | 4 | 0 | RFC 7555 |
| 7 | IPv6 Protocol Adj | 16 | 0 | RFC 7555 |
| 8-255 | Unassigned |
Reply Path Return Codes
Reference
- RFC 7110: Return Path Specified Label Switched Path (LSP) Ping
Available Formats
| Range | Registration Procedures |
|---|---|
| 0x0000-0xFFFB | Standards Action |
| 0xFFFC-0xFFFF | Experimental Use |
| Value | Meaning | Reference |
|---|---|---|
| 0x0000 | No return code | RFC 7110 |
| 0x0001 | Malformed Reply Path TLV was received | RFC 7110 |
| 0x0002 | One or more of the sub-TLVs in the Reply Path TLV were not understood | RFC 7110 |
| 0x0003 | The echo reply was sent successfully using the specified Reply Path | RFC 7110 |
| 0x0004 | The specified Reply Path was not found, the echo reply was sent via other LSP | RFC 7110 |
| 0x0005 | The specified Reply Path was not found, the echo reply was sent via pure IP forwarding (non-MPLS) path | RFC 7110 |
| 0x0006 | Use Reply Path TLV from this echo reply for building the next echo request | RFC 9716 |
| 0x0007 | Local policy does not allow dynamic return path building | RFC 9716 |
| 0x0008-0xFFFB | Unassigned | RFC 7110 |
| 0xFFFC-0xFFFF | Reserved for Experimental Use | RFC 7110 |
DS Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
Available Formats
Multipath Types
Registration Procedure(s)
- Standards Action
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-250 | Standards Action |
| 251-254 | Experimental Use |
| Value | Meaning | Reference |
|---|---|---|
| 0 | no multipath | RFC 8029 |
| 1 | Unassigned | |
| 2 | IP address | RFC 8029 |
| 3 | Unassigned | |
| 4 | IP address range | RFC 8029 |
| 5-7 | Unassigned | |
| 8 | Bit-masked IP address set | RFC 8029 |
| 9 | Bit-masked label set | RFC 8029 |
| 10 | IP and label set | RFC 8012 |
| 11-250 | Unassigned | |
| 251-254 | Reserved for Experimental Use | RFC 8029 |
| 255 | Reserved | RFC 8029 |
Pad Types
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
Available Formats
| Range | Registration Procedures |
|---|---|
| 1-250 | Standards Action |
| 251-254 | Experimental Use |
Interface and Label Stack and Detailed Interface and Label Stack Address Types
Reference
- RFC 8029: Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures
- RFC 8611: Label Switched Path (LSP) Ping and Traceroute Multipath Support for Link Aggregation Group (LAG) Interfaces
Available Formats
| Range | Registration Procedures |
|---|---|
| 1-250 | Standards Action |
| 251-254 | Experimental Use |
Proxy Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 7555: Proxy MPLS Echo Request
Available Formats
MPLS OAM Function Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 7759: Configuration of Proactive Operations, Administration, and Maintenance (OAM) Functions for MPLS-Based Transport Networks Using Label Switched Path (LSP) Ping
Available Formats
| Bit Position | MPLS OAM Function Flag | Description | Reference |
|---|---|---|---|
| 0 | C | Continuity Check (CC) | RFC 7759 |
| 1 | V | Connectivity Verification (CV) | RFC 7759 |
| 2 | F | Fault Management Signal (FMS) | RFC 7759 |
| 3 | L | Performance Monitoring/Loss (PM/Loss) | RFC 7759 |
| 4 | D | Performance Monitoring/Delay (PM/Delay) | RFC 7759 |
| 5 | T | Throughput Measurement | RFC 7759 |
| 6-30 | Unassigned (Must be zero) | ||
| 31 | Reserved | RFC 7759 |
Protocol in the Segment ID Sub-TLV
Reference
- RFC 8287: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-250 | Standards Action |
| 251-254 | Experimental Use |
Adjacency Type in the IGP-Adjacency Segment ID
Reference
- RFC 8287: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-250 | Standards Action |
| 251-254 | Experimental Use |
Protocol in Label Stack Sub-TLV of Downstream Detailed Mapping TLV
Reference
- RFC 8287: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) IGP-Prefix and IGP-Adjacency Segment Identifiers (SIDs) with MPLS Data Planes
Available Formats
| Range | Registration Procedures |
|---|---|
| 0-250 | Standards Action |
| 251-254 | Experimental Use |
| Value | Meaning | Reference | Notes |
|---|---|---|---|
| 0 | Unknown | RFC 8029, Section 3.4.1.2 | |
| 1 | Static | RFC 8029, Section 3.4.1.2 | |
| 2 | BGP | RFC 8029, Section 3.4.1.2 | |
| 3 | LDP | RFC 8029, Section 3.4.1.2 | |
| 4 | RSVP-TE | RFC 8029, Section 3.4.1.2 | |
| 5 | OSPF | RFC 8287, Section 6 | To be used for OSPFv2 only. |
| 6 | ISIS | RFC 8287, Section 6 | |
| 7 | OSPFv3 | RFC 9214 | |
| 8-250 | Unassigned | ||
| 251-254 | Reserved for Experimental Use | RFC 8287 | |
| 255 | Reserved | RFC 8287 |
LSR Capability Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 8611: Label Switched Path (LSP) Ping and Traceroute Multipath Support for Link Aggregation Group (LAG) Interfaces
Available Formats
Interface Index Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 8611: Label Switched Path (LSP) Ping and Traceroute Multipath Support for Link Aggregation Group (LAG) Interfaces
Available Formats
| Bit Number | Name | Reference |
|---|---|---|
| 15 | M: LAG Member Link Indicator | RFC 8611 |
| 0-14 | Unassigned |
Segment ID Sub-TLV Flags
Registration Procedure(s)
- Standards Action
Reference
- RFC 9716: Mechanisms for MPLS Ping and Traceroute Procedures in Inter-Domain Segment Routing Networks
Available Formats
| Bit Number | Name | Reference |
|---|---|---|
| 0 | Unassigned | |
| 1 | A-Flag | RFC 9716, Section 4.4 |
| 2-7 | Unassigned |
Footnotes
| [1] | The Return Subcode (RSC) contains the point in the label stack where pro- cessing was terminated. If the RSC is 0, no labels were processed. Otherwise, the packet was label switched at depth RSC. |
| [2] | The Return Code is per "Downstream Detailed Mapping TLV" (Section 3.4). This Return Code MUST be used only in the message header and MUST be set only in the MPLS echo reply message. If the Return Code is set in the MPLS echo request message, then it MUST be ignored. When this Return Code is set, each Downstream Detailed Mapping TLV MUST have an appropriate Return Code and Return Subcode. This Return Code MUST be used when there are multiple downstreams for a given node (such as Point-to-Multipoint (P2MP)or ECMP),and the node needs to return a Return Code/Return Subcode for each downstream. This Return Code MAY be used even when there is only one downstream for a given node. |