Session Initiation Protocol (SIP) Parameters

Created

  • 2002-01

Last Updated

  • 2026-08-17

Available Formats


Header Fields

Expert(s)

  • Adam Roach

Reference

  • RFC 3261: SIP: Session Initiation Protocol
  • RFC 5727: Change Process for the Session Initiation Protocol (SIP) and the Real-time Applications and Infrastructure Area

Note

The table below lists the header fields currently defined for the Session Initiation Protocol (SIP) RFC 3261. Some headers have single-letter compact forms (Section 7.3 of RFC 3261). Header field names are case-insensitive.

Standard header fields and messages MUST NOT begin with the leading characters "P-". Existing "P-" header field registrations are considered grandfathered, but new registrations of Informational header fields should not begin with the leading characters "P-" (unless the "P-" would preserve compatibility with an pre-existing unregistered usage of the header field, at the discretion of the Designated Expert). Short forms of header fields MUST only be assigned to standards track header fields. At the discretion of the Designated Expert, a header registration may require a Standards Action.

Available Formats

Range Registration Procedures
Informational Header Expert Review
Standard Header Standards Action
Header Name compact Reference
Accept RFC 3261
Accept-Contact a RFC 3841
Accept-Encoding RFC 3261
Accept-Language RFC 3261
Accept-Resource-Priority RFC 4412
Additional-Identity 3GPP TS 24.229 v16.7.0; Dongwook Kim
Alert-Info RFC 3261
AlertMsg-Error RFC 8876
Allow RFC 3261
Allow-Events u RFC 6665
Answer-Mode RFC 5373
Attestation-Info 3GPP TS 24.229 v15.11.0; Dongwook Kim
Authentication-Info RFC 3261
Authorization RFC 3261
Call-ID i RFC 3261
Call-Info RFC 3261
Cellular-Network-Info 3GPP TS 24.229 v13.9.0; Dongwook Kim
Contact m RFC 3261
Content-Disposition RFC 3261
Content-Encoding e RFC 3261
Content-ID RFC 8262
Content-Language RFC 3261
Content-Length l RFC 3261
Content-Type c RFC 3261
CSeq RFC 3261
Date RFC 3261
DC-Info 3GPP TS 24.229 v19.4.1; Dongwook Kim
Encryption (Deprecated) RFC 3261
Error-Info RFC 3261
Event o RFC 6665; RFC 6446
Expires RFC 3261
Feature-Caps RFC 6809
Flow-Timer RFC 5626
From f RFC 3261
Geolocation RFC 6442
Geolocation-Error RFC 6442
Geolocation-Routing RFC 6442
Hide (Deprecated) RFC 3261
History-Info RFC 7044
Identity y RFC 8224
Identity-Info (deprecated by RFC 8224) RFC 8224
Info-Package RFC 6086
In-Reply-To RFC 3261
Join RFC 3911
Max-Breadth RFC 5393
Max-Forwards RFC 3261
MIME-Version RFC 3261
Min-Expires RFC 3261
Min-SE RFC 4028
Organization RFC 3261
Origination-Id 3GPP TS 24.229 v15.11.0; Dongwook Kim
P-Access-Network-Info RFC 7315
P-Answer-State RFC 4964
P-Asserted-Identity RFC 3325
P-Asserted-Service RFC 6050
P-Associated-URI RFC 7315
P-Called-Party-ID RFC 7315
P-Charge-Info RFC 8496
P-Charging-Function-Addresses RFC 7315
P-Charging-Vector RFC 7315
P-DCS-Trace-Party-ID RFC 5503
P-DCS-OSPS RFC 5503
P-DCS-Billing-Info RFC 5503
P-DCS-LAES RFC 5503
P-DCS-Redirect RFC 5503
P-Early-Media RFC 5009
P-Media-Authorization RFC 3313
P-Preferred-Identity RFC 3325
P-Preferred-Service RFC 6050
P-Private-Network-Indication RFC 7316
P-Profile-Key RFC 5002
P-Refused-URI-List RFC 5318
P-Served-User RFC 5502; RFC 8498
P-User-Database RFC 4457
P-Visited-Network-ID RFC 7315
Path RFC 3327
Permission-Missing RFC 5360
Policy-Contact RFC 6794
Policy-ID RFC 6794
Priority RFC 3261
Priority-Share 3GPP TS 24.229 v13.16.0; Dongwook Kim
Priority-Verstat 3GPP TS 24.229; Lionel Morand
Priv-Answer-Mode RFC 5373
Privacy RFC 3323
Proxy-Authenticate RFC 3261
Proxy-Authorization RFC 3261
Proxy-Require RFC 3261
RAck RFC 3262
Reason RFC 3326
Reason-Phrase Reserved to avoid conflict with RFC 6873. Adam Roach
Record-Route RFC 3261
Recv-Info RFC 6086
Refer-Events-At RFC 7614
Refer-Sub RFC 4488
Refer-To r RFC 3515
Referred-By b RFC 3892
Reject-Contact j RFC 3841
Relayed-Charge 3GPP TS 24.229 v12.14.0; Dongwook Kim
Replaces RFC 3891
Reply-To RFC 3261
Request-Disposition d RFC 3841
Require RFC 3261
Resource-Priority RFC 4412
Resource-Share 3GPP TS 24.229 v13.7.0; Dongwook Kim
Response-Key (Deprecated) RFC 3261
Response-Source 3GPP TS 24.229 v15.11.0; Dongwook Kim
Restoration-Info 3GPP TS 24.229 v12.14.0; Dongwook Kim
Retry-After RFC 3261
Route RFC 3261
RSeq RFC 3262
Security-Client RFC 3329
Security-Server RFC 3329
Security-Verify RFC 3329
Server RFC 3261
Service-Interact-Info 3GPP TS 24.229 v13.18.0; Dongwook Kim
Service-Route RFC 3608
Session-Expires x RFC 4028
Session-ID RFC 7989
SIP-ETag RFC 3903
SIP-If-Match RFC 3903
Subject s RFC 3261
Subscription-State RFC 6665
Supported k RFC 3261
Suppress-If-Match RFC 5839
Target-Dialog RFC 4538
Timestamp RFC 3261
To t RFC 3261
Trigger-Consent RFC 5360
Unsupported RFC 3261
User-Agent RFC 3261
User-to-User RFC 7433
Via v RFC 3261; RFC 7118
Warning RFC 3261
WWW-Authenticate RFC 3261

Reason Protocols

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Christer Holmberg

Reference

  • RFC 3326: The Reason Header Field for the Session Initiation Protocol (SIP)

Available Formats

Protocol Value Protocol Cause Reference
SIP Status code RFC 3261
Q.850 Cause value in decimal representation ITU-T Q.850
Preemption Cause value in decimal [1] RFC 4411
EMM Cause value in decimal representation [2] 3GPP TS 24.301 subclause 9.9.3.9, Table 9.9.3.9.1; 3GPP Specifications Manager
ESM Cause value in decimal representation [3] 3GPP TS 24.301 subclause 9.9.4.4, Table 9.9.4.4.1; 3GPP Specifications Manager
S1AP-RNL Radio network layer cause value in decimal representation 3GPP TS 36.413; 3GPP Specifications Manager
S1AP-TL Radio network layer cause value in decimal representation 3GPP TS 36.413 subclause 9.2.1.3[4]3GPP Specifications Manager
S1AP-NAS Non-access stratum cause value in decimal representation 3GPP TS 36.413 subclause 9.2.1.3[4]3GPP Specifications Manager
S1AP-MISC Miscellaneous cause value in decimal representation 3GPP TS 36.413 subclause 9.2.1.3[4]3GPP Specifications Manager
S1AP-PROT S1 Protocol cause value in decimal representation 3GPP TS 36.413 subclause 9.2.1.3[4]3GPP Specifications Manager
DIAMETER Cause for protocol failure of GTP-C supporting WLAN, as a representation in decimal digits of the received binary value. 3GPP TS 29.274 subclause 8.103[5]3GPP Specifications Manager
IKEV2 Cause for protocol failure of IKEV2 supporting untrusted WLAN, as a representation in decimal digits of the received binary value. 3GPP TS 29.274 subclause 8.103[6]3GPP Specifications Manager
RELEASE_CAUSE

cause value 1: User ends call

cause value 2: RTP/RTCP time-out

cause value 3: Media bearer loss

cause value 4: SIP timeout - no ACK

cause value 5: SIP response time-out

cause value 6: Call-setup time-out

cause value 7: Redirection failure

3GPP TS 24.229
FAILURE_CAUSE

cause value 1: Media bearer or QoS lost

cause value 2: Release of signalling bearer

cause value 3: Indication of failed resources allocation

3GPP TS 24.229 v14.4.0; Dongwook Kim
STIR STIR Error code RFC 8224
5GMM Cause value in decimal representation 3GPP TS 24.501 subclause 9.11.3.2; 3GPP Specifications Manager
5GSM Cause value in decimal representation 3GPP TS 24.501 subclause 9.11.4.2; 3GPP Specifications Manager
NGAP-RNL Radio network layer cause value in decimal representation 3GPP TS 38.413 subclause 9.3.1.2; 3GPP Specifications Manager
NGAP-TL Radio network layer cause value in decimal representation 3GPP TS 38.413 subclause 9.3.1.2; 3GPP Specifications Manager
NGAP-NAS Non-access stratum cause value in decimal representation 3GPP TS 38.413 subclause 9.3.1.2; 3GPP Specifications Manager
NGAP-MISC Miscellaneous cause value in decimal representation 3GPP TS 38.413 subclause 9.3.1.2; 3GPP Specifications Manager
NGAP-PROT S1 Protocol cause value in decimal representation 3GPP TS 38.413 subclause 9.3.1.2; 3GPP Specifications Manager

Option Tags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3261: SIP: Session Initiation Protocol
  • RFC 5727: Change Process for the Session Initiation Protocol (SIP) and the Real-time Applications and Infrastructure Area

Note

Option tags are used in header fields such as Require, Supported, Proxy-Require, and Unsupported in support of SIP compatibility mechanisms for extensions. The option tag itself is a string that is associated with a particular SIP option (that is, an extension). It identifies the option to SIP endpoints.

Note

When this registry is modified, the YANG module iana-sip-option-tags must be updated as defined in RFC 10006.

Available Formats

Name Description Reference
100rel This option tag is for reliability of provisional responses. When present in a Supported header, it indicates that the UA can send or receive reliable provisional responses. When present in a Require header in a request it indicates that the UAS MUST send all provisional responses reliably. When present in a Require header in a reliable provisional response, it indicates that the response is to be sent reliably. RFC 3262
199 This option-tag is for indicating support of the 199 Early Dialog Terminated provisional response code. When present in a Supported header of a request, it indicates that the UAC supports the 199 response code. When present in a Require or Proxy-Require header field of a request, it indicates that the UAS, or proxies, MUST support the 199 response code. It does not require the UAS, or proxies, to actually send 199 responses. RFC 6228
answermode This option tag is for support of the Answer-Mode and Priv-Answer-Mode extensions used to negotiate automatic or manual answering of a request. RFC 5373
early-session A UA adding the early-session option tag to a message indicates that it understands the early-session content disposition. RFC 3959
eventlist Extension to allow subscriptions to lists of resources RFC 4662
explicitsub This option tag identifies an extension to REFER to suppress the implicit subscription and provide a URI for an explicit subscription. RFC 7614
from-change This option tag is used to indicate that a UA supports changes to URIs in From and To header fields during a dialog. RFC 4916
geolocation-http The "geolocation-http" option tag signals support for acquiring location information via an HTTP RFC 2616. A location recipient who supports this option can request location with an HTTP GET and parse a resulting 200 response containing a PIDF-LO object. The URI schemes supported by this option include "http" and "https". RFC 6442
geolocation-sip The "geolocation-sip" option tag signals support for acquiring location information via the presence event package of SIP RFC 3856. A location recipient who supports this option can send a SUBSCRIBE request and parse a resulting NOTIFY containing a PIDF-LO object. The URI schemes supported by this option include "sip", "sips", and "pres". RFC 6442
gin This option tag is used to identify the extension that provides Registration for Multiple Phone Numbers in SIP. When present in a Require or Proxy-Require header field of a REGISTER request, it indicates that support for this extension is required of registrars and proxies, respectively, that are a party to the registration transaction. RFC 6140
gruu This option tag is used to identify the Globally Routable User Agent URI (GRUU) extension. When used in a Supported header, it indicates that a User Agent understands the extension. When used in a Require header field of a REGISTER request, it indicates that the registrar is not expected to process the registration unless it supports the GRUU extension. RFC 5627
histinfo When used with the Supported header field, this option tag indicates the UAC supports the History Information to be captured for requests and returned in subsequent responses. This tag is not used in a Proxy-Require or Require header field, since support of History-Info is optional. RFC 7044
ice This option tag is used to identify the Interactive Connectivity Establishment (ICE) extension. When present in a Require header field, it indicates that ICE is required by an agent. RFC 5768
join Support for the SIP Join Header RFC 3911
multiple-refer This option tag indicates support for REFER requests that contain a resource list document describing multiple REFER targets. RFC 5368
norefersub This option tag specifies a User Agent ability of accepting a REFER request without establishing an implicit subscription (compared to the default case defined in RFC 3515. RFC 4488
nosub This option tag identifies an extension to REFER to suppress the implicit subscription and indicate that no explicit subscription is forthcoming. RFC 7614
outbound This option-tag is used to identify UAs and Registrars which support extensions for Client Initiated Connections. A UA places this option in a Supported header to communicate its support for this extension. A Registrar places this option-tag in a Require header to indicate to the registering User Agent that the Registrar used registrations using the binding rules defined in this extension. RFC 5626
path A SIP UA that supports the Path extension header field includes this option tag as a header field value in a Supported header field in all requests generated by that UA. Intermediate proxies may use the presence of this option tag in a REGISTER request to determine whether to offer Path service for for that request. If an intermediate proxy requires that the registrar support Path for a request, then it includes this option tag as a header field value in a Requires header field in that request. RFC 3327
policy This option tag is used to indicate that a UA can process policy server URIs for and subscribe to session-specific policies. RFC 6794
precondition An offerer MUST include this tag in the Require header field if the offer contains one or more "mandatory" strength-tags. If all the strength-tags in the description are "optional" or "none" the offerer MUST include this tag either in a Supported header field or in a Require header field. RFC 3312
pref This option tag is used to ensure that a server understands the callee capabilities parameters used in the request. RFC 3840
privacy This option tag indicates support for the Privacy mechanism. When used in the Proxy-Require header, it indicates that proxy servers do not forward the request unless they can provide the requested privacy service. This tag is not used in the Require or Supported headers. Proxies remove this option tag before forwarding the request if the desired privacy function has been performed. RFC 3323
recipient-list-invite The body contains a list of URIs that indicates the recipients of the SIP INVITE request RFC 5366
recipient-list-message The body contains a list of URIs that indicates the recipients of the SIP MESSAGE request RFC 5365
recipient-list-subscribe This option tag is used to ensure that a server can process the recipient-list body used in a SUBSCRIBE request. RFC 5367
record-aware This option tag is to indicate the ability of the UA to receive recording indicators in media-level or session-level SDP. When present in a Supported header, it indicates that the UA can receive recording indicators in media-level or session-level SDP. RFC 7866
replaces This option tag indicates support for the SIP Replaces header. RFC 3891
resource-priority Indicates or requests support for the resource priority mechanism. RFC 4412
sdp-anat The option-tag sdp-anat is defined for use in the Require and Supported SIP RFC 3261 header fields. SIP user agents that place this option-tag in a Supported header field understand the ANAT semantics as defined in RFC 4091. RFC 4092
sec-agree This option tag indicates support for the Security Agreement mechanism. When used in the Require, or Proxy-Require headers, it indicates that proxy servers are required to use the Security Agreement mechanism. When used in the Supported header, it indicates that the User Agent Client supports the Security Agreement mechanism. When used in the Require header in the 494 (Security Agreement Required) or 421 (Extension Required) responses, it indicates that the User Agent Client must use the Security Agreement Mechanism. RFC 3329
siprec This option tag is for identifying that the SIP session is for the purpose of an RS. This is typically not used in a Supported header. When present in a Require header in a request, it indicates that the UA is either an SRC or SRS capable of handling a recording session. RFC 7866
tdialog This option tag is used to identify the target dialog header field extension. When used in a Require header field, it implies that the recipient needs to support the Target-Dialog header field. When used in a Supported header field, it implies that the sender of the message supports it. RFC 4538
timer This option tag is for support of the session timer extension. Inclusion in a Supported header field in a request or response indicates that the UA is capable of performing refreshes according to that specification. Inclusion in a Require header in a request means that the UAS must understand the session timer extension to process the request. Inclusion in a Require header field in a response indicates that the UAC must look for the Session-Expires header field in the response, and process accordingly. RFC 4028
trickle-ice This option tag is used to indicate that a UA supports and understands Trickle ICE. RFC 8840
uui This option tag is used to indicate that a UA supports and understands the User-to-User header field. RFC 7433

Warning Codes (warn-codes)

Registration Procedure(s)

  • RFC Required

Reference

Note

Warning codes provide information supplemental to the status code in SIP response messages.

Available Formats

Code Description Reference
300 Incompatible network protocol: One or more network protocols contained in the session description are not available. RFC 3261
301 Incompatible network address formats: One or more network address formats contained in the session description are not available. RFC 3261
302 Incompatible transport protocol: One or more transport protocols described in the session description are not available. RFC 3261
303 Incompatible bandwidth units: One or more bandwidth measurement units contained in the session description were not understood. RFC 3261
304 Media type not available: One or more media types contained in the session description are not available. RFC 3261
305 Incompatible media format: One or more media formats contained in the session description are not available. RFC 3261
306 Attribute not understood: One or more of the media attributes in the session description are not supported. RFC 3261
307 Session description parameter not understood: A parameter other than those listed above was not understood. RFC 3261
308 Incompatible language specification: Requested languages not supported. Supported languages and media are: [list of supported languages and media]. RFC 8373
330 Multicast not available: The site where the user is located does not support multicast. RFC 3261
331 Unicast not available: The site where the user is located does not support unicast communication (usually due to the presence of a firewall). RFC 3261
370 Insufficient bandwidth: The bandwidth specified in the session description or defined by the media exceeds that known to be available. RFC 3261
380 SIPS Not Allowed: The UAS or proxy cannot process the request because the SIPS scheme is not allowed (e.g., because there are currently no registered SIPS Contacts). RFC 5630
381 SIPS Required: The UAS or proxy cannot process the request because the SIPS scheme is required. RFC 5630
399 Miscellaneous warning: The warning text can include arbitrary information to be presented to a human user or logged. A system receiving this warning MUST NOT take any automated action. RFC 3261

Methods and Response Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3261: SIP: Session Initiation Protocol
  • RFC 5727: Change Process for the Session Initiation Protocol (SIP) and the Real-time Applications and Infrastructure Area

Available Formats

Methods Reference
ACK RFC 3261
BYE RFC 3261
CANCEL RFC 3261
INFO RFC 6086
INVITE RFC 3261; RFC 6026
MESSAGE RFC 3428
NOTIFY RFC 6665
OPTIONS RFC 3261
PRACK RFC 3262
PUBLISH RFC 3903
REFER RFC 3515
REGISTER RFC 3261
SUBSCRIBE RFC 6665
UPDATE RFC 3311

Response Codes

Registration Procedure(s)

  • RFC Required

Reference

  • RFC 3261: SIP: Session Initiation Protocol

Note

All response codes below are defined by RFC 3261 unless otherwise noted.

1xx: Provisional
2xx: Successful
3xx: Redirection
4xx: Request Failure
5xx: Server Failure
6xx: Global Failures

Available Formats

Response Code Description Reference
100 Trying
180 Ringing
181 Call Is Being Forwarded
182 Queued
183 Session Progress
199 Early Dialog Terminated RFC 6228
200 OK
202 Accepted (Deprecated) RFC 6665
204 No Notification RFC 5839
300 Multiple Choices
301 Moved Permanently
302 Moved Temporarily
305 Use Proxy
380 Alternative Service
400 Bad Request
401 Unauthorized
402 Payment Required
403 Forbidden
404 Not Found
405 Method Not Allowed
406 Not Acceptable
407 Proxy Authentication Required
408 Request Timeout
410 Gone
412 Conditional Request Failed RFC 3903
413 Request Entity Too Large
414 Request-URI Too Long
415 Unsupported Media Type
416 Unsupported URI Scheme
417 Unknown Resource-Priority RFC 4412
420 Bad Extension
421 Extension Required
422 Session Interval Too Small RFC 4028
423 Interval Too Brief
424 Bad Location Information RFC 6442
425 Bad Alert Message RFC 8876
428 Use Identity Header RFC 8224
429 Provide Referrer Identity RFC 3892
430 Flow Failed RFC 5626
433 Anonymity Disallowed RFC 5079
436 Bad Identity Info RFC 8224
437 Unsupported Credential RFC 8224
438 Invalid Identity Header RFC 8224
439 First Hop Lacks Outbound Support RFC 5626
440 Max-Breadth Exceeded RFC 5393
469 Bad Info Package RFC 6086
470 Consent Needed RFC 5360
480 Temporarily Unavailable
481 Call/Transaction Does Not Exist
482 Loop Detected
483 Too Many Hops
484 Address Incomplete
485 Ambiguous
486 Busy Here
487 Request Terminated
488 Not Acceptable Here
489 Bad Event RFC 6665
491 Request Pending
493 Undecipherable
494 Security Agreement Required RFC 3329
500 Server Internal Error
501 Not Implemented
502 Bad Gateway
503 Service Unavailable
504 Server Time-out
505 Version Not Supported
513 Message Too Large
555 Push Notification Service Not Supported RFC 8599
580 Precondition Failure RFC 3312
600 Busy Everywhere
603 Decline
604 Does Not Exist Anywhere
606 Not Acceptable
607 Unwanted RFC 8197
608 Rejected RFC 8688

SIP Privacy Header Field Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3323: A Privacy Mechanism for the Session Initiation Protocol (SIP)

Available Formats

Privacy Type Description Registrant Reference
user Request that privacy services provide a user-level privacy function Jon Peterson RFC 3323
header Request that privacy services modify headers that cannot be set arbitrarily by the user (Contact/Via). Jon Peterson RFC 3323
session Request that privacy services provide privacy for session media Jon Peterson RFC 3323
none Privacy services must not perform any privacy function Jon Peterson RFC 3323
critical Privacy service must perform the specified services or fail the request Jon Peterson RFC 3323
id Privacy requsted for Third-Party Asserted Identity Cullen Jennings RFC 3325
history Privacy requested for History-Info header field(s) Mary Barnes RFC 7044

Security Mechanism Names

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3329: Security Mechanism Agreement for the Session Initiation Protocol (SIP)

Available Formats

Mechanism Name Reference
digest RFC 3329
tls RFC 3329
ipsec-ike RFC 3329
ipsec-man RFC 3329
ipsec-3gpp RFC 3329

Compression Schemes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3486: Compressing the Session Initiation Protocol (SIP)

Available Formats

Compression Scheme Token Reference
Signaling Compression sigcomp RFC 3486

SIP/SIPS URI Parameters

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 3969: The Internet Assigned Number Authority (IANA) Uniform Resource Identifier (URI) Parameter Registry for the Session Initiation Protocol (SIP)
  • RFC 5727: Change Process for the Session Initiation Protocol (SIP) and the Real-time Applications and Infrastructure Area

Available Formats

Parameter Name Predefined Values Reference
aai No RFC 5552
bnc No RFC 6140
cause Yes RFC 4458; RFC 8119
ccxml No RFC 5552
comp Yes RFC 3486
content-type No RFC 4240
delay No RFC 4240
duration No RFC 4240
extension No RFC 4240
gr No RFC 5627
iotl Yes RFC 7549
locale No RFC 4240
lr No RFC 3261
m Yes RFC 6910
maddr No RFC 3261
maxage No RFC 5552
maxstale No RFC 5552
method "get" / "post" RFC 5552
method Yes RFC 3261
ob No RFC 5626
param[n] No RFC 4240
play No RFC 4240
pn-param No RFC 8599
pn-prid No RFC 8599
pn-provider No RFC 8599
pn-purr No RFC 8599
postbody No RFC 5552
repeat No RFC 4240
sg No RFC 6140
sigcomp-id No RFC 5049
target No RFC 4458
transport Yes RFC 3261; RFC 7118
ttl No RFC 3261
user Yes RFC 3261; RFC 4967
voicexml No RFC 4240

Header Field Parameters and Parameter Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 3968: The Internet Assigned Number Authority (IANA) Header Field Parameter Registry for the Session Initiation Protocol (SIP)

Available Formats

Header Field Parameter Name Predefined Values Reference
Accept q No RFC 3261
Accept-Encoding q No RFC 3261
Accept-Language q No RFC 3261
Alert-Info appearance No RFC 7463
AlertMsg-Error code no RFC 8876
Answer-Mode require No RFC 5373
Authorization algorithm Yes RFC 3261; RFC 3310
Authorization auts No RFC 3310
Authorization cnonce No RFC 3261
Authorization nc No RFC 3261
Authorization nonce No RFC 3261
Authorization opaque No RFC 3261
Authorization qop Yes RFC 3261
Authorization realm No RFC 3261
Authorization response No RFC 3261
Authorization uri No RFC 3261
Authorization username No RFC 3261
Authentication-Info cnonce No RFC 3261
Authentication-Info nc No RFC 3261
Authentication-Info nextnonce No RFC 3261
Authentication-Info qop Yes RFC 3261
Authentication-Info rspauth No RFC 3261
Call-Info call-reason No RFC 9796
Call-Info integrity No RFC 9796
Call-Info m Yes RFC 6910
Call-Info purpose Yes RFC 3261; RFC 5367; RFC 6910; RFC 6993; RFC 7082; RFC 7852; RFC 8688; RFC 9248; RFC 9796
Call-Info verified Yes RFC 9796
Contact expires No RFC 3261
Contact mp No RFC 7044
Contact np No RFC 7044
Contact pub-gruu No RFC 5627
Contact q No RFC 3261
Contact rc No RFC 7044
Contact reg-id No RFC 5626
Contact temp-gruu No RFC 5627
Contact temp-gruu-cookie No RFC 6140
Content-Disposition handling Yes RFC 3204; RFC 3261; RFC 3459; RFC 5621
Event adaptive-min-rate No RFC 6446
Event body Yes RFC 5989
Event call-id No RFC 4235
Event effective-by No RFC 6080
Event from-tag No RFC 4235
Event id No RFC 6665
Event include-session-description No RFC 4235
Event max-rate No RFC 6446
Event min-rate No RFC 6446
Event model No RFC 6080
Event profile-type Yes RFC 6080
Event shared No RFC 7463
Event to-tag No RFC 4235
Event vendor No RFC 6080
Event version No RFC 6080
Feature-Caps fcap-name [7] No RFC 6809
From tag No RFC 3261
Geolocation loc-src No RFC 8787
Geolocation-Error code Yes RFC 6442
History-Info mp No RFC 7044
History-Info np No RFC 7044
History-Info rc No RFC 7044
P-Access-Network-Info cgi-3gpp No RFC 7315
P-Access-Network-Info ci-3gpp2 No RFC 7315
P-Access-Network-Info ci-3gpp2-femto No RFC 7315
P-Access-Network-Info dsl-location No RFC 7315
P-Access-Network-Info dvb-rcs2-node-id No RFC 7315
P-Access-Network-Info eth-location No RFC 7315
P-Access-Network-Info fiber-location No RFC 7315
P-Access-Network-Info gstn-location No RFC 7315
P-Access-Network-Info i-wlan-node-id No RFC 7315
P-Access-Network-Info local-time-zone No RFC 7315
P-Access-Network-Info operator-specific-GI No RFC 7315
P-Access-Network-Info utran-cell-id-3gpp No RFC 7315
P-Access-Network-Info utran-sai-3gpp No RFC 7315
P-Charging-Function-Addresses ccf No RFC 7315
P-Charging-Function-Addresses ccf-2 No RFC 7315
P-Charging-Function-Addresses ecf No RFC 7315
P-Charging-Function-Addresses ecf-2 No RFC 7315
P-Charging-Vector icid-value No RFC 7315
P-Charging-Vector icid-generated-at No RFC 7315
P-Charging-Vector orig-ioi No RFC 7315
P-Charging-Vector related-icid No RFC 7315
P-Charging-Vector related-icid-generated-at No RFC 7315
P-Charging-Vector term-ioi No RFC 7315
P-Charging-Vector transit-ioi No RFC 7315
P-DCS-Billing-Info called No RFC 5503
P-DCS-Billing-Info calling No RFC 5503
P-DCS-Billing-Info charge No RFC 5503
P-DCS-Billing-Info jip No RFC 5503
P-DCS-Billing-Info locroute No RFC 5503
P-DCS-Billing-Info rksgroup No RFC 5503
P-DCS-Billing-Info routing No RFC 5503
P-DCS-LAES bcid No RFC 5503
P-DCS-LAES cccid No RFC 5503
P-DCS-LAES content No RFC 5503
P-DCS-LAES key (OBSOLETED) No RFC 3603; RFC 5503
P-DCS-Redirect count No RFC 5503
P-DCS-Redirect redirector-uri No RFC 5503
P-DCS-Trace-Party-ID timestamp No RFC 5503
P-Refused-URI-List members No RFC 5318
P-Served-User sescase Yes RFC 5502
P-Served-User regstate Yes RFC 5502
P-Served-User orig-cdiv No RFC 8498
Policy-Contact non-cacheable Yes RFC 6794
Priv-Answer-Mode require No RFC 5373
Proxy-Authenticate algorithm Yes RFC 3261; RFC 3310
Proxy-Authenticate authz_server No RFC 8898
Proxy-Authenticate domain No RFC 3261
Proxy-Authenticate error No RFC 8898
Proxy-Authenticate nonce No RFC 3261
Proxy-Authenticate opaque No RFC 3261
Proxy-Authenticate qop Yes RFC 3261
Proxy-Authenticate realm No RFC 3261
Proxy-Authenticate scope No RFC 8898
Proxy-Authenticate stale Yes RFC 3261
Proxy-Authorization algorithm Yes RFC 3261; RFC 3310
Proxy-Authorization auts No RFC 3310
Proxy-Authorization cnonce No RFC 3261
Proxy-Authorization nc No RFC 3261
Proxy-Authorization nonce No RFC 3261
Proxy-Authorization opaque No RFC 3261
Proxy-Authorization qop Yes RFC 3261
Proxy-Authorization realm No RFC 3261
Proxy-Authorization response No RFC 3261
Proxy-Authorization uri No RFC 3261
Proxy-Authorization username No RFC 3261
Reason cause Yes RFC 3326
Reason location Yes RFC 8606
Reason ppi No RFC 9410
Reason text No RFC 3326
Retry-After duration No RFC 3261
Security-Client alg Yes RFC 3329
Security-Client ealg Yes RFC 3329
Security-Client d-alg Yes RFC 3329
Security-Client d-qop Yes RFC 3329
Security-Client d-ver No RFC 3329
Security-Client mod Yes RFC 3329
Security-Client port1 No RFC 3329
Security-Client port2 No RFC 3329
Security-Client prot Yes RFC 3329
Security-Client q No RFC 3329
Security-Client spi No RFC 3329
Security-Server alg Yes RFC 3329
Security-Server ealg Yes RFC 3329
Security-Server d-alg Yes RFC 3329
Security-Server d-qop Yes RFC 3329
Security-Server d-ver No RFC 3329
Security-Server mod Yes RFC 3329
Security-Server port1 No RFC 3329
Security-Server port2 No RFC 3329
Security-Server prot Yes RFC 3329
Security-Server q No RFC 3329
Security-Server spi No RFC 3329
Security-Verify alg Yes RFC 3329
Security-Verify ealg Yes RFC 3329
Security-Verify d-alg Yes RFC 3329
Security-Verify d-qop Yes RFC 3329
Security-Verify d-ver No RFC 3329
Security-Verify mod Yes RFC 3329
Security-Verify port1 No RFC 3329
Security-Verify port2 No RFC 3329
Security-Verify prot Yes RFC 3329
Security-Verify q No RFC 3329
Security-Verify spi No RFC 3329
Session-ID logme No (no values are allowed) RFC 8497
Session-ID remote No RFC 7989
Subscription-State adaptive-min-rate No RFC 6446
Subscription-State expires No RFC 6665
Subscription-State max-rate No RFC 6446
Subscription-State min-rate No RFC 6446
Subscription-State reason Yes RFC 6665
Subscription-State retry-after No RFC 6665
Target-Dialog local-tag No RFC 4538
Target-Dialog remote-tag No RFC 4538
To tag No RFC 3261
Trigger-Consent target-uri No RFC 5360
User-to-User content No RFC 7433
User-to-User encoding Yes RFC 7433
User-to-User purpose No RFC 7433
Via alias No RFC 5923
Via branch No RFC 3261
Via comp Yes RFC 3486
Via keep No RFC 6223
Via maddr No RFC 3261
Via oc Yes RFC 7339
Via oc-algo Yes RFC 7339; RFC 7415
Via oc-seq Yes RFC 7339
Via oc-validity Yes RFC 7339
Via received No RFC 3261; RFC 7118
Via received-realm No RFC 8055
Via rport No RFC 3581
Via sigcomp-id No RFC 5049
Via ttl No RFC 3261
WWW-Authenticate algorithm Yes RFC 3261; RFC 3310
WWW-Authenticate authz_server No RFC 8898
WWW-Authenticate domain Yes RFC 3261
WWW-Authenticate error No RFC 8898
WWW-Authenticate nonce No RFC 3261
WWW-Authenticate opaque No RFC 3261
WWW-Authenticate qop Yes RFC 3261
WWW-Authenticate realm No RFC 3261
WWW-Authenticate scope No RFC 8898
WWW-Authenticate stale Yes RFC 3261

URI Purposes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 4575: A Session Initiation Protocol (SIP) Event Package for Conference State

Available Formats

Value Description Reference
participation The URI can be used to join the conference RFC 4575
streaming The URI can be used to access the streamed conference data RFC 4575
event The URI can be used to subscribe to the conference event package RFC 4575
recording The URI can be used to access the recorded conference data RFC 4575
web-page The URI can be used to access a web page that contains additional information of the conference RFC 4575
ccmp The URI can be used to indicate that the conference focus supports CCMP. RFC 7082
grouptextchat The URI can be used to join a multi-user chat directly associated with the conference RFC 7106

Resource-Priority Namespaces

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)
  • RFC 7134: The Management Policy of the Resource Priority Header (RPH) Registry Changed to "IETF Review"

Note

Namespace      = the unique string identifying the namespace
Namespace Numerical Value = the unique numerical value identifying the namespace
Levels         = the number of priority-values within the namespace
Algorithm      = Intended operational behavior of SIP elements
                 implementing this namespace
New Warn code  = New Warning Codes (warn-codes) introduced by this namespace
New Resp. code = New SIP response codes introduced by this namespace
Reference      = IETF document reference for this namespace
Namespace Numerical Value = 

Available Formats

Namespace Namespace Numerical Value Levels Algorithm Intended Code New warn-code New resp. Reference
dsn 0 5 preemption no no RFC 4412
drsn 1 6 preemption no no RFC 4412
q735 2 5 preemption no no RFC 4412
ets 3 5 queue no no RFC 4412
wps 4 5 queue no no RFC 4412
dsn-000000 5 10 preemption no no RFC 5478
dsn-000001 6 10 preemption no no RFC 5478
dsn-000002 7 10 preemption no no RFC 5478
dsn-000003 8 10 preemption no no RFC 5478
dsn-000004 9 10 preemption no no RFC 5478
dsn-000005 10 10 preemption no no RFC 5478
dsn-000006 11 10 preemption no no RFC 5478
dsn-000007 12 10 preemption no no RFC 5478
dsn-000008 13 10 preemption no no RFC 5478
dsn-000009 14 10 preemption no no RFC 5478
drsn-000000 15 10 preemption no no RFC 5478
drsn-000001 16 10 preemption no no RFC 5478
drsn-000002 17 10 preemption no no RFC 5478
drsn-000003 18 10 preemption no no RFC 5478
drsn-000004 19 10 preemption no no RFC 5478
drsn-000005 20 10 preemption no no RFC 5478
drsn-000006 21 10 preemption no no RFC 5478
drsn-000007 22 10 preemption no no RFC 5478
drsn-000008 23 10 preemption no no RFC 5478
drsn-000009 24 10 preemption no no RFC 5478
rts-000000 25 10 preemption no no RFC 5478
rts-000001 26 10 preemption no no RFC 5478
rts-000002 27 10 preemption no no RFC 5478
rts-000003 28 10 preemption no no RFC 5478
rts-000004 29 10 preemption no no RFC 5478
rts-000005 30 10 preemption no no RFC 5478
rts-000006 31 10 preemption no no RFC 5478
rts-000007 32 10 preemption no no RFC 5478
rts-000008 33 10 preemption no no RFC 5478
rts-000009 34 10 preemption no no RFC 5478
crts-000000 35 10 preemption no no RFC 5478
crts-000001 36 10 preemption no no RFC 5478
crts-000002 37 10 preemption no no RFC 5478
crts-000003 38 10 preemption no no RFC 5478
crts-000004 39 10 preemption no no RFC 5478
crts-000005 40 10 preemption no no RFC 5478
crts-000006 41 10 preemption no no RFC 5478
crts-000007 42 10 preemption no no RFC 5478
crts-000008 43 10 preemption no no RFC 5478
crts-000009 44 10 preemption no no RFC 5478
esnet 45 5 queue no no RFC 7135
mcpttp 46 16 preemption no no RFC 8101
mcpttq 47 16 queue no no RFC 8101

Resource-Priority Priority-values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)
  • RFC 7134: The Management Policy of the Resource Priority Header (RPH) Registry Changed to "IETF Review"

Note

Legend: Namespace Numerical Value = the unique numerical value identifying the namespace Priority Numerical Value: RFC 6401


Namespace: drsn

Reference

  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"routine" 5
"priority" 4
"immediate" 3
"flash" 2
"flash-override" 1
"flash-override-override" 0

Namespace: dsn

Reference

  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"routine" 4
"priority" 3
"immediate" 2
"flash" 1
"flash-override" 0

Namespace: q735

Reference

  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"4" 4
"3" 3
"2" 2
"1" 1
"0" 0

Namespace: ets

Reference

  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"4" 4
"3" 3
"2" 2
"1" 1
"0" 0

Namespace: wps

Reference

  • RFC 4412: Communications Resource Priority for the Session Initiation Protocol (SIP)

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"4" 4
"3" 3
"2" 2
"1" 1
"0" 0

Namespace: dsn-000000

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000001

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000002

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000003

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000004

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000005

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000006

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000007

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000008

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: dsn-000009

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000000

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000001

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000002

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000003

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000004

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000005

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000006

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000007

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000008

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: drsn-000009

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000000

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000001

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000002

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000003

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000004

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000005

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000006

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000007

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000008

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: rts-000009

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000000

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000001

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000002

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000003

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000004

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000005

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000006

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000007

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000008

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: crts-000009

Reference

  • RFC 5478: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespaces

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 9
"1" 8
"2" 7
"3" 6
"4" 5
"5" 4
"6" 3
"7" 2
"8" 1
"9" 0

Namespace: esnet

Reference

  • RFC 7135: Registering a SIP Resource Priority Header Field Namespace for Local Emergency Communications

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"0" 4
"1" 3
"2" 2
"3" 1
"4" 0

Namespace: mcpttp

Reference

  • RFC 8101: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespace for Mission Critical Push To Talk Service

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"mcpttp.0" 15
"mcpttp.1" 14
"mcpttp.2" 13
"mcpttp.3" 12
"mcpttp.4" 11
"mcpttp.5" 10
"mcpttp.6" 9
"mcpttp.7" 8
"mcpttp.8" 7
"mcpttp.9" 6
"mcpttp.10" 5
"mcpttp.11" 4
"mcpttp.12" 3
"mcpttp.13" 2
"mcpttp.14" 1
"mcpttp.15" 0

Namespace: mcpttq

Reference

  • RFC 8101: IANA Registration of New Session Initiation Protocol (SIP) Resource-Priority Namespace for Mission Critical Push To Talk Service

Available Formats

Priority-Values (least to greatest) Priority Numerical Value
"mcpttq.0" 15
"mcpttq.1" 14
"mcpttq.2" 13
"mcpttq.3" 12
"mcpttq.4" 11
"mcpttq.5" 10
"mcpttq.6" 9
"mcpttq.7" 8
"mcpttq.8" 7
"mcpttq.9" 6
"mcpttq.10" 5
"mcpttq.11" 4
"mcpttq.12" 3
"mcpttq.13" 2
"mcpttq.14" 1
"mcpttq.15" 0

Identity Parameters

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 8224: Authenticated Identity Management in the Session Initiation Protocol (SIP)

Available Formats

Parameter Name Reference
alg RFC 8224
info RFC 8224

Identity-Info Algorithm Parameter Values

Registration Procedure(s)

Reference

  • RFC 8224: Authenticated Identity Management in the Session Initiation Protocol (SIP)

Available Formats

'alg' Parameter Name Reference
rsa-sha1 RFC 4474
rsa-sha256 RFC 6072

SIP Forum User Agent Configuration Parameters

Reference

  • RFC 6011: Session Initiation Protocol (SIP) User Agent Configuration

Available Formats

Range Registration Procedures
begins with 'sfua-' RFC Required
all other names First Come First Served
Parameter Name Description Reference
sfua-id The URN identifying the User Agent, constructed as specified in Section 4.1 of RFC 5626 "Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)". Since the procedure defined by RFC 5626 allows any UA to construct a value for this parameter, the sfua-id parameter MUST always be included. If the UA implements RFC 5626, and includes the '+sip.instance' Contact header field parameter in any request, when requesting configuration it MUST use the same value for the sfua-id parameter. RFC 6011
sfua-user An identifier for a user associated with the configuration. Note that this might be different than any SIP 'user' in the UA configuration: it could, for example, be the login name of an account on the service provider web site. The syntax of this parameter is that of the RFC 2617 'userid'. See Section 2.4.1, "Configuration Data Request Authentication" for how this parameter relates to authentication of the configuration data request. RFC 6011
sfua-vendor An identifier that specifies the vendor of the User Agent. The syntax of the value of this parameter is that of a DNS domain. The domain value MUST be that of a domain owned by the vendor. RFC 6011
sfua-model An identifier that further specifies the User Agent from among those produced by the vendor. The syntax of the value of this parameter is the same as the RFC 3261 'token'. Values for this parameter are selected by the vendor.
sfua-revision An identifier that further specifies the User Agent from among those produced by the vendor. The syntax of the value of this parameter is the same as the RFC 3261 'token'. Values for this parameter are selected by the vendor. RFC 6011

Service-ID/Application-ID Labels

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6050: A Session Initiation Protocol (SIP) Extension for the Identification of Services

Available Formats

Service/Application Description Reference
3gpp-service Communication services defined by 3GPP for use by the IM CN subsystem and its attached UAs. This value in itself does not define a service and requires subsequent labels to define the service. RFC 6050
3gpp-application Applications defined by 3GPP for use by UAs attached to the IM CN subsystem. This value in itself does not define a service and requires subsequent labels to define the service. RFC 6050

Info Packages Registry

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Adam Roach

Reference

  • RFC 6086: Session Initiation Protocol (SIP) INFO Method and Package Framework

Available Formats

Name Reference
g.3gpp.access-transfer-events 3GPP TS 24.237 v11.14.0; Dongwook Kim
g.3gpp.mid-call 3GPP TS 24.237 v10.19.0; Dongwook Kim
g.3gpp.ussd 3GPP TS 24.390 v11.5.0; Dongwook Kim
g.3gpp.state-and-event 3GPP 24.237 Rel-10; Dongwook Kim
EmergencyCallData.eCall.MSD RFC 8147
EmergencyCallData.VEDS RFC 8148
infoDtmf 3GPP 24.229 v12.16.0; Dongwook Kim
g.3gpp.mcptt-floor-request 3GPP 24.379 v13.7.0, Section J.1.2; Dongwook Kim
g.3gpp.mcptt-info 3GPP 24.379 v13.7.0, Section J.2.2; Dongwook Kim
g.3gpp.mcdata-com-release 3GPP TS 24.282 14.3.0; Dongwook Kim
trickle-ice RFC 8840
g.3gpp.mcvideo-info 3GPP TS 24.281 14.3.0; Dongwook Kim
g.3gpp.current-location-discovery 3GPP TS 24.229; Lionel Morand

SIP Configuration Profile Types

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6080: A Framework for Session Initiation Protocol User Agent Profile Delivery

Available Formats

Profile Type Reference
local-network RFC 6080
device RFC 6080
user RFC 6080

Geolocation-Error Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Unassigned

Reference

  • RFC 6442: Location Conveyance for the Session Initiation Protocol

Available Formats

Code Default Reason Phrase Reference
100 "Cannot Process Location" RFC 6442
200 "Permission to Use Location Information" RFC 6442
201 "Permission to Retransmit Location Information to a Third Party" RFC 6442
202 "Permission to Route Based on Location Information" RFC 6442
300 "Deference Failure" RFC 6442

Reason Codes

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6665: SIP-Specific Event Notification

Available Formats

Reason Code Reference
deactivated RFC 6665
probation RFC 6665
rejected RFC 6665
timeout RFC 6665
giveup RFC 6665
noresource RFC 6665
invariant RFC 6665
badfilter RFC 4660

Proxy-Feature Feature-Capability Indicator Trees

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 6809: Mechanism to Indicate Support of Features and Capabilities in the Session Initiation Protocol (SIP)

Available Formats

Leading Facet Feature-Capability Indicator Tree Reference
g. Global Feature Capability Indicator Tree RFC 6809
sip. SIP Feature Capability Indicator Tree RFC 6809

Global Feature-Capability Indicator Registration Tree

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Paul Kyzivat (primary), Christer Holmberg (secondary)

Reference

  • RFC 6809: Mechanism to Indicate Support of Features and Capabilities in the Session Initiation Protocol (SIP)

Available Formats

Name Description Reference
g.3gpp.iut-focus This feature-capability indicator when used in a Feature-Caps header field of a SIP request or a SIP response indicates that the function which inserted the Feature-Caps header field supports anchoring an IUT session. 3GPP TS 24.337 10.7.0
g.3gpp.mid-call This feature-capability indicator when used in a Feature-Caps header field of a SIP request or a SIP response indicates that: 1. the functional entity including the feature-capability indicator in the SIP message supports the MSC server assisted mid-call feature; and 2. all entities of which the functional entity including the feature-capability indicator in the SIP message is aware of being requested to support the feature do support the MSC server assisted mid-call feature. 3GPP TS 24.237 10.10.0
g.3gpp.atcf This feature-capability indicator when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP REGISTER request or a SIP response to the SIP REGISTER request indicates presence and support of a resource which is an Access Transfer Control Function (ATCF) and also the session transfer number allocated to the ATCF. 3GPP TS 24.237 10.10.0
g.3gpp.srvcc-alerting This feature-capability indicator when used in a Feature-Caps header field of a SIP request or a SIP response indicates that: 1. the functional entity including the feature-capability indicator in the SIP message supports access transfer for calls in alerting phase; and 2. all entities of which the functional entity including the feature-capability indicator in the SIP message is aware of being requested to support the feature do support access transfer for calls in alerting phase. 3GPP TS 24.237 10.10.0
g.3gpp.atcf-mgmt-uri This feature-capability indicator when used in a Feature-Caps header field as specified in IETF RFC 6809 [60] in SIP REGISTER request indicates presence and support of performing as a UAS for SIP requests for ATCF management received at this URI. 3GPP TS 24.237 10.10.0
g.3gpp.srvcc This feature-capability indicator when included in a Feature-Caps header field as specified in IETF RFC 6809 of: - a SIP INVITE request; or - a SIP INVITE response; indicates presence and support of a resource capable of performing the SRVCC access transfer procedure as specified in 3GPP TS 24.237. 3GPP TS 24.237 10.10.0
g.3gpp.atcf-path This feature-capability indicator when used in a Feature-Caps header field as specified in IETF RFC 6809 in SIP REGISTER request indicates capability of identifying the registration path and binding SRVCC related information to it. 3GPP TS 24.237 10.10.0
g.3gpp.cs2ps-srvcc This feature-capability indicator when included in Feature-Caps header field as specified in IETF RFC 6809 [60] indicates support of the CS to PS single radio voice call continuity as specified in 3GPP TS 24.237. 3GPP TS 24.237 11.10.0; Dongwook Kim
g.3gpp.ti This feature-capability indicator when used in a Feature-Caps header field as specified in IETF RFC 6809 in SIP INVITE request or SIP response to the SIP INVITE request indicates the capability of associating a CS call with dialog created by the SIP INVITE request. 3GPP TS 24.237 11.10.0; Dongwook Kim
g.3gpp.loopback This feature-capability indicator, when included in a Feature-Caps header field as specified in RFC 6809 in a SIP INVITE request, indicates the support of the roaming architecture for voice over IMS with local breakout. 3GPP TS 24.229; Dongwook Kim
g.3gpp.trf This feature-capability indicator, when included in a Feature-Caps header field as specified in RFC 6809 in a SIP INVITE request, indicates that in a roaming scenario, the visited network supports a transit and roaming functionality in order to allow loopback of session requests to the visited network from the home network. When used, it may indicate the URI of the transit and roaming functionality. 3GPP TS 24.229 11.11.0; Dongwook Kim
g.3gpp.home-visited This feature-capability indicator, when included in a Feature-Caps header field as specified in RFC 6809 in a SIP INVITE request, indicates that the home network supports loopback to the identified visited network for this session. The loopback is expected to be applied at some subsequent entity to the insertion point. The feature-capability indicator carries a parameter value which indicates the visited network. 3GPP TS 24.229; Dongwook Kim
g.3gpp.mrb This feature-capability indicator when included in a Feature-Caps header field as specified in RFC 6809 in a SIP INVITE request indicates that in a roaming scenario, the visited network supports media resource broker functionality for the allocation of multimedia resources in the visited network. When used, it indicates the URI of the visited network MRB. 3GPP TS 24.229 11.11.0; Dongwook Kim
g.3gpp.icsi-ref Each value of the Service Reference feature-capability indicator indicates the software applications supported by the entity. The values for this feature-capability indicator equal the IMS communication Service Identifier (ICSI) values supported by the entity. Multiple feature-capability indicator values can be included in the Service Reference feature-capability indicators. When included in the Feature-Caps header field, according to RFC 6809, the value of this feature-capability indicator contains the IMS communication service identifier (ICSI) of the IMS communication service supported for use 1) in the standalone transaction (if included in a request for a standalone transaction or a response associated with it) or 2) in the dialog (if included in an initial request for dialog or a response associated with it) by the entity which included the Feature-Caps header field. 3GPP TS 24.229 11.12.0; Dongwook Kim
g.3gpp.drvcc-alerting This feature-capability indicator when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP INVITE request or a SIP response to the SIP INVITE request indicates support of PS to CS dual radio access transfer for calls in alerting phase. 3GPP TS 24.237 12.8.0; Dongwook Kim
g.3gpp.dynamic-stn This feature-capability indicator g.3gpp.dynamic-stn, when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP INVITE request or a SIP response to the SIP INVITE request, indicates support to transfer the session to the circuit switched (CS) domain using the dynamic STN (session transfer number) digit string. 3GPP TS 24.237 12.8.0; Dongwook Kim
g.3gpp.ps2cs-drvcc-orig-pre-alerting This feature-capability indicator g.3gpp.ps2cs-srvcc-orig-pre-alerting when used in a Feature-Caps header field of a SIP request or a SIP response indicates that: 1. the functional entity including the feature-capability indicator in the SIP message supports the PS to CS SRVCC for originating calls in pre-alerting phase; and 2. all entities of which the functional entity including the feature-capability indicator in the SIP message is aware of being requested to support the feature do support the PS to CS SRVCC for originating calls in pre-alerting phase. 3GPP TS 24.237 12.8.0; Dongwook Kim
g.3gpp.ps2cs-srvcc-orig-pre-alerting This feature-capability indicator g.3gpp.ps2cs-srvcc-orig-pre-alerting when used in a Feature-Caps header field of a SIP request or a SIP response indicates that: 1. the functional entity including the feature-capability indicator in the SIP message supports the PS to CS SRVCC for originating calls in pre-alerting phase; and 2. all entities of which the functional entity including the feature-capability indicator in the SIP message is aware of being requested to support the feature do support the PS to CS SRVCC for originating calls in pre-alerting phase. 3GPP TS 24.237 12.8.0; Dongwook Kim
g.3gpp.cs2ps-drvcc-alerting This feature-capability indicator, when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP request or a SIP response to the SIP request, indicates support of CS to PS dual radio access transfer for calls in alerting phase. 3GPP TS 24.237 12.9.0; Dongwook Kim
g.3gpp.cs2ps-drvcc-orig-pre-alerting This feature-capability indicator when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP request or a SIP response to the SIP request indicates support of CS to PS dual radio access transfer for originating calls in pre-alerting phase. 3GPP TS 24.237 12.9.0; Dongwook Kim
g.3gpp.ics This feature-capability indicator when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP initial request for dialog or a response associated with the SIP initial request indicates support of IMS Centralized Services (ICS). 3GPP TS 24.292 12.8.0; Dongwook Kim
g.3gpp.registration-token This feature-capability indicator, when included in a Feature-Caps header field as specified in RFC 6809 [190] in a SIP REGISTER request, indicates the support of using a token to identify the registration used for the request. This feature-capability indicator can be included in an originating initial INVITE request to identify which registration was used for this request by setting the indicator to the same value as in the +g.3gpp.registration-token media feature tag in the Contact header field of the REGISTER request. This feature-capability indicator can be included in any response to a terminating INVITE request to identify which registration was used for the response by setting the indicator to the same value as in the +g.3gpp.registration-token media feature tag in the Contact header field of the REGISTER request. 3GPP TS 24.229 12.16.0; Dongwook Kim
g.3gpp.verstat This feature-capability indicator, when included in a Feature-Caps header field as specified in RFC 6809 in a 200 (OK) response to a REGISTER request, indicates that the home network supports calling party number verification, as described in RFC 8224. 3GPP TS 24.229 v14.7.0; Dongwook Kim
g.3gpp.mcvideo.ambient-viewing-call-release This feature-capability indicator when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP INVITE request or a SIP 200 (OK) response to a SIP INVITE request indicates that the MCVideo server is capable of receiving a SIP BYE from an MCVideo client to release an ambient-viewing call. 3GPP TS 24.281 Rel-15; Dongwook Kim
g.3gpp.mcptt.ambient-listening-call-release This feature-capability indicator when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP INVITE request or a SIP 200 (OK) response to a SIP INVITE request indicates that the MCPTT server is capable of receiving a SIP BYE from an MCPTT client to release an ambient-listening call. 3GPP TS 24.379 v14.5.0; Dongwook Kim
g.3gpp.dynamic-e-stn-drvcc This feature-capability indicator, when included in a Feature-Caps header field as specified in IETF RFC 6809 in a SIP response to a SIP INVITE request, indicates support to transfer the session to the circuit switched (CS) domain using the Emergency Session Transfer Number for DRVCC digit string. 3GPP TS 24.237; Dongwook Kim
g.3gpp.ps2cs-srvcc-term-pre-alerting This feature-capability indicator when used in a Feature-Caps header field of a SIP request or a SIP response indicates that: 1. the functional entity including the feature-capability indicator in the SIP message supports the PS to CS SRVCC for terminating calls in pre-alerting phase; and 2. all entities of which the functional entity including the feature-capability indicator in the SIP message is aware of being requested to support the feature do support the PS to CS SRVCC for terminating calls in pre-alerting phase. 3GPP TS 24.237; Dongwook Kim
g.3gpp.priority-share When included in a Feature-Caps header field in SIP requests or SIP responses, the sender indicates that priority sharing is supported. 3GPP TS 24.229 13.16.0; Dongwook Kim
g.3gpp.thig-path This feature-capability indicator when included in a Feature-Caps header field as specified in RFC 6809 in a 200 (OK) response to the REGISTER request indicates that in a roaming scenario, the visited network IBCF supports topology hiding of a Path header field. 3GPP TS 24.229
g.3gpp.anbr This feature-capability indicator, when included in a Feature-Caps header field as specified in RFC 6809 in a 200 (OK) response to a REGISTER request, indicates that the network supports ANBR as specified in 3GPP TS 26.114. 3GPP TS 24.229
g.3gpp.in-call-access-update This feature-capability indicator, when included in a Feature-Caps header field as specified in RFC 6809 in a SIP INVITE request or a response to a SIP INVITE, indicates that the entity supports in-call access update procedure specified in 3GPP TS 24.229. The value of this feature capability indicator is a SIP URI to where the entity can be reached. 3GPP TS 24.229
g.3gpp.datachannel This feature-capability indicator indicates the support of data channel capability in the network, and can be included in a Feature-Caps header field as specified in RFC 6809 in a 200 (OK) response to the REGISTER request. 3GPP TS 24.186
g.3gpp.dc-mux This feature-capability indicator indicates the support of IMS data channel multiplexing capability in the network, and can be included in a Feature-Caps header field as specified in RFC 6809 in SIP request and response. 3GPP TS 24.186

SIP Feature-Capability Indicator Registration Tree

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 6809: Mechanism to Indicate Support of Features and Capabilities in the Session Initiation Protocol (SIP)

Available Formats

Name Description Reference
sip.607 This feature-capability indicator, when included in a Feature-Caps header field of a REGISTER response, indicates that the server supports, and will process, the 607 (Unwanted) response code. RFC 8197
sip.pns This feature-capability indicator, when inserted in a Feature-Caps header field of a SIP REGISTER request or a SIP 2xx response to a REGISTER request, denotes that the entity associated with the indicator supports the SIP push mechanism and the type of push notification service conveyed by the indicator value. RFC 8599
sip.vapid This feature-capability indicator, when inserted in a SIP 2xx response to a SIP REGISTER request, denotes that the entity associated with the indicator supports the Voluntary Application Server Identification (VAPID) mechanism when the entity requests that a push notification be sent to a SIP UA. The indicator value is a public key identifying the entity, which can be used by a SIP UA to restrict subscriptions to that entity. RFC 8599
sip.pnsreg This feature-capability indicator, when inserted in a SIP 2xx response to a SIP REGISTER request, denotes that the entity associated with the indicator expects to receive binding-refresh REGISTER requests for the binding from the SIP UA associated with the binding before the binding expires, even if the entity does not request that a push notification be sent to the SIP UA in order to trigger the binding-refresh REGISTER requests. The indicator value conveys the minimum time (given in seconds) prior to the binding expiration when the UA MUST send the REGISTER request. RFC 8599
sip.pnspurr This feature-capability indicator, when inserted in a SIP 2xx response to a SIP REGISTER request, conveys that the entity associated with the indicator will store information that can be used to associate a mid-dialog SIP request with the binding information in the REGISTER request. The indicator value is an identifier that can be used as a key to retrieve the binding information. RFC 8599
sip.608 This feature-capability indicator, when included in a Feature-Caps header field of an INVITE request, indicates that the entity associated with the indicator will be responsible for indicating to the caller any information contained in the 608 SIP response code, specifically, the value referenced by the Call-Info header. RFC 8688

Priority Header Field Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 6878: IANA Registry for the Session Initiation Protocol (SIP) "Priority" Header Field

Available Formats

Reason Code Reference
non-urgent RFC 3261
normal RFC 3261
urgent RFC 3261
emergency RFC 3261
psap-callback RFC 7090

SIP Transport

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7118: The WebSocket Protocol as a Transport for the Session Initiation Protocol (SIP)

Available Formats

Transport Reference
UDP RFC 3261
TCP RFC 3261
TLS RFC 3261
SCTP RFC 3261; RFC 4168
TLS-SCTP RFC 4168
WS RFC 7118
WSS RFC 7118

UUI Packages

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7433: A Mechanism for Transporting User-to-User Call Control Information in SIP

Note

UUI packages provide information about the usage of the UUI data in a User-to-User header field RFC 7433.

Available Formats

Package Description Reference
isdn-uui The associated application is being used with constraints suitable for interworking with the ISDN User-to-User service, and therefore can be interworked at ISDN gateways. RFC 7434

UUI Content Parameters

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7433: A Mechanism for Transporting User-to-User Call Control Information in SIP

Note

UUI content provides information about the content of the UUI data in
a User-to-User header field RFC 7433.

Available Formats

Content Description Reference
isdn-uui The associated contents conforms to the content associated with the ISDN User-to-User service. In the presence of the "purpose" header field parameter set to "isdn-uui" (or the absence of any "purpose" header field parameter) this is the default meaning and therefore need not be included in this case. RFC 7434

UUI Encoding Parameters

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7433: A Mechanism for Transporting User-to-User Call Control Information in SIP

Note

UUI encoding provides information about the encoding of the UUI data in a User-to-User header field RFC 7433.

Available Formats

Encoding Description Reference
hex The UUI data is encoded using hexadecimal RFC 7433

Push Notification Service (PNS)

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Christer Holmberg

Reference

  • RFC 8599: Push Notification with the Session Initiation Protocol (SIP)

Available Formats

Value Description Reference
apns Apple Push Notification service RFC 8599
fcm Firebase Cloud Messaging RFC 8599
webpush Generic Event Delivery Using HTTP Push RFC 8599

SIP AlertMsg-Error Codes

Registration Procedure(s)

  • Specification Required

Expert(s)

  • Brian Rosen

Reference

  • RFC 8876: Non-interactive Emergency Calls

Available Formats

Code Default Reason Phrase Reference
100 "Cannot process the alert payload" RFC 8876
101 "Alert payload was not present or could not be found" RFC 8876
102 "Not enough information to determine the purpose of the alert" RFC 8876
103 "Alert payload was corrupted" RFC 8876

Contact Information

Name Contact URI Last Updated
3GPP Specifications Manager 3gppContact&etsi.org 2023-07-31
Adam Roach adam&nostrum.com 2013-02-26
Cullen Jennings fluffy&cisco.com
Dongwook Kim dongwook.kim&etsi.org 2026-01-15
Jon Peterson jon.peterson&neustar.biz
Lionel Morand lionel.morand&orange.com 2023-03-13
Mary Barnes mary.ietf.barnes&gmail.com 2013-06-18

Footnotes

[1]

see the separate "Preemption" Registry for default reason-text strings Preemption Namespace Registry

[2]

This protocol value can also be used to represent MM cause from 3GPP TS 24.008. The MM causes in 3GPP TS 24.008 use the same decimal value as the causes in 3GPP TS 24.301. The MM causes are specified in 3GPP TS 24.008 in subclause 10.5.5.14, Table 10.5.147.

[3]

This protocol value can also be used to represent SM cause from 3GPP TS 24.008. The SM causes in 3GPP TS 24.008 use the same decimal value as the causes in 3GPP TS 24.301. The SM causes are specified in 3GPP TS 24.008 in subclause 10.5.6.6, Table 10.5.157.

[4]

The decimal values for the causes are derived from the ASN.1 encoding in subclause 9.3.4.

[5]

The decimal values for the causes are derived from the Termination-Cause AVP Values (code 295) registry.

[6]

The decimal values for the causes are derived from the IKEv2 Notify Message Types - Error Types registry.

[7]

<fcap-name> denotes parameter names conforming to the syntax <fcap-name> defined in RFC 6809. Valid feature-capability indicators are registered in the Proxy-Feature Feature-Capability Indicator Trees registry.