C509 Certificate Types
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Description | Reference |
|---|---|---|
| -32768 to -1 | Unassigned | |
| 0 | Reserved | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | Reserved | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | Natively Signed C509 Certificate | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | CBOR Re-encoded X.509 v3 Certificate | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4-32767 | Unassigned |
C509 Certification Request Types
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Description | Reference |
|---|---|---|
| -32768 to -1 | Unassigned | |
| 0 | Reserved | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | Reserved | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | Natively Signed C509 Certification Request | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | CBOR re-encoding of RFC 2986 certification request | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4-32767 | Unassigned |
C509 Private Key Types
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Comments | subjectPrivateKey | Reference |
|---|---|---|---|
| -32768 to -1 | Unassigned | ||
| 0 | Asymmetric Key Package RFC 5958 | PrivateKey OCTET STRING encoded as CBOR byte string | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | COSE Key Object RFC 9052 | COSE_Key containing a private key | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 to 32767 | Unassigned |
C509 Certification Request Templates Types
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Description | Reference |
|---|---|---|
| -32768 to -1 | Unassigned | |
| 0 | Simple C509 Certification Request Template | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1-32767 | Unassigned |
C509 RDN Attributes
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| 0 - 23 | IETF Review with Expert Review |
| 24 - 32767 | Expert Review |
| 32768 - 65535 | Reserved for Private Use |
| 65536 - 9223372036854775807 | Reserved for Future Use |
| Value | Name | Identifiers | OID | DER | Comments | Reference |
|---|---|---|---|---|---|---|
| 0 | Email Address | emailAddress, e-mailAddress | 1.2.840.113549.1.9.1 | 06 09 2A 86 48 86 F7 0D 01 09 01 | RFC 2985 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | Common Name | commonName, cn | 2.5.4.3 | 06 03 55 04 03 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | Surname | surname, sn | 2.5.4.4 | 06 03 55 04 04 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | Serial Number | serialNumber | 2.5.4.5 | 06 03 55 04 05 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4 | Country | countryName, c | 2.5.4.6 | 06 03 55 04 06 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 5 | Locality | localityName, locality, l | 2.5.4.7 | 06 03 55 04 07 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 6 | State or Province | stateOrProvinceName, st | 2.5.4.8 | 06 03 55 04 08 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 7 | Street Address | streetAddress, street | 2.5.4.9 | 06 03 55 04 09 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 8 | Organization | organizationName, o | 2.5.4.10 | 06 03 55 04 0A | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 9 | Organizational Unit | organizationalUnitName, ou | 2.5.4.11 | 06 03 55 04 0B | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 10 | Title | title | 2.5.4.12 | 06 03 55 04 0C | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 11 | Business Category | businessCategory | 2.5.4.15 | 06 03 55 04 0F | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 12 | Postal Code | postalCode | 2.5.4.17 | 06 03 55 04 11 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 13 | Given Name | givenName | 2.5.4.42 | 06 03 55 04 2A | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 14 | Initials | initials | 2.5.4.43 | 06 03 55 04 2B | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 15 | Generation Qualifier | generationQualifier | 2.5.4.44 | 06 03 55 04 2C | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 16 | DN Qualifier | dnQualifier | 2.5.4.46 | 06 03 55 04 2E | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 17 | Pseudonym | pseudonym | 2.5.4.65 | 06 03 55 04 41 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 18 | Organization Identifier | organizationIdentifier | 2.5.4.97 | 06 03 55 04 61 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 19 | Jurisdiction Locality Name | jurisdictionLocalityName | 1.3.6.1.4.1.311.60.2.1.1 | 06 0B 2B 06 01 04 01 82 37 3C 02 01 01 | Proprietary Microsoft Attribute | RFC-ietf-cose-cbor-encoded-cert-21 |
| 20 | Jurisdiction State or Province | jurisdictionStateOrProvinceName | 1.3.6.1.4.1.311.60.2.1.2 | 06 0B 2B 06 01 04 01 82 37 3C 02 01 02 | Proprietary Microsoft Attribute | RFC-ietf-cose-cbor-encoded-cert-21 |
| 21 | Jurisdiction Country Name | jurisdictionCountryName | 1.3.6.1.4.1.311.60.2.1.3 | 06 0B 2B 06 01 04 01 82 37 3C 02 01 03 | Proprietary Microsoft Attribute | RFC-ietf-cose-cbor-encoded-cert-21 |
| 22 | Domain Component | domainComponent, dc | 0.9.2342.19200300.100.1.25 | 06 0A 09 92 26 89 93 F2 2C 64 01 19 | RFC 4524 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 23-24 | Unassigned | |||||
| 25 | Name | name | 2.5.4.41 | 06 03 55 04 29 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 26 | Telephone Number | telephoneNumber | 2.5.4.20 | 06 03 55 04 14 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 27 | Directory Management Domain Name | dmdName | 2.5.4.54 | 06 03 55 04 36 | X.520 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 28 | userid | uid | 0.9.2342.19200300.100.1.1 | 06 0A 09 92 26 89 93 F2 2C 64 01 01 | RFC 4524 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 29 | Unstructured Name | unstructuredName | 1.2.840.113549.1.9.2 | 06 09 2A 86 48 86 F7 0D 01 09 02 | RFC 2985 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 30 | Unstructured Address | unstructuredAddress | 1.2.840.113549.1.9.8 | 06 09 2A 86 48 86 F7 0D 01 09 08 | RFC 2985 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 31-32767 | Unassigned | |||||
| 32768-65535 | Reserved for Private Use | RFC-ietf-cose-cbor-encoded-cert-21 | ||||
| 65536-9223372036854775807 | Reserved for Future Use | RFC-ietf-cose-cbor-encoded-cert-21 |
C509 CR Attributes
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -9223372036854775808 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| 32768-65535 | Reserved for Private Use |
| 32768-9223372036854775807 | Reserved for Future Use |
| Value | Name | Identifiers | OID | DER | Comments | attributeValue | Reference |
|---|---|---|---|---|---|---|---|
| -9223372036854775808 to -1 | Unassigned | ||||||
| 0 | Extension Request | extensionRequest | 1.2.840.113549.1.9.14 | 06 09 2A 86 48 86 F7 0D 01 09 0E | RFC 2985 | Extensions | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | Challenge Password | challengePassword | 1.2.840.113549.1.9.7 | 06 09 2A 86 48 86 F7 0D 01 09 07 | RFC 2985 | ChallengePassword | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | Private Key Possession Statement | privateKeyPossessionStatement | 1.3.6.1.4.1.22112.2.1 | 06 0A 2B 06 01 04 01 81 AC 60 02 01 | RFC 9883 | PrivateKeyPossessionStatement | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3-32767 | Unassigned | ||||||
| 32767-65535 | Reserved for Private Use | RFC-ietf-cose-cbor-encoded-cert-21 | |||||
| 65536-9223372036854775807 | Reserved for Future Use | RFC-ietf-cose-cbor-encoded-cert-21 |
C509 Extensions
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| 1 - 23 | IETF Review with Expert Review |
| 24 - 32767 | Expert Review |
| 32768 - 65535 | Reserved for Private Use |
| 65536 - 9223372036854775807 | Reserved for Future Use |
| Value | Name | Identifiers | OID | DER | Comments | extensionValue | Reference |
|---|---|---|---|---|---|---|---|
| 1 | Subject Key Identifier | subjectKeyIdentifier | 2.5.29.14 | 06 03 55 1D 0E | RFC 5280 | SubjectKeyIdentifier | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | Key Usage | keyUsage | 2.5.29.15 | 06 03 55 1D 0F | RFC 5280 | KeyUsage | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | Subject Alternative Name | subjectAltName | 2.5.29.17 | 06 03 55 1D 11 | RFC 5280 | SubjectAltName | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4 | Basic Constraints | basicConstraints | 2.5.29.19 | 06 03 55 1D 13 | RFC 5280 | BasicConstraints | RFC-ietf-cose-cbor-encoded-cert-21 |
| 5 | CRL Distribution Points | cRLDistributionPoints | 2.5.29.31 | 06 03 55 1D 1F | RFC 5280 | CRLDistributionPoints | RFC-ietf-cose-cbor-encoded-cert-21 |
| 6 | Certificate Policies | certificatePolicies | 2.5.29.32 | 06 03 55 1D 20 | RFC 5280 | CertificatePolicies | RFC-ietf-cose-cbor-encoded-cert-21 |
| 7 | Authority Key Identifier | authorityKeyIdentifier | 2.5.29.35 | 06 03 55 1D 23 | RFC 5280 | AuthorityKeyIdentifier | RFC-ietf-cose-cbor-encoded-cert-21 |
| 8 | Extended Key Usage | extKeyUsage | 2.5.29.37 | 06 03 55 1D 25 | RFC 5280 | ExtKeyUsageSyntax | RFC-ietf-cose-cbor-encoded-cert-21 |
| 9 | Authority Information Access | authorityInfoAccess | 1.3.6.1.5.5.7.1.1 | 06 08 2B 06 01 05 05 07 01 01 | RFC 5280 | AuthorityInfoAccessSyntax | RFC-ietf-cose-cbor-encoded-cert-21 |
| 10-24 | Unassigned | ||||||
| 25 | Issuer Alternative Name | issuerAltName | 2.5.29.18 | 06 03 55 1D 12 | RFC 5280 | IssuerAltName | RFC-ietf-cose-cbor-encoded-cert-21 |
| 26 | Name Constraints | nameConstraints | 2.5.29.30 | 06 03 55 1D 1E | RFC 9549 | NameConstraints | RFC-ietf-cose-cbor-encoded-cert-21 |
| 27 | Policy Mappings | policyMappings | 2.5.29.33 | 06 03 55 1D 21 | RFC 5280 | PolicyMappings | RFC-ietf-cose-cbor-encoded-cert-21 |
| 28 | Policy Constraints | policyConstraints | 2.5.29.36 | 06 03 55 1D 24 | RFC 5280 | PolicyConstraints | RFC-ietf-cose-cbor-encoded-cert-21 |
| 29 | Freshest CRL | freshestCRL | 2.5.29.46 | 06 03 55 1D 2E | RFC 5280 | FreshestCRL | RFC-ietf-cose-cbor-encoded-cert-21 |
| 30 | Inhibit anyPolicy | inhibitAnyPolicy | 2.5.29.54 | 06 03 55 1D 36 | RFC 5280 | InhibitAnyPolicy | RFC-ietf-cose-cbor-encoded-cert-21 |
| 31 | Subject Information Access | subjectInfoAccess | 1.3.6.1.5.5.7.1.11 | 06 08 2B 06 01 05 05 07 01 0B | RFC 5280 | SubjectInfoAccessSyntax | RFC-ietf-cose-cbor-encoded-cert-21 |
| 32 | IPAddrBlocks | id-pe-ipAddrBlocks | 1.3.6.1.5.5.7.1.7 | 06 08 2B 06 01 05 05 07 01 07 | RFC 3779 | IPAddrBlocks | RFC-ietf-cose-cbor-encoded-cert-21 |
| 33 | AS Identifiers | id-pe-autonomousSysIds | 1.3.6.1.5.5.7.1.8 | 06 08 2B 06 01 05 05 07 01 08 | RFC 3779 | ASIdentifiers | RFC-ietf-cose-cbor-encoded-cert-21 |
| 34 | IPAddrBlocks v2 | id-pe-ipAddrBlocks-v2 | 1.3.6.1.5.5.7.1.28 | 06 08 2B 06 01 05 05 07 01 1C | RFC 8360 | IPAddrBlocks | RFC-ietf-cose-cbor-encoded-cert-21 |
| 35 | AS Identifiers v2 | id-pe-autonomousSysIds-v2 | 1.3.6.1.5.5.7.1.29 | 06 08 2B 06 01 05 05 07 01 1D | RFC 8360 | ASIdentifiers | RFC-ietf-cose-cbor-encoded-cert-21 |
| 36 | OCSP No Check | id-pkix-ocsp-nocheck | 1.3.6.1.5.5.7.48.1.5 | 06 09 2B 06 01 05 05 07 30 01 05 | RFC 6960 | null | RFC-ietf-cose-cbor-encoded-cert-21 |
| 37 | Unassigned | ||||||
| 38 | TLS Features | id-pe-tlsfeature | 1.3.6.1.5.5.7.1.24 | 06 08 2B 06 01 05 05 07 01 18 | RFC 7633 | TLSFeatures | RFC-ietf-cose-cbor-encoded-cert-21 |
| 39-32767 | Unassigned | ||||||
| 32768-65535 | Reserved for Private Use | RFC-ietf-cose-cbor-encoded-cert-21 | |||||
| 65536-9223372036854775807 | Reserved for Future Use | RFC-ietf-cose-cbor-encoded-cert-21 |
C509 Certificate Policies
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -9223372036854775808 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| 32768-65535 | Reserved for Private Use |
| 65536-9223372036854775807 | Reserved for Future Use |
| Value | Name | Identifiers | OID | DER | Comments | Reference |
|---|---|---|---|---|---|---|
| -9223372036854775808 to -1 | Unassigned | |||||
| 0 | Any Policy | anyPolicy | 2.5.29.32.0 | 06 04 55 1D 20 00 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | Domain Validation (DV) | domain-validated | 2.23.140.1.2.1 | 06 06 67 81 0C 01 02 01 | CA/Browser Forum | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | Organization Validation (OV) | organization-validated | 2.23.140.1.2.2 | 06 06 67 81 0C 01 02 02 | CA/Browser Forum | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | Individual Validation (IV) | individual-validated | 2.23.140.1.2.3 | 06 06 67 81 0C 01 02 03 | CA/Browser Forum | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4 | Extended Validation (EV) | ev-guidelines | 2.23.140.1.1 | 06 05 67 81 0C 01 01 | CA/Browser Forum | RFC-ietf-cose-cbor-encoded-cert-21 |
| 5-6 | Unassigned | |||||
| 7 | Resource PKI (RPKI) | id-cp-ipAddr-asNumber | 1.3.6.1.5.5.7.14.2 | 06 08 2B 06 01 05 05 07 0E 02 | RFC 3779 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 8 | Resource PKI (RPKI) (Alternative) | id-cp-ipAddr-asNumber-v2 | 1.3.6.1.5.5.7.14.3 | 06 08 2B 06 01 05 05 07 0E 03 | RFC 8360 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 9-23 | Unassigned | |||||
| 24 | Remote SIM Provisioning Role Certificate Issuer | id-rspRole-ci | 2.23.146.1.2.1.0 | 06 07 67 81 12 01 02 01 00 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 25 | Remote SIM Provisioning Role eUICC v2 | id-rspRole-euicc-v2 | 2.23.146.1.2.1.1 | 06 07 67 81 12 01 02 01 01 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 26 | Remote SIM Provisioning Role eUICC | id-rspRole-euicc | 2.23.146.1.2.1.0.0.0.0.0 | 06 0B 67 81 12 01 02 01 00 00 00 00 00 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 27 | Remote SIM Provisioning Role eUICC Manufacturer v2 | id-rspRole-eum-v2 | 2.23.146.1.2.1.2 | 06 07 67 81 12 01 02 01 02 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 28 | Remote SIM Provisioning Role eUICC Manufacturer | id-rspRole-eum | 2.23.146.1.2.1.0.0.0 | 06 09 67 81 12 01 02 01 00 00 00 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 29 | Remote SIM Provisioning Role SM-DP+ TLS v2 | id-rspRole-dp-tls-v2 | 2.23.146.1.2.1.3 | 06 07 67 81 12 01 02 01 03 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 30 | Remote SIM Provisioning Role SM-DP+ TLS | id-rspRole-dp-tls | 2.23.146.1.2.1.0.0.1.0 | 06 0A 67 81 12 01 02 01 00 00 01 00 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 31 | Remote SIM Provisioning Role SM-DP+ Authentication v2 | id-rspRole-dp-auth-v2 | 2.23.146.1.2.1.4 | 06 07 67 81 12 01 02 01 04 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 32 | Remote SIM Provisioning Role SM-DP+ Authentication | id-rspRole-dp-auth | 2.23.146.1.2.1.0.0.1.1 | 06 0A 67 81 12 01 02 01 00 00 01 01 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 33 | Remote SIM Provisioning Role SM-DP+ Profile Binding v2 | id-rspRole-dp-pb-v2 | 2.23.146.1.2.1.5 | 06 07 67 81 12 01 02 01 05 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 34 | Remote SIM Provisioning Role SM-DP+ Profile Binding | id-rspRole-dp-pb | 2.23.146.1.2.1.0.0.1.2 | 06 0A 67 81 12 01 02 01 00 00 01 02 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 35 | Remote SIM Provisioning Role SM-DS TLS v2 | id-rspRole-ds-tls-v2 | 2.23.146.1.2.1.6 | 06 07 67 81 12 01 02 01 06 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 36 | Remote SIM Provisioning Role SM-DS TLS | id-rspRole-ds-tls | 2.23.146.1.2.1.0.0.2.0 | 06 0A 67 81 12 01 02 01 00 00 02 00 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 37 | Remote SIM Provisioning Role SM-DS Authentication v2 | id-rspRole-ds-auth-v2 | 2.23.146.1.2.1.7 | 06 07 67 81 12 01 02 01 07 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 38 | Remote SIM Provisioning Role SM-DS Authentication | id-rspRole-ds-auth | 2.23.146.1.2.1.0.0.2.1 | 06 0A 67 81 12 01 02 01 00 00 02 01 | GSMA SGP.22 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 39-32767 | Unassigned | |||||
| 32768-65535 | Reserved for Private Use | RFC-ietf-cose-cbor-encoded-cert-21 | ||||
| 65536-9223372036854775807 | Reserved for Future Use | RFC-ietf-cose-cbor-encoded-cert-21 |
C509 Policies Qualifiers
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Name | Identifiers | OID | DER | Comments | Reference |
|---|---|---|---|---|---|---|
| -32768 to 0 | Unassigned | |||||
| 1 | Certification Practice Statement | id-qt-cps, cps | 1.3.6.1.5.5.7.2.1 | 06 08 2B 06 01 05 05 07 02 01 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | User Notice | id-qt-unotice, unotice | 1.3.6.1.5.5.7.2.2 | 06 08 2B 06 01 05 05 07 02 02 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3-32767 | Unassigned |
C509 Information Access
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Name | Identifiers | OID | DER | Comments | Reference |
|---|---|---|---|---|---|---|
| -32768 to 0 | Unassigned | |||||
| 1 | OCSP | id-ad-ocsp, id-pkix-ocsp | 1.3.6.1.5.5.7.48.1 | 06 08 2B 06 01 05 05 07 30 01 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | CA Issuers | id-ad-caIssuers, caIssuers | 1.3.6.1.5.5.7.48.2 | 06 08 2B 06 01 05 05 07 30 02 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | Time Stamping | id-ad-timeStamping, timeStamping | 1.3.6.1.5.5.7.48.3 | 06 08 2B 06 01 05 05 07 30 03 | RFC 3161 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4 | Unassigned | |||||
| 5 | CA Repository | id-ad-caRepository | 1.3.6.1.5.5.7.48.5 | 06 08 2B 06 01 05 05 07 30 05 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 6-9 | Unassigned | |||||
| 10 | RPKI Manifest | id-ad-rpkiManifest | 1.3.6.1.5.5.7.48.10 | 06 08 2B 06 01 05 05 07 30 0A | RFC 6487 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 11 | Signed Object | id-ad-signedObject | 1.3.6.1.5.5.7.48.11 | 06 08 2B 06 01 05 05 07 30 0B | RFC 6487 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 12 | Unassigned | |||||
| 13 | RPKI Notify | id-ad-rpkiNotify | 1.3.6.1.5.5.7.48.13 | 06 08 2B 06 01 05 05 07 30 0D | RFC 8182 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 14-32767 | Unassigned |
C509 Extended Key Usages
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -9223372036854775808 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| 32768-65535 | Reserved for Private Use |
| 65536-9223372036854775807 | Reserved for Future Use |
| Value | Name | Identifiers | OID | DER | Comments | Reference |
|---|---|---|---|---|---|---|
| -9223372036854775808 to -1 | Unassigned | |||||
| 0 | Any Extended Key Usage | anyExtendedKeyUsage | 2.5.29.37.0 | 06 04 55 1D 25 00 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | TLS Server authentication | id-kp-serverAuth | 1.3.6.1.5.5.7.3.1 | 06 08 2B 06 01 05 05 07 03 01 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | TLS Client Authentication | id-kp-clientAuth | 1.3.6.1.5.5.7.3.2 | 06 08 2B 06 01 05 05 07 03 02 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | Code Signing | id-kp-codeSigning | 1.3.6.1.5.5.7.3.3 | 06 08 2B 06 01 05 05 07 03 03 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4 | Email protection (S/MIME) | id-kp-emailProtection | 1.3.6.1.5.5.7.3.4 | 06 08 2B 06 01 05 05 07 03 04 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 5-7 | Unassigned | |||||
| 8 | Time Stamping | id-kp-timeStamping, timestamping | 1.3.6.1.5.5.7.3.8 | 06 08 2B 06 01 05 05 07 03 08 | RFC 3161 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 9 | OCSP Signing | id-kp-OCSPSigning | 1.3.6.1.5.5.7.3.9 | 06 08 2B 06 01 05 05 07 03 09 | RFC 5280 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 10 | Kerberos PKINIT Client Auth | id-pkinit-KPClientAuth | 1.3.6.1.5.2.3.4 | 06 07 2B 06 01 05 02 03 04 | RFC 4556 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 11 | Kerberos PKINIT KDC | id-pkinit-KPKdc | 1.3.6.1.5.2.3.5 | 06 07 2B 06 01 05 02 03 05 | RFC 4556 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 12 | SSH Client | id-kp-secureShellClient | 1.3.6.1.5.5.7.3.21 | 06 08 2B 06 01 05 05 07 03 15 | RFC 6187 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 13 | SSH Server | id-kp-secureShellServer | 1.3.6.1.5.5.7.3.22 | 06 08 2B 06 01 05 05 07 03 16 | RFC 6187 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 14 | Bundle Security | id-kp-bundleSecurity | 1.3.6.1.5.5.7.3.35 | 06 08 2B 06 01 05 05 07 03 23 | RFC 9174 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 15 | CMC Certification Authority | id-kp-cmcCA | 1.3.6.1.5.5.7.3.27 | 06 08 2B 06 01 05 05 07 03 1B | RFC 6402 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 16 | CMC Registration Authority | id-kp-cmcRA | 1.3.6.1.5.5.7.3.28 | 06 08 2B 06 01 05 05 07 03 1C | RFC 6402 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 17 | CMC Archive Server | id-kp-cmcArchive | 1.3.6.1.5.5.7.3.29 | 06 08 2B 06 01 05 05 07 03 1D | RFC 6402 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 18 | CMC Key Generation Authority | id-kp-cmKGA | 1.3.6.1.5.5.7.3.32 | 06 08 2B 06 01 05 05 07 03 20 | RFC 9480 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 19 | Unassigned | |||||
| 20 | Wi-SUN FAN Device | id-kp-wisun-fan-device | 1.3.6.1.4.1.45605.1 | 06 09 2B 06 01 04 01 82 E4 25 01 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 21-32767 | Unassigned | |||||
| 32768-65535 | Reserved for Private Use | RFC-ietf-cose-cbor-encoded-cert-21 | ||||
| 65536-9223372036854775807 | Reserved for Future Use | RFC-ietf-cose-cbor-encoded-cert-21 |
C509 General Names
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Name | Comments | GeneralNameValue | Reference |
|---|---|---|---|---|
| -32768 to -4 | Unassigned | |||
| -3 | otherName with MACAddress | 12 id-on-MACAddress (1.3.6.1.5.5.7.8.12) 06 08 2B 06 01 05 05 07 08 0C | bytes | RFC-ietf-cose-cbor-encoded-cert-21 |
| -2 | otherName with SmtpUTF8Mailbox | RFC 9598 id-on-SmtpUTF8Mailbox (1.3.6.1.5.5.7.8.9) 06 08 2B 06 01 05 05 07 08 09 | text | RFC-ietf-cose-cbor-encoded-cert-21 |
| -1 | otherName with hardwareModuleName | RFC 4180 id-on-hardwareModuleName (1.3.6.1.5.5.7.8.4) 06 08 2B 06 01 05 05 07 08 04 | [~oid, bytes] | RFC-ietf-cose-cbor-encoded-cert-21 |
| 0 | otherName | RFC 5280 | [~oid, bytes] | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | rfc822Name | RFC 5280 | text | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | dNSName | RFC 5280 | text | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | Unassigned | |||
| 4 | directoryName | RFC 5280 | Name | RFC-ietf-cose-cbor-encoded-cert-21 |
| 6 | uniformResourceIdentifier | RFC 5280 | text | RFC-ietf-cose-cbor-encoded-cert-21 |
| 7 | iPAddress | RFC 5280 | bytes | RFC-ietf-cose-cbor-encoded-cert-21 |
| 8 | registeredID | RFC 5280 | ~oid | RFC-ietf-cose-cbor-encoded-cert-21 |
| 9-32767 | Unassigned |
C509 Signature Algorithms
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Name | Identifiers | OID | Parameters | DER | Comments | Reference |
|---|---|---|---|---|---|---|---|
| -32768 to -257 | Unassigned | ||||||
| -256 | RSASSA-PKCS1-v1_5 with SHA-1 | sha1-with-rsa-signature, sha1WithRSAEncryption, sha-1WithRSAEncryption | 1.2.840.113549.1.1.5 | NULL | 30 0D 06 09 2A 86 48 86 F7 0D 01 01 05 05 00 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| -255 | ECDSA with SHA-1 | ecdsa-with-SHA1 | 1.2.840.10045.4.1 | Absent | 30 09 06 07 2A 86 48 CE 3D 04 01 | See RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.2 | RFC-ietf-cose-cbor-encoded-cert-21 |
| -254 to -1 | Unassigned | ||||||
| 0 | ECDSA with SHA-256 | ecdsa-with-SHA256 | 1.2.840.10045.4.3.2 | Absent | 30 0A 06 08 2A 86 48 CE 3D 04 03 02 | See RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.2 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | ECDSA with SHA-384 | ecdsa-with-SHA384 | 1.2.840.10045.4.3.3 | Absent | 30 0A 06 08 2A 86 48 CE 3D 04 03 03 | See RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.2 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | ECDSA with SHA-512 | ecdsa-with-SHA512 | 1.2.840.10045.4.3.4 | Absent | 30 0A 06 08 2A 86 48 CE 3D 04 03 04 | See RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.2 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | ECDSA with SHAKE128 | id-ecdsa-with-shake128 | 1.3.6.1.5.5.7.6.32 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 20 | See RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.2 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4 | ECDSA with SHAKE256 | id-ecdsa-with-shake256 | 1.3.6.1.5.5.7.6.33 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 21 | See RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.2 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 5 | Unsigned | id-alg-unsigned | 1.3.6.1.5.5.7.6.36 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 24 | bytes of size 0 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 6-7 | Unassigned | ||||||
| 8 | SM2 with SM3 | sm2-with-sm3 | 1.2.156.10197.1.501 | Absent | 30 0A 06 08 2A 81 1C CF 55 01 83 75 | See RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.2 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 9-11 | Unassigned | ||||||
| 12 | Ed25519 | id-Ed25519, id-EdDSA25519 | 1.3.101.112 | Absent | 30 05 06 03 2B 65 70 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 13 | Ed448 | id-Ed448, id-EdDSA448 | 1.3.101.113 | Absent | 30 05 06 03 2B 65 71 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 14 | PoP with SHA-256 and HMAC-SHA256 | sa-ecdhPop-sha256-hmac-sha256 | 1.3.6.1.5.5.7.6.26 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 1A | Proof-of-possession algorithm, indexed with KDF and MAC, see RFC 6955. Requires recipient's public static Diffie-Hellman key | RFC-ietf-cose-cbor-encoded-cert-21 |
| 15 | PoP with SHA-384 and HMAC-SHA384 | sa-ecdhPop-sha384-hmac-sha384 | 1.3.6.1.5.5.7.6.27 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 1B | Proof-of-possession algorithm, indexed with KDF and MAC, see RFC 6955. Requires recipient's public static Diffie-Hellman key | RFC-ietf-cose-cbor-encoded-cert-21 |
| 16 | PoP with SHA-512 and HMAC-SHA512 | sa-ecdhPop-sha512-hmac-sha512 | 1.3.6.1.5.5.7.6.28 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 1C | Proof-of-possession algorithm, indexed with KDF and MAC, see RFC 6955. Requires recipient's public static Diffie-Hellman key | RFC-ietf-cose-cbor-encoded-cert-21 |
| 17-22 | Unassigned | ||||||
| 23 | RSASSA-PKCS1-v1_5 with SHA-256 | sha256WithRSAEncryption | 1.2.840.113549.1.1.11 | NULL | 30 0D 06 09 2A 86 48 86 F7 0D 01 01 0B 05 00 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 24 | RSASSA-PKCS1-v1_5 with SHA-384 | sha384WithRSAEncryption | 1.2.840.113549.1.1.12 | NULL | 30 0D 06 09 2A 86 48 86 F7 0D 01 01 0C 05 00 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 25 | RSASSA-PKCS1-v1_5 with SHA-512 | sha512WithRSAEncryption | 1.2.840.113549.1.1.13 | NULL | 30 0D 06 09 2A 86 48 86 F7 0D 01 01 0D 05 00 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 26 | RSASSA-PSS with SHA-256 | rsassa-pss, id-RSASSA-PSS | 1.2.840.113549.1.1.10 | SHA-256, MGF-1 with SHA-256, saltLength = 32 | 30 41 06 09 2A 86 48 86 F7 0D 01 01 0A 30 34 A0 0F 30 0D 06 09 60 86 48 01 65 03 04 02 01 05 00 A1 1C 30 1A 06 09 2A 86 48 86 F7 0D 01 01 08 30 0D 06 09 60 86 48 01 65 03 04 02 01 05 00 A2 03 02 01 20 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 27 | RSASSA-PSS with SHA-384 | rsassa-pss, id-RSASSA-PSS | 1.2.840.113549.1.1.10 | SHA-384, MGF-1 with SHA-384, saltLength = 48 | 30 41 06 09 2A 86 48 86 F7 0D 01 01 0A 30 34 A0 0F 30 0D 06 09 60 86 48 01 65 03 04 02 02 05 00 A1 1C 30 1A 06 09 2A 86 48 86 F7 0D 01 01 08 30 0D 06 09 60 86 48 01 65 03 04 02 02 05 00 A2 03 02 01 30 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 28 | RSASSA-PSS with SHA-512 | rsassa-pss, id-RSASSA-PSS | 1.2.840.113549.1.1.10 | SHA-512, MGF-1 with SHA-512, saltLength = 64 | 30 41 06 09 2A 86 48 86 F7 0D 01 01 0A 30 34 A0 0F 30 0D 06 09 60 86 48 01 65 03 04 02 03 05 00 A1 1C 30 1A 06 09 2A 86 48 86 F7 0D 01 01 08 30 0D 06 09 60 86 48 01 65 03 04 02 03 05 00 A2 03 02 01 40 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 29 | RSASSA-PSS with SHAKE128 | id-RSASSA-PSS-SHAKE128 | 1.3.6.1.5.5.7.6.30 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 1E | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 30 | RSASSA-PSS with SHAKE256 | id-RSASSA-PSS-SHAKE256 | 1.3.6.1.5.5.7.6.31 | Absent | 30 0A 06 08 2B 06 01 05 05 07 06 1F | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 31-32767 | Unassigned |
C509 Public Key Algorithms
Expert(s)
- Unassigned
Reference
- RFC-ietf-cose-cbor-encoded-cert-21: CBOR Encoded X.509 Certificates (C509 Certificates)
Available Formats
| Range | Registration Procedures |
|---|---|
| -32768 to -25 | Expert Review |
| -24 - 23 | IETF Review with Expert Review |
| 24 to 32767 | Expert Review |
| Value | Name | Identifiers | OID | Parameters | DER | Comments | Reference |
|---|---|---|---|---|---|---|---|
| -32768 to -1 | Unassigned | ||||||
| 0 | RSA | rsaEncryption | 1.2.840.113549.1.1.1 | NULL | 30 0D 06 09 2A 86 48 86 F7 0D 01 01 01 05 00 | subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 1 | EC Public Key (Weierstrass) with secp256r1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = secp256r1 (1.2.840.10045.3.1.7) | 30 13 06 07 2A 86 48 CE 3D 02 01 06 08 2A 86 48 CE 3D 03 01 07 |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1. Also known as P-256, ansip256r1, prime256v1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 2 | EC Public Key (Weierstrass) with secp384r1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = secp384r1 (1.3.132.0.34) | 30 10 06 07 2A 86 48 CE 3D 02 01 06 05 2B 81 04 00 22 |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1. Also known as P-384, ansip384r1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 3 | EC Public Key (Weierstrass) with secp521r1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = secp521r1 (1.3.132.0.35) | 30 10 06 07 2A 86 48 CE 3D 02 01 06 05 2B 81 04 00 23 |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1. Also known as P-521, ansip521r1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 4-5 | Unassigned | ||||||
| 6 | EC Public Key (Weierstrass) with sm2p256v1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = sm2p256v1 (1.2.156.10197.1.301) | 30 13 06 07 2A 86 48 CE 3D 02 01 06 08 2A 81 1C CF 55 01 82 2D |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 7 | Unassigned | ||||||
| 8 | X25519 (Montgomery) | id-X25519 | 1.3.101.110 | Absent | 30 05 06 03 2B 65 6E | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 9 | X448 (Montgomery) | id-X448 | 1.3.101.111 | Absent | 30 05 06 03 2B 65 6F | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 10-11 | Unassigned | ||||||
| 12 | Ed25519 (Twisted Edwards) | id-Ed25519, id-EdDSA25519 | 1.3.101.112 | Absent | 30 05 06 03 2B 65 70 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 13 | Ed448 (Edwards) | id-Ed448, id-EdDSA448 | 1.3.101.113 | Absent | 30 05 06 03 2B 65 71 | RFC-ietf-cose-cbor-encoded-cert-21 | |
| 14-23 | Unassigned | ||||||
| 24 | EC Public Key (Weierstrass) with brainpoolP256r1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = brainpoolP256r1 (1.3.36.3.3.2.8.1.1.7) | 30 14 06 07 2A 86 48 CE 3D 02 01 06 09 2B 24 03 03 02 08 01 01 07 |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 25 | EC Public Key (Weierstrass) with brainpoolP384r1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = brainpoolP384r1 (1.3.36.3.3.2.8.1.1.11) | 30 14 06 07 2A 86 48 CE 3D 02 01 06 09 2B 24 03 03 02 08 01 01 0B |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 26 | EC Public Key (Weierstrass) with brainpoolP512r1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = brainpoolP512r1 (1.3.36.3.3.2.8.1.1.13) | 30 14 06 07 2A 86 48 CE 3D 02 01 06 09 2B 24 03 03 02 08 01 01 0D |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 27 | EC Public Key (Weierstrass) with FRP256v1 | ecPublicKey, id-ecPublicKey | 1.2.840.10045.2.1 | namedCurve = FRP256v1 (1.2.250.1.223.101.256.1) | 30 15 06 07 2A 86 48 CE 3D 02 01 06 0A 2A 81 7A 01 81 5F 65 82 00 01 |
subjectPublicKey encoded as in RFC-ietf-cose-cbor-encoded-cert-21, Section 3.2.1 | RFC-ietf-cose-cbor-encoded-cert-21 |
| 28-32767 | Unassigned |