Transport Layer Security (TLS) Compression Method Identifiers

Created

  • 2004-05-03

Last Updated

  • 2018-08-10

Available Formats


TLS Compression Method Identifiers

Expert(s)

  • Yoav Nir, Rich Salz, Nick Sullivan

Reference

  • RFC 3749: Transport Layer Security Protocol Compression Methods
  • RFC 8447: IANA Registry Updates for TLS and DTLS

Note

Value 0 (NULL) is the only value in this registry applicable to (D)TLS protocol version 1.3 or later.

Available Formats

Range Registration Procedures
0-63 Standards Action
64-223 Specification Required
224-255 Reserved for Private Use
Value Description Reference
0 NULL RFC 5246
1 DEFLATE RFC 3749
2-63 Unassigned
64 LZS RFC 3943
65-223 Unassigned
224-255 Reserved for Private Use RFC 3749