Internet Protocol Version 4 (IPv4) Parameters

Last Updated

  • 2018-05-03

Available Formats


IP Option Numbers

Registration Procedure(s)

  • Not defined

Note

The Internet Protocol (IP) has provision for optional header fields identified by an option type field. Options 0 and 1 are exactly one octet which is their type field. All other options have their one octet type field, followed by a one octet length field, followed by length-2 octets of option data. The option type field is sub-divided into a one bit copied flag, a two bit class field, and a five bit option number. These taken together form an eight bit value for the option type field. IP options are commonly referred to by this value.

Available Formats

Copy Class Number Value Name Reference
0 0 0 0
EOOL   - End of Options List
RFC 791; Jon Postel
0 0 1 1
NOP    - No Operation
RFC 791; Jon Postel
1 0 2 130
SEC    - Security
RFC 1108
1 0 3 131
LSR    - Loose Source Route
RFC 791; Jon Postel
0 2 4 68
TS     - Time Stamp
RFC 791; Jon Postel
1 0 5 133
E-SEC  - Extended Security
RFC 1108
1 0 6 134
CIPSO  - Commercial Security
draft-ietf-cipso-ipsecurity-01
0 0 7 7
RR     - Record Route
RFC 791; Jon Postel
1 0 8 136
SID    - Stream ID
RFC 791; Jon Postel; RFC 6814[1]
1 0 9 137
SSR    - Strict Source Route
RFC 791; Jon Postel
0 0 10 10
ZSU    - Experimental Measurement
ZSu
0 0 11 11
MTUP   - MTU Probe
RFC 1063; RFC 1191[1]
0 0 12 12
MTUR   - MTU Reply
RFC 1063; RFC 1191[1]
1 2 13 205
FINN   - Experimental Flow Control
Greg Finn
1 0 14 142
VISA   - Experimental Access Control
Deborah Estrin; RFC 6814[1]
0 0 15 15
ENCODE - ???
VerSteeg; RFC 6814[1]
1 0 16 144
IMITD  - IMI Traffic Descriptor
Lee
1 0 17 145
EIP    - Extended Internet Protocol
RFC 1385; RFC 6814[1]
0 2 18 82
TR     - Traceroute
RFC 1393; RFC 6814[1]
1 0 19 147
ADDEXT - Address Extension
Ullmann IPv7; RFC 6814[1]
1 0 20 148
RTRALT - Router Alert
RFC 2113
1 0 21 149
SDB    - Selective Directed Broadcast
Charles "Bud" Graff; RFC 6814[1]
1 0 22 150
       - Unassigned (Released 18 October 2005)
1 0 23 151
DPS    - Dynamic Packet State
Andy Malis; RFC 6814[1]
1 0 24 152
UMP    - Upstream Multicast Pkt.
Dino Farinacci; RFC 6814[1]
0 0 25 25
QS     - Quick-Start
RFC 4782
0 0 30 30
EXP    - RFC3692-style Experiment [2]
RFC 4727
0 2 30 94
EXP    - RFC3692-style Experiment [2]
RFC 4727
1 0 30 158
EXP    - RFC3692-style Experiment [2]
RFC 4727
1 2 30 222
EXP    - RFC3692-style Experiment [2]
RFC 4727

IPv4 Router Alert Option Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5350: IANA Considerations for the IPv4 and IPv6 Router Alert Options

Available Formats

Value Description Reference
0 Router shall examine packet RFC 2113
1-32 Aggregated Reservation Nesting Level RFC 3175
33-64 QoS NSLP Aggregation Levels 0-31 RFC 5974
65 NSIS NATFW NSLP RFC 5973
66-65502 Unassigned
65503-65534 Reserved for experimental use RFC 5350
65535 Reserved RFC 5350

IP Time to Live Parameter

Registration Procedure(s)

  • Not defined

Note

The current recommended default time to live (TTL) for the Internet Protocol (IP) is 64 RFC 791; RFC 1122.


IP TOS Parameters

Registration Procedure(s)

  • Registrations no longer accepted

Note

This registry was deprecated following the publication of RFC 2474.


Type-of-Service Values

Registration Procedure(s)

  • Registrations no longer accepted

Note

This registry was deprecated following the publication of RFC 2474.


Contact Information

Name Contact URI Last Updated
Andy Malis agmalis&gmail.com 2013-05-28
Charles "Bud" Graff bud&fotlan.army.mil 1995-03
Deborah Estrin Estrin&usc.edu 1994-10
Dino Farinacci dino&cisco.com 1999-05
Greg Finn Finn&isi.edu 1994-10
Jon Postel postel&isi.edu 1994-10

Footnotes

[1]

obsoleted IP Option Number

[2]

It is only appropriate to use these values in explicitly-configured experiments; they MUST NOT be shipped as defaults in implementations. See RFC 3692 for details.