Path Computation Element Protocol (PCEP) Numbers

Created

  • 2008-12-19

Last Updated

  • 2026-08-06

Available Formats


PCEP Messages

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Available Formats

Range Registration Procedures
0-251 IETF Review
252-255 Experimental Use
Value Description Reference
0 Reserved RFC 5440
1 Open RFC 5440
2 Keepalive RFC 5440
3 Path Computation Request RFC 5440
4 Path Computation Reply RFC 5440
5 Notification RFC 5440
6 Error RFC 5440
7 Close RFC 5440
8 Path Computation Monitoring Request (PCMonReq) RFC 5886
9 Path Computation Monitoring Reply (PCMonRep) RFC 5886
10 Report RFC 8231
11 Update RFC 8231
12 LSP Initiate Request RFC 8281
13 StartTLS RFC 8253
14-251 Unassigned
252-255 Experimental Use RFC 8356

PCEP Objects

Reference

Available Formats

Range Registration Procedures
0-247 IETF Review
248-255 Experimental Use
Object-Class Value Name Object-Type Reference
0 Reserved 0-15: Reserved RFC 5440; RFC Errata 4956
1 OPEN 0: Reserved RFC 5440; RFC Errata 4956
1: Open RFC 5440
2-15: Unassigned
2 RP 0: Reserved RFC 5440; RFC Errata 4956
1: Request Parameters RFC 5440
2-15: Unassigned
3 NO-PATH 0: Reserved RFC 5440; RFC Errata 4956
1: No Path RFC 5440
2-15: Unassigned
4 END-POINTS 0: Reserved RFC 5440; RFC Errata 4956
1: IPv4 addresses RFC 5440
2: IPv6 addresses RFC 5440
3: IPv4 RFC 8306
4: IPv6 RFC 8306
5: Generalized Endpoint RFC 8779, Section 2.5
6-15: Unassigned
5 BANDWIDTH 0: Reserved RFC 5440; RFC Errata 4956
1: Requested bandwidth RFC 5440
2: Bandwidth of an existing TE LSP for which a reoptimization is requested RFC 5440
3: Generalized bandwidth RFC 8779, Section 2.3
4: Generalized bandwidth of an existing TE-LSP for which a reoptimization is requested RFC 8779, Section 2.3
5-15: Unassigned
6 METRIC 0: Reserved RFC 5440; RFC Errata 4956
1: Metric RFC 5440
2-15: Unassigned
7 ERO 0: Reserved RFC 5440; RFC Errata 4956
1: Explicit Route RFC 5440
2-15: Unassigned
8 RRO 0: Reserved RFC 5440; RFC Errata 4956
1: Recorded Route RFC 5440
2-15: Unassigned
9 LSPA 0: Reserved RFC 5440; RFC Errata 4956
1: LSP Attributes RFC 5440
2-15: Unassigned
10 IRO 0: Reserved RFC 5440; RFC Errata 4956
1: Include Route RFC 5440
2-15: Unassigned
11 SVEC 0: Reserved RFC 5440; RFC Errata 4956
1: Synchronization Vector RFC 5440
2-15: Unassigned
12 NOTIFICATION 0: Reserved RFC 5440; RFC Errata 4956
1: Notification RFC 5440
2-15: Unassigned
13 PCEP-ERROR 0: Reserved RFC 5440; RFC Errata 4956
1: PCEP Error RFC 5440
2-15: Unassigned
14 LOAD-BALANCING 0: Reserved RFC 5440; RFC Errata 4956
1: Load Balancing RFC 5440
2: Generalized Load Balancing RFC 8779, Section 2.4
3-15: Unassigned
15 CLOSE 0: Reserved RFC 5440; RFC Errata 4956
1: Close RFC 5440
2-15: Unassigned
16 PATH-KEY 0: Reserved RFC 5520; RFC Errata 4956
1: Path Key RFC 5520
2-15: Unassigned
17 XRO 0: Reserved RFC 5521; RFC Errata 4956
1: Route exclusion RFC 5521
2-15: Unassigned
18 Unassigned 0: Reserved RFC Errata 4956
1-15: Unassigned
19 MONITORING 0: Reserved RFC 5886; RFC Errata 4956
1: Monitoring RFC 5886
2-15: Unassigned
20 PCC-REQ-ID 0: Reserved RFC 5886; RFC Errata 4956
1: IPV4 Addresses RFC 5886
2: IPV6 Addresses RFC 5886
3-15: Unassigned
21 OF 0: Reserved RFC 5541; RFC Errata 4956
1: Objective Function RFC 5541
2-15: Unassigned
22 CLASSTYPE 0: Reserved RFC 5455; RFC Errata 4956
1: Class-Type RFC 5455
2-15: Unassigned
23 Unassigned 0: Reserved RFC Errata 4956
1-15: Unassigned
24 GLOBAL-CONSTRAINTS 0: Reserved RFC 5557; RFC Errata 4956
1: Global Constraints RFC 5557
2-15: Unassigned
25 PCE-ID 0: Reserved RFC 5886; RFC Errata 4956
1: IPV4 Addresses RFC 5886
2: IPV6 Addresses RFC 5886
3-15: Unassigned
26 PROC-TIME 0: Reserved RFC 5886; RFC Errata 4956
1: PROC-TIME RFC 5886
2-15: Unassigned
27 OVERLOAD 0: Reserved RFC 5886; RFC Errata 4956
1: overload RFC 5886
2-15: Unassigned
28 UNREACH-DESTINATION 0: Reserved RFC 8306
1: IPv4 RFC 8306
2: IPv6 RFC 8306
3-15: Unassigned
29 SERO 0: Reserved RFC 8306
1: SERO RFC 8306
2-15: Unassigned
30 SRRO 0: Reserved RFC 8306
1: SRRO RFC 8306
2-15: Unassigned
31 BNC 0: Reserved RFC 8306
1: Branch node list RFC 8306
2: Non-branch node list RFC 8306
3-15: Unassigned
32 LSP 0: Reserved RFC 8231
1: LSP RFC 8231
2-15: Unassigned
33 SRP 0: Reserved RFC 8231
1: SRP RFC 8231
2-15: Unassigned
34 VENDOR-INFORMATION 0: Reserved RFC 7470; RFC Errata 4956
1: Vendor-Specific Constraints RFC 7470
2-15: Unassigned
35 BU 0: Reserved RFC 8233; RFC Errata 4956
1: BU RFC 8233
2-15: Unassigned
36 INTER-LAYER 0: Reserved RFC 8282
1: Inter-layer RFC 8282
2-15: Unassigned
37 SWITCH-LAYER 0: Reserved RFC 8282
1: Switch-layer RFC 8282
2-15: Unassigned
38 REQ-ADAP-CAP 0: Reserved RFC 8282
1: Req-Adap-Cap RFC 8282
2-15: Unassigned
39 SERVER-INDICATION 0: Reserved RFC 8282
1: Server-indication RFC 8282
2-15: Unassigned
40 ASSOCIATION 0: Reserved RFC 8697
1: IPv4 RFC 8697
2: IPv6 RFC 8697
3-15: Unassigned
41 S2LS 0: Reserved RFC 8623
1: S2LS RFC 8623
2-15: Unassigned
42 WA 0: Reserved RFC 8780
1: Wavelength Assignment RFC 8780
2-15: Unassigned
43 FLOWSPEC 0: Reserved RFC 9168
1: Flow Specification RFC 9168
2-15: Unassigned
44 CCI Object-Type 0: Reserved RFC 9050
1: MPLS Label RFC 9050
2: Native IP RFC 9757
3: SR P2MP Policy (TEMPORARY - registered 2024-08-27, extension registered 2026-08-06, expires 2027-08-27) draft-ietf-pce-sr-p2mp-policy-11
4-15: Unassigned
45 PATH-ATTRIB 0: Reserved RFC-ietf-pce-multipath-29
1: PATH-ATTRIB RFC-ietf-pce-multipath-29
2-15: Unassigned
46 BGP Peer Info Object-Type 0: Reserved RFC 9757
1: IPv4 address RFC 9757
2: IPv6 address RFC 9757
3-15: Unassigned
47 Explicit Peer Route Object-Type 0: Reserved RFC 9757
1: IPv4 address RFC 9757
2: IPv6 address RFC 9757
3-15: Unassigned
48 Peer Prefix Advertisement Object-Type 0: Reserved RFC 9757
1: IPv4 address RFC 9757
2: IPv6 address RFC 9757
3-15: Unassigned
49-247 Unassigned 0: Reserved RFC Errata 4956
1-15: Unassigned
248-255 Experimental Use 0-15: Experimental Use RFC 8356

PCEP Message Common Header Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-4 Unassigned

Open Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-4 Unassigned

RP Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-14 Unassigned
15-16 Routing Granularity (RG) RFC 8779, Section 2.2
17 Core-tree computation (C-bit) RFC 7334
18 Fragmentation (F-bit) RFC 8306
19 P2MP (N-bit) RFC 8306
20 ERO-compression (E-bit) RFC 8306
21 Make-before-break (M-bit) RFC 5557
22 Report the request order (D-bit) RFC 5557
23 Path Key (P-bit) RFC 5520
24 Supply OF on response RFC 5541
25 VSPT RFC 5441
26 Strict/Loose RFC 5440
27 Bi-directional RFC 5440
28 Reoptimization RFC 5440
29-31 Priority RFC 5440

NO-PATH Object NI Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Available Formats

Value Description Reference
0 No path satisfying the set of constraints could be found RFC 5440
1 PCE chain broken RFC 5440
2-255 Unassigned

NO-PATH Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0 Unsatisfied constrained indicated RFC 5440
1-15 Unassigned

METRIC Object T Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Available Formats

Value Description Reference
0 Reserved RFC 5440
1 IGP metric RFC 5440
2 TE metric RFC 5440
3 Hop Counts RFC 5440
4 Aggregate bandwidth consumption RFC 5541
5 Load of the most loaded link RFC 5541
6 Cumulative IGP cost RFC 5541
7 Cumulative TE cost RFC 5541
8 P2MP IGP metric RFC 8306
9 P2MP TE metric RFC 8306
10 P2MP hop count metric RFC 8306
11 Segment-ID (SID) Depth. RFC 8664
12 Path Delay metric RFC 8233
13 Path Delay Variation metric RFC 8233
14 Path Loss metric RFC 8233
15 P2MP Path Delay metric RFC 8233
16 P2MP Path Delay variation metric RFC 8233
17 P2MP Path Loss metric RFC 8233
18 Number of adaptations on a path RFC 8282
19 Number of layers on a path RFC 8282
20 Domain Count metric RFC 8685
21 Border Node Count metric RFC 8685
22 Path Min Delay metric RFC 9933
23 P2MP Path Min Delay metric RFC 9933
24 Path Bandwidth metric RFC 9933
25 P2MP Path Bandwidth metric RFC 9933
26-127 Unassigned
128-255 User-defined metric RFC 9933

METRIC Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-5 Unassigned
6 Computed metric RFC 5440
7 Bound RFC 5440

LSPA Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-5 Unassigned
6 Protection Enforcement RFC 9488
7 Local Protection Desired RFC 5440

IRO Subobjects

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5521: Extensions to the Path Computation Element Communication Protocol (PCEP) for Route Exclusions

Available Formats

Value Description Reference
1 IPv4 prefix RFC 3209
2 IPv6 prefix RFC 3209
3 Unassigned
4 Unnumbered Interface ID RFC 3477
5 4-byte AS number RFC 7897; RFC 7898
6 OSPF Area ID RFC 7897; RFC 7898
7 IS-IS Area ID RFC 7897; RFC 7898
8 Optical Interface Class List RFC 8780
9 Client Signal Information RFC 8780
10 Label RFC 8779
11-31 Unassigned
32 Autonomous system number RFC 3209
33 Explicit Exclusion Route subobject (EXRS) RFC 4874
34-127 Unassigned

SVEC Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-17 Unassigned
18 Domain Diverse O-bit RFC 8685
19 Partial Path Diverse RFC 8306
20 Link Direction Diverse RFC 8306
21 SRLG Diverse RFC 5440
22 Node Diverse RFC 5440
23 Link Diverse RFC 5440

Notification Object

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Available Formats

Notification-type Name Notification-value Reference
0 Reserved 1-255: Reserved RFC 5440
1 Pending Request cancelled 1: PCC cancels a set of pending requests RFC 5440
2: PCE cancels a set of pending requests RFC 5440
3-255: Unassigned
2 PCE Congestion 1: PCE in congested state RFC 5440
2: PCE no longer in congested state RFC 5440
3-255: Unassigned
3 Unassigned 1-255: Unassigned
4 Stateful PCE resource limit exceeded 0: Unassigned
1: Entering resource limit exceeded state RFC 8231
2: Deprecated RFC 8231
3-255: Unassigned
5 Auto-Bandwidth Overwhelm State 0: Unassigned
1: Entering Auto-Bandwidth Overwhelm State RFC 8733
2: Clearing Auto-Bandwidth Overwhelm State RFC 8733
3-255: Unassigned
6-255 Unassigned 1-255: Unassigned

Notification Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-7 Unassigned

PCEP-ERROR Object Error Types and Values

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Range Registration Procedures Note
0-251 IETF Review The IETF Review procedure applies to all Error-values (0-255) for Error-Types in this range.
252-255 Experimental Use The Experimental Use policy applies to all Error-values (0-255) for Error-Types in this range.
Error-Type Meaning Error-value Reference
0 Reserved 0-255: Reserved RFC 5440
1 PCEP session establishment failure 0: Unassigned RFC 5440
1: reception of an invalid Open message or a non Open message. RFC 5440
2: no Open message received before the expiration of the OpenWait timer RFC 5440
3: unacceptable and non negotiable session characteristics RFC 5440
4: unacceptable but negotiable session characteristics RFC 5440
5: reception of a second Open message with still unacceptable session characteristics RFC 5440
6: reception of a PCErr message proposing unacceptable session characteristics RFC 5440
7: No Keepalive or PCErr message received before the expiration of the KeepWait timer RFC 5440
8: PCEP version not supported RFC 5440
9-255: Unassigned
2 Capability not supported 0-255: Unassigned RFC 5440
3 Unknown Object 0: Unassigned RFC 5440
1: Unrecognized object class RFC 5440
2: Unrecognized object Type RFC 5440
3-255: Unassigned
4 Not supported object 0: Unassigned RFC 5440
1: Not supported object class RFC 5440
2: Not supported object Type RFC 5440
3: Unassigned
4: Unsupported parameter RFC 5441
5: Unsupported network performance constraint RFC 8233
6: BANDWIDTH object type 3 or 4 not supported RFC 8779
7: Unsupported endpoint type in END-POINTS Generalized Endpoint object type RFC 8779
8: Unsupported TLV present in END-POINTS Generalized Endpoint object type RFC 8779
9: Unsupported granularity in the RP object flags RFC 8779
10-255: Unassigned
5 Policy violation 0: Unassigned RFC 5440
1: C bit of the METRIC object set (request rejected) RFC 5440
2: O bit of the RP object cleared (request rejected) RFC 5440
3: objective function not allowed (request rejected) RFC 5541
4: OF bit of the RP object set (request rejected) RFC 5541
5: Global concurrent optimization not allowed RFC 5557
6: Monitoring message supported but rejected due to policy violation RFC 5886
7: P2MP Path computation is not allowed RFC 8306
8: Not allowed network performance constraint RFC 8233
9-255: Unassigned
6 Mandatory Object missing 0: Unassigned RFC 5440
1: RP object missing RFC 5440
2: RRO missing for a reoptimization request (R bit of the RP object set) RFC 5440
3: END-POINTS object missing RFC 5440
4: MONITORING object missing RFC 5886
5-7: Unassigned
8: LSP object missing RFC 8231
9: ERO object missing RFC 8231
10: SRP object missing RFC 8231
11: LSP-IDENTIFIERS TLV missing RFC 8231
12: LSP-DB-VERSION TLV missing RFC 8232
13: S2LS object missing RFC 8623
14: P2MP-LSP-IDENTIFIERS TLV missing RFC 8623
15: DISJOINTNESS-CONFIGURATION TLV missing RFC 8800
16: Scheduled TLV missing RFC 8934
17: CCI object missing RFC 9050
18: VIRTUAL-NETWORK-TLV missing RFC 9358
19: Native IP object missing RFC 9757
20: LABEL-REQUEST TLV missing RFC 9504
21: Missing SR Policy Mandatory TLV RFC 9862
22: Missing SR Policy Association RFC 9862
23-255: Unassigned
7 Synchronized path computation request missing 0-255: Unassigned RFC 5440
8 Unknown request reference 0-255: Unassigned RFC 5440
9 Attempt to establish a second PCEP session 0-255: Unassigned RFC 5440
10 Reception of an invalid object 0: Unassigned RFC 5440
1: Reception of an object with P flag not set although the P-flag must be set according to this specification. RFC 5440
2: Bad label value RFC 8664
3: Unsupported number of SR-ERO subobjects RFC 8664
4: Bad label format RFC 8664
5: ERO mixes SR-ERO subobjects with other subobject types RFC 8664
6: Both SID and NAI are absent in the SR-ERO subobject RFC 8664
7: Both SID and NAI are absent in the SR-RRO subobject RFC 8664
8: SYMBOLIC-PATH-NAME TLV missing RFC 8281
9: MSD exceeds the default for the PCEP session RFC 8664
10: RRO mixes SR-RRO subobjects with other subobject types RFC 8664
11: Malformed object RFC 8408
12: Missing PCE-SR-CAPABILITY sub-TLV RFC 8664
13: Unsupported NAI Type in the SR-ERO/SR-RRO subobject RFC 8664
14: Unknown SID RFC 8664
15: NAI cannot be resolved to a SID RFC 8664
16: Could not find SRGB RFC 8664
17: SID index exceeds SRGB size RFC 8664
18: Could not find SRLB RFC 8664
19: SID index exceeds SRLB size RFC 8664
20: Inconsistent SIDs in SR-ERO / SR-RRO subobjects RFC 8664
21: MSD must be nonzero RFC 8664
22: Mismatch of O field in S2LS and LSP object RFC 8623
23: Incompatible OF codes in H-PCE RFC 8685
24: Bad BANDWIDTH object type 3 or 4 RFC 8779
25: Unsupported LSP Protection Flags in PROTECTION-ATTRIBUTE TLV RFC 8779
26: Unsupported Secondary LSP Protection Flags in PROTECTION-ATTRIBUTE TLV RFC 8779
27: Unsupported Link Protection Type in PROTECTION-ATTRIBUTE TLV RFC 8779
28: LABEL-SET TLV present with O bit set but without R bit set in RP RFC 8779
29: Wrong LABEL-SET TLV present with O and L bits set RFC 8779
30: Wrong LABEL-SET TLV present with O bit set and wrong format RFC 8779
31: Missing GMPLS-CAPABILITY TLV RFC 8779
32: Incompatible OF code RFC 8800
33: Missing PCECC Capability sub-TLV RFC 9050
34: Missing PCE-SRv6-CAPABILITY sub-TLV RFC 9603
35: Both SID and NAI are absent in SRv6-RRO subobject RFC 9603
36: RRO mixes SRv6-RRO subobjects with other subobject types RFC 9603
37: Invalid SRv6 SID Structure RFC 9603
38: Conflicting Path ID RFC-ietf-pce-multipath-29
39: PCECC NATIVE-IP-TE-CAPABILITY bit is not set RFC 9757
40: Unsupported number of SRv6-ERO subobjects RFC 9603
41: Unsupported NAI Type in the SRv6-ERO/SRv6-RRO subobject RFC 9603
42: Both SID and NAI are absent in the SRv6-ERO subobject RFC 9603
43: ERO mixes SRv6-ERO subobjects with other subobject types RFC 9603
44: Missing SRPOLICY-CAPABILITY TLV RFC 9862
45: Unexpected PATH-ATTRIB Object RFC-ietf-pce-multipath-29
46-255: Unassigned
11 Unrecognized EXRS subobject 0-255: Unassigned RFC 5521
12 Diffserv-aware TE error 0: Unassigned RFC 5455
1: Unsupported class-type RFC 5455
2: Invalid class-type RFC 5455
3: Class-Type and setup priority do not form a configured TE-class RFC 5455
4-255: Unassigned
13 BRPC procedure completion failure 0: Unassigned RFC 5441
1: BRPC procedure not supported by one or more PCEs along the domain path RFC 5441
2-255: Unassigned
14 Unassigned 0-255: Unassigned
15 Global Concurrent Optimization Error 0: Unassigned RFC 5557
1: Insufficient memory RFC 5557
2: Global concurrent optimization not supported RFC 5557
3-255: Unassigned
16 P2MP Capability Error 0: Unassigned RFC 8306
1: The PCE cannot satisfy the request due to insufficient memory RFC 8306
2: The PCE is not capable of P2MP computation RFC 8306
3-255: Unassigned
17 P2MP END-POINTS Error 0: Unassigned RFC 8306
1: The PCE cannot satisfy the request due to no END-POINTS with leaf type 2 RFC 8306
2: The PCE cannot satisfy the request due to no END-POINTS with leaf type 3 RFC 8306
3: The PCE cannot satisfy the request due to no END-POINTS with leaf type 4 RFC 8306
4: The PCE cannot satisfy the request due to inconsistent END-POINTS RFC 8306
5-255: Unassigned
18 P2MP Fragmentation Error 0: Unassigned RFC 8306
1: Fragmented request failure RFC 8306
2: Fragmented Report failure RFC 8623
3: Fragmented Update failure RFC 8623
4: Fragmented Instantiation failure RFC 8623
5-255: Unassigned
19 Invalid Operation 0: Unassigned RFC 8231
1: Attempted LSP Update Request for a non-delegated LSP. The PCEP-ERROR object is followed by the LSP object that identifies the LSP. RFC 8231
2: Attempted LSP Update Request if the stateful PCE capability was not advertised. RFC 8231
3: Attempted LSP Update Request for an LSP identified by an unknown PLSP-ID. RFC 8231
4: Unassigned
5: Attempted LSP State Report if active stateful PCE capability was not advertised. RFC 8231
6: PCE-initiated LSP limit reached RFC 8281
7: Delegation for PCE-initiated LSP cannot be revoked RFC 8281
8: Non-zero PLSP-ID in LSP Initiate Request RFC 8281
9: LSP is not PCE initiated RFC 8281
10: PCE-initiated operation-frequency limit reached RFC 8281
11: Attempted LSP State Report for P2MP if stateful PCE capability for P2MP was not advertised RFC 8623
12: Attempted LSP Update Request for P2MP if active stateful PCE capability for P2MP was not advertised RFC 8623
13: Attempted LSP Instantiation Request for P2MP if stateful PCE instantiation capability for P2MP was not advertised RFC 8623
14: Auto-Bandwidth capability was not advertised RFC 8733
15: Attempted LSP scheduling while the scheduling capability was not advertised RFC 8934
16: Attempted PCECC operations when PCECC capability was not advertised RFC 9050
17: Stateful PCE capability was not advertised RFC 9050
18: Unknown Label RFC 9050
19: Attempted SRv6 when the capability was not advertised RFC 9603
20: Not supported path backup (TEMPORARY - registered 2022-05-09, extension registered 2026-04-03, expires 2027-05-09) draft-ietf-pce-sr-p2mp-policy-17
21: Non-empty path RFC-ietf-pce-multipath-29
22: Only one BPI, EPR, or PPA object can be included in this message RFC 9757
23: LSP state info unavailable for reoptimization RFC 9504
24: LSP state info for route exclusion not found RFC 9504
25: Attempted LSP update request for GMPLS if stateful PCE capability not advertised RFC 9504
26: Attempted LSP State Report for GMPLS if stateful PCE capability not advertised RFC 9504
27: Attempted LSP instantiation request for GMPLS if stateful PCE instantiation capability not advertised RFC 9504
28: Use of the Generalized Endpoint object type for non-GMPLS LSPs RFC 9504
29: Attempted Native IP operations when the capability was not advertised RFC 9757
30: Unknown Native IP Info RFC 9757
31: Invalid Color RFC 9863
32: Inconsistent Color RFC 9863
33: Attempted use of SR-Algorithm without advertised capability RFC 9933
34: Unsupported combination of constraints RFC 9933
35: Path modification is blocked by constraint RFC-ietf-pce-circuit-style-pcep-extensions-16
36: Unsupported multipath capability RFC-ietf-pce-multipath-29
37: Invalid opposite-direction path mapping RFC-ietf-pce-multipath-29
38: LOAD-BALANCING and MULTIPATH-CAP TLV in the same request RFC-ietf-pce-multipath-29
39-255: Unassigned
20 LSP State Synchronization Error 0: Unassigned RFC 8231
1: A PCE indicates to a PCC that it cannot process (an otherwise valid) LSP State Report. The PCEP- ERROR object is followed by the LSP object that identifies the LSP. RFC 8231
2: LSP-DB version mismatch. RFC 8232
3: Attempt to trigger synchronization before PCE trigger. RFC 8232
4: Attempt to trigger a synchronization when the PCE triggered synchronization capability has not been advertised. RFC 8232
5: A PCC indicates to a PCE that it cannot complete the State Synchronization. RFC 8231
6: Received an invalid LSP-DB Version Number. RFC 8232
7: Received an invalid Speaker Entity Identifier. RFC 8232
8-255: Unassigned
21 Invalid traffic engineering path setup type 0: Unassigned RFC 8408
1: Unsupported path setup type RFC 8408
2: Mismatched path setup type RFC 8408
3-255: Unassigned
22 Unassigned 0-255: Unassigned
23 Bad parameter value 0: Unassigned RFC 8281
1: SYMBOLIC-PATH-NAME in use RFC 8281
2: Speaker identity included for an LSP that is not PCE initiated RFC 8281
3-255: Unassigned
24 LSP instantiation error 0: Unassigned RFC 8281
1: Unacceptable instantiation parameters RFC 8281
2: Internal error RFC 8281
3: Signaling error RFC 8281
4-255: Unassigned
25 PCEP StartTLS failure 0: Unassigned RFC 8253
1: Reception of StartTLS after any PCEP exchange RFC 8253
2: Reception of any other message apart from StartTLS, Open, or PCErr RFC 8253
3: Failure, connection without TLS is not possible RFC 8253
4: Failure, connection without TLS is possible RFC 8253
5: No StartTLS message (nor PCErr/Open) before StartTLSWait timer expiry RFC 8253
6-255: Unassigned
26 Association Error 0: Unassigned RFC 8697
1: Association Type is not supported RFC 8697
2: Too many LSPs in the association group RFC 8697
3: Too many association groups RFC 8697
4: Association unknown RFC 8697
5: Operator-configured association information mismatch RFC 8697
6: Association information mismatch RFC 8697
7: Cannot join the association group RFC 8697
8: Association ID not in range RFC 8697
9: Tunnel ID or End points mismatch for Path Protection Association RFC 8745
10: Attempt to add another working/protection LSP for Path Protection Association RFC 8745
11: Protection type is not supported RFC 8745
12: Not expecting policy parameters RFC 9005
13: Unacceptable policy parameters RFC 9005
14: Association group mismatch RFC 9059
15: Tunnel mismatch in the association group RFC 9059
16: Path Setup Type not supported RFC 9059
17: Bidirectional LSP direction mismatch RFC 9059
18: Bidirectional LSP co-routed mismatch RFC 9059
19: Endpoint mismatch in the association group RFC 9059
20: SR Policy Identifiers Mismatch RFC 9862
21: SR Policy Candidate Path Identifier Mismatch RFC 9862
22-255: Unassigned
27 WSON RWA error 0: Unassigned RFC 8780
1: Insufficient memory RFC 8780
2: RWA computation not supported RFC 8780
3: Syntactical encoding error RFC 8780
4-255: Unassigned
28 H-PCE Error 0: Unassigned RFC 8685
1: H-PCE Capability not advertised RFC 8685
2: Parent PCE Capability cannot be provided RFC 8685
3-255: Unassigned
29 Path computation failure 0: Unassigned RFC 8779
1: Unacceptable request message RFC 8779
2: Generalized bandwidth value not supported RFC 8779
3: Label set constraint could not be met RFC 8779
4: Label constraint could not be met RFC 8779
5: Constraints could not be met for some intervals RFC 8934
6-255: Unassigned
30 FlowSpec error 0: Unassigned RFC 9168
1: Unsupported FlowSpec RFC 9168
2: Malformed FlowSpec RFC 9168
3: Unresolvable Conflict RFC 9168
4: Unknown FlowSpec RFC 9168
5: Unsupported LPM Route RFC 9168
6-255: Unassigned
31 PCECC failure 0: Unassigned RFC 9050
1: Label out of range RFC 9050
2: Instruction failed RFC 9050
3: Invalid CCI RFC 9050
4: Unable to allocate the specified CCI RFC 9050
5: Invalid next-hop information RFC 9050
6-255: Unassigned
32 Binding label/SID failure 0: Unassigned RFC 9604
1: Invalid SID RFC 9604
2: Unable to allocate the specified binding value RFC 9604
3: Unable to allocate a new binding label/SID RFC 9604
4: Unable to remove the binding value RFC 9604
5: Inconsistent binding types RFC 9604
6-255: Unassigned
33 Native IP TE failure 0: Unassigned RFC 9757
1: Local IP is in use RFC 9757
2: Remote IP is in use RFC 9757
3: Explicit Peer Route Error RFC 9757
4: EPR/BPI Peer Info mismatch RFC 9757
5: BPI/PPA Address Family mismatch RFC 9757
6: PPA/BPI Peer Info mismatch RFC 9757
7-255: Unassigned
34-251 Unassigned 0-255: Unassigned
252-255 Reserved for Experimental Use 0-255: Reserved for Experimental Use RFC 9756

PCEP-ERROR Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-7 Unassigned

LOAD-BALANCING Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-7 Unassigned

CLOSE Object Reason Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Available Formats

Value Description Reference
0 Reserved RFC 5440
1 No explanation provided RFC 5440
2 DeadTimer expired RFC 5440
3 Reception of a malformed PCEP message RFC 5440
4 Reception of an unacceptable number of unknown requests/replies RFC 5440
5 Reception of an unacceptable number of unrecognized PCEP messages RFC 5440
6-255 Unassigned

CLOSE Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-7 Unassigned

PATH-KEY Subobjects

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5520: Preserving Topology Confidentiality in Inter-Domain Path Computation Using a Path-Key-Based Mechanism

Available Formats

Value Description Reference
1-63 Unassigned
64 Path Key with 32-bit PCE ID RFC 5520
65 Path Key with 128-bit PCE ID RFC 5520
66-127 Unassigned

XRO Subobjects

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5521: Extensions to the Path Computation Element Communication Protocol (PCEP) for Route Exclusions

Available Formats

Value Description Reference
1 IPv4 prefix RFC 3209
2 IPv6 prefix RFC 3209
3 Unassigned
4 Unnumbered Interface ID RFC 3477
5 4-byte AS number RFC 7897; RFC 7898
6 OSPF Area ID RFC 7897; RFC 7898
7 IS-IS Area ID RFC 7897; RFC 7898
8 Optical Interface Class List RFC 8780
9 Client Signal Information RFC 8780
10 Label RFC 8779
11 LSP RFC 9504
12-31 Unassigned
32 Autonomous system number RFC 3209
33 Unassigned
34 SRLG RFC 4874
35-63 Unassigned
64 IPv4 Path Key RFC 5520
65 IPv6 Path Key RFC 5520
66-127 Unassigned

XRO Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5521: Extensions to the Path Computation Element Communication Protocol (PCEP) for Route Exclusions

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-14 Unassigned
15 Fail (F-bit) RFC 5521

Objective Function

Reference

  • RFC 5541: Encoding of Objective Functions in the Path Computation Element Communication Protocol (PCEP)

Available Formats

Range Registration Procedures
1-1023 IETF Review
1024-32767 First Come First Served
32768-65535 Reserved for Private Use
Code Point Name Reference
0 Reserved RFC 5541
1 MCP RFC 5541
2 MLP RFC 5541
3 MBP RFC 5541
4 MBC RFC 5541
5 MLL RFC 5541
6 MCC RFC 5541
7 SPT RFC 8306
8 MCT RFC 8306
9 Minimum Packet Loss Path (MPLP) RFC 8233
10 Maximum Under-Utilized Path (MUP) RFC 8233
11 Maximum Reserved Under-Utilized Path (MRUP) RFC 8233
12 Minimize the number of Transit Domains (MTD) RFC 8685
13 Minimize the number of Border Nodes (MBN) RFC 8685
14 Minimize the number of Common Transit Domains (MCTD) RFC 8685
15 Minimize the number of Shared Links (MSL) RFC 8800
16 Minimize the number of Shared SRLGs (MSS) RFC 8800
17 Minimize the number of Shared Nodes (MSN) RFC 8800
18-32767 Unassigned
32768-65535 Reserved for Private Use RFC 5541

PCEP TLV Type Indicators

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Available Formats

Range Registration Procedures
0-65503 IETF Review
65504-65535 Experimental Use
Value Description Reference
0 Reserved RFC 5440
1 NO-PATH-VECTOR TLV RFC 5440
2 OVERLOADED-DURATION TLV RFC 5440; RFC Errata 8344
3 REQ-MISSING TLV RFC 5440
4 OF-List RFC 5541
5 Order TLV RFC 5557
6 P2MP capable RFC 8306
7 VENDOR-INFORMATION-TLV RFC 7470
8 Wavelength Selection RFC 8780
9 Wavelength Restriction RFC 8780
10 Wavelength Allocation RFC 8780
11 Optical Interface Class List RFC 8780
12 Client Signal Information RFC 8780
13 H-PCE-CAPABILITY RFC 8685
14 Domain-ID RFC 8685
15 H-PCE-FLAG RFC 8685
16 STATEFUL-PCE-CAPABILITY RFC 8231
17 SYMBOLIC-PATH-NAME RFC 8231
18 IPV4-LSP-IDENTIFIERS RFC 8231
19 IPV6-LSP-IDENTIFIERS RFC 8231
20 LSP-ERROR-CODE RFC 8231
21 RSVP-ERROR-SPEC RFC 8231
22 Unassigned
23 LSP-DB-VERSION RFC 8232
24 SPEAKER-ENTITY-ID RFC 8232
25 Unassigned
26 SR-PCE-CAPABILITY (deprecated) RFC 8664
27 Unassigned
28 PATH-SETUP-TYPE RFC 8408
29 Operator-configured Association Range RFC 8697
30 Global Association Source RFC 8697
31 Extended Association ID RFC 8697
32 P2MP-IPV4-LSP-IDENTIFIERS RFC 8623
33 P2MP-IPV6-LSP-IDENTIFIERS RFC 8623
34 PATH-SETUP-TYPE-CAPABILITY RFC 8408
35 ASSOC-Type-List RFC 8697
36 AUTO-BANDWIDTH-CAPABILITY RFC 8733
37 AUTO-BANDWIDTH-ATTRIBUTES RFC 8733
38 Path Protection Association Group TLV RFC 8745
39 IPV4-ADDRESS RFC 8779, Section 2.5.2.1
40 IPV6-ADDRESS RFC 8779, Section 2.5.2.2
41 UNNUMBERED-ENDPOINT RFC 8779, Section 2.5.2.3
42 LABEL-REQUEST RFC 8779, Section 2.5.2.4
43 LABEL-SET RFC 8779, Section 2.5.2.5
44 PROTECTION-ATTRIBUTE RFC 8779, Section 2.8
45 GMPLS-CAPABILITY RFC 8779, Section 2.1.2
46 DISJOINTNESS-CONFIGURATION RFC 8800
47 DISJOINTNESS-STATUS RFC 8800
48 POLICY-PARAMETERS-TLV RFC 9005
49 SCHED-LSP-ATTRIBUTE RFC 8934
50 SCHED-PD-LSP-ATTRIBUTE RFC 8934
51 PCE-FLOWSPEC-CAPABILITY TLV RFC 9168
52 FLOW FILTER TLV RFC 9168
53 Unassigned
54 Bidirectional LSP Association Group TLV RFC 9059
55 TE-PATH-BINDING RFC 9604
56 SRPOLICY-POL-NAME RFC 9862
57 SRPOLICY-CPATH-ID RFC 9862
58 SRPOLICY-CPATH-NAME RFC 9862
59 SRPOLICY-CPATH-PREFERENCE RFC 9862
60 MULTIPATH-CAP RFC-ietf-pce-multipath-29
61 MULTIPATH-WEIGHT RFC-ietf-pce-multipath-29
62 MULTIPATH-BACKUP (TEMPORARY - registered 2022-05-09, extension registered 2026-04-03, expires 2027-05-09) draft-ietf-pce-sr-p2mp-policy-17
63 MULTIPATH-OPPDIR-PATH RFC-ietf-pce-multipath-29
64 LSP-EXTENDED-FLAG RFC 9357
65 VIRTUAL-NETWORK-TLV RFC 9358
66 SR-Algorithm RFC 9933
67 Color RFC 9863
68 COMPUTATION-PRIORITY RFC 9862
69 EXPLICIT-NULL-LABEL-POLICY RFC 9862
70 INVALIDATION RFC 9862
71 SRPOLICY-CAPABILITY RFC 9862
72 PATH-MODIFICATION TLV RFC-ietf-pce-circuit-style-pcep-extensions-16
73 SR-P2MP-POLICY-CAPABILITY (TEMPORARY - registered 2024-08-27, extension registered 2026-08-06, expires 2027-08-27) draft-ietf-pce-sr-p2mp-policy-11
74 IPV4-SR-P2MP-INSTANCE-ID TLV (TEMPORARY - registered 2024-08-27, extension registered 2026-08-06, expires 2027-08-27) draft-ietf-pce-sr-p2mp-policy-11
75 IPV6-SR-P2MP-INSTANCE-ID TLV (TEMPORARY - registered 2024-08-27, extension registered 2026-08-06, expires 2027-08-27) draft-ietf-pce-sr-p2mp-policy-11
76 MULTIPATH-FORWARD-CLASS RFC-ietf-pce-multipath-29
77-65503 Unassigned
65504-65535 Experimental Use RFC 8356

NO-PATH-VECTOR TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5440: Path Computation Element (PCE) Communication Protocol (PCEP)

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-9 Unassigned
10 Requested disjoint computation not supported RFC 8800
11 Disjoint path not found RFC 8800
12 LOAD-BALANCING could not be performed with the bandwidth constraints RFC 8779
13 No label resource in range RFC 8779
14 No endpoint label resource in range RFC 8779
15 No endpoint label resource RFC 8779
16 Granularity not supported RFC 8779
17 No Resource RFC 8779
18 Protection Mismatch RFC 8779
19 Destination is not found in the indicated domain RFC 8685
20 No available resource in one or more domains RFC 8685
21 Unresponsive child PCE(s) RFC 8685
22 Destination domain unknown RFC 8685
23 No RWA constraints met RFC 8780
24 P2MP Reachability Problem RFC 8306
25 No GCO solution found RFC 5557
26 No GCO migration path found RFC 5557
27 PKS expansion failure RFC 5520
28 BRPC Path computation chain unavailable RFC 5441
29 Unknown Source RFC 5440
30 Unknown Destination RFC 5440
31 PCE currently Unavailable RFC 5440

MONITORING Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5886: A Set of Monitoring Tools for Path Computation Element (PCE)-Based Architecture

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-18 Unassigned
19 Incomplete RFC 5886
20 Overload RFC 5886
21 Processing Time RFC 5886
22 General RFC 5886
23 Liveness RFC 5886

PROC-TIME Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5886: A Set of Monitoring Tools for Path Computation Element (PCE)-Based Architecture

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-14 Unassigned
15 Estimated RFC 5886

OVERLOAD Object Flag field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 5886: A Set of Monitoring Tools for Path Computation Element (PCE)-Based Architecture

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0-7 Unassigned

BU Object Type Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8233: Extensions to the Path Computation Element Communication Protocol (PCEP) to Compute Service-Aware Label Switched Paths (LSPs)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Type Name Reference
0 Reserved RFC 8233
1 LBU (Link Bandwidth Utilization) RFC 8233
2 LRBU (Link Residual Bandwidth Utilization) RFC 8233
3-255 Unassigned

Inter-Layer Object Path Property Bits

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8282: Extensions to the Path Computation Element Communication Protocol (PCEP) for Inter-Layer MPLS and GMPLS Traffic Engineering

Available Formats

Bit Flag Multi-Layer Path Property Reference
0-28 Unassigned
29 T Triggered Signaling Allowed RFC 8282
30 M Multi-Layer Requested RFC 8282
31 I Inter-Layer Allowed RFC 8282

LSP Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8231: Path Computation Element Communication Protocol (PCEP) Extensions for Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Bit Description Reference
0 PCE-allocation RFC 9604
1 ERO-compression RFC 8623
2 Fragmentation RFC 8623
3 P2MP RFC 8623
4 Create RFC 8281
5-7 Operational (3 bits) RFC 8231
8 Administrative RFC 8231
9 Remove RFC 8231
10 SYNC RFC 8231
11 Delegate RFC 8231

STATEFUL-PCE-CAPABILITY TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8231: Path Computation Element Communication Protocol (PCEP) Extensions for Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Note

Bits are numbered from bit 0 as the most significant bit.

Available Formats

Value Description Reference
0-16 Unassigned
17 RELAX RFC 9753
18 STRICT-PATH-CAPABILITY RFC-ietf-pce-circuit-style-pcep-extensions-16
19 PATH-MODIFICATION-CAPABILITY RFC-ietf-pce-circuit-style-pcep-extensions-16
20 COLOR-CAPABILITY RFC 9863
21 PD-LSP-CAPABILITY (PD-bit) RFC 8934
22 LSP-SCHEDULING-CAPABILITY (B-bit) RFC 8934
23 P2MP-LSP-INSTANTIATION-CAPABILITY RFC 8623
24 P2MP-LSP-UPDATE-CAPABILITY RFC 8623
25 P2MP-CAPABILITY RFC 8623
26 TRIGGERED-INITIAL-SYNC RFC 8232
27 DELTA-LSP-SYNC-CAPABILITY RFC 8232
28 TRIGGERED-RESYNC RFC 8232
29 LSP-INSTANTIATION-CAPABILITY (I) RFC 8281
30 INCLUDE-DB-VERSION RFC 8232
31 LSP-UPDATE-CAPABILITY RFC 8231

LSP-ERROR-CODE TLV Error Code Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8231: Path Computation Element Communication Protocol (PCEP) Extensions for Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Value Meaning Reference
0 Reserved RFC 8231
1 Unknown reason RFC 8231
2 Limit reached for PCE-controlled LSPs RFC 8231
3 Too many pending LSP update requests RFC 8231
4 Unacceptable parameters RFC 8231
5 Internal error RFC 8231
6 LSP administratively brought down RFC 8231
7 LSP preempted RFC 8231
8 RSVP signaling error RFC 8231
9 Deprecated (Unsupported Color) RFC 9863
10 SID Verification fails RFC 9603
11-65535 Unassigned

SRP Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8281: Path Computation Element Communication Protocol (PCEP) Extensions for PCE-Initiated LSP Setup in a Stateful PCE Model
  • RFC 8786: Updated Rules for Processing Stateful PCE Request Parameters Flags
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Value Description Reference
0-29 Unassigned
30 LSP Control Request RFC 8741
31 LSP-Remove RFC 8281

PCEP Path Setup Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8408: Conveying Path Setup Type in PCE Communication Protocol (PCEP) Messages

Available Formats

Value Description Reference
0 Path is set up using the RSVP-TE signaling protocol RFC 8408
1 Traffic-engineering path is set up using Segment Routing. RFC 8664
2 Traffic engineering path is set up using PCECC mode RFC 9050
3 Traffic engineering path is set up using SRv6. RFC 9603
4 Native IP TE Path RFC 9757
5-255 Unassigned

PCEP SR-ERO NAI Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8664: Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing

Available Formats

Value Description Reference
0 NAI is absent. RFC 8664
1 NAI is an IPv4 node ID. RFC 8664
2 NAI is an IPv6 node ID. RFC 8664
3 NAI is an IPv4 adjacency. RFC 8664
4 NAI is an IPv6 adjacency with global IPv6 addresses. RFC 8664
5 NAI is an unnumbered adjacency with IPv4 node IDs. RFC 8664
6 NAI is an IPv6 adjacency with link-local IPv6 addresses. RFC 8664
7-15 Unassigned

SR-ERO Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8664: Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-6 Unassigned
7 SR-Algorithm Flag (A) RFC 9933
8 NAI is absent (F) RFC 8664
9 SID is absent (S) RFC 8664
10 SID specifies TC, S, and TTL in addition to an MPLS label (C) RFC 8664
11 SID specifies an MPLS label (M) RFC 8664

PATH-SETUP-TYPE-CAPABILITY Sub-TLV Type Indicators

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8664: Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Value Meaning Reference
0 Reserved RFC 8664
1 PCECC-CAPABILITY RFC 9050
2-25 Unassigned
26 SR-PCE-CAPABILITY RFC 8664
27 SRv6-PCE-CAPABILITY RFC 9603
28-65535 Unassigned

SR Capability Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8664: Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-4 Unassigned
5 SR-Algorithm Capability RFC 9933
6 Node or Adjacency Identifier (NAI) is supported (N) RFC 8664
7 Unlimited Maximum SID Depth (X) RFC 8664

WA Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8780: The Path Computation Element Communication Protocol (PCEP) Extension for Wavelength Switched Optical Network (WSON) Routing and Wavelength Assignment (RWA)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-14 Unassigned
15 Wavelength Allocation Mode RFC 8780

Wavelength Restriction TLV Action Values

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8780: The Path Computation Element Communication Protocol (PCEP) Extension for Wavelength Switched Optical Network (WSON) Routing and Wavelength Assignment (RWA)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Value Meaning Reference
0 Inclusive List RFC 8780
1 Inclusive Range RFC 8780
2-255 Unassigned

Wavelength Allocation TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8780: The Path Computation Element Communication Protocol (PCEP) Extension for Wavelength Switched Optical Network (WSON) Routing and Wavelength Assignment (RWA)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-14 Unassigned
15 Wavelength Allocation Mode RFC 8780

S2LS Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8623: Stateful Path Computation Element (PCE) Protocol Extensions for Usage with Point-to-Multipoint TE Label Switched Paths (LSPs)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-28 Unassigned
29-31 Operational (3 bits) RFC 8623

H-PCE-CAPABILITY TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8685: Path Computation Element Communication Protocol (PCEP) Extensions for the Hierarchical Path Computation Element (H-PCE) Architecture
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-30 Unassigned
31 P (Parent PCE Request bit) RFC 8685

Domain-ID TLV Domain Type

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8685: Path Computation Element Communication Protocol (PCEP) Extensions for the Hierarchical Path Computation Element (H-PCE) Architecture

Available Formats

Value Meaning Reference
0 Reserved RFC 8685
1 2-byte AS number RFC 8685
2 4-byte AS number RFC 8685
3 4-byte OSPF area ID RFC 8685
4 Variable-length IS-IS area ID RFC 8685
5-255 Unassigned

H-PCE-FLAG TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8685: Path Computation Element Communication Protocol (PCEP) Extensions for the Hierarchical Path Computation Element (H-PCE) Architecture
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-29 Unassigned
30 D (Disallow Domain Re-entry bit) RFC 8685
31 S (Domain Sequence bit) RFC 8685

ASSOCIATION Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8697: Path Computation Element Communication Protocol (PCEP) Extensions for Establishing Relationships between Sets of Label Switched Paths (LSPs)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-14 Unassigned
15 R (Removal) RFC 8697

ASSOCIATION Type Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8697: Path Computation Element Communication Protocol (PCEP) Extensions for Establishing Relationships between Sets of Label Switched Paths (LSPs)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Type Name Reference
0 Reserved RFC 8697
1 Path Protection Association RFC 8745
2 Disjoint Association RFC 8800
3 Policy Association RFC 9005
4 Single-Sided Bidirectional LSP Association RFC 9059
5 Double-Sided Bidirectional LSP Association RFC 9059
6 SR Policy Association RFC 9862
7 VN Association RFC 9358
8 Bidirectional SR LSP Association RFC-ietf-pce-sr-bidir-path-25
9 P2MP SR Policy Association (TEMPORARY - registered 2024-08-27, extension registered 2026-08-06, expires 2027-08-27) draft-ietf-pce-sr-p2mp-policy-11
10-65535 Unassigned

AUTO-BANDWIDTH-CAPABILITY TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8733: Path Computation Element Communication Protocol (PCEP) Extensions for MPLS-TE Label Switched Path (LSP) Auto-Bandwidth Adjustment with Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-31 Unassigned

AUTO-BANDWIDTH-ATTRIBUTES Sub-TLV Types

Reference

  • RFC 8733: Path Computation Element Communication Protocol (PCEP) Extensions for MPLS-TE Label Switched Path (LSP) Auto-Bandwidth Adjustment with Stateful PCE

Available Formats

Range Registration Procedures
0-65503 IETF Review
65504-65535 Experimental Use
Type Name Reference
0 Reserved RFC 8733
1 Sample-Interval RFC 8733
2 Adjustment-Interval RFC 8733
3 Down-Adjustment-Interval RFC 8733
4 Adjustment-Threshold RFC 8733
5 Adjustment-Threshold-Percentage RFC 8733
6 Down-Adjustment-Threshold RFC 8733
7 Down-Adjustment-Threshold-Percentage RFC 8733
8 Minimum-Bandwidth RFC 8733
9 Maximum-Bandwidth RFC 8733
10 Overflow-Threshold RFC 8733
11 Overflow-Threshold-Percentage RFC 8733
12 Underflow-Threshold RFC 8733
13 Underflow-Threshold-Percentage RFC 8733
14-65503 Unassigned
65504-65535 Experimental Use RFC 8733

Path Protection Association Group TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8745: Path Computation Element Communication Protocol (PCEP) Extensions for Associating Working and Protection Label Switched Paths (LSPs) with Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Name Reference
31 P - PROTECTION-LSP RFC 8745
30 S - SECONDARY-LSP RFC 8745
6-29 Unassigned
0-5 Protection Type Flags RFC 8745

Generalized Endpoint Types

Reference

  • RFC 8779: Path Computation Element Communication Protocol (PCEP) Extensions for GMPLS
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Range Registration Procedures
0-244 IETF Review
245-255 Experimental Use
Value Type Reference
0 Point-to-Point RFC 8779
1 Point-to-Multipoint with leaf type 1 RFC 8779
2 Point-to-Multipoint with leaf type 2 RFC 8779
3 Point-to-Multipoint with leaf type 3 RFC 8779
4 Point-to-Multipoint with leaf type 4 RFC 8779
5 Point-to-Multipoint with leaf type 5 (TEMPORARY - registered 2024-08-27, extension registered 2026-08-06, expires 2027-08-27) draft-ietf-pce-sr-p2mp-policy-11
6-244 Unassigned
245-255 Experimental Use RFC 8779

GMPLS-CAPABILITY TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8779: Path Computation Element Communication Protocol (PCEP) Extensions for GMPLS
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Capability Description Reference
31 LSP-REPORT-CAPABILITY (R) RFC 9504
30 LSP-UPDATE-CAPABILITY (U) RFC 9504
29 LSP-INSTANTIATION-CAPABILITY (I) RFC 9504
0-28 Unassigned

DISJOINTNESS-CONFIGURATION TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8800: Path Computation Element Communication Protocol (PCEP) Extension for Label Switched Path (LSP) Diversity Constraint Signaling
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Name Reference
31 L - Link Diverse RFC 8800
30 N - Node Diverse RFC 8800
29 S - SRLG Diverse RFC 8800
28 P - Shortest Path RFC 8800
27 T - Strict Disjointness RFC 8800
0-26 Unassigned

SCHED-PD-LSP-ATTRIBUTE TLV Opt Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8934: PCE Communication Protocol (PCEP) Extensions for Label Switched Path (LSP) Scheduling with Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Value Description Reference
0 Reserved RFC 8934
1 REPEAT-EVERY-MONTH RFC 8934
2 REPEAT-EVERY-YEAR RFC 8934
3 REPEAT-EVERY-REPEAT-TIME-LENGTH RFC 8934
4-14 Unassigned
15 Reserved RFC 8934

Schedule TLVs Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 8934: PCE Communication Protocol (PCEP) Extensions for Label Switched Path (LSP) Scheduling with Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-3 Unassigned
4 Relative Time (R-bit) RFC 8934
5 PCC Responsible (C-bit) RFC 8934
6 LSP Activated (A-bit) RFC 8934
7 Grace Period Included (G-bit) RFC 8934

FLOWSPEC Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9168: Path Computation Element Communication Protocol (PCEP) Extension for Flow Specification
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-5 Unassigned
6 LPM (L bit) RFC 9168
7 Remove (R bit) RFC 9168

PCEP Flow Specification TLV Type Indicators

Reference

  • RFC 9168: Path Computation Element Communication Protocol (PCEP) Extension for Flow Specification

Available Formats

Range Registration Procedures Note
0-255 Reserved Must not be allocated. Usage mirrors the BGP Flowspec registry.
256-64506 Specification Required
64507-65531 First Come First Served
65532-65535 Experimental Use
Value Meaning Reference
0-255 Reserved. Must not be allocated. Usage mirrors the BGP FlowSpec registry draft-ietf-idr-rfc5575bis-27 and draft-ietf-idr-flow-spec-v6-19 RFC 9168
256 Route Distinguisher RFC 9168
257 IPv4 Multicast RFC 9168
258 IPv6 Multicast RFC 9168
259-65531 Unassigned
65532-65535 Experimental Use RFC 9168

Bidirectional LSP Association Group TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9059: Path Computation Element Communication Protocol (PCEP) Extensions for Associated Bidirectional Label Switched Paths (LSPs)
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-29 Unassigned
30 C - Co-routed Path RFC 9059
31 R - Reverse LSP RFC 9059

PCECC-CAPABILITY sub-TLV

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9050: Path Computation Element Communication Protocol (PCEP) Procedures and Extensions for Using the PCE as a Central Controller (PCECC) of LSPs
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Name Reference
0-29 Unassigned
30 Native IP RFC 9757
31 Label RFC 9050

CCI Object Flag Field for MPLS Label

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9050: Path Computation Element Communication Protocol (PCEP) Procedures and Extensions for Using the PCE as a Central Controller (PCECC) of LSPs
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-13 Unassigned
14 C Bit - PCC allocation RFC 9050
15 O Bit - Specifies label is out-label RFC 9050

TE-PATH-BINDING TLV BT Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9604: Carrying Binding Label/SID in PCE-Based Networks
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Value Description Reference
0 MPLS Label RFC 9604
1 MPLS Label Stack Entry RFC 9604
2 SRv6 SID RFC 9604
3 SRv6 SID with Behavior and Structure RFC 9604
4-255 Unassigned

TE-PATH-BINDING TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9604: Carrying Binding Label/SID in PCE-Based Networks
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0 R (Removal) RFC 9604
1 Deprecated (Specified-BSID-only) RFC 9862
2-7 Unassigned

LSP-EXTENDED-FLAG TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9357: Label Switched Path (LSP) Object Flag Extension for Stateful PCE
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Capability Description Reference
0 GMPLS LSP (G) RFC 9504
1 Bidirectional Co-routed LSP (B) RFC 9504
2-3 Routing Granularity (RG) RFC 9504
4 Strict-Path Flag (O) RFC-ietf-pce-circuit-style-pcep-extensions-16
5-31 Unassigned

LSP Exclusion Subobject Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9504: Path Computation Element Communication Protocol (PCEP) Extensions for Stateful PCE Usage in GMPLS-Controlled Networks
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-7 Unassigned

PCEP SRv6-ERO NAI Types

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9603: Path Computation Element Communication Protocol (PCEP) Extensions for IPv6 Segment Routing

Available Formats

Value Description Reference
0 NAI is absent. RFC 9603
1 Unassigned
2 NAI is an IPv6 node ID. RFC 9603
3 Unassigned
4 NAI is an IPv6 adjacency with global IPv6 addresses. RFC 9603
5 Unassigned
6 NAI is an IPv6 adjacency with link-local IPv6 addresses. RFC 9603
7-15 Unassigned

SRv6-ERO Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9603: Path Computation Element Communication Protocol (PCEP) Extensions for IPv6 Segment Routing
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-6 Unassigned
7 SR-Algorithm Flag (A) RFC 9933
8 SID Verification (V) RFC 9603
9 SID Structure is present (T) RFC 9603
10 NAI is absent (F) RFC 9603
11 SID is absent (S) RFC 9603

SRv6 Capability Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9603: Path Computation Element Communication Protocol (PCEP) Extensions for IPv6 Segment Routing
  • RFC 9756: Update to the IANA Path Communication Element Protocol (PCEP) Numbers Registration Procedures and the Allowance of Experimental Error Codes

Available Formats

Bit Description Reference
0-12 Unassigned
13 SR-Algorithm Capability RFC 9933
14 Node or Adjacency Identifier (NAI) is supported (N) RFC 9603
15 Unassigned

CCI Object Flag Field for Native IP

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9757: Path Computation Element Communication Protocol (PCEP) Extensions for Native IP Networks

Available Formats

Bit Description Reference
0-15 Unassigned

BPI Object Status Code Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9757: Path Computation Element Communication Protocol (PCEP) Extensions for Native IP Networks

Available Formats

Value Meaning Reference
0 Reserved RFC 9757
1 BGP Session Established RFC 9757
2 BGP Session Establishment In Progress RFC 9757
3 BGP Session Down RFC 9757
4-255 Unassigned

BPI Object Error Code Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9757: Path Computation Element Communication Protocol (PCEP) Extensions for Native IP Networks

Available Formats

Value Meaning Reference
0 Reserved RFC 9757
1 ASes do not match - BGP Session Failure RFC 9757
2 Peer IP can't be reached - BGP Session Failure RFC 9757
3-255 Unassigned

BPI Object Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9757: Path Computation Element Communication Protocol (PCEP) Extensions for Native IP Networks

Available Formats

Bit Meaning Reference
0-6 Unassigned
7 T (IP-in-IP) bit RFC 9757

SR Policy Invalidation Operational Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9862: Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing (SR) Policy Candidate Paths

Available Formats

Bit Description Reference
0-6 Unassigned
7 D: Dropping - the LSP is actively dropping traffic as a result of Drop-Upon-Invalid behavior being activated. RFC 9862

SR Policy Invalidation Configuration Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9862: Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing (SR) Policy Candidate Paths

Available Formats

Bit Description Reference
0-6 Unassigned
7 D: Drop enabled - the Candidate Path has Drop-Upon-Invalid feature enabled. RFC 9862

SR Policy Capability TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9862: Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing (SR) Policy Candidate Paths

Available Formats

Bit Description Reference
0-26 Unassigned
27 Stateless Operation (L-flag) RFC 9862
28 Unassigned
29 Invalidation (I-flag) RFC 9862
30 Explicit NULL Label Policy (E-flag) RFC 9862
31 Computation Priority (P-flag) RFC 9862

PATH-MODIFICATION TLV Flag Field

Registration Procedure(s)

  • IETF Review

Reference

Available Formats

Bit Description Reference
0-13 Unassigned
14 Permanent (P) RFC-ietf-pce-circuit-style-pcep-extensions-16
15 Force (F) RFC-ietf-pce-circuit-style-pcep-extensions-16

Flags in MULTIPATH-CAP TLV

Registration Procedure(s)

  • IETF Review

Reference

  • RFC-ietf-pce-multipath-29: Path Computation Element Communication Protocol (PCEP) Extensions for Signaling Multipath Information

Available Formats

Bit Description Reference
0-10 Unassigned
11 C-flag: Composite Candidate Path support RFC-ietf-pce-multipath-29
12 F-flag: MULTIPATH-FORWARD-CLASS TLV support RFC-ietf-pce-multipath-29
13 O-flag: MULTIPATH-OPPDIR-PATH TLV support RFC-ietf-pce-multipath-29
14 Unassigned
15 W-flag: MULTIPATH-WEIGHT TLV support RFC-ietf-pce-multipath-29

Flags in PATH-ATTRIB Object

Registration Procedure(s)

  • IETF Review

Reference

  • RFC-ietf-pce-multipath-29: Path Computation Element Communication Protocol (PCEP) Extensions for Signaling Multipath Information

Available Formats

Bit Description Reference
0-27 Unassigned
28 R-flag: Reverse path RFC-ietf-pce-multipath-29
29-31 O-flag: Operational state RFC-ietf-pce-multipath-29

Flags in MULTIPATH-OPPDIR-PATH TLV

Registration Procedure(s)

  • IETF Review

Reference

  • RFC-ietf-pce-multipath-29: Path Computation Element Communication Protocol (PCEP) Extensions for Signaling Multipath Information

Available Formats

Bit Description Reference
0-13 Unassigned
14 L-flag: Link co-routed RFC-ietf-pce-multipath-29
15 N-flag: Node co-routed RFC-ietf-pce-multipath-29

Flags in MULTIPATH-FORWARD-CLASS TLV

Registration Procedure(s)

  • IETF Review

Reference

  • RFC-ietf-pce-multipath-29: Path Computation Element Communication Protocol (PCEP) Extensions for Signaling Multipath Information

Available Formats

Bit Description Reference
0 T-flag: MPLS TC type RFC-ietf-pce-multipath-29
1-28 Unassigned
29-31 FC: Forwarding class RFC-ietf-pce-multipath-29