Simple Authentication and Security Layer (SASL) Mechanisms
Last Updated
- 2024-12-06
Note
The Simple Authentication and Security Layer (SASL) RFC 4422 is a method for adding authentication support to connection-based protocols. To use this specification, a protocol includes a command for identifying and authenticating a user to a server and for optionally negotiating a security layer for subsequent protocol interactions. The command has a required argument identifying a SASL mechanism.
SASL mechanisms are named by strings, from 1 to 20 characters in length, consisting of upper-case letters, digits, hyphens, and/or underscores. SASL mechanism names must be registered with the IANA. Procedures for registering new SASL mechanisms are described in RFC 4422.
SASL mechanism names starting with "GS2-" are reserved for SASL mechanisms which conform to RFC 5801.
Registration procedures for SASL mechanism names starting with "SCRAM-" are defined in RFC 7677.
Available Formats
SASL Mechanisms
Registration Procedure(s)
- First Come First Served for mechanisms. Expert Review with mailing list for family name registrations. For names beginning with "GS2-", see RFC 5801. For names beginning with "SCRAM-", see RFC 7677.
Expert(s)
- Simon Josefsson
Reference
- RFC 4422: Simple Authentication and Security Layer (SASL)
Note
SASL mechanisms are named by character strings from 1 to 20 characters in length, consisting of ASCII uppercase letters, digits, hyphens, and/or underscores.
Available Formats
| Mechanism | Usage | Reference | Owner |
|---|---|---|---|
| 9798-M-DSA-SHA1 | COMMON | RFC 3163 | Robert Zuccherato |
| 9798-M-ECDSA-SHA1 | COMMON | RFC 3163 | Robert Zuccherato |
| 9798-M-RSA-SHA1-ENC | COMMON | RFC 3163 | Robert Zuccherato |
| 9798-U-DSA-SHA1 | COMMON | RFC 3163 | Robert Zuccherato |
| 9798-U-ECDSA-SHA1 | COMMON | RFC 3163 | Robert Zuccherato |
| 9798-U-RSA-SHA1-ENC | COMMON | RFC 3163 | Robert Zuccherato |
| ANONYMOUS | COMMON | RFC 4505 | IESG |
| CRAM-MD5 | LIMITED | RFC 2195 | IESG |
| DIGEST-MD5 | OBSOLETE | RFC 6331 | IESG |
| EAP-AES128 | COMMON | RFC 7055 | IESG |
| EAP-AES128-PLUS | COMMON | RFC 7055 | IESG |
| ECDH-X25519-CHALLENGE[1] | LIMITED USE | https://github.com/atheme/atheme/blob/master/modules/saslserv/ecdh-x25519-challenge.c | Simon Ser |
| ECDSA-NIST256P-CHALLENGE[1] | LIMITED USE | https://github.com/kaniini/ecdsatool#mechanism-spec | Simon Ser |
| EXTERNAL | COMMON | RFC 4422 | IESG |
| GS2-* | COMMON | RFC 5801 | IESG |
| GS2-KRB5 | COMMON | RFC 5801 | IESG |
| GS2-KRB5-PLUS | COMMON | RFC 5801 | IESG |
| GSS-SPNEGO | LIMITED | Paul Leach | Paul Leach |
| GSSAPI | COMMON | RFC 4752 | IESG |
| KERBEROS_V4 | OBSOLETE | RFC 2222 | IESG |
| KERBEROS_V5 | COMMON | Simon Josefsson | Simon Josefsson |
| LOGIN | OBSOLETE | draft-murchison-sasl-login-00 | Kenneth Murchison; Mark R. Crispin |
| NMAS_AUTHEN | LIMITED | Mark G. Gayman | Mark G. Gayman |
| NMAS_LOGIN | LIMITED | Mark G. Gayman | Mark G. Gayman |
| NMAS-SAMBA-AUTH | LIMITED | Vince Brimhall | Vince Brimhall |
| NTLM | LIMITED | Paul Leach | Paul Leach |
| OAUTH10A | COMMON | RFC 7628 | IESG |
| OAUTHBEARER | COMMON | RFC 7628 | IESG |
| OPENID20 | COMMON | RFC 6616 | IESG |
| OTP | COMMON | RFC 2444 | IESG |
| PLAIN | COMMON | RFC 4616 | IESG |
| SAML20 | COMMON | RFC 6595 | IESG |
| SCRAM-* | COMMON | RFC 7677 | IESG |
| SECURID | COMMON | RFC 2808 | Magnus Nystrom |
| SKEY | OBSOLETE | RFC 2444 | IESG |
| SPNEGO | MUST NOT be used | RFC 5801 | IESG |
| SPNEGO-PLUS | MUST NOT be used | RFC 5801 | IESG |
| SXOVER-PLUS | COMMON | draft-vanrein-diameter-sasl-06 | Rick van Rein |
| XOAUTH | OBSOLETE | N/A | IESG |
| XOAUTH2 | OBSOLETE | N/A | IESG |
SASL SCRAM Family Mechanisms
Registration Procedure(s)
- IETF Review with mailing list
Reference
- RFC 7677: SCRAM-SHA-256 and SCRAM-SHA-256-PLUS Simple Authentication and Security Layer (SASL) Mechanisms
Available Formats
| Mechanism | Usage | Reference | Minimum iteration-count | Associated OID | Owner |
|---|---|---|---|---|---|
| SCRAM-SHA-1 | COMMON | RFC 5802; RFC 7677 | 4096 | 1.3.6.1.5.5.14 | IESG |
| SCRAM-SHA-1-PLUS | COMMON | RFC 5802; RFC 7677 | 4096 | 1.3.6.1.5.5.14 | IESG |
| SCRAM-SHA-256 | COMMON | RFC 7677 | 4096 | 1.3.6.1.5.5.18 | IESG |
| SCRAM-SHA-256-PLUS | COMMON | RFC 7677 | 4096 | 1.3.6.1.5.5.18 | IESG |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| IESG | iesg&ietf.org | |
| Kenneth Murchison | ken&oceana.com | 2014-11-10 |
| Magnus Nystrom | magnus&rsasecurity.com | |
| Mark G. Gayman | mgayman&novell.com | 2000-09 |
| Mark R. Crispin | MRC&CAC.Washington.EDU | 2014-11-10 |
| Paul Leach | paulleµsoft.com | 2000-06 |
| Rick van Rein | rick&openfortress.nl | 2022-03-16 |
| Robert Zuccherato | robert.zuccherato&entrust.com | |
| Simon Josefsson | simon&josefsson.org | 2004-01 |
| Simon Ser | contact&emersion.fr | 2021-07-21 |
| Vince Brimhall | vbrimhall&novell.com | 2004-04 |