Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dsfgw 438 udp dsfgw Andy McKeen Andy McKeen
dasp 439 tcp dasp Thomas Obermair Thomas Obermair
dasp 439 udp dasp Thomas Obermair Thomas Obermair
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
creativeserver 453 tcp CreativeServer
creativeserver 453 udp CreativeServer
alpes 463 tcp alpes Alain Durand Alain Durand
alpes 463 udp alpes Alain Durand Alain Durand
submissions 465 tcp Message Submission over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
igmpv3lite 465 udp IGMP over UDP for SSM Toerless Eckert Toerless Eckert
hybrid-pop 473 tcp hybrid-pop Rami Rubin Rami Rubin
hybrid-pop 473 udp hybrid-pop Rami Rubin Rami Rubin
ulpnet 483 tcp ulpnet Kevin Mooney Kevin Mooney
ulpnet 483 udp ulpnet Kevin Mooney Kevin Mooney
ticf-2 493 tcp Transport Independent Convergence for FNA Mamoru Ito Mamoru Ito
ticf-2 493 udp Transport Independent Convergence for FNA Mamoru Ito Mamoru Ito
intrinsa 503 tcp Intrinsa Robert Ford Robert Ford
intrinsa 503 udp Intrinsa Robert Ford Robert Ford
login 513 tcp remote login a la telnet; automatic authentication performed based on priviledged port numbers and distributed data bases which identify "authentication domains"
who 513 udp maintains data bases showing who's logged in to machines on a local net and the load average of the machine
ibm-db2 523 tcp IBM-DB2 Juliana Hsu Juliana Hsu
ibm-db2 523 udp IBM-DB2 Juliana Hsu Juliana Hsu
courier 530 tcp rpc
courier 530 udp rpc
conference 531 tcp chat
conference 531 udp chat
netnews 532 tcp readnews
netnews 532 udp readnews
netwall 533 tcp for emergency broadcasts Andreas Heidemann Andreas Heidemann
netwall 533 udp for emergency broadcasts Andreas Heidemann Andreas Heidemann
windream 534 tcp windream Admin Uwe Honermann Uwe Honermann
windream 534 udp windream Admin Uwe Honermann Uwe Honermann
iiop 535 tcp iiop Jeff M.Michaud Jeff M.Michaud
iiop 535 udp iiop Jeff M.Michaud Jeff M.Michaud
opalis-rdv 536 tcp opalis-rdv Laurent Domenech Laurent Domenech
opalis-rdv 536 udp opalis-rdv Laurent Domenech Laurent Domenech
nmsp 537 tcp Networked Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
nmsp 537 udp Networked Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
gdomap 538 tcp gdomap Richard Frith-Macdonald Richard Frith-Macdonald
gdomap 538 udp gdomap Richard Frith-Macdonald Richard Frith-Macdonald
apertus-ldp 539 tcp Apertus Technologies Load Determination
apertus-ldp 539 udp Apertus Technologies Load Determination
klogin 543 tcp
klogin 543 udp
pirp 553 tcp pirp D. J. Bernstein D. J. Bernstein
pirp 553 udp pirp D. J. Bernstein D. J. Bernstein
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
banyan-vip 573 tcp banyan-vip Denis Leclerc Denis Leclerc
banyan-vip 573 udp banyan-vip Denis Leclerc Denis Leclerc
philips-vc 583 tcp Philips Video-Conferencing Janna Chang Janna Chang
philips-vc 583 udp Philips Video-Conferencing Janna Chang Janna Chang
585 De-registered 2006-04-25 Use of 585 is not recommended, use 993 instead
http-rpc-epmap 593 tcp HTTP RPC Ep Map Edward Reus Edward Reus
http-rpc-epmap 593 udp HTTP RPC Ep Map Edward Reus Edward Reus
sco-websrvrmg3 598 tcp SCO Web Server Manager 3 Simon Baldwin Simon Baldwin
sco-websrvrmg3 598 udp SCO Web Server Manager 3 Simon Baldwin Simon Baldwin
syslog-conn 601 tcp Reliable Syslog Service RFC 3195
syslog-conn 601 udp Reliable Syslog Service RFC 3195
xmlrpc-beep 602 tcp XML-RPC over BEEP RFC 3529
xmlrpc-beep 602 udp XML-RPC over BEEP RFC 3529
idxp 603 tcp IDXP RFC 4767
idxp 603 udp IDXP RFC 4767
tunnel 604 tcp TUNNEL RFC 3620
tunnel 604 udp TUNNEL RFC 3620
hmmp-op 613 tcp HMMP Operation Andrew Sinclair Andrew Sinclair
hmmp-op 613 udp HMMP Operation Andrew Sinclair Andrew Sinclair
oob-ws-http 623 tcp DMTF out-of-band web services management protocol Jim Davis Jim Davis 2007-06
asf-rmcp 623 udp ASF Remote Management and Control Protocol Carl First Carl First
3com-amp3 629 tcp 3Com AMP3 Prakash Banthia Prakash Banthia
3com-amp3 629 udp 3Com AMP3 Prakash Banthia Prakash Banthia
rda 630 tcp RDA John Hadjioannou John Hadjioannou
rda 630 udp RDA John Hadjioannou John Hadjioannou
ipp 631 tcp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipp 631 udp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipps 631 tcp Internet Printing Protocol over HTTPS IESG IETF Chair 2018-07-06 RFC 8011
bmpp 632 tcp bmpp Troy Rollo Troy Rollo
bmpp 632 udp bmpp Troy Rollo Troy Rollo
servstat 633 tcp Service Status update (Sterling Software) Greg Rose Greg Rose
servstat 633 udp Service Status update (Sterling Software) Greg Rose Greg Rose
ginad 634 tcp ginad Mark Crother Mark Crother
ginad 634 udp ginad Mark Crother Mark Crother
rlzdbase 635 tcp RLZ DBase Michael Ginn Michael Ginn
rlzdbase 635 udp RLZ DBase Michael Ginn Michael Ginn
ldaps 636 tcp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
ldaps 636 udp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
lanserver 637 tcp lanserver Chris Larsson Chris Larsson
lanserver 637 udp lanserver Chris Larsson Chris Larsson
mcns-sec 638 tcp mcns-sec Kaz Ozawa Kaz Ozawa
mcns-sec 638 udp mcns-sec Kaz Ozawa Kaz Ozawa
msdp 639 tcp MSDP Dino Farinacci Dino Farinacci
msdp 639 udp MSDP Dino Farinacci Dino Farinacci
esro-emsdp 642 tcp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
esro-emsdp 642 udp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
sanity 643 tcp SANity Peter Viscarola Peter Viscarola
sanity 643 udp SANity Peter Viscarola Peter Viscarola
cadview-3d 649 tcp Cadview-3d - streaming 3d models over the internet David Cooper David Cooper
cadview-3d 649 udp Cadview-3d - streaming 3d models over the internet David Cooper David Cooper
repscmd 653 tcp RepCmd Scott Dale Scott Dale

Contact Information

Name Organization Contact URI Last Updated
Alain Durand Alain.Durand&imag.fr
Andreas Heidemann a.heidemann&ais-gmbh.de
Andrew Sinclair andrsin&microsoft.com
Andy McKeen mckeen&osf.org
Carl First Carl.L.First&intel.com
Chris Larsson clarsson&vnet.ibm.com
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
David Cooper david.cooper&oracle.com
Denis Leclerc DLeclerc&banyan.com
Dino Farinacci dino&cisco.com 2008-08-21
Edward Reus edwardr&microsoft.com
Greg Rose Greg_Rose&sydney.sterling.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Janna Chang janna&pmc.philips.com
Jeff M.Michaud michaud&zk3.dec.com
Jim Davis jim.davis&wbemsolutions.com 2007-06
John Hadjioannou john&minster.co.uk
Juliana Hsu jhsu&ca.ibm.com
Kaz Ozawa k.ozawa&cablelabs.com
Kevin Mooney kevinm&bfs.unibol.com
Laurent Domenech Opalis ldomenech&opalis.com
Mamoru Ito Ito&pcnet.ks.pfu.co.jp
Mark Crother mark&eis.calstate.edu
Michael Ginn ginn&tyxar.com
Mohsen Banan mohsen&neda.com
Pat Richard patr&xcert.com
Paul Santinelli Jr. psantinelli&narrative.com
Peter Viscarola PeterGV&osr.com
Prakash Banthia prakash_banthia&3com.com
Rami Rubin rami&hybrid.com
Randall Stewart IETF TSVWG rrs&lakerest.net
Richard Frith-Macdonald richard&brainstorm.co.uk
Robert Ford robert&intrinsa.com
Scott Dale scott&tioga.com
Simon Baldwin simonb&sco.com
Thomas Obermair tommy&inlab.m.eunet.de
Toerless Eckert eckert&cisco.com
Troy Rollo troy&kroll.corvu.com.au
Uwe Honermann u.honermann&windream.com