Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-09
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER REGISTERED OR NOT.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| turbonote-1 | 39681 | tcp | TurboNote Default Port | Peter Hyde | Peter Hyde | ||||||
| turbonote-1 | 39681 | udp | TurboNote Default Port | Peter Hyde | Peter Hyde | ||||||
| 39682-39999 | Unassigned | ||||||||||
| 40023 | tcp | Reserved | |||||||||
| k-patentssensor | 40023 | udp | K-PatentsSensorInformation | Vaisala | Saku Lähteenmäki | 2015-12-02 | 2021-02-02 | ||||
| 40024-40403 | Unassigned | ||||||||||
| csccfirewall | 40843 | tcp | CSCCFIREWALL | Sudhir Menon | Sudhir Menon | ||||||
| csccfirewall | 40843 | udp | CSCCFIREWALL | Sudhir Menon | Sudhir Menon | ||||||
| 40853 | tcp | Reserved | |||||||||
| ortec-disc | 40853 | udp | ORTEC Service Discovery | Jesse Ursery | Jesse Ursery | 2010-11-22 | |||||
| z-wave-s | 41230 | tcp | Z-Wave Protocol over SSL/TLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| z-wave-s | 41230 | udp | Z-Wave Protocol over DTLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| 41231-41793 | Unassigned | ||||||||||
| recvr-rc | 43000 | tcp | Receiver Remote Control | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| recvr-rc-disc | 43000 | udp | Receiver Remote Control Discovery | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| 43001-43187 | Unassigned | ||||||||||
| reachout | 43188 | tcp | REACHOUT | Roman Kriis | Roman Kriis | ||||||
| reachout | 43188 | udp | REACHOUT | Roman Kriis | Roman Kriis | ||||||
| ndm-agent-port | 43189 | tcp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis | ||||||
| ndm-agent-port | 43189 | udp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | tcp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | udp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| noit-transport | 43191 | tcp | Reconnoiter Agent Data Transport | Theo Schlossnagle | Theo Schlossnagle | 2009-05-19 | |||||
| 43191 | udp | Reserved | |||||||||
| 43192-43209 | Unassigned | ||||||||||
| shaperai | 43210 | tcp | Shaper Automation Server Management | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| shaperai-disc | 43210 | udp | Shaper Automation Server Management Discovery | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| 43211-43437 | Unassigned | ||||||||||
| 43438 | tcp | Reserved | |||||||||
| hmip-routing | 43438 | udp | HmIP LAN Routing | eQ-3 Entwicklung GmbH | Tido de Vries | 2018-02-28 | |||||
| eq3-update | 43439 | tcp | EQ3 firmware update | eQ-3 Entwicklung GmbH | Tido de Vries | 2012-02-10 | 2014-05-09 | ||||
| eq3-config | 43439 | udp | EQ3 discovery and configuration | eQ-3 Entwicklung GmbH | Tido de Vries | 2012-02-10 | 2014-05-09 | ||||
| ew-mgmt | 43440 | tcp | Cisco EnergyWise Management | ||||||||
| ew-disc-cmd | 43440 | udp | Cisco EnergyWise Discovery and Command Flooding | John Parello | John Parello | 2009-05-19 | |||||
| ciscocsdb | 43441 | tcp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| ciscocsdb | 43441 | udp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| 43442-44122 | Unassigned | ||||||||||
| z-wave-tunnel | 44123 | tcp | Z-Wave Secure Tunnel | Sigma Designs, Inc. | Anders Brandt | 2012-10-12 | 2015-06-26 | ||||
| 44123 | udp | Reserved | |||||||||
| 44124-44320 | Unassigned | ||||||||||
| pmcd | 44321 | tcp | PCP server (pmcd) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2010-12-20 | 2025-09-29 | ||||
| pmcd | 44321 | udp | PCP server (pmcd) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2010-12-20 | 2025-09-29 | ||||
| pmproxy | 44322 | tcp | PCP proxy (pmproxy) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2003-07 | 2025-09-26 | ||||
| pmproxy | 44322 | udp | PCP proxy (pmproxy) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2003-07 | 2025-09-26 | ||||
| pmwebapi | 44323 | tcp | HTTP binding for Performance Co-Pilot client API | Performance Co-Pilot (PCP) Project | Ken McDonell | 2013-10-09 | |||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 | ||||||||
| 44324-44443 | Unassigned | ||||||||||
| 44446-44543 | Unassigned | Known UNAUTHORIZED USE: Ports 44515 & 44516 | |||||||||
| rbr-debug | 44553 | tcp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| rbr-debug | 44553 | udp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| m3da | 44900 | tcp | M3DA is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 | |||||
| m3da-disc | 44900 | udp | M3DA Discovery is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 | |||||
| 45003-45044 | Unassigned | ||||||||||
| 45046-45053 | Unassigned | ||||||||||
| 45186-45513 | Unassigned | ||||||||||
| 45679-45823 | Unassigned | ||||||||||
| 45967-46335 | Unassigned | ||||||||||
| inedo | 46336 | tcp | Listen port used for Inedo agent communication | Inedo | Steve Dennis | 2016-01-12 | |||||
| 46336 | udp | Reserved | |||||||||
| 46337-46997 | Unassigned | ||||||||||
| 47558-47623 | Unassigned | ||||||||||
| nimgtw | 48003 | tcp | Nimbus Gateway | Carstein Seeberg | Carstein Seeberg | ||||||
| nimgtw | 48003 | udp | Nimbus Gateway | Carstein Seeberg | Carstein Seeberg | ||||||
| 3gpp-cbsp | 48049 | tcp | 3GPP Cell Broadcast Service Protocol | Gert Thomasen | Gert Thomasen | 2009-12-07 | |||||
| 48130-48555 | Unassigned | ||||||||||
| robotraconteur | 48653 | tcp | Robot Raconteur transport | Wason Technology, LLC | John Wason | 2014-01-27 | |||||
| robotraconteur | 48653 | udp | Robot Raconteur transport | Wason Technology, LLC | John Wason | 2014-01-27 | |||||
| nusrp | 49001 | tcp | Nuance Unity Service Request Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| nusdp-disc | 49001 | udp | Nuance Unity Service Discovery Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| 49151 | Reserved | 2024-12-20 | RFC 6335 | ||||||||
| netconfsoapbeep | NETCONF for SOAP over BEEP | RFC 4743; RFC 9900 | |||||||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 | |||||||||
| airmate | tcp | Airmate interworking protocol | Myriel Aviation / Airmate | Daniel Mavrakis | 2020-09-21 | Defined TXT keys: proprietary | |||||
| airmate | udp | Airmate interworking protocol | Myriel Aviation / Airmate | Daniel Mavrakis | 2020-09-21 | Defined TXT keys: proprietary | |||||
| airplay | tcp | Protocol for streaming of audio/video content | Apple Inc. | Bob Bradley | 2012-09-19 | Defined TXT keys: am, cn, et, ft, fv, md, pk, pw, sf, tp, vn, vs | |||||
| airplay | udp | Protocol for streaming of audio/video content | Apple Inc. | Bob Bradley | 2012-09-19 | Defined TXT keys: am, cn, et, ft, fv, md, pk, pw, sf, tp, vn, vs | |||||
| appletv | Apple TV | Amandeep Jawa | Amandeep Jawa | Defined TXT keys: txtvers, PrVs, OSsi, MniT | |||||||
| appletv-itunes | Apple TV discovery of iTunes | Amandeep Jawa | Amandeep Jawa | Defined TXT keys: txtvers | |||||||
| appletv-pair | Apple TV Pairing | Amandeep Jawa | Amandeep Jawa | Defined TXT keys: txtvers | |||||||
| b3d-convince | 3M Unitek Digital Orthodontic System | Rajiv Aaron Manglani | Rajiv Aaron Manglani | Defined TXT keys: txtvers=1, protovers=<api version>, guid=<32 hex digits> | |||||||
| brski-pledge | tcp | The Bootstrapping Remote Secure Key Infrastructure Pledge | IESG | IETF Chair | 2026-05-11 | RFC-ietf-anima-brski-prm-23 | Defined TXT keys: None | ||||
| brski-reg-cmp | tcp | Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 | IESG | IETF Chair | 2024-09-23 | RFC 9733 | Defined TXT keys: None | ||||
| canon-chmp | tcp | Canon HTTP Management Protocol | Canon Inc. | Tomoyuki Hansaki | 2014-09-03 | 2015-03-16 | Defined TXT keys: txtvers, mpath | ||||
| carddav | tcp | vCard Extensions to WebDAV (CardDAV) - non-TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the http service. Defined TXT keys: path=<context path> | ||||
| carddavs | tcp | vCard Extensions to WebDAV (CardDAV) - over TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the https service. Defined TXT keys: path=<context path> | ||||
| convert | tcp | 0-RTT TCP Convert Protocol | IESG | IETF Chair | 2020-03-27 | RFC 8803 | Defined TXT keys: None | ||||
| dacp | Digital Audio Control Protocol (iTunes) | Amandeep Jawa | Amandeep Jawa | Defined TXT keys: txtvers, Ver, DbId | |||||||
| dccp-ping | dccp | ping/traceroute using DCCP | Samuel Jero | Samuel Jero | 2012-11-14 | 1885957735 | Defined TXT keys: None | ||||
| dell-soo-ds | tcp | Spotlight on Oracle Diagnostic Server | Dell | Rob Griffin | 2013-10-03 | Defined TXT keys: None | |||||
| dell-soo-ds | udp | Spotlight on Oracle Diagnostic Server | Dell | Rob Griffin | 2013-10-03 | Defined TXT keys: None | |||||
| dell-soss-ds-w | tcp | Spotlight on SQL Server Diagnostic Server HTTP | Dell | Rob Griffin | 2013-10-03 | Defined TXT keys: None | |||||
| dell-ssms-ds | tcp | Spotlight SSMS Plugin Diagnostic Server | Dell | Rob Griffin | 2013-10-03 | Defined TXT keys: None | |||||
| displaysrc | tcp | Wi-Fi Alliance Display Source service | Wi-Fi Alliance | Gaurav Jain | 2017-03-14 | Defined TXT keys: None | |||||
| dltimesync | udp | Local Area Dynamic Time Synchronisation Protocol | Geoff Back | Geoff Back | Defined TXT keys: None | ||||||
| dns-update | tcp | DNS Dynamic Update Service | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | |||||
| dns-update | udp | DNS Dynamic Update Service | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | |||||
| dns-update-tls | tcp | DNS Dynamic Update Service over TLS | Stuart Cheshire | Stuart Cheshire | 2019-05-04 | RFC 6281 | DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain. | ||||
| dots-call-home | tcp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-call-home | udp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-data | tcp | DOTS Data Channel Protocol. The service name is used to construct the SRV service name "_dots-data._tcp" for discovering DOTS servers used to establish DOTS data channel. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| edge1 | tcp | Edge1 Base Station | Skycatch, Inc. | Ruben Beltran del Rio | 2018-02-09 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aaron Ballman | aaron&realsoftware.com | 2004-11 | |
| Amandeep Jawa | daap&apple.com | ||
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2012-10-12 |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 |
| Andrew Andrews | Andrew.Andrews&Nuance.com | 2017-04-26 | |
| Apple Inc. | bradley&apple.com | 2012-09-19 | |
| Bob Bradley | Apple Inc. | bradley&apple.com | 2012-09-19 |
| Canon Inc. | fujii.ken-ichi149&canon.co.jp | 2014-09-03 | |
| Carstein Seeberg | case&nimsoft.no | ||
| Cisco Systems | nmtg-port-numbers&cisco.com | 2005-11 | |
| Daniel Mavrakis | mavrakis.daniel&myriel.lu | 2020-09-21 | |
| Dell | rob.gri55in&gmail.com | 2013-10-03 | |
| Didier Lahay | dlahay&sierrawireless.com | 2013-02-22 | |
| Eclipse Foundation | license&eclipse.org | 2013-02-22 | |
| eQ-3 Entwicklung GmbH | ports&entwicklung.eq-3.de | 2018-02-28 | |
| Gaurav Jain | Wi-Fi Alliance | gjain&wifi.org | 2017-03-14 |
| Geoff Back | geoff&demonlair.co.uk | ||
| Gert Thomasen | gert.thomasen&etsi.org | 2009-12-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Inedo | support&inedo.com | 2016-01-12 | |
| Jesse Ursery | jesse.ursery&ametek.com | 2010-11-22 | |
| John Parello | jparello&cisco.com | 2009-05-19 | |
| John Wason | Wason Technology, LLC | wason&wasontech.com | 2014-01-27 |
| Ken McDonell | kenj&kenj.id.au | 2025-09-26 | |
| Myriel Aviation / Airmate | mavrakis.daniel&myriel.lu | 2020-09-21 | |
| Nuance Communications, Inc. | Andrew.Andrews&Nuance.com | 2017-04-20 | |
| Performance Co-Pilot (PCP) Project | pcp-maintainers&groups.io | 2025-09-26 | |
| Peter Hyde | peter&spis.co.nz | ||
| Rajiv Aaron Manglani | rajivmanglani&mmm.com | ||
| Research Electronics International | software&reiusa.net | 2012-12-20 | |
| Rob Griffin | Dell | rob.gri55in&gmail.com | 2013-10-03 |
| Roman Kriis | roman&previo.ee | ||
| Ross Binkley | Research Electronics International | software&reiusa.net | 2012-12-20 |
| Ruben Beltran del Rio | benb&skycatch.com | 2018-02-09 | |
| Saku Lähteenmäki | saku.lahteenmaki&vaisala.com | 2021-02-02 | |
| Samuel Jero | sj323707&ohio.edu | 2012-11-14 | |
| Shaper Automation Inc. | ports&shaperai.com | 2012-06-22 | |
| Sigma Designs, Inc. | anders_brandt&sigmadesigns.com | 2011-10-03 | |
| Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 | |
| Skycatch, Inc. | dev&skycatch.com | 2018-02-09 | |
| Steve Dennis | sdennis&inedo.com | 2016-01-12 | |
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 | |
| Sudhir Menon | sudhir¢erspan.com | ||
| Theo Schlossnagle | jesus&omniti.com | 2009-05-19 | |
| Tido de Vries | eQ-3 Entwicklung GmbH | tido.devries&entwicklung.eq-3.de | 2018-02-28 |
| Tomoyuki Hansaki | Canon Inc. | hansaki.tomoyuki&canon.co.jp | 2014-09-03 |
| Vaisala | saku.lahteenmaki&vaisala.com | 2021-02-02 | |
| Wason Technology, LLC | wason&wasontech.com | 2014-01-27 | |
| Wi-Fi Alliance | gjain&wi-fi.org | 2017-03-14 | |
| Yohann Sulaiman | ports&shaperai.com | 2012-06-22 |