Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
nntp 119 tcp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
nntp 119 udp Network News Transfer Protocol IESG IETF Chair 2018-07-06 RFC 3977
nnsp 433 tcp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
nnsp 433 udp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642

Contact Information

Name Organization Contact URI Last Updated
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org