Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 0 | tcp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 0 | udp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 2 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 2 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| discard | 9 | dccp | Discard | Eddie Kohler | Eddie Kohler | RFC 4340 | 1145656131 | ||||
| daytime | 13 | tcp | Daytime | Jon Postel | Jon Postel | RFC 867 | |||||
| daytime | 13 | udp | Daytime | Jon Postel | Jon Postel | RFC 867 | |||||
| telnet | 23 | tcp | Telnet | Jon Postel | Jon Postel | RFC 854 | Defined TXT keys: u=<username> p=<password> | ||||
| telnet | 23 | udp | Telnet | Jon Postel | Jon Postel | RFC 854 | Defined TXT keys: u=<username> p=<password> | ||||
| smtp | 25 | tcp | Simple Mail Transfer | IESG | IETF Chair | 2017-06-05 | RFC-ietf-emailcore-rfc5321bis-43 | ||||
| smtp | 25 | udp | Simple Mail Transfer | IESG | IETF Chair | 2017-06-05 | RFC-ietf-emailcore-rfc5321bis-43 | ||||
| 30 | tcp | Unassigned | |||||||||
| 30 | udp | Unassigned | |||||||||
| msg-auth | 31 | tcp | MSG Authentication | Robert Thomas | Robert Thomas | ||||||
| msg-auth | 31 | udp | MSG Authentication | Robert Thomas | Robert Thomas | ||||||
| 32 | tcp | Unassigned | |||||||||
| 32 | udp | Unassigned | |||||||||
| dsp | 33 | tcp | Display Support Protocol | Ed Cain | Ed Cain | ||||||
| dsp | 33 | udp | Display Support Protocol | Ed Cain | Ed Cain | ||||||
| 34 | tcp | Unassigned | |||||||||
| 34 | udp | Unassigned | |||||||||
| 35 | tcp | any private printer server | Jon Postel | Jon Postel | |||||||
| 35 | udp | any private printer server | Jon Postel | Jon Postel | |||||||
| 36 | tcp | Unassigned | |||||||||
| 36 | udp | Unassigned | |||||||||
| time | 37 | tcp | Time | Jon Postel | Jon Postel | ||||||
| time | 37 | udp | Time | Jon Postel | Jon Postel | ||||||
| rap | 38 | tcp | Route Access Protocol | Robert Ullmann | Robert Ullmann | ||||||
| rap | 38 | udp | Route Access Protocol | Robert Ullmann | Robert Ullmann | ||||||
| rlp | 39 | tcp | Resource Location Protocol | Mike Accetta | Mike Accetta | ||||||
| rlp | 39 | udp | Resource Location Protocol | Mike Accetta | Mike Accetta | ||||||
| nicname | 43 | tcp | Who Is | ||||||||
| nicname | 43 | udp | Who Is | ||||||||
| 51 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| domain | 53 | tcp | Domain Name Server | Paul Mockapetris | Paul Mockapetris | ||||||
| domain | 53 | udp | Domain Name Server | Paul Mockapetris | Paul Mockapetris | ||||||
| whoispp | 63 | tcp | whois++ IANA assigned this well-formed service name as a replacement for "whois++". |
Rickard Schoultz | Rickard Schoultz | ||||||
| whois++ | 63 | tcp | whois++ | Rickard Schoultz | Rickard Schoultz | This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| whoispp | 63 | udp | whois++ IANA assigned this well-formed service name as a replacement for "whois++". |
Rickard Schoultz | Rickard Schoultz | ||||||
| whois++ | 63 | udp | whois++ | Rickard Schoultz | Rickard Schoultz | This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| netrjs-3 | 73 | tcp | Remote Job Service | ||||||||
| netrjs-3 | 73 | udp | Remote Job Service | ||||||||
| mit-ml-dev | 83 | tcp | MIT ML Device | David Reed | David Reed | ||||||
| mit-ml-dev | 83 | udp | MIT ML Device | David Reed | David Reed | ||||||
| dcp | 93 | tcp | Device Control Protocol | Daniel Tappan | Daniel Tappan | ||||||
| dcp | 93 | udp | Device Control Protocol | Daniel Tappan | Daniel Tappan | ||||||
| gppitnp | 103 | tcp | Genesis Point-to-Point Trans Net | ||||||||
| gppitnp | 103 | udp | Genesis Point-to-Point Trans Net | ||||||||
| acr-nema | 104 | tcp | ACR-NEMA Digital Imag. & Comm. 300 | Patrick McNamee | Patrick McNamee | ||||||
| acr-nema | 104 | udp | ACR-NEMA Digital Imag. & Comm. 300 | Patrick McNamee | Patrick McNamee | ||||||
| 3com-tsmux | 106 | tcp | 3COM-TSMUX | Jeremy Siegel | Jeremy Siegel | Known Unauthorized Use on 106 | |||||
| 3com-tsmux | 106 | udp | 3COM-TSMUX | Jeremy Siegel | Jeremy Siegel | Known Unauthorized Use on 106 | |||||
| pop3 | 110 | tcp | Post Office Protocol - Version 3 | Marshall Rose | Marshall Rose | ||||||
| pop3 | 110 | udp | Post Office Protocol - Version 3 | Marshall Rose | Marshall Rose | ||||||
| ident | 113 | tcp | |||||||||
| auth | 113 | tcp | Authentication Service | Mike St. Johns | Mike St. Johns | ||||||
| auth | 113 | udp | Authentication Service | Mike St. Johns | Mike St. Johns | ||||||
| nntp | 119 | tcp | Network News Transfer Protocol | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| nntp | 119 | udp | Network News Transfer Protocol | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| ntp | 123 | tcp | Network Time Protocol | Dave Mills | Dave Mills | RFC 5905 | |||||
| ntp | 123 | udp | Network Time Protocol | Dave Mills | Dave Mills | RFC 5905 | |||||
| cisco-fna | 130 | tcp | cisco FNATIVE | ||||||||
| cisco-fna | 130 | udp | cisco FNATIVE | ||||||||
| cisco-tna | 131 | tcp | cisco TNATIVE | ||||||||
| cisco-tna | 131 | udp | cisco TNATIVE | ||||||||
| cisco-sys | 132 | tcp | cisco SYSMAINT | ||||||||
| cisco-sys | 132 | udp | cisco SYSMAINT | ||||||||
| statsrv | 133 | tcp | Statistics Service | Dave Mills | Dave Mills | ||||||
| statsrv | 133 | udp | Statistics Service | Dave Mills | Dave Mills | ||||||
| ingres-net | 134 | tcp | INGRES-NET Service | Mike Berrow | Mike Berrow | ||||||
| ingres-net | 134 | udp | INGRES-NET Service | Mike Berrow | Mike Berrow | ||||||
| epmap | 135 | tcp | DCE endpoint resolution | Joe Pato | Joe Pato | ||||||
| epmap | 135 | udp | DCE endpoint resolution | Joe Pato | Joe Pato | ||||||
| profile | 136 | tcp | PROFILE Naming System | Larry Peterson | Larry Peterson | ||||||
| profile | 136 | udp | PROFILE Naming System | Larry Peterson | Larry Peterson | ||||||
| netbios-ns | 137 | tcp | NETBIOS Name Service | ||||||||
| netbios-ns | 137 | udp | NETBIOS Name Service | ||||||||
| netbios-dgm | 138 | tcp | NETBIOS Datagram Service | ||||||||
| netbios-dgm | 138 | udp | NETBIOS Datagram Service | ||||||||
| netbios-ssn | 139 | tcp | NETBIOS Session Service | Jon Postel | Jon Postel | ||||||
| netbios-ssn | 139 | udp | NETBIOS Session Service | Jon Postel | Jon Postel | ||||||
| imap | 143 | tcp | Internet Message Access Protocol | IESG | IETF Chair | 2021-02-22 | RFC 3501; RFC 9051 | ||||
| 143 | udp | Reserved | 2021-02-22 | RFC 9051 | |||||||
| sgmp | 153 | tcp | SGMP | Marty Schoffstahl | Marty Schoffstahl | ||||||
| sgmp | 153 | udp | SGMP | Marty Schoffstahl | Marty Schoffstahl | ||||||
| cmip-man | 163 | tcp | CMIP/TCP Manager | ||||||||
| cmip-man | 163 | udp | CMIP/TCP Manager | ||||||||
| xyplex-mux | 173 | tcp | Xyplex | Bob Stewart | Bob Stewart | ||||||
| xyplex-mux | 173 | udp | Xyplex | Bob Stewart | Bob Stewart | ||||||
| ocbinder | 183 | tcp | OCBinder | ||||||||
| ocbinder | 183 | udp | OCBinder | ||||||||
| srmp | 193 | tcp | Spider Remote Monitoring Protocol | Ted J. Socolofsky | Ted J. Socolofsky | ||||||
| srmp | 193 | udp | Spider Remote Monitoring Protocol | Ted J. Socolofsky | Ted J. Socolofsky | ||||||
| at-3 | 203 | tcp | AppleTalk Unused | ||||||||
| at-3 | 203 | udp | AppleTalk Unused | ||||||||
| z39-50 | 210 | tcp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman | ||||||
| z39.50 | 210 | tcp | ANSI Z39.50 | Mark H. Needleman | Mark H. Needleman | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| z39-50 | 210 | udp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bernie Volz | volz&cisco.com | ||
| Bob Stewart | STEWART&xyplex.com | ||
| Daniel Tappan | Tappan&bbn.com | ||
| Dave Mills | mills&udel.edu | 2022-06-03 | |
| Dave Mills | Mills&huey.udel.edu | ||
| David Reed | |||
| Ed Cain | cain&edn-unix.dca.mil | ||
| Eddie Kohler | IETF dccp WG | kohler&cs.ucla.edu | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jeremy Siegel | jzs&nsd.3com.com | ||
| Joe Pato | pato&apollo.hp.com | ||
| Jon Postel | postel&isi.edu | ||
| Larry Peterson | llp&arizona.edu | ||
| Mark H. Needleman | markn&sirsi.com | ||
| Marshall Rose | mrose17&gmail.com | 2024-07-29 | |
| Marty Schoffstahl | schoff&nisc.nyser.net | ||
| Mike Accetta | MIKE.ACCETTA&cmu-cs-a.edu | ||
| Mike Berrow | |||
| Mike St. Johns | stjohns&arpa.mil | ||
| Patrick McNamee | |||
| Paul Mockapetris | PVM&isi.edu | ||
| Rickard Schoultz | schoultz&sunet.se | ||
| Robert Thomas | BThomas&f.bbn.com | ||
| Robert Ullmann | ariel&world.std.com | ||
| Ted J. Socolofsky | Teds&spider.co.uk |