Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
netopia-vo3 1841 tcp netopia-vo3
netopia-vo3 1841 udp netopia-vo3
netopia-vo5 1843 tcp netopia-vo5 Marc Epard Marc Epard
netopia-vo5 1843 udp netopia-vo5 Marc Epard Marc Epard
slp-notify 1847 tcp SLP Notification RFC 3082
slp-notify 1847 udp SLP Notification RFC 3082
vids-avtp 1853 tcp VIDS-AVTP Sascha Kuemmel Sascha Kuemmel
vids-avtp 1853 udp VIDS-AVTP Sascha Kuemmel Sascha Kuemmel
msnp 1863 tcp MSNP William Lai William Lai
msnp 1863 udp MSNP William Lai William Lai
paradym-31port 1864 tcp Paradym 31 Port David Wooden David Wooden
paradym-31port 1864 udp Paradym 31 Port David Wooden David Wooden
fjmpjps 1873 tcp Fjmpjps
fjmpjps 1873 udp Fjmpjps
mqtt 1883 tcp Message Queuing Telemetry Transport Protocol OASIS Robin Cover 2015-02-10
mqtt 1883 udp Message Queuing Telemetry Transport Protocol OASIS Robin Cover 2015-02-10
elad 1893 tcp ELAD Protocol Franco Milan Franco Milan
elad 1893 udp ELAD Protocol Franco Milan Franco Milan
linkname 1903 tcp Local Link Name Resolution Dan Harrington Dan Harrington
linkname 1903 udp Local Link Name Resolution Dan Harrington Dan Harrington
armadp 1913 tcp armadp Kevin Welton Kevin Welton
armadp 1913 udp armadp Kevin Welton Kevin Welton
spice 1923 tcp SPICE Nicholas Chua Nicholas Chua
spice 1923 udp SPICE Nicholas Chua Nicholas Chua
driveappserver 1930 tcp Drive AppServer Andrew Johnson Andrew Johnson
driveappserver 1930 udp Drive AppServer Andrew Johnson Andrew Johnson
amdsched 1931 tcp AMD SCHED Michael Walsh Michael Walsh
amdsched 1931 udp AMD SCHED Michael Walsh Michael Walsh
ctt-broker 1932 tcp CTT Broker Jens Edlund Jens Edlund
ctt-broker 1932 udp CTT Broker Jens Edlund Jens Edlund
xmapi 1933 tcp IBM LM MT Agent
xmapi 1933 udp IBM LM MT Agent
xaapi 1934 tcp IBM LM Appl Agent Helga Wolin Helga Wolin
xaapi 1934 udp IBM LM Appl Agent Helga Wolin Helga Wolin
macromedia-fcs 1935 tcp Macromedia Flash Communications Server MX Pritham Shetty Pritham Shetty
macromedia-fcs 1935 udp Macromedia Flash Communications server MX Pritham Shetty Pritham Shetty
jetcmeserver 1936 tcp JetCmeServer Server Port
jetcmeserver 1936 udp JetCmeServer Server Port
jwserver 1937 tcp JetVWay Server Port
jwserver 1937 udp JetVWay Server Port
jwclient 1938 tcp JetVWay Client Port
jwclient 1938 udp JetVWay Client Port
jvserver 1939 tcp JetVision Server Port
jvserver 1939 udp JetVision Server Port
beeyond-media 1943 tcp Beeyond Media Bob Deblier Bob Deblier
beeyond-media 1943 udp Beeyond Media Bob Deblier Bob Deblier
rapidbase 1953 tcp Rapid Base Antoni Wolski Antoni Wolski
rapidbase 1953 udp Rapid Base Antoni Wolski Antoni Wolski
webmachine 1963 tcp WebMachine Tim Jowers Tim Jowers
webmachine 1963 udp WebMachine Tim Jowers Tim Jowers
dlsrap 1973 tcp Data Link Switching Remote Access Protocol Steve T. Chiang Steve T. Chiang
dlsrap 1973 udp Data Link Switching Remote Access Protocol Steve T. Chiang Steve T. Chiang
lhtp 1983 tcp Loophole Test Protocol Kade Hansson Kade Hansson
lhtp 1983 udp Loophole Test Protocol Kade Hansson Kade Hansson
tr-rsrb-p3 1989 tcp cisco RSRB Priority 3 port
tr-rsrb-p3 1989 udp cisco RSRB Priority 3 port
stun-p3 1992 tcp cisco STUN Priority 3 port
stun-p3 1992 udp cisco STUN Priority 3 port
snmp-tcp-port 1993 tcp cisco SNMP TCP port
snmp-tcp-port 1993 udp cisco SNMP TCP port
brutus 2003 tcp Brutus Server Johannes Skov Frandsen Johannes Skov Frandsen 2008-02-28
brutus 2003 udp Brutus Server Johannes Skov Frandsen Johannes Skov Frandsen 2008-02-28
raid-am 2013 tcp
raid-cd 2013 udp
xinuexpansion3 2023 tcp
xinuexpansion3 2023 udp
device2 2030 tcp
device2 2030 udp
mobrien-chat 2031 tcp mobrien-chat Mike O'Brien Mike O'Brien 2004-11
mobrien-chat 2031 udp mobrien-chat Mike O'Brien Mike O'Brien 2004-11
blackboard 2032 tcp
blackboard 2032 udp
glogger 2033 tcp
glogger 2033 udp
scoremgr 2034 tcp
scoremgr 2034 udp
imsldoc 2035 tcp
imsldoc 2035 udp
e-dpnet 2036 tcp Ethernet WS DP network Peter Kaever Peter Kaever 2005-08
e-dpnet 2036 udp Ethernet WS DP network Peter Kaever Peter Kaever 2005-08
applus 2037 tcp APplus Application Server Alfred Weindl Marcus Schairer 2008-06-06 2021-07-20 Unauthorized Use Known on port 2037 Formerly was P2plus Application Server
applus 2037 udp APplus Application Server Alfred Weindl Marcus Schairer 2008-06-06 2021-07-20 Unauthorized Use Known on port 2037 Formerly was P2plus Application Server
objectmanager 2038 tcp
objectmanager 2038 udp
prizma 2039 tcp Prizma Monitoring Service Dotan Ofek Dotan Ofek 2005-12
prizma 2039 udp Prizma Monitoring Service Dotan Ofek Dotan Ofek 2005-12
isis-bcast 2043 tcp isis-bcast Ken Chapman Ken Chapman
isis-bcast 2043 udp isis-bcast Ken Chapman Ken Chapman
lot105-ds-upd 2053 tcp Lot105 DSuper Updates Piers Scannell Piers Scannell
lot105-ds-upd 2053 udp Lot105 DSuper Updates Piers Scannell Piers Scannell
icg-bridge 2063 tcp ICG Bridge Port
icg-bridge 2063 udp ICG Bridge Port
gxs-data-port 2073 tcp DataReel Database Socket Douglas M. Gaer Douglas M. Gaer
gxs-data-port 2073 udp DataReel Database Socket Douglas M. Gaer Douglas M. Gaer
radsec 2083 tcp Secure Radius Service IESG IETF Chair 2005-05 RFC 6614 The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details.
radsec 2083 udp Secure Radius Service IESG IETF Chair 2005-05 2014-07-14 RFC 7360 The UDP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC.
descent3 2092 tcp Descent 3 Kevin Bentley Kevin Bentley
descent3 2092 udp Descent 3 Kevin Bentley Kevin Bentley
nbx-cc 2093 tcp NBX CC
nbx-cc 2093 udp NBX CC
zephyr-clt 2103 tcp Zephyr serv-hm connection

Contact Information

Name Organization Contact URI Last Updated
Alfred Weindl alfred.weindl&assecosol.com 2021-08-09
Andrew Johnson andrew.johnson&bliss-support.demon.co.uk
Antoni Wolski antoni.wolski&vtt.fi
Bob Deblier bob&virtualunlimited.com
Dan Harrington dth&lucent.com
David Wooden dwooden&wizdom.com
Dotan Ofek dotan.ofek&prizmasoft.com 2005-12
Douglas M. Gaer doug&datareel.com
Franco Milan franco&eladit.com
Helga Wolin hwolin&us.ibm.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jens Edlund edlund&speech.kth.se 2005-08
Johannes Skov Frandsen joe&42tools.com 2008-02-28
Kade Hansson kade_fh&postoffice.utas.edu.au
Ken Chapman kchapman&isis.com
Kevin Bentley Kevin&outrage.com
Kevin Welton Kevin.Welton&armltd.co.uk
Marc Epard marc&netopia.com
Marcus Schairer marcus.schairer&assecosol.com 2021-08-09
Michael Walsh mww&warwick.net
Mike O'Brien mike&mobrien.com 2004-11
Nicholas Chua nick&sendit.se
OASIS robin&oasis-open.org 2015-02-10
Peter Kaever kaever.peter&westfalia.com 2005-08
Piers Scannell iana-form&lot105.com
Pritham Shetty pritham&macromedia.com
Robin Cover OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Sascha Kuemmel kuemmel&vidsoft.de
Steve T. Chiang schiang&cisco.com
Tim Jowers Tim.Jowers&columbiasc.ncr.com
William Lai wlai&microsoft.com