Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
suitcase 2903 tcp SUITCASE Milton E. Sagen Milton E. Sagen
suitcase 2903 udp SUITCASE Milton E. Sagen Milton E. Sagen
m3ua 2905 tcp M3UA Lyndon Ong Lyndon Ong RFC 4666
m3ua 2905 sctp M3UA Lyndon Ong Lyndon Ong RFC 4666
boosterware 2913 tcp Booster Ware Ido Ben-David Ido Ben-David
boosterware 2913 udp Booster Ware Ido Ben-David Ido Ben-David
wta-wsp-wtp-s 2923 tcp WTA-WSP-WTP-S Sebastien Bury Sebastien Bury
wta-wsp-wtp-s 2923 udp WTA-WSP-WTP-S Sebastien Bury Sebastien Bury
amx-weblinx 2930 tcp AMX-WEBLINX Mike Morris Mike Morris
amx-weblinx 2930 udp AMX-WEBLINX Mike Morris Mike Morris
circle-x 2931 tcp Circle-X Norm Freedman Norm Freedman
circle-x 2931 udp Circle-X Norm Freedman Norm Freedman
incp 2932 tcp INCP Keith Paulsen Keith Paulsen
incp 2932 udp INCP Keith Paulsen Keith Paulsen
4-tieropmgw 2933 tcp 4-TIER OPM GW Francois Peloffy Francois Peloffy
4-tieropmgw 2933 udp 4-TIER OPM GW Francois Peloffy Francois Peloffy
4-tieropmcli 2934 tcp 4-TIER OPM CLI Francois Peloffy Francois Peloffy
4-tieropmcli 2934 udp 4-TIER OPM CLI Francois Peloffy Francois Peloffy
qtp 2935 tcp QTP Cameron Young Cameron Young
qtp 2935 udp QTP Cameron Young Cameron Young
otpatch 2936 tcp OTPatch Brett Goldstein Brett Goldstein
otpatch 2936 udp OTPatch Brett Goldstein Brett Goldstein
pnaconsult-lm 2937 tcp PNACONSULT-LM Theo Nijssen Theo Nijssen
pnaconsult-lm 2937 udp PNACONSULT-LM Theo Nijssen Theo Nijssen
sm-pas-1 2938 tcp SM-PAS-1
sm-pas-1 2938 udp SM-PAS-1
sm-pas-2 2939 tcp SM-PAS-2
sm-pas-2 2939 udp SM-PAS-2
sm-pas-3 2940 tcp SM-PAS-3
sm-pas-3 2940 udp SM-PAS-3
ttnrepository 2943 tcp TTNRepository Robert Orr Robert Orr
ttnrepository 2943 udp TTNRepository Robert Orr Robert Orr
megaco-h248 2944 sctp Megaco-H.248 text Tom Taylor Tom Taylor 2006-09
h248-binary 2945 sctp Megaco/H.248 binary Tom Taylor Tom Taylor 2006-09
ovalarmsrv 2953 tcp OVALARMSRV
ovalarmsrv 2953 udp OVALARMSRV
iph-policy-adm 2963 tcp IPH-POLICY-ADM Shai Herzog Shai Herzog
iph-policy-adm 2963 udp IPH-POLICY-ADM Shai Herzog Shai Herzog
svnetworks 2973 tcp SV Networks Sylvia Siu Sylvia Siu
svnetworks 2973 udp SV Networks Sylvia Siu Sylvia Siu
h263-video 2979 tcp H.263 Video Streaming Jauvane C. de Oliveira Jauvane C. de Oliveira
h263-video 2979 udp H.263 Video Streaming Jauvane C. de Oliveira Jauvane C. de Oliveira
netplan 2983 tcp NETPLAN Thomas Driemeyer Thomas Driemeyer
netplan 2983 udp NETPLAN Thomas Driemeyer Thomas Driemeyer
veritas-vis1 2993 tcp VERITAS VIS1
veritas-vis1 2993 udp VERITAS VIS1
hbci 3000 tcp HBCI Kurt Haubner Kurt Haubner
hbci 3000 udp HBCI Kurt Haubner Kurt Haubner
remoteware-cl 3000 tcp RemoteWare Client Tim Farley Tim Farley This entry records an unassigned but widespread use
remoteware-cl 3000 udp RemoteWare Client Tim Farley Tim Farley This entry records an unassigned but widespread use
origo-native 3001 tcp OrigoDB Server Native Interface Devrex Labs Robert Friberg 2013-03-29 port 3001 previously "Removed on 2006-05-25"
3001 udp Reserved 2013-03-29 port 3001 previously "Removed on 2006-05-25"
exlm-agent 3002 tcp EXLM Agent Randy Martin Randy Martin
exlm-agent 3002 udp EXLM Agent Randy Martin Randy Martin
remoteware-srv 3002 tcp RemoteWare Server Tim Farley Tim Farley This entry records an unassigned but widespread use
remoteware-srv 3002 udp RemoteWare Server Tim Farley Tim Farley This entry records an unassigned but widespread use
cgms 3003 tcp CGMS Corey Clinton Corey Clinton 2011-02-02
cgms 3003 udp CGMS Corey Clinton Corey Clinton 2011-02-02
csoftragent 3004 tcp Csoft Agent Nedelcho Stanev Nedelcho Stanev
csoftragent 3004 udp Csoft Agent Nedelcho Stanev Nedelcho Stanev
geniuslm 3005 tcp Genius License Manager Jakob Spies Jakob Spies
geniuslm 3005 udp Genius License Manager Jakob Spies Jakob Spies
ii-admin 3006 tcp Instant Internet Admin PerfTech, Inc. Lewis Donzis 2019-12-19
ii-admin 3006 udp Instant Internet Admin PerfTech, Inc. Lewis Donzis 2019-12-19
lotusmtap 3007 tcp Lotus Mail Tracking Agent Protocol Ken Lin Ken Lin
lotusmtap 3007 udp Lotus Mail Tracking Agent Protocol Ken Lin Ken Lin
midnight-tech 3008 tcp Midnight Technologies Kyle Unice Kyle Unice
midnight-tech 3008 udp Midnight Technologies Kyle Unice Kyle Unice
pxc-ntfy 3009 tcp PXC-NTFY Takeshi Nishizawa Takeshi Nishizawa
pxc-ntfy 3009 udp PXC-NTFY Takeshi Nishizawa Takeshi Nishizawa
gw 3010 tcp Telerate Workstation
ping-pong 3010 udp Telerate Workstation Timo Sivonen Timo Sivonen
trusted-web 3011 tcp Trusted Web
trusted-web 3011 udp Trusted Web
twsdss 3012 tcp Trusted Web Client Alex Duncan Alex Duncan
twsdss 3012 udp Trusted Web Client Alex Duncan Alex Duncan
gilatskysurfer 3013 tcp Gilat Sky Surfer Yossi Gal Yossi Gal
gilatskysurfer 3013 udp Gilat Sky Surfer Yossi Gal Yossi Gal
broker-service 3014 tcp Broker Service

IANA assigned this well-formed service name as a replacement for "broker_service".
Dale Bethers Dale Bethers
broker_service 3014 tcp Broker Service Dale Bethers Dale Bethers This entry is an alias to "broker-service". This entry is now historic, not usable for use with many common service discovery mechanisms.
broker-service 3014 udp Broker Service

IANA assigned this well-formed service name as a replacement for "broker_service".
Dale Bethers Dale Bethers
broker_service 3014 udp Broker Service Dale Bethers Dale Bethers This entry is an alias to "broker-service". This entry is now historic, not usable for use with many common service discovery mechanisms.
nati-dstp 3015 tcp NATI DSTP Paul Austin Paul Austin
nati-dstp 3015 udp NATI DSTP Paul Austin Paul Austin
notify-srvr 3016 tcp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 tcp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
notify-srvr 3016 udp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 udp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
event-listener 3017 tcp Event Listener

IANA assigned this well-formed service name as a replacement for "event_listener".
Ted Tronson Ted Tronson
event_listener 3017 tcp Event Listener Ted Tronson Ted Tronson This entry is an alias to "event-listener". This entry is now historic, not usable for use with many common service discovery mechanisms.
event-listener 3017 udp Event Listener

IANA assigned this well-formed service name as a replacement for "event_listener".
Ted Tronson Ted Tronson
event_listener 3017 udp Event Listener Ted Tronson Ted Tronson This entry is an alias to "event-listener". This entry is now historic, not usable for use with many common service discovery mechanisms.
srvc-registry 3018 tcp Service Registry

IANA assigned this well-formed service name as a replacement for "srvc_registry".
Mark Killgore Mark Killgore
srvc_registry 3018 tcp Service Registry Mark Killgore Mark Killgore This entry is an alias to "srvc-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
srvc-registry 3018 udp Service Registry

IANA assigned this well-formed service name as a replacement for "srvc_registry".
Mark Killgore Mark Killgore
srvc_registry 3018 udp Service Registry Mark Killgore Mark Killgore This entry is an alias to "srvc-registry". This entry is now historic, not usable for use with many common service discovery mechanisms.
resource-mgr 3019 tcp Resource Manager

IANA assigned this well-formed service name as a replacement for "resource_mgr".
Gary Glover Gary Glover
resource_mgr 3019 tcp Resource Manager Gary Glover Gary Glover This entry is an alias to "resource-mgr". This entry is now historic, not usable for use with many common service discovery mechanisms.
resource-mgr 3019 udp Resource Manager

IANA assigned this well-formed service name as a replacement for "resource_mgr".
Gary Glover Gary Glover
resource_mgr 3019 udp Resource Manager Gary Glover Gary Glover This entry is an alias to "resource-mgr". This entry is now historic, not usable for use with many common service discovery mechanisms.
cifs 3020 tcp CIFS Paul Leach Paul Leach

Contact Information

Name Organization Contact URI Last Updated
Alex Duncan alex.duncan&sse.ie
Brett Goldstein bgoldstein&opentable.com
Cameron Young Cameron_Young&inetco.com
Corey Clinton ccclinton&travisassoc.com 2011-02-02
Dale Bethers dbethers&novell.com
Devrex Labs robert.friberg&devrex.se 2013-03-29
Francois Peloffy fpeloffy&4tier.com
Gary Glover gglover&novell.com
Hugo Parra hparra&novell.com
Ido Ben-David dgntcom&netvision.net.il
Jakob Spies Jakob.Spies&genius.de
Jauvane C. de Oliveira jauvane&acm.org
Keith Paulsen kpaulsen&phobos.com
Ken Lin klin&us.ibm.com
Kurt Haubner haubner&ibm.net
Kyle Unice kyle&midnighttech.com
Lewis Donzis lew&perftech.com 2019-12-19
Lyndon Ong LyOng&ciena.com
Mark Killgore MKillgore&novell.com
Mike Morris mike.morris&amx.com
Milton E. Sagen msagen&extensis.com
Nedelcho Stanev decho&csoft.bg
Norm Freedman normfree&worldnet.att.net
Paul Austin paul.austin&natinst.com
Paul Leach paulle&microsoft.com
PerfTech, Inc. contact&perftech.com 2019-12-19
Randy Martin exlmoc&clemson.edu
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
Robert Orr rorr&teltone.com
Sebastien Bury WAP Forum sebastien.bury&art.alcatel.fr
Shai Herzog herzog&iphighway.com
Sylvia Siu ssiu&svnetworks.com
Takeshi Nishizawa takeshi&cp10.es.xerox.com
Ted Tronson ttronson&novell.com
Theo Nijssen theon&nijssen.nl
Thomas Driemeyer thomas&bitrot.de
Tim Farley Tim.Farley&xcellenet.com
Timo Sivonen timo.sivonen&ccmail.dowjones.com
Tom Taylor taylor&nortel.com 2006-09
Yossi Gal yossi&gilat.com