Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
z39-50 210 udp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
ipx 213 tcp IPX Don Provan Don Provan
ipx 213 udp IPX Don Provan Don Provan
imap3 220 tcp Interactive Mail Access Protocol v3 James Rice James Rice
imap3 220 udp Interactive Mail Access Protocol v3 James Rice James Rice
cdc 223 tcp Certificate Distribution Center Kannan Alagappan Kannan Alagappan
cdc 223 udp Certificate Distribution Center Kannan Alagappan Kannan Alagappan
sur-meas 243 tcp Survey Measurement Dave Clark Dave Clark
sur-meas 243 udp Survey Measurement Dave Clark Dave Clark
dsp3270 246 tcp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
dsp3270 246 udp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
hdap 263 tcp HDAP Troy Gau Troy Gau
hdap 263 udp HDAP Troy Gau Troy Gau
rescap 283 tcp rescap Paul Hoffman Paul Hoffman
rescap 283 udp rescap Paul Hoffman Paul Hoffman
tacacss 300 tcp TLS Secure Login Host Protocol (TACACSS) IESG IETF Chair 2025-07-15 RFC 9887
300 udp Reserved
301-307 Unassigned
novastorbakcup 308 tcp Novastor Backup Brian Dickman Brian Dickman
novastorbakcup 308 udp Novastor Backup Brian Dickman Brian Dickman
entrusttime 309 tcp EntrustTime Peter Whittaker Peter Whittaker
entrusttime 309 udp EntrustTime Peter Whittaker Peter Whittaker
bhmds 310 tcp bhmds John Kelly John Kelly
bhmds 310 udp bhmds John Kelly John Kelly
asip-webadmin 311 tcp AppleShare IP WebAdmin Ann Huang Ann Huang
asip-webadmin 311 udp AppleShare IP WebAdmin Ann Huang Ann Huang
vslmp 312 tcp VSLMP Gerben Wierda Gerben Wierda
vslmp 312 udp VSLMP Gerben Wierda Gerben Wierda
magenta-logic 313 tcp Magenta Logic Karl Rousseau Karl Rousseau
magenta-logic 313 udp Magenta Logic Karl Rousseau Karl Rousseau
opalis-robot 314 tcp Opalis Robot Laurent Domenech Laurent Domenech
opalis-robot 314 udp Opalis Robot Laurent Domenech Laurent Domenech
dpsi 315 tcp DPSI Tony Scamurra Tony Scamurra
dpsi 315 udp DPSI Tony Scamurra Tony Scamurra
decauth 316 tcp decAuth Michael Agishtein Michael Agishtein
decauth 316 udp decAuth Michael Agishtein Michael Agishtein
zannet 317 tcp Zannet Zan Oliphant Zan Oliphant
zannet 317 udp Zannet Zan Oliphant Zan Oliphant
pkix-timestamp 318 tcp PKIX TimeStamp Robert Zuccherato Robert Zuccherato
pkix-timestamp 318 udp PKIX TimeStamp Robert Zuccherato Robert Zuccherato
ptp-event 319 tcp PTP Event Kang Lee Kang Lee 2010-07-27
ptp-event 319 udp PTP Event Kang Lee Kang Lee 2010-07-27
ptp-general 320 tcp PTP General Kang Lee Kang Lee 2010-07-27
ptp-general 320 udp PTP General Kang Lee Kang Lee 2010-07-27
pip 321 tcp PIP Gordon Mohr Gordon Mohr
pip 321 udp PIP Gordon Mohr Gordon Mohr
rtsps 322 tcp RTSPS Anders Klemets Anders Klemets
rtsps 322 udp RTSPS Anders Klemets Anders Klemets
rpki-rtr 323 tcp Resource PKI to Router Protocol IESG IETF Chair RFC 6810
323 udp Reserved
rpki-rtr-tls 324 tcp Resource PKI to Router Protocol over TLS IESG IETF Chair RFC 6810
324 udp Reserved
325-332 Unassigned
texar 333 tcp Texar Security Port Eugen Bacic Eugen Bacic
texar 333 udp Texar Security Port Eugen Bacic Eugen Bacic
334-343 Unassigned
pdap 344 tcp Prospero Data Access Protocol B. Clifford Neuman B. Clifford Neuman
pdap 344 udp Prospero Data Access Protocol B. Clifford Neuman B. Clifford Neuman
pawserv 345 tcp Perf Analysis Workbench
pawserv 345 udp Perf Analysis Workbench
zserv 346 tcp Zebra server
zserv 346 udp Zebra server
fatserv 347 tcp Fatmen Server
fatserv 347 udp Fatmen Server
csi-sgwp 348 tcp Cabletron Management Protocol
csi-sgwp 348 udp Cabletron Management Protocol
mftp 349 tcp mftp Dave Feinleib Dave Feinleib
mftp 349 udp mftp Dave Feinleib Dave Feinleib
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-b 351 tcp MATIP Type B Alain Robert Alain Robert RFC 2351
matip-type-b 351 udp MATIP Type B Alain Robert Alain Robert RFC 2351
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
dtag-ste-sb 352 tcp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
dtag-ste-sb 352 udp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
ndsauth 353 tcp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
ndsauth 353 udp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
bh611 354 tcp bh611 John Kelly John Kelly
bh611 354 udp bh611 John Kelly John Kelly
datex-asn 355 tcp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
datex-asn 355 udp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
cloanto-net-1 356 tcp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
cloanto-net-1 356 udp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
bhevent 357 tcp bhevent John Kelly John Kelly
bhevent 357 udp bhevent John Kelly John Kelly
shrinkwrap 358 tcp Shrinkwrap Bill Simpson Bill Simpson
shrinkwrap 358 udp Shrinkwrap Bill Simpson Bill Simpson
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
scoi2odialog 360 tcp scoi2odialog Keith Petley Keith Petley
scoi2odialog 360 udp scoi2odialog Keith Petley Keith Petley
semantix 361 tcp Semantix Semantix Semantix
semantix 361 udp Semantix Semantix Semantix
srssend 362 tcp SRS Send Curt Mayer Curt Mayer
srssend 362 udp SRS Send Curt Mayer Curt Mayer
rsvp-tunnel 363 tcp RSVP Tunnel

IANA assigned this well-formed service name as a replacement for "rsvp_tunnel".
Andreas Terzis Andreas Terzis
rsvp_tunnel 363 tcp RSVP Tunnel Andreas Terzis Andreas Terzis This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.

Contact Information

Name Organization Contact URI Last Updated
Alain Robert arobert&par.sita.int
Anders Klemets anderskl&microsoft.com
Andreas Terzis terzis&cs.ucla.edu
Ann Huang annhuang&apple.com
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bill Simpson wsimpson&greendragon.com
Brian Dickman brian&novastor.com
Curt Mayer curt&emergent.com
Dave Clark ddc&lcs.mit.edu
Dave Feinleib davefe&microsoft.com
Don Provan donp&xlnvax.novell.com
Eugen Bacic ebacic&texar.com
Gerben Wierda Gerben_Wierda&rna.nl
Gordon Mohr gojomo&usa.net
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Rice RICE&sumex-aim.stanford.edu
Jayakumar Ramalingam jayakumar&novell.com
John Kelly johnk&bellhow.com
Kang Lee I&M Society TC-9 kang.lee&nist.gov 2010-07-27
Kannan Alagappan kannan&sejour.enet.dec.com
Karl Rousseau kr&netfusion.co.uk
Keith Petley keithp&sco.com
Kenneth Vaughn kvaughn&mail.viggen.com
Laurent Domenech Opalis ldomenech&opalis.com
Mark H. Needleman markn&sirsi.com
Michael Agishtein misha&unx.dec.com
Michael Battilana mcb-iana&cloanto.net 2010-04-30
Paul Hoffman phoffman&proper.com 2024-07-23
Peter Whittaker pww&entrust.com
Robert Zuccherato robert.zuccherato&entrust.com
Ruediger Wald wald&ez-darmstadt.telekom.de
Semantix xsSupport&semantix.com
Tony Scamurra Tony&desktoppaging.com
Troy Gau troy&zyxel.com
Weldon J. Showalter Gamma&mintaka.dca.mil
Zan Oliphant zan&accessone.com