Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| tip2 | 3372 | udp | TIP 2 | Keith Evans | Keith Evans | ||||||
| lavenir-lm | 3373 | tcp | Lavenir License Manager | Marius Matioc | Marius Matioc | ||||||
| lavenir-lm | 3373 | udp | Lavenir License Manager | Marius Matioc | Marius Matioc | ||||||
| cluster-disc | 3374 | tcp | Cluster Disc | Jeff Hughes | Jeff Hughes | ||||||
| cluster-disc | 3374 | udp | Cluster Disc | Jeff Hughes | Jeff Hughes | ||||||
| vsnm-agent | 3375 | tcp | VSNM Agent | Venkat Rangan | Venkat Rangan | ||||||
| vsnm-agent | 3375 | udp | VSNM Agent | Venkat Rangan | Venkat Rangan | ||||||
| cdbroker | 3376 | tcp | CD Broker | Moon Ho Chung | Moon Ho Chung | ||||||
| cdbroker | 3376 | udp | CD Broker | Moon Ho Chung | Moon Ho Chung | ||||||
| cogsys-lm | 3377 | tcp | Cogsys Network License Manager | Simon Chinnick | Simon Chinnick | ||||||
| cogsys-lm | 3377 | udp | Cogsys Network License Manager | Simon Chinnick | Simon Chinnick | ||||||
| wsicopy | 3378 | tcp | WSICOPY | James Overby | James Overby | ||||||
| wsicopy | 3378 | udp | WSICOPY | James Overby | James Overby | ||||||
| socorfs | 3379 | tcp | SOCORFS | Hugo Charbonneau | Hugo Charbonneau | ||||||
| socorfs | 3379 | udp | SOCORFS | Hugo Charbonneau | Hugo Charbonneau | ||||||
| sns-channels | 3380 | tcp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| sns-channels | 3380 | udp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| geneous | 3381 | tcp | Geneous | Nick de Smith | Nick de Smith | ||||||
| geneous | 3381 | udp | Geneous | Nick de Smith | Nick de Smith | ||||||
| fujitsu-neat | 3382 | tcp | Fujitsu Network Enhanced Antitheft function | Markku Viima | Markku Viima | ||||||
| fujitsu-neat | 3382 | udp | Fujitsu Network Enhanced Antitheft function | Markku Viima | Markku Viima | ||||||
| esp-lm | 3383 | tcp | Enterprise Software Products License Manager | George Rudy | George Rudy | ||||||
| esp-lm | 3383 | udp | Enterprise Software Products License Manager | George Rudy | George Rudy | ||||||
| hp-clic | 3384 | tcp | Cluster Management Services | Rajesh Srinivasaraghavan | Rajesh Srinivasaraghavan | ||||||
| hp-clic | 3384 | udp | Hardware Management | Rajesh Srinivasaraghavan | Rajesh Srinivasaraghavan | ||||||
| qnxnetman | 3385 | tcp | qnxnetman | Michael Hunter | Michael Hunter | ||||||
| qnxnetman | 3385 | udp | qnxnetman | Michael Hunter | Michael Hunter | ||||||
| gprs-data | 3386 | tcp | GPRS Data | ||||||||
| gprs-sig | 3386 | udp | GPRS SIG | Ansgar Bergmann | Ansgar Bergmann | ||||||
| backroomnet | 3387 | tcp | Back Room Net | Clayton Wilkinson | Clayton Wilkinson | ||||||
| backroomnet | 3387 | udp | Back Room Net | Clayton Wilkinson | Clayton Wilkinson | ||||||
| cbserver | 3388 | tcp | CB Server | Allen Wei | Allen Wei | ||||||
| cbserver | 3388 | udp | CB Server | Allen Wei | Allen Wei | ||||||
| ms-wbt-server | 3389 | tcp | MS WBT Server | Jordan Marchese | Jordan Marchese | 2022-11-03 | |||||
| ms-wbt-server | 3389 | udp | MS WBT Server | Jordan Marchese | Jordan Marchese | ||||||
| dsc | 3390 | tcp | Distributed Service Coordinator | Charles Honton | Charles Honton | ||||||
| dsc | 3390 | udp | Distributed Service Coordinator | Charles Honton | Charles Honton | ||||||
| savant | 3391 | tcp | SAVANT | Andy Bruce | Andy Bruce | ||||||
| savant | 3391 | udp | SAVANT | Andy Bruce | Andy Bruce | ||||||
| efi-lm | 3392 | tcp | EFI License Management | Ross E. Greinke | Ross E. Greinke | ||||||
| efi-lm | 3392 | udp | EFI License Management | Ross E. Greinke | Ross E. Greinke | ||||||
| d2k-tapestry1 | 3393 | tcp | D2K Tapestry Client to Server | ||||||||
| d2k-tapestry1 | 3393 | udp | D2K Tapestry Client to Server | ||||||||
| d2k-tapestry2 | 3394 | tcp | D2K Tapestry Server to Server | Eric Lan | Eric Lan | ||||||
| d2k-tapestry2 | 3394 | udp | D2K Tapestry Server to Server | Eric Lan | Eric Lan | ||||||
| dyna-lm | 3395 | tcp | Dyna License Manager (Elam) | Anjana Iyer | Anjana Iyer | ||||||
| dyna-lm | 3395 | udp | Dyna License Manager (Elam) | Anjana Iyer | Anjana Iyer | ||||||
| printer-agent | 3396 | tcp | Printer Agent IANA assigned this well-formed service name as a replacement for "printer_agent". |
Devon Taylor | Devon Taylor | ||||||
| printer_agent | 3396 | tcp | Printer Agent | Devon Taylor | Devon Taylor | This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| printer-agent | 3396 | udp | Printer Agent IANA assigned this well-formed service name as a replacement for "printer_agent". |
Devon Taylor | Devon Taylor | ||||||
| printer_agent | 3396 | udp | Printer Agent | Devon Taylor | Devon Taylor | This entry is an alias to "printer-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| cloanto-lm | 3397 | tcp | Cloanto License Manager | Takeo Sato | Takeo Sato | 2010-04-30 | |||||
| cloanto-lm | 3397 | udp | Cloanto License Manager | Takeo Sato | Takeo Sato | 2010-04-30 | |||||
| mercantile | 3398 | tcp | Mercantile | Erik Kragh Jensen | Erik Kragh Jensen | ||||||
| mercantile | 3398 | udp | Mercantile | Erik Kragh Jensen | Erik Kragh Jensen | ||||||
| csms | 3399 | tcp | CSMS | ||||||||
| csms | 3399 | udp | CSMS | ||||||||
| csms2 | 3400 | tcp | CSMS2 | Markus Michels | Markus Michels | ||||||
| csms2 | 3400 | udp | CSMS2 | Markus Michels | Markus Michels | ||||||
| filecast | 3401 | tcp | filecast | Eden Sherry | Eden Sherry | ||||||
| filecast | 3401 | udp | filecast | Eden Sherry | Eden Sherry | ||||||
| fxaengine-net | 3402 | tcp | FXa Engine Network Port | Lucas Alonso | Lucas Alonso | 2002-02 | |||||
| fxaengine-net | 3402 | udp | FXa Engine Network Port | Lucas Alonso | Lucas Alonso | 2002-02 | |||||
| 3403 | De-registered | 2006-10-27 | |||||||||
| 3404 | Removed | 2002-05-01 | |||||||||
| nokia-ann-ch1 | 3405 | tcp | Nokia Announcement ch 1 | ||||||||
| nokia-ann-ch1 | 3405 | udp | Nokia Announcement ch 1 | ||||||||
| nokia-ann-ch2 | 3406 | tcp | Nokia Announcement ch 2 | Morteza Kalhour | Morteza Kalhour | 2002-02 | |||||
| nokia-ann-ch2 | 3406 | udp | Nokia Announcement ch 2 | Morteza Kalhour | Morteza Kalhour | 2002-02 | |||||
| ldap-admin | 3407 | tcp | LDAP admin server port | Stephen Tsun | Stephen Tsun | 2002-02 | |||||
| ldap-admin | 3407 | udp | LDAP admin server port | Stephen Tsun | Stephen Tsun | 2002-02 | |||||
| BESApi | 3408 | tcp | BES Api Port | Colin Griffiths | Colin Griffiths | 2002-02 | |||||
| BESApi | 3408 | udp | BES Api Port | Colin Griffiths | Colin Griffiths | 2002-02 | |||||
| networklens | 3409 | tcp | NetworkLens Event Port | ||||||||
| networklens | 3409 | udp | NetworkLens Event Port | ||||||||
| networklenss | 3410 | tcp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| networklenss | 3410 | udp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| biolink-auth | 3411 | tcp | BioLink Authenteon server | BioLink Support | BioLink Support | 2002-02 | |||||
| biolink-auth | 3411 | udp | BioLink Authenteon server | BioLink Support | BioLink Support | 2002-02 | |||||
| xmlblaster | 3412 | tcp | xmlBlaster | Marcel Ruff | Marcel Ruff | 2002-02 | |||||
| xmlblaster | 3412 | udp | xmlBlaster | Marcel Ruff | Marcel Ruff | 2002-02 | |||||
| svnet | 3413 | tcp | SpecView Networking | Richard Dickins | Richard Dickins | 2002-02 | |||||
| svnet | 3413 | udp | SpecView Networking | Richard Dickins | Richard Dickins | 2002-02 | |||||
| wip-port | 3414 | tcp | BroadCloud WIP Port | ||||||||
| wip-port | 3414 | udp | BroadCloud WIP Port | ||||||||
| bcinameservice | 3415 | tcp | BCI Name Service | Dennis Parker | Dennis Parker | 2002-02 | |||||
| bcinameservice | 3415 | udp | BCI Name Service | Dennis Parker | Dennis Parker | 2002-02 | |||||
| commandport | 3416 | tcp | AirMobile IS Command Port | Mike Klein | Mike Klein | 2002-02 | |||||
| commandport | 3416 | udp | AirMobile IS Command Port | Mike Klein | Mike Klein | 2002-02 | |||||
| csvr | 3417 | tcp | ConServR file translation | Albert Leung | Albert Leung | 2002-02 | |||||
| csvr | 3417 | udp | ConServR file translation | Albert Leung | Albert Leung | 2002-02 | |||||
| rnmap | 3418 | tcp | Remote nmap | Tuomo Makinen | Tuomo Makinen | 2002-02 | |||||
| rnmap | 3418 | udp | Remote nmap | Tuomo Makinen | Tuomo Makinen | 2002-02 | |||||
| softaudit | 3419 | tcp | Isogon SoftAudit | Per Hellberg | Per Hellberg | 2002-02 | |||||
| softaudit | 3419 | udp | ISogon SoftAudit | Per Hellberg | Per Hellberg | 2002-02 | |||||
| ifcp-port | 3420 | tcp | iFCP User Port | RFC 4172 | |||||||
| ifcp-port | 3420 | udp | iFCP User Port | RFC 4172 | |||||||
| bmap | 3421 | tcp | Bull Apprise portmapper | Jeremy Gilbert | Jeremy Gilbert | ||||||
| bmap | 3421 | udp | Bull Apprise portmapper | Jeremy Gilbert | Jeremy Gilbert | ||||||
| rusb-sys-port | 3422 | tcp | Remote USB System Port | Steven Klein | Steven Klein | 2002-02 | |||||
| rusb-sys-port | 3422 | udp | Remote USB System Port | Steven Klein | Steven Klein | 2002-02 |