Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rsvp_tunnel 363 tcp RSVP Tunnel Andreas Terzis Andreas Terzis This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
rsvp-tunnel 363 udp RSVP Tunnel

IANA assigned this well-formed service name as a replacement for "rsvp_tunnel".
Andreas Terzis Andreas Terzis
rsvp_tunnel 363 udp RSVP Tunnel Andreas Terzis Andreas Terzis This entry is an alias to "rsvp-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
aurora-cmgr 364 tcp Aurora CMGR Philip Budne Philip Budne
aurora-cmgr 364 udp Aurora CMGR Philip Budne Philip Budne
dtk 365 tcp DTK Fred Cohen Fred Cohen
dtk 365 udp DTK Fred Cohen Fred Cohen
odmr 366 tcp ODMR Randall Gellens Randall Gellens
odmr 366 udp ODMR Randall Gellens Randall Gellens
mortgageware 367 tcp MortgageWare Ole Hellevik Ole Hellevik
mortgageware 367 udp MortgageWare Ole Hellevik Ole Hellevik
qbikgdp 368 tcp QbikGDP Adrien de Croy Adrien de Croy
qbikgdp 368 udp QbikGDP Adrien de Croy Adrien de Croy
rpc2portmap 369 tcp rpc2portmap
rpc2portmap 369 udp rpc2portmap
codaauth2 370 tcp codaauth2 Robert Watson Robert Watson
codaauth2 370 udp codaauth2 Robert Watson Robert Watson
clearcase 371 tcp Clearcase Dave LeBlang Dave LeBlang
clearcase 371 udp Clearcase Dave LeBlang Dave LeBlang
ulistproc 372 tcp ListProcessor Anastasios Kotsikonas Anastasios Kotsikonas
ulistproc 372 udp ListProcessor Anastasios Kotsikonas Anastasios Kotsikonas
legent-1 373 tcp Legent Corporation
legent-1 373 udp Legent Corporation
legent-2 374 tcp Legent Corporation Keith Boyce Keith Boyce
legent-2 374 udp Legent Corporation Keith Boyce Keith Boyce
hassle 375 tcp Hassle Reinhard Doelz Reinhard Doelz
hassle 375 udp Hassle Reinhard Doelz Reinhard Doelz
nip 376 tcp Amiga Envoy Network Inquiry Protocol Heinz Wrobel Heinz Wrobel 2020-10-02
nip 376 udp Amiga Envoy Network Inquiry Protocol Heinz Wrobel Heinz Wrobel 2020-10-02
tnETOS 377 tcp NEC Corporation
tnETOS 377 udp NEC Corporation
dsETOS 378 tcp NEC Corporation Tomoo Fujita Tomoo Fujita
dsETOS 378 udp NEC Corporation Tomoo Fujita Tomoo Fujita
is99c 379 tcp TIA/EIA/IS-99 modem client
is99c 379 udp TIA/EIA/IS-99 modem client
is99s 380 tcp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
is99s 380 udp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
hp-collector 381 tcp hp performance data collector
hp-collector 381 udp hp performance data collector
hp-managed-node 382 tcp hp performance data managed node
hp-managed-node 382 udp hp performance data managed node
hp-alarm-mgr 383 tcp hp performance data alarm manager Frank Blakely Frank Blakely
hp-alarm-mgr 383 udp hp performance data alarm manager Frank Blakely Frank Blakely
arns 384 tcp A Remote Network Server System David Hornsby David Hornsby
arns 384 udp A Remote Network Server System David Hornsby David Hornsby
ibm-app 385 tcp IBM Application Lisa Tomita Lisa Tomita
ibm-app 385 udp IBM Application Lisa Tomita Lisa Tomita
asa 386 tcp ASA Message Router Object Def. Steve Laitinen Steve Laitinen
asa 386 udp ASA Message Router Object Def. Steve Laitinen Steve Laitinen
aurp 387 tcp Appletalk Update-Based Routing Pro. Chris Ranch Chris Ranch
aurp 387 udp Appletalk Update-Based Routing Pro. Chris Ranch Chris Ranch
unidata-ldm 388 tcp Unidata LDM The University Corporation for Atmospheric Research Steven Emmerson 2012-05-18
unidata-ldm 388 udp Unidata LDM The University Corporation for Atmospheric Research Steven Emmerson 2012-05-18
ldap 389 tcp Lightweight Directory Access Protocol Tim Howes Tim Howes
ldap 389 udp Lightweight Directory Access Protocol Tim Howes Tim Howes
uis 390 tcp UIS Ed Barron Ed Barron
uis 390 udp UIS Ed Barron Ed Barron
synotics-relay 391 tcp SynOptics SNMP Relay Port
synotics-relay 391 udp SynOptics SNMP Relay Port
synotics-broker 392 tcp SynOptics Port Broker Port Illan Raab Illan Raab
synotics-broker 392 udp SynOptics Port Broker Port Illan Raab Illan Raab
meta5 393 tcp Meta5 Jim Kanzler Jim Kanzler
meta5 393 udp Meta5 Jim Kanzler Jim Kanzler
embl-ndt 394 tcp EMBL Nucleic Data Transfer Peter Gad Peter Gad
embl-ndt 394 udp EMBL Nucleic Data Transfer Peter Gad Peter Gad
netcp 395 tcp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
netcp 395 udp NetScout Control Protocol Ashwani Singhal Ashwani Singhal 2010-04-07
netware-ip 396 tcp Novell Netware over IP
netware-ip 396 udp Novell Netware over IP
mptn 397 tcp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
mptn 397 udp Multi Protocol Trans. Net. Soumitra Sarkar Soumitra Sarkar
kryptolan 398 tcp Kryptolan Peter de Laval Peter de Laval
kryptolan 398 udp Kryptolan Peter de Laval Peter de Laval
iso-tsap-c2 399 tcp ISO Transport Class 2 Non-Control over TCP Yanick Pouffary Yanick Pouffary
iso-tsap-c2 399 udp ISO Transport Class 2 Non-Control over UDP Yanick Pouffary Yanick Pouffary
decap 403 tcp decap
decap 403 udp decap
smsp 413 tcp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
smsp 413 udp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
ariel3 422 tcp Ariel 3 Joel Karafin Joel Karafin
ariel3 422 udp Ariel 3 Joel Karafin Joel Karafin
opc-job-start 423 tcp IBM Operations Planning and Control Start
opc-job-start 423 udp IBM Operations Planning and Control Start
utmpsd 430 tcp UTMPSD
utmpsd 430 udp UTMPSD
utmpcd 431 tcp UTMPCD
utmpcd 431 udp UTMPCD
iasd 432 tcp IASD Nir Baroz Nir Baroz
iasd 432 udp IASD Nir Baroz Nir Baroz
nnsp 433 tcp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
nnsp 433 udp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
mobileip-agent 434 tcp MobileIP-Agent
mobileip-agent 434 udp MobileIP-Agent
mobilip-mn 435 tcp MobilIP-MN Kannan Alagappan Kannan Alagappan
mobilip-mn 435 udp MobilIP-MN Kannan Alagappan Kannan Alagappan
dna-cml 436 tcp DNA-CML Dan Flowers Dan Flowers
dna-cml 436 udp DNA-CML Dan Flowers Dan Flowers
comscm 437 tcp comscm Jim Teague Jim Teague
comscm 437 udp comscm Jim Teague Jim Teague
dsfgw 438 tcp dsfgw Andy McKeen Andy McKeen
dsfgw 438 udp dsfgw Andy McKeen Andy McKeen

Contact Information

Name Organization Contact URI Last Updated
Adrien de Croy adrien&qbik.com
Anastasios Kotsikonas tasos&cs.bu.edu
Andreas Terzis terzis&cs.ucla.edu
Andy McKeen mckeen&osf.org
Ashwani Singhal Ashwani.Singhal&netscout.com 2010-04-07
Chris Ranch cranch&novell.com
Dan Flowers flowers&smaug.lkg.dec.com
Dave LeBlang leglang&atria.com
David Hornsby djh&munnari.oz.au
Ed Barron
Frank Blakely frankb&hpptc16.rose.hp.com
Frank Quick fquick&qualcomm.com
Fred Cohen fc&all.net
Heinz Wrobel hwrobel&gmx.de
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Illan Raab iraab&synoptics.com
Jim Kanzler jim.kanzler&meta5.com
Jim Teague teague&zso.dec.com
Joel Karafin jkarafin&infotrieve.com
Kannan Alagappan kannan&sejour.lkg.dec.com
Keith Boyce
Lisa Tomita
Murthy Srinivas murthy&novell.com
Nir Baroz nbaroz&encore.com
Ole Hellevik oleh&interlinq.com
Peter Gad peter&bmc.uu.se
Peter de Laval pdl&sectra.se
Philip Budne budne&auroratech.com
Randall Gellens rg+ietf&coretechnologyconsulting.com 2024-07-29
Reinhard Doelz doelz&comp.bioz.unibas.ch
Robert Watson robert&cyrus.watson.org
Soumitra Sarkar sarkar&vnet.ibm.com
Steve Laitinen laitinen&brutus.aa.ab.com
Steven Emmerson The University Corporation for Atmospheric Research support-ldm&unidata.ucar.edu 2012-05-18
Tim Howes Tim.Howes&terminator.cc.umich.edu
Tomoo Fujita tf&arc.bs1.fc.nec.co.jp
The University Corporation for Atmospheric Research support-ldm&unidata.ucar.edu 2012-05-18
Yanick Pouffary pouffary&taec.enet.dec.com