Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ccu-comm-3 4055 tcp CosmoCall Universe Communications Port 3 Steve Dellutri Steve Dellutri 2006-07
ccu-comm-3 4055 udp CosmoCall Universe Communications Port 3 Steve Dellutri Steve Dellutri 2006-07
ice-router 4063 tcp Ice Firewall Traversal Service (TCP)
ice-router 4063 udp Ice Firewall Traversal Service (TCP)
iRAPP 4073 tcp Interactive Remote Application Pairing Protocol Volodymyr_Bykov Volodymyr_Bykov 2007-08-20 2016-11-23
iRAPP 4073 udp Interactive Remote Application Pairing Protocol Volodymyr_Bykov Volodymyr_Bykov 2007-08-20 2016-11-23
lorica-out-sec 4083 tcp Lorica outside facing (SSL) Johannes Skov Frandsen Johannes Skov Frandsen 2008-02-28
lorica-out-sec 4083 udp Lorica outside facing (SSL) Johannes Skov Frandsen Johannes Skov Frandsen 2008-02-28
pvxpluscs 4093 tcp Pvx Plus CS Host Michael King Michael King 2006-07
pvxpluscs 4093 udp Pvx Plus CS Host Michael King Michael King 2006-07
brlp-2 4103 tcp Braille protocol
brlp-2 4103 udp Braille protocol
brlp-3 4104 tcp Braille protocol Sébastien Hinderer Sébastien Hinderer 2006-03
brlp-3 4104 udp Braille protocol Sébastien Hinderer Sébastien Hinderer 2006-03
aipn-reg 4113 tcp AIPN LS Registration Qiang Zhang Qiang Zhang 2006-10
aipn-reg 4113 udp AIPN LS Registration Qiang Zhang Qiang Zhang 2006-10
z-wave 4123 tcp Z-Wave Protocol Sigma Designs, Inc. Anders Brandt; Mary Miller 2007-02 2012-11-08
z-wave 4123 udp Z-Wave Protocol Sigma Designs, Inc. Anders Brandt; Mary Miller 2007-02 2012-11-08
fronet 4130 tcp FRONET message protocol Christer Nygren Christer Nygren 2007-08-07
fronet 4130 udp FRONET message protocol Christer Nygren Christer Nygren 2007-08-07
stars 4131 tcp Global Maintech Stars Harry Goldschmitt Harry Goldschmitt 2007-06
stars 4131 udp Global Maintech Stars Harry Goldschmitt Harry Goldschmitt 2007-06
nuts-dem 4132 tcp NUTS Daemon

IANA assigned this well-formed service name as a replacement for "nuts_dem".
nuts_dem 4132 tcp NUTS Daemon This entry is an alias to "nuts-dem". This entry is now historic, not usable for use with many common service discovery mechanisms.
nuts-dem 4132 udp NUTS Daemon

IANA assigned this well-formed service name as a replacement for "nuts_dem".
nuts_dem 4132 udp NUTS Daemon This entry is an alias to "nuts-dem". This entry is now historic, not usable for use with many common service discovery mechanisms.
nuts-bootp 4133 tcp NUTS Bootp Server

IANA assigned this well-formed service name as a replacement for "nuts_bootp".
Martin Freiss Martin Freiss
nuts_bootp 4133 tcp NUTS Bootp Server Martin Freiss Martin Freiss This entry is an alias to "nuts-bootp". This entry is now historic, not usable for use with many common service discovery mechanisms.
nuts-bootp 4133 udp NUTS Bootp Server

IANA assigned this well-formed service name as a replacement for "nuts_bootp".
Martin Freiss Martin Freiss
nuts_bootp 4133 udp NUTS Bootp Server Martin Freiss Martin Freiss This entry is an alias to "nuts-bootp". This entry is now historic, not usable for use with many common service discovery mechanisms.
nifty-hmi 4134 tcp NIFTY-Serve HMI protocol Ryuichi Suzuki Ryuichi Suzuki
nifty-hmi 4134 udp NIFTY-Serve HMI protocol Ryuichi Suzuki Ryuichi Suzuki
cl-db-attach 4135 tcp Classic Line Database Server Attach
cl-db-attach 4135 udp Classic Line Database Server Attach
cl-db-request 4136 tcp Classic Line Database Server Request
cl-db-request 4136 udp Classic Line Database Server Request
cl-db-remote 4137 tcp Classic Line Database Server Remote Arno Kirmeir Arno Kirmeir 2007-01
cl-db-remote 4137 udp Classic Line Database Server Remote Arno Kirmeir Arno Kirmeir 2007-01
nettest 4138 tcp nettest David Borman David Borman 2003-03
nettest 4138 udp nettest David Borman David Borman 2003-03
thrtx 4139 tcp Imperfect Networks Server Dinkar Chivaluri Dinkar Chivaluri 2006-02
thrtx 4139 udp Imperfect Networks Server Dinkar Chivaluri Dinkar Chivaluri 2006-02
cedros-fds 4140 tcp Cedros Fraud Detection System

IANA assigned this well-formed service name as a replacement for "cedros_fds".
Markus Michels Markus Michels 2006-10
cedros_fds 4140 tcp Cedros Fraud Detection System Markus Michels Markus Michels 2006-10 This entry is an alias to "cedros-fds". This entry is now historic, not usable for use with many common service discovery mechanisms.
cedros-fds 4140 udp Cedros Fraud Detection System

IANA assigned this well-formed service name as a replacement for "cedros_fds".
Markus Michels Markus Michels 2006-10
cedros_fds 4140 udp Cedros Fraud Detection System Markus Michels Markus Michels 2006-10 This entry is an alias to "cedros-fds". This entry is now historic, not usable for use with many common service discovery mechanisms.
oidsr 4143 tcp Document Replication Norman Brie Norman Brie
oidsr 4143 udp Document Replication Norman Brie Norman Brie
mbl-battd 4153 tcp MBL Remote Battery Monitoring Claudio Procida Claudio Procida 2007-05
mbl-battd 4153 udp MBL Remote Battery Monitoring Claudio Procida Claudio Procida 2007-05
silverpeakpeer 4163 tcp Silver Peak Peer Protocol Damon Ennis Damon Ennis 2007-03
silverpeakpeer 4163 udp Silver Peak Peer Protocol Damon Ennis Damon Ennis 2007-03
4173 tcp Reserved
mma-discovery 4173 udp MMA Device Discovery MIDI Manufacturers Assoc Inc Tom White 2011-11-14
cyborgnet 4183 tcp CyborgNet communications protocol Gareth Nelson Gareth Nelson 2015-11-13
cyborgnet 4183 udp CyborgNet communications protocol Gareth Nelson Gareth Nelson 2015-11-13
pvxplusio 4193 tcp PxPlus remote file srvr Mike King Mike King 2009-11-09
4193 udp Reserved
corelccam 4300 tcp Corel CCam Jason Aiken Jason Aiken
corelccam 4300 udp Corel CCam Jason Aiken Jason Aiken
d-data 4301 tcp Diagnostic Data
d-data 4301 udp Diagnostic Data
d-data-control 4302 tcp Diagnostic Data Control Jon March Jon March 2006-09
d-data-control 4302 udp Diagnostic Data Control Jon March Jon March 2006-09
srcp 4303 tcp Simple Railroad Command Protocol Matthias Trute Matthias Trute 2007-01
srcp 4303 udp Simple Railroad Command Protocol Matthias Trute Matthias Trute 2007-01
owserver 4304 tcp One-Wire Filesystem Server Paul Alfille Paul Alfille 2007-01 Defined TXT keys: txtvers
owserver 4304 udp One-Wire Filesystem Server Paul Alfille Paul Alfille 2007-01 Defined TXT keys: txtvers
batman 4305 tcp better approach to mobile ad-hoc networking Simon Wunderlich Simon Wunderlich 2007-08-30
batman 4305 udp better approach to mobile ad-hoc networking Simon Wunderlich Simon Wunderlich 2007-08-30
pinghgl 4306 tcp Hellgate London David Berk David Berk 2007-08-30
pinghgl 4306 udp Hellgate London David Berk David Berk 2007-08-30
trueconf 4307 tcp TrueConf Videoconference Service Dmitry Odintsov Lev Yakupov 2007-10-22 2017-05-12
trueconf 4307 udp TrueConf Videoconference Service Dmitry Odintsov Lev Yakupov 2007-10-22 2017-05-12
compx-lockview 4308 tcp CompX-LockView John Payson John Payson 2007-10-22
compx-lockview 4308 udp CompX-LockView John Payson John Payson 2007-10-22
dserver 4309 tcp Exsequi Appliance Discovery Angelo Masci Angelo Masci 2007-01
dserver 4309 udp Exsequi Appliance Discovery Angelo Masci Angelo Masci 2007-01
mirrtex 4310 tcp Mir-RT exchange service Sylvain Robert Sylvain Robert 2008-02-14
mirrtex 4310 udp Mir-RT exchange service Sylvain Robert Sylvain Robert 2008-02-14
p6ssmc 4311 tcp P6R Secure Server Management Console Jim Susoy Jim Susoy 2010-01-21
4311 udp Reserved
pscl-mgt 4312 tcp Parascale Membership Manager John Muth John Muth 2010-01-21
4312 udp Reserved
perrla 4313 tcp PERRLA User Services Cliff Batson Cliff Batson 2010-01-21
4313 udp Reserved
choiceview-agt 4314 tcp ChoiceView Agent Radish Systems Richard A. Davis 2013-03-28
4314 udp Reserved
4315 Unassigned Unauthorized Use Known on port 4315
choiceview-clt 4316 tcp ChoiceView Client Radish Systems Richard A. Davis 2013-03-28
4316 udp Reserved
opentelemetry 4317 tcp OpenTelemetry Protocol OpenTelemetry Morgan McLean 2020-12-09
4317 udp Reserved
4318 Unassigned
skytale 4319 tcp Sentyron SkyTale encrypted communication Sentyron B.V. Mark Revier 2022-01-20 2025-10-30
skytale 4319 udp Sentyron SkyTale encrypted communication Sentyron B.V. Mark Revier 2022-01-20 2025-10-30
fdt-rcatp 4320 tcp FDT Remote Categorization Protocol Russell P. Holsclaw Russell P. Holsclaw 2006-03
fdt-rcatp 4320 udp FDT Remote Categorization Protocol Russell P. Holsclaw Russell P. Holsclaw 2006-03
rwhois 4321 tcp Remote Who Is Mark Kosters Mark Kosters RFC 2167
rwhois 4321 udp Remote Who Is Mark Kosters Mark Kosters RFC 2167
trim-event 4322 tcp TRIM Event Service

Contact Information

Name Organization Contact URI Last Updated
Anders Brandt Sigma Designs, Inc. Anders_Brandt&sigmadesigns.com 2012-11-08
Angelo Masci angelomasci&yahoo.co.uk 2007-01
Arno Kirmeir Arno.kirmeir&sage.de 2007-01
Christer Nygren christer.nygren&fro.se 2007-08-07
Claudio Procida claudio&emeraldion.it 2007-05
Cliff Batson cliff&perrla.com 2010-01-21
Damon Ennis damon&silver-peak.com 2007-03
David Berk dberk&ping-0.com 2007-08-30
David Borman david.borman&quantum.com 2015-02-05
Dinkar Chivaluri dchivaluri&imperfectnetworks.com 2006-02
Dmitry Odintsov dimodin&trueconf.com 2017-05-12
Gareth Nelson gareth&garethnelson.com 2015-11-13
Harry Goldschmitt harry&hgac.com 2007-06
Jason Aiken jasona&corelcomputer.com
Jim Susoy jim.susoy&p6r.com 2010-01-21
Johannes Skov Frandsen joe&42tools.com 2008-02-28
John Muth muth&parascale.com 2010-01-21
John Payson john&circad.com 2007-10-22
Jon March jon.march&paget-analyst-services.co.uk 2006-09
Lev Yakupov lyakupov&trueconf.com 2017-05-12
Mark Kosters markk&internic.net
Mark Revier Sentyron B.V. iana&sentyron.com 2025-10-30
Markus Michels markus.michels&cedros.com 2006-10
Martin Freiss freiss.pad@sni.
Mary Miller Sigma Designs, Inc. Mary_Miller&sigmadesigns.com 2012-11-08
Matthias Trute mtrute&web.de 2007-01
Michael King mike.king&pvxplus.com 2006-07
MIDI Manufacturers Assoc Inc info&midi.org 2011-11-14
Mike King mike.king&pvxplus.com 2009-11-09
Morgan McLean OpenTelemetry morgan_mclean&hotmail.com 2020-12-09
Norman Brie norm_brie&sns.ca
OpenTelemetry cncf-opentelemetry-governance&lists.cncf.io 2020-12-09
Paul Alfille paul.alfille&gmail.com 2007-01
Qiang Zhang iad&iwncomm.com 2006-10
Radish Systems rad&radishsystems.com 2013-03-28
Richard A. Davis Radish Systems rad&radishsystems.com 2013-03-28
Russell P. Holsclaw Fast Data Technology Inc. rholsclaw&fastdatatech.com 2006-03
Ryuichi Suzuki SCI00376&niftyserve.or.jp
Sébastien Hinderer Sebastien.Hinderer&ens-lyon.org 2006-03
Sentyron B.V. iana&sentyron.com 2025-10-30
Sigma Designs, Inc. pr&sdesigns.com 2012-11-08
Simon Wunderlich siwu&hrz.tu-chemnitz.de 2007-08-30
Steve Dellutri sdellutri&cosmocom.com 2006-07
Sylvain Robert sylvain.robert&datadis.com 2008-02-14
Tom White MIDI Manufacturers Assoc Inc info&midi.org 2011-11-14
Volodymyr_Bykov vbickov&gmail.com 2016-11-23