Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
trim-event 4322 tcp TRIM Event Service
trim-event 4322 udp TRIM Event Service
trim-ice 4323 tcp TRIM ICE Service Siva Poobalasingam Siva Poobalasingam 2007-02
trim-ice 4323 udp TRIM ICE Service Siva Poobalasingam Siva Poobalasingam 2007-02
4324 Reserved 2015-05-12 This entry is being removed on 2015-05-12.
geognosisadmin 4325 tcp Cadcorp GeognoSIS Administrator Computer Aided Development Corporation Ltd (Cadcorp) Martin Daly 2022-08-12
geognosisman 4325 udp Cadcorp GeognoSIS Administrator Computer Aided Development Corporation Ltd (Cadcorp) Martin Daly 2022-08-12
geognosis 4326 tcp Cadcorp GeognoSIS Martin Daly Martin Daly 2006-11 2022-08-12
geognosis 4326 udp Cadcorp GeognoSIS Martin Daly Martin Daly 2006-11 2022-08-12
jaxer-web 4327 tcp Jaxer Web Protocol Uri Sarid Uri Sarid 2008-01-07
jaxer-web 4327 udp Jaxer Web Protocol Uri Sarid Uri Sarid 2008-01-07
jaxer-manager 4328 tcp Jaxer Manager Command Protocol Uri Sarid Uri Sarid 2008-01-22
jaxer-manager 4328 udp Jaxer Manager Command Protocol Uri Sarid Uri Sarid 2008-01-22
publiqare-sync 4329 tcp PubliQare Distributed Environment Synchronisation Engine Tom Maaswinkel Tom Maaswinkel 2011-02-07
4329 udp Reserved
dey-sapi 4330 tcp DEY Storage Administration REST API DEY Storage Systems, Inc. Garrett D'Amore 2013-03-01
4330 udp Reserved
ktickets-rest 4331 tcp ktickets REST API for event management and ticketing systems (embedded POS devices) KeyTicket Solutions MANG Ioan-Alexandru 2014-04-04
4331 udp Reserved
getty-focus 4332 tcp Getty Images FOCUS service Matthew Margolis Bryan Ramirez 2019-04-18
4332 udp Reserved
ahsp 4333 tcp ArrowHead Service Protocol (AHSP) QuantuMatriX Technologies Matthew Schultz 2014-04-10
ahsp 4333 udp ArrowHead Service Protocol (AHSP) QuantuMatriX Technologies Matthew Schultz 2014-04-10
ahsp 4333 sctp ArrowHead Service Protocol (AHSP) QuantuMatriX Technologies Matthew Schultz 2014-04-10
netconf-ch-ssh 4334 tcp NETCONF Call Home (SSH) IESG IETF Chair 2016-01-12 RFC 8071
4334 udp Reserved
netconf-ch-tls 4335 tcp NETCONF Call Home (TLS) IESG IETF Chair 2016-01-12 RFC 8071
4335 udp Reserved
restconf-ch-tls 4336 tcp RESTCONF Call Home (TLS) IESG IETF Chair 2016-01-12 RFC 8071
4336 udp Reserved
4337-4339 Unassigned
gaia 4340 tcp Gaia Connector Protocol Philippe Detournay Philippe Detournay 2007-11-12
gaia 4340 udp Gaia Connector Protocol Philippe Detournay Philippe Detournay 2007-11-12
4341 tcp Reserved 2007-11-12 2018-11-30
lisp-data 4341 udp LISP Data Packets IESG IETF Chair 2007-11-12 2021-02-17 RFC 9300
4342 tcp Reserved 2018-11-30
lisp-control 4342 udp LISP Control Packets IETF IESG 2007-05 2021-02-25 RFC 9301
unicall 4343 tcp UNICALL James Powell James Powell
unicall 4343 udp UNICALL James Powell James Powell
vinainstall 4344 tcp VinaInstall Jay Slupesky Jay Slupesky
vinainstall 4344 udp VinaInstall Jay Slupesky Jay Slupesky
m4-network-as 4345 tcp Macro 4 Network AS Paul Wren Paul Wren
m4-network-as 4345 udp Macro 4 Network AS Paul Wren Paul Wren
elanlm 4346 tcp ELAN LM Paul Ballew Paul Ballew
elanlm 4346 udp ELAN LM Paul Ballew Paul Ballew
lansurveyor 4347 tcp LAN Surveyor Michael Swan Michael Swan
lansurveyor 4347 udp LAN Surveyor Michael Swan Michael Swan
itose 4348 tcp ITOSE Michael Haeuptle Michael Haeuptle
itose 4348 udp ITOSE Michael Haeuptle Michael Haeuptle
fsportmap 4349 tcp File System Port Map Ron Minnich Ron Minnich
fsportmap 4349 udp File System Port Map Ron Minnich Ron Minnich
net-device 4350 tcp Net Device Glenn Peterson Glenn Peterson
net-device 4350 udp Net Device Glenn Peterson Glenn Peterson
plcy-net-svcs 4351 tcp PLCY Net Services J.J. Ekstrom J.J. Ekstrom
plcy-net-svcs 4351 udp PLCY Net Services J.J. Ekstrom J.J. Ekstrom
pjlink 4352 tcp Projector Link Mitsuo Kodama Mitsuo Kodama 2005-06
pjlink 4352 udp Projector Link Mitsuo Kodama Mitsuo Kodama 2005-06
f5-iquery 4353 tcp F5 iQuery Tom Kee Tom Kee
f5-iquery 4353 udp F5 iQuery Tom Kee Tom Kee
qsnet-trans 4354 tcp QSNet Transmitter
qsnet-trans 4354 udp QSNet Transmitter
qsnet-workst 4355 tcp QSNet Workstation
qsnet-workst 4355 udp QSNet Workstation
qsnet-assist 4356 tcp QSNet Assistant
qsnet-assist 4356 udp QSNet Assistant
qsnet-cond 4357 tcp QSNet Conductor
qsnet-cond 4357 udp QSNet Conductor
qsnet-nucl 4358 tcp QSNet Nucleus Neer Kleinman Neer Kleinman
qsnet-nucl 4358 udp QSNet Nucleus Neer Kleinman Neer Kleinman
omabcastltkm 4359 tcp OMA BCAST Long-Term Key Messages Frank Hartung Frank Hartung 2007-09-07
omabcastltkm 4359 udp OMA BCAST Long-Term Key Messages Frank Hartung Frank Hartung 2007-09-07
matrix-vnet 4360 tcp Matrix VNet Communication Protocol

IANA assigned this well-formed service name as a replacement for "matrix_vnet".
Rehan Mahmood Rehan Mahmood 2009-03-18
matrix_vnet 4360 tcp Matrix VNet Communication Protocol Rehan Mahmood Rehan Mahmood 2009-03-18 This entry is an alias to "matrix-vnet". This entry is now historic, not usable for use with many common service discovery mechanisms.
4360 udp Reserved
4361 tcp Reserved
nacnl 4361 udp NavCom Discovery and Control Port Yilei Jia Yilei Jia 2009-03-18
4362 tcp Reserved
afore-vdp-disc 4362 udp AFORE vNode Discovery protocol Michael Richardson Michael Richardson 2011-02-08
4363-4365 Unassigned
shadowstream 4366 udp ShadowStream System StorageCraft Technology Corporation David McConkie 2014-12-17
4366 tcp Reserved
4367 Unassigned
wxbrief 4368 tcp WeatherBrief Direct Kim Alan Waggoner Kim Alan Waggoner 2006-11
wxbrief 4368 udp WeatherBrief Direct Kim Alan Waggoner Kim Alan Waggoner 2006-11
epmd 4369 tcp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
epmd 4369 udp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
elpro-tunnel 4370 tcp ELPRO V2 Protocol Tunnel

IANA assigned this well-formed service name as a replacement for "elpro_tunnel".
Harry Courtice Harry Courtice 2008-04-14
elpro_tunnel 4370 tcp ELPRO V2 Protocol Tunnel Harry Courtice Harry Courtice 2008-04-14 This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
elpro-tunnel 4370 udp ELPRO V2 Protocol Tunnel

IANA assigned this well-formed service name as a replacement for "elpro_tunnel".
Harry Courtice Harry Courtice 2008-04-14
elpro_tunnel 4370 udp ELPRO V2 Protocol Tunnel Harry Courtice Harry Courtice 2008-04-14 This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
l2c-control 4371 tcp LAN2CAN Control Phil Tolson Phil Tolson 2008-07-07 Modified: 21 January 2010
l2c-disc 4371 udp LAN2CAN Discovery Phil Tolson Phil Tolson 2010-01-21
l2c-data 4372 tcp LAN2CAN Data Phil Tolson Phil Tolson 2008-07-07 Modified: 21 January 2010
l2c-data 4372 udp LAN2CAN Data Phil Tolson Phil Tolson 2010-01-21
remctl 4373 tcp Remote Authenticated Command Service Russ Allbery Russ Allbery 2007-08-30
remctl 4373 udp Remote Authenticated Command Service Russ Allbery Russ Allbery 2007-08-30
psi-ptt 4374 tcp PSI Push-to-Talk Protocol Frank Bredenbröcker Frank Bredenbröcker 2008-07-17
4374 udp Reserved
tolteces 4375 tcp Toltec EasyShare Joon Radley Joon Radley 2008-10-21
tolteces 4375 udp Toltec EasyShare Joon Radley Joon Radley 2008-10-21
bip 4376 tcp BioAPI Interworking Jean-Paul Lemaire Jean-Paul Lemaire 2007-07-05

Contact Information

Name Organization Contact URI Last Updated
Bryan Ramirez bryan.ramirez&gettyimages.com 2019-04-18
Computer Aided Development Corporation Ltd (Cadcorp) martin.daly&cadcorp.com 2022-08-12
David McConkie StorageCraft Technology Corporation dave.mcconkie&storagecraft.com 2014-12-17
DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
Erlang/OTP support epmd&erix.ericsson.se 2004-12
Frank Bredenbröcker fbredenbroecker&psi.de 2008-07-17
Frank Hartung Frank.Hartung&ericsson.com 2007-09-07
Garrett D'Amore DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
Glenn Peterson glennp&microsoft.com
Harry Courtice harry.courtice&elprotech.com 2008-04-14
IESG iesg&ietf.org
IETF iesg&ietf.org
IETF Chair IETF chair&ietf.org
J.J. Ekstrom
James Powell james&enghp.unidata.comp
Jay Slupesky js&vina-tech.com
Jean-Paul Lemaire jean-paul.lemaire&univ-paris-diderot.fr 2007-07-05
Joon Radley joon&toltec.co.za
support&toltec.co.za
2008-10-21
KeyTicket Solutions amang&keyticket.eu 2014-04-04
Kim Alan Waggoner kimw&weatherbank.com 2006-11
MANG Ioan-Alexandru KeyTicket Solutions amang&keyticket.eu 2014-04-04
Martin Daly martin.daly&cadcorp.com 2022-08-12
Matthew Margolis matthew.margolis&gettyimages.com 2019-04-18
Matthew Schultz QuantuMatriX Technologies matt&qmxtech.com 2014-04-10
Michael Haeuptle Michael_Haeuptle&hp.com
Michael Richardson mcr&sandelman.ca 2011-02-08
Michael Swan swan&neon.com 2004-04
Mitsuo Kodama kodama&jbmia.or.jp 2005-06
Neer Kleinman neer&qsr.co.il
Paul Ballew ballew&projtech.com
Paul Wren Paul.Wren&macro4.com
Phil Tolson philtolson&eaton.com 2010-01-21
Philippe Detournay philippe.detournay&acrosoft.be 2007-11-12
QuantuMatriX Technologies admin&qmxtech.com 2014-04-10
Rehan Mahmood rehan&matrixmultimedia.co.uk 2009-03-18
Ron Minnich rminnich&sarnoff.com
Russ Allbery rra&stanford.edu 2007-08-30
Siva Poobalasingam Siva.Poobalasingam&towersoft.com.au 2007-02
StorageCraft Technology Corporation dave.mcconkie&storagecraft.com 2014-12-17
Tom Kee t.kee&f5.com
Tom Maaswinkel tom.maaswinkel&publiqare.nl 2011-02-07
Uri Sarid uri&aptana.com 2008-01-22
Yilei Jia yjia&navcomtech.com 2009-03-18