Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| bip | 4376 | tcp | BioAPI Interworking | Jean-Paul Lemaire | Jean-Paul Lemaire | 2007-07-05 | |||||
| bip | 4376 | udp | BioAPI Interworking | Jean-Paul Lemaire | Jean-Paul Lemaire | 2007-07-05 | |||||
| cp-spxsvr | 4377 | tcp | Cambridge Pixel SPx Server | ||||||||
| cp-spxsvr | 4377 | udp | Cambridge Pixel SPx Server | ||||||||
| cp-spxdpy | 4378 | tcp | Cambridge Pixel SPx Display | Richard Warren | Richard Warren | 2007-07-05 | |||||
| cp-spxdpy | 4378 | udp | Cambridge Pixel SPx Display | Richard Warren | Richard Warren | 2007-07-05 | |||||
| ctdb | 4379 | tcp | CTDB | Ronnie Sahlberg | Ronnie Sahlberg | 2007-07-05 | |||||
| ctdb | 4379 | udp | CTDB | Ronnie Sahlberg | Ronnie Sahlberg | 2007-07-05 | |||||
| 4380-4388 | Unassigned | ||||||||||
| xandros-cms | 4389 | tcp | Xandros Community Management Service | Stephen M. Webb | Stephen M. Webb | 2007-05 | |||||
| xandros-cms | 4389 | udp | Xandros Community Management Service | Stephen M. Webb | Stephen M. Webb | 2007-05 | |||||
| wiegand | 4390 | tcp | Physical Access Control | Scott Guthery | Scott Guthery | 2008-08-25 | |||||
| wiegand | 4390 | udp | Physical Access Control | Scott Guthery | Scott Guthery | 2008-08-25 | |||||
| apwi-imserver | 4391 | tcp | American Printware IMServer Protocol | Lech Lakomy | Lech Lakomy | 2009-02-12 | |||||
| 4391 | udp | Reserved | |||||||||
| apwi-rxserver | 4392 | tcp | American Printware RXServer Protocol | Lech Lakomy | Lech Lakomy | 2009-02-12 | |||||
| 4392 | udp | Reserved | |||||||||
| apwi-rxspooler | 4393 | tcp | American Printware RXSpooler Protocol | Lech Lakomy | Lech Lakomy | 2009-02-12 | |||||
| 4393 | udp | Reserved | |||||||||
| 4394 | tcp | Reserved | |||||||||
| apwi-disc | 4394 | udp | American Printware Discovery | Lech Lakomy | Lech Lakomy | 2009-02-12 | |||||
| omnivisionesx | 4395 | tcp | OmniVision communication for Virtual environments | Vacquier Serge | Vacquier Serge | 2009-02-12 | |||||
| omnivisionesx | 4395 | udp | OmniVision communication for Virtual environments | Vacquier Serge | Vacquier Serge | 2009-02-12 | |||||
| fly | 4396 | tcp | Fly Object Space | Nigel Warren | Nigel Warren | 2009-02-12 | |||||
| 4396 | udp | Reserved | |||||||||
| 4397-4399 | Unassigned | ||||||||||
| ds-user | 4403 | tcp | ASIGRA Televaulting DS-Client Monitoring/Management | ||||||||
| ds-user | 4403 | udp | ASIGRA Televaulting DS-Client Monitoring/Management | ||||||||
| vision-mon | 4413 | tcp | FORTÉ Vision Monitoring platform | FORTÉ | Rob Duram | 2015-09-18 | 2025-11-14 | ||||
| vision-mon-disc | 4413 | udp | FORTÉ Vision Monitoring platform | FORTÉ | Rob Duram | 2015-09-18 | 2025-11-14 | ||||
| thingkit | 4423 | tcp | thingkit secure mesh | thingkit, inc. | Chris Bell | 2016-06-27 | |||||
| 4423 | udp | Reserved | |||||||||
| rsqlserver | 4430 | tcp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| rsqlserver | 4430 | udp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| wspipe | 4431 | tcp | adWISE Pipe | Heikki Ellilä | Heikki Ellilä | 2009-06-18 | |||||
| 4431 | udp | Reserved | |||||||||
| l-acoustics | 4432 | tcp | L-ACOUSTICS management | L-ACOUSTICS | Christophe Pignon | 2012-08-13 | |||||
| l-acoustics | 4432 | udp | L-ACOUSTICS management | L-ACOUSTICS | Christophe Pignon | 2012-08-13 | |||||
| vop | 4433 | tcp | Versile Object Protocol | Versile AS | Tore Skaug | 2012-02-01 | |||||
| 4433 | udp | Reserved | |||||||||
| 4434-4440 | Unassigned | ||||||||||
| pharos | 4443 | tcp | Pharos | TeleConsult GmbH, 76275 Ettlingen, Germany | TeleConsult GmbH, 76275 Ettlingen, Germany | Known Unauthorized Use on port 4443 | |||||
| pharos | 4443 | udp | Pharos | TeleConsult GmbH, 76275 Ettlingen, Germany | TeleConsult GmbH, 76275 Ettlingen, Germany | Known Unauthorized Use on port 4443 | |||||
| nssalertmgr | 4453 | tcp | NSS Alert Manager | ||||||||
| nssalertmgr | 4453 | udp | NSS Alert Manager | ||||||||
| 4481-4483 | Unassigned | ||||||||||
| ipsec-nat-t | 4500 | tcp | IPsec NAT-Traversal | 2022-09-15 | RFC 9329 | ||||||
| ipsec-nat-t | 4500 | udp | IPsec NAT-Traversal | 2017-07-07 | RFC 3948; RFC 7296 | ||||||
| a25-fap-fgw | 4502 | sctp | A25 (FAP-FGW) | 3GPP2 | Zhiming Li | 2012-01-11 | |||||
| 4503 | tcp | Reserved | |||||||||
| m-bus-oms | 4503 | udp | M-Bus-OMS over UDP | OMS-Group e. V. (Open Metering System Group) | Ahmed Kasttet | 2025-05-19 | |||||
| 4504-4533 | Unassigned | ||||||||||
| 4534 | tcp | Reserved | |||||||||
| armagetronad | 4534 | udp | Armagetron Advanced Game Server | Manuel Moos | Yann Kaiser | 2012-11-02 | |||||
| ehs | 4535 | tcp | Event Heap Server | ||||||||
| ehs | 4535 | udp | Event Heap Server | ||||||||
| ehs-ssl | 4536 | tcp | Event Heap Server SSL | Brad Johanson | Brad Johanson | 2005-08 | |||||
| ehs-ssl | 4536 | udp | Event Heap Server SSL | Brad Johanson | Brad Johanson | 2005-08 | |||||
| wssauthsvc | 4537 | tcp | WSS Security Service | Mark Tirschwell | Mark Tirschwell | 2006-01 | |||||
| wssauthsvc | 4537 | udp | WSS Security Service | Mark Tirschwell | Mark Tirschwell | 2006-01 | |||||
| swx-gate | 4538 | tcp | Software Data Exchange Gateway | Julien VALIENTE | Julien VALIENTE | 2006-05 | |||||
| swx-gate | 4538 | udp | Software Data Exchange Gateway | Julien VALIENTE | Julien VALIENTE | 2006-05 | |||||
| 4539-4544 | Unassigned | ||||||||||
| icshostsvc | 4553 | tcp | ICS host services | Gordan Vosicki | Gordan Vosicki | 2009-09-23 | |||||
| 4553 | udp | Reserved | |||||||||
| rsip | 4555 | tcp | RSIP Port | RFC 3103 | |||||||
| rsip | 4555 | udp | RSIP Port | RFC 3103 | |||||||
| dtn-bundle | 4556 | dccp | DTN Bundle DCCP CL Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 1685351985 | ||||
| amahi-anywhere | 4563 | tcp | Amahi Anywhere | Amahi | Carlos Puchol | 2014-02-27 | |||||
| 4563 | udp | Reserved | |||||||||
| deploymentmap | 4570 | tcp | Service to distribute and update within a site deployment information for Oracle Communications Suite | Oracle Corp. | Dan Newman | 2013-09-20 | |||||
| cardifftec-back | 4573 | tcp | A port for communication between a server and client for a custom backup system | CardiffTec | Benjamin Misell | 2016-05-19 | |||||
| 4573 | udp | Reserved | |||||||||
| l3t-at-an | 4591 | tcp | HRPD L3T (AT-AN) | Avi Lior | Avi Lior | 2009-02-27 | |||||
| l3t-at-an | 4591 | udp | HRPD L3T (AT-AN) | Avi Lior | Avi Lior | 2009-02-27 | |||||
| ipt-anri-anri | 4593 | tcp | IPT (ANRI-ANRI) | ||||||||
| ipt-anri-anri | 4593 | udp | IPT (ANRI-ANRI) | ||||||||
| menandmice-upg | 4603 | tcp | Men & Mice Upgrade Agent | Eggert Thorlacius | Eggert Thorlacius | 2010-01-27 | |||||
| 4603 | udp | Reserved | |||||||||
| dots-signal | 4646 | tcp | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. | IESG | IETF Chair | 2020-01-16 | 2021-06-14 | RFC 8973; RFC 9132 | |||
| dots-signal | 4646 | udp | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. | IESG | IETF Chair | 2020-01-16 | 2021-06-14 | RFC 8973; RFC 9132 | |||
| noteit | 4663 | tcp | Note It! Message Service | Pedro Alpedrinha | Pedro Alpedrinha | 2006-02 | |||||
| noteit | 4663 | udp | Note It! Message Service | Pedro Alpedrinha | Pedro Alpedrinha | 2006-02 | |||||
| cxws | 4673 | tcp | CXWS Operations | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| cxws | 4673 | udp | CXWS Operations | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| spike | 4683 | tcp | Spike Clipboard Service | Scott Herscher | Scott Herscher | 2005-08 | |||||
| spike | 4683 | udp | Spike Clipboard Service | Scott Herscher | Scott Herscher | 2005-08 | |||||
| 4693-4699 | Unassigned | ||||||||||
| npqes-test | 4703 | tcp | Network Performance Quality Evaluation System Test Service | Zhengli | Zhengli | 2010-06-28 | |||||
| 4703 | udp | Reserved | |||||||||
| trinity-dist | 4711 | tcp | Trinity Trust Network Node Communication | P3KI GmbH | Gregor Jehle | 2017-01-12 | |||||
| trinity-dist | 4711 | udp | Trinity Trust Network Node Communication | P3KI GmbH | Gregor Jehle | 2017-01-12 | |||||
| trinity-dist | 4711 | sctp | Trinity Trust Network Node Communication | P3KI GmbH | Gregor Jehle | 2017-01-12 | |||||
| gearman | 4730 | tcp | Gearman Job Queue System | Eric Day | Eric Day | 2009-01-16 | |||||
| gearman | 4730 | udp | Gearman Job Queue System | Eric Day | Eric Day | 2009-01-16 | |||||
| remcap | 4731 | tcp | Remote Capture Protocol | Marc Donner | Marc Donner | 2009-01-16 | |||||
| 4731 | udp | Reserved | |||||||||
| 4732 | tcp | Reserved | |||||||||
| ohmtrigger | 4732 | udp | OHM server trigger | Franck Lefevre | Franck Lefevre | 2009-11-18 | |||||
| resorcs | 4733 | tcp | RES Orchestration Catalog Services | Bob Janssen | Bob Janssen | 2009-11-18 | |||||
| 4733 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP2 | lizhiming&huawei.com | 2012-01-11 | |
| Ahmed Kasttet | OMS-Group e. V. (Open Metering System Group) | ahmed.kasttet&oms-group.org | 2025-05-19 |
| Amahi | iana&amahi.org | 2014-02-27 | |
| Avi Lior | avi&bridgewatersystems.com | 2009-02-27 | |
| Benjamin Misell | beninjam174&gmail.com | 2016-05-19 | |
| Bob Janssen | b.janssen&ressoftware.com | 2009-11-18 | |
| Brad Johanson | bradj&tidebreak.com | 2005-08 | |
| CardiffTec | beninjam174&gmail.com | 2016-05-19 | |
| Carlos Puchol | Amahi | iana&amahi.org | 2014-02-27 |
| Chris Bell | cb&thingkit.co | 2016-06-27 | |
| Christophe Pignon | L-ACOUSTICS | christophe.pignon&l-acoustics.com | 2012-08-13 |
| Dan Newman | Oracle Corp. | dan.c.newman&oracle.com | 2013-09-20 |
| Eggert Thorlacius | eggi&menandmice.com | 2010-01-27 | |
| Eric Day | eday&oddments.org | 2009-01-16 | |
| FORTÉ | rob.duram&ourforte.com | 2025-10-30 | |
| Franck Lefevre | franck.lefevre&digitalairways.com | 2009-11-18 | |
| Gordan Vosicki | admin&icsa.ch | 2009-09-23 | |
| Gregor Jehle | hadez&p3ki.com | 2017-01-12 | |
| Heikki Ellilä | heikki.ellila&western.fi | 2009-06-18 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jean-Paul Lemaire | jean-paul.lemaire&univ-paris-diderot.fr | 2007-07-05 | |
| Julien VALIENTE | j.valiente&objectif-software.com | 2006-05 | |
| L-ACOUSTICS | christophe.pignon&l-acoustics.com | 2012-08-13 | |
| Lech Lakomy | llakomy&apwi.com | 2009-02-12 | |
| Manuel Moos | z-man&users.sf.net | 2012-11-02 | |
| Marc Donner | mail&poweraudio.de | 2009-01-16 | |
| Marco Bambini | marco&realsoftware.com | 2008-08-28 | |
| Mark Tirschwell | mark.tirschwell&wallstreetsystems.com | 2006-01 | |
| Nigel Warren | info&flyobjectspace.com | 2009-02-12 | |
| OMS-Group e. V. (Open Metering System Group) | office&oms-group.org | 2025-05-19 | |
| Oracle Corp. | dan.c.newman&oracle.com | 2013-09-20 | |
| P3KI GmbH | iana&p3ki.com | 2017-01-12 | |
| Pedro Alpedrinha | pedro.alpedrinha&redevirtual.com | 2006-02 | |
| Phil Abercrombie | phil.abercrombie&appiq.com | 2005-08 | |
| Richard Warren | richard&cambridgepixel.com | 2008-09-17 | |
| Rob Duram | rob.duram&ourforte.com | 2025-10-30 | |
| Ronnie Sahlberg | ronniesahlberg&gmail.com | 2007-07-05 | |
| Scott Guthery | sguthery&hidcorp.com | 2008-08-25 | |
| Scott Herscher | scott&porchdogsoft.com | 2005-08 | |
| Stephen M. Webb | stephenw&xandros.com | 2007-05 | |
| TeleConsult GmbH, 76275 Ettlingen, Germany | teleconsult&t-online.de | ||
| thingkit, inc. | cb&thingkit.co | 2016-06-27 | |
| Tore Skaug | Versile AS | tore.skaug&versile.com | 2012-02-01 |
| Vacquier Serge | vacquier&systar.fr | 2009-02-12 | |
| Versile AS | contact&versile.com | 2012-02-01 | |
| Yann Kaiser | kaiser.yann&gmail.com | 2012-11-02 | |
| Zhengli | std&iwncomm.com | 2010-06-28 | |
| Zhiming Li | 3GPP2 | lizhiming&huawei.com | 2012-01-11 |