Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
4733 udp Reserved
4734-4736 Unassigned
ipdr-sp 4737 tcp IPDR/SP Ken Sarno Ken Sarno 2005-08
ipdr-sp 4737 udp IPDR/SP Ken Sarno Ken Sarno 2005-08
solera-lpn 4738 tcp SoleraTec Locator Mark Armstrong Mark Armstrong 2005-12
solera-lpn 4738 udp SoleraTec Locator Mark Armstrong Mark Armstrong 2005-12
ipfix 4739 tcp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 udp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 sctp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2006-01
openhpid 4743 tcp openhpi HPI service Thomas Kanngieser Thomas Kanngieser 2006-01
openhpid 4743 udp openhpi HPI service Thomas Kanngieser Thomas Kanngieser 2006-01
simon 4753 tcp Simple Invocation of Methods Over Network (SIMON) Alexander Christian Alexander Christian 2012-04-19
simon-disc 4753 udp Simple Invocation of Methods Over Network (SIMON) Discovery Alexander Christian Alexander Christian 2012-04-19
4757-4773 Unassigned
4775-4783 Unassigned
vxlan 4789 udp Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2013-04-19 2014-06-17 RFC 7348
4793 tcp Reserved
uet 4793 udp Ultra Ethernet Transport Ultra Ethernet Consortium Vivek Kashyap 2025-06-16
notateit 4803 tcp Notateit Messaging
notateit-disc 4803 udp Notateit Messaging Discovery Ean Black Ean Black 2009-04-08
4828-4836 Unassigned
varadero-0 4837 tcp Varadero-0
varadero-0 4837 udp Varadero-0
varadero-1 4838 tcp Varadero-1
varadero-1 4838 udp Varadero-1
varadero-2 4839 tcp Varadero-2 Carlos Arteaga Carlos Arteaga
varadero-2 4839 udp Varadero-2 Carlos Arteaga Carlos Arteaga
opcua-tls 4843 tcp OPC UA TCP Protocol over TLS/SSL OPC Foundation Randy Armstrong 2006-09 2017-05-23
opcua-tls 4843 udp OPC UA TCP Protocol over TLS/SSL OPC Foundation Randy Armstrong 2006-09
wmlserver 4883 tcp Meier-Phelps License Server William Phelps William Phelps 2010-03-22
4883 udp Reserved
4890-4893 Unassigned
4903-4911 Unassigned
lutcp 4913 tcp LUTher Control Protocol Markus Loeffler Markus Loeffler 2007-07-03
fmsg 4930 tcp Host-to-host messaging FMSG AI PTY LTD Mark Mennell 2026-10-15
4930 udp Reserved
4931-4935 Unassigned
an-signaling 4936 udp Signal protocol port for autonomic networking Cisco Systems Toerless Eckert 2014-06-06
4936 tcp Reserved
4937 tcp Reserved
atsc-mh-ssc 4937 udp ATSC-M/H Service Signaling Channel Jerry Whitaker Jerry Whitaker 2008-10-27
4938-4939 Unassigned
4943-4948 Unassigned
dbsyncarbiter 4953 tcp Synchronization Arbiter Dave Neudoerffer Dave Neudoerffer 2009-11-18
4953 udp Reserved
4983 Unassigned 2005-12-22
fmpro-internal 5003 tcp FileMaker, Inc. - Proprietary transport Clay Maeckel Clay Maeckel
fmpro-internal 5003 udp FileMaker, Inc. - Proprietary name binding Clay Maeckel Clay Maeckel
avt-profile-1 5004 tcp RTP media data RFC 3551; RFC 4571
avt-profile-1 5004 udp RTP media data RFC 3551
avt-profile-1 5004 dccp RTP media data RFC 3551; RFC 5762
avt-profile-2 5005 tcp RTP control protocol RFC 3551; RFC 4571
avt-profile-2 5005 udp RTP control protocol RFC 3551
avt-profile-2 5005 dccp RTP control protocol RFC 3551; RFC 5762
fmpro-v6 5013 tcp FileMaker, Inc. - Proprietary transport Alex Chen Alex Chen 2007-08-01
fmpro-v6 5013 udp FileMaker, Inc. - Proprietary transport Alex Chen Alex Chen 2007-08-01
htuilsrv 5023 tcp Htuil Server for PLD2 Dennis Reinhardt Dennis Reinhardt
htuilsrv 5023 udp Htuil Server for PLD2 Dennis Reinhardt Dennis Reinhardt
5030 tcp Reserved 2006-12 2022-01-10 Historic usage was surfpass. De-Assigned on 2022-01-10
5030 udp Reserved 2006-12 2022-01-10 Historic usage was surfpass. De-Assigned on 2022-01-10
5031 tcp Reserved
dmp 5031 udp Direct Message Protocol Gjermund Wallenius Gjermund Wallenius 2009-09-30
signacert-agent 5032 tcp SignaCert Enterprise Trust Server Agent Harris, Corporation Daniel R Somerfield 2011-08-05
5032 udp Reserved
jtnetd-server 5033 tcp Janstor Secure Data Janstor Technology Anthony Johnson 2015-06-08
5033 udp Reserved
jtnetd-status 5034 tcp Janstor Status Janstor Technology Anthony Johnson 2015-06-08
5034 udp Reserved
5035-5041 Unassigned
swxadmin 5043 tcp ShopWorX Administration Don W. Fitzpatrick Don W. Fitzpatrick 2005-08
swxadmin 5043 udp ShopWorX Administration Don W. Fitzpatrick Don W. Fitzpatrick 2005-08
rlm 5053 tcp RLM License Server Matt Christiano Matt Christiano 2008-07-28
rlm-disc 5053 udp RLM Discovery Server Reprise Software, Inc. Matt Christiano 2012-11-06
sip 5060 tcp SIP 2014-04-09 RFC 3263
sip 5060 udp SIP 2014-04-09 RFC 3263
sips 5061 tcp SIP-TLS 2014-04-09 RFC 3263
sips 5061 udp SIP-TLS 2014-04-09 RFC 3263
csrpc 5063 tcp centrify secure RPC Paul Moore Paul Moore 2009-10-28
5063 udp Reserved
tag-pm 5073 tcp Advantage Group Port Mgr James Goddard James Goddard 2005-08
tag-pm 5073 udp Advantage Group Port Mgr James Goddard James Goddard 2005-08
qfp 5083 tcp Qpur File Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
qfp 5083 udp Qpur File Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
sentinel-lm 5093 tcp Sentinel LM Derick Snyder Derick Snyder
sentinel-lm 5093 udp Sentinel LM Derick Snyder Derick Snyder
actifio-c2c 5103 tcp Actifio C2C Ravi Kollipara Ravi Kollipara 2010-06-18
5103 udp Reserved
5113 Unassigned 2010-11-09
5121-5132 Unassigned
nbt-pc 5133 tcp Policy Commander Emily Harris Emily Harris 2004-11
nbt-pc 5133 udp Policy Commander Emily Harris Emily Harris 2004-11
ppactivation 5134 tcp PP ActivationServer Ian Bradley Ian Bradley 2009-10-14
5134 udp Reserved
erp-scale 5135 tcp ERP-Scale Ian Bradley Ian Bradley 2009-10-14 Defined TXT keys:
RFC=<RFC destination and status>
Device=<Scale device and status>
5135 udp Reserved
5136 tcp Reserved
minotaur-sa 5136 udp Minotaur SA Kenneth Flynn Kenneth Flynn 2009-10-14
ctsd 5137 tcp MyCTS server port Jilles Oldenbeuving Jilles Oldenbeuving 2002-06
ctsd 5137 udp MyCTS server port Jilles Oldenbeuving Jilles Oldenbeuving 2002-06
5138-5144 Unassigned
5153 tcp Reserved 2009-07-01 2018-04-19 Historic usage was toruxserver. De-Assigned on 2018-04-19

Contact Information

Name Organization Contact URI Last Updated
Alex Chen alex_chen&filemaker.com 2009-11-25
Alexander Christian alexander.christian&root1.de 2012-04-19
Anthony Johnson Janstor Technology jtadmin&janstor.com 2015-06-08
Carlos Arteaga carteaga&abacoinc.com
Cisco Systems eckert&cisco.com 2014-06-06
Clay Maeckel clay&claris.com 2023-09-12
Daniel R Somerfield dsomerfi&harris.com 2011-08-05
Dave Neudoerffer dave.neudoerffer&sybase.com 2009-11-18
Dennis Reinhardt DennisR&dair.com
Derick Snyder dsnyder&rainbow.com
Don W. Fitzpatrick dwf&internetworxsystems.com 2005-08
Ean Black eanb&bladesoftware.co.uk 2009-04-08
Emily Harris eharris&newboundary.com 2004-11
FMSG AI PTY LTD mark&fmsg.ai 2026-10-15
Gjermund Wallenius gwallenius&ndlocis.mil.no 2009-09-30
Harris, Corporation dsomerfi&harris.com 2011-08-05
Ian Bradley ian.bradley&pocketprograms.com
development&pocketprograms.com
2009-10-14
James Goddard jamesg&taglim.com 2005-08
Janstor Technology jtadmin&janstor.com 2015-06-08
Jerry Whitaker jwhitaker&atsc.org 2008-10-27
Jilles Oldenbeuving ojilles&gmail.com 2020-11-18
Joachim Kluemper ports&raikosoft.com 2008-03-19
Ken Sarno kensarno&insightbb.com 2005-08
Kenneth Flynn flynnk&darkcornersoftware.com 2009-10-14
Lawrence Kreeger kreeger&cisco.com 2013-04-19
Mark Armstrong Mark.Armstrong&soleratec.com 2005-12
Mark Mennell mark&fmsg.ai 2026-10-15
Markus Loeffler markus.loeffler&thomson.net 2009-02-17
Matt Christiano matt&reprisesoftware.com 2008-07-28
Matt Christiano Reprise Software, Inc. matt&reprisesoftware.com 2012-11-06
Nevil Brownlee n.brownlee&auckland.ac.nz 2006-10
OPC Foundation tcb&opcfoundation.org 2017-05-23
Paul Moore paul.moore&centrify.com 2009-10-28
Randy Armstrong tcb&opcfoundation.org 2017-05-23
Ravi Kollipara ravi.kollipara&actifio.com 2010-06-18
Reprise Software, Inc. matt&reprisesoftware.com 2012-11-06
Thomas Kanngieser thomas.kanngieser&arcor.de 2006-01
Toerless Eckert Cisco Systems eckert&cisco.com 2014-06-06
Ultra Ethernet Consortium vivek.kashyap&intel.com 2025-06-16
Vivek Kashyap vivek.kashyap&intel.com 2025-06-16
William Phelps william&meier-phelps.com 2010-03-22