Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
5153 tcp Reserved 2009-07-01 2018-04-19 Historic usage was toruxserver. De-Assigned on 2018-04-19
5153 udp Reserved
sbackup 5163 tcp Shadow Backup Glenn Allen Glenn Allen 2009-08-05
5163 udp Reserved
scte30 5168 tcp SCTE30 Connection Thomas Russell Thomas Russell 2005-05
scte30 5168 udp SCTE30 Connection Thomas Russell Thomas Russell 2005-05
5173-5189 Unassigned
aol-3 5193 tcp AmericaOnline3 Bruce Mackey Bruce Mackey
aol-3 5193 udp AmericaOnline3 Bruce Mackey Bruce Mackey
targus-getdata3 5203 tcp TARGUS GetData 3 John Keaveney John Keaveney
targus-getdata3 5203 udp TARGUS GetData 3 John Keaveney John Keaveney
3exmp 5221 tcp 3eTI Extensible Management Protocol for OAMP Bill Rettig Bill Rettig 2010-05-19
hpvirtgrp 5223 tcp HP Virtual Machine Group Management John Williams John Williams 2007-06
hpvirtgrp 5223 udp HP Virtual Machine Group Management John Williams John Williams 2007-06
jaxflow-data 5230 tcp JaxMP RealFlow application and protocol data JaxMP Stephen Hull 2014-08-15
5230 udp Reserved
crusecontrol 5231 tcp Remote Control of Scan Software for Cruse Scanners Cruse Spezialmaschinen GmbH Christof J. Reetz 2014-08-15
5231 udp Reserved
csedaemon 5232 tcp Cruse Scanning System Service Christof J. Reetz Christof J. Reetz 2011-03-09
5232 udp Reserved
enfs 5233 tcp Etinnae Network File Service Chris Peel Chris Peel 2011-03-09
5233 udp Reserved
eenet 5234 tcp EEnet communications Helmut Giritzer Helmut Giritzer 2005-11
eenet 5234 udp EEnet communications Helmut Giritzer Helmut Giritzer 2005-11
galaxy-network 5235 tcp Galaxy Network Service Michael Andre Michael Andre 2007-10-04
galaxy-network 5235 udp Galaxy Network Service Michael Andre Michael Andre 2007-10-04
padl2sim 5236 tcp
padl2sim 5236 udp
mnet-discovery 5237 tcp m-net discovery Andy Crick Andy Crick 2007-11-13
mnet-discovery 5237 udp m-net discovery Andy Crick Andy Crick 2007-11-13
5238-5241 Unassigned
xycstatus 5243 tcp xyClient Status API and rendevous point Xycare Ltd Luke Bailey 2022-06-06
5243 udp Reserved
kpdp 5253 tcp Kohler Power Device Protocol Bill Gross Bill Gross 2010-11-01
5253 udp Reserved
5255-5263 Unassigned
3com-njack-1 5264 tcp 3Com Network Jack Port 1 Abhay Rajaram Abhay Rajaram 2003-03
3com-njack-1 5264 udp 3Com Network Jack Port 1 Abhay Rajaram Abhay Rajaram 2003-03
3com-njack-2 5265 tcp 3Com Network Jack Port 2 Abhay Rajaram Abhay Rajaram 2003-03
3com-njack-2 5265 udp 3Com Network Jack Port 2 Abhay Rajaram Abhay Rajaram 2003-03
5273-5279 Unassigned
5283-5297 Unassigned
hacl-hb 5300 tcp HA cluster heartbeat Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-hb 5300 udp HA cluster heartbeat Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-gs 5301 tcp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-gs 5301 udp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-cfg 5302 tcp HA cluster configuration Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-cfg 5302 udp HA cluster configuration Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-probe 5303 tcp HA cluster probing Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-probe 5303 udp HA cluster probing Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-local 5304 tcp HA Cluster Commands Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-local 5304 udp HA Cluster Commands Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-test 5305 tcp HA Cluster Test Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-test 5305 udp HA Cluster Test Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
sun-mc-grp 5306 tcp Sun MC Group Michael DeMoney Michael DeMoney
sun-mc-grp 5306 udp Sun MC Group Michael DeMoney Michael DeMoney
sco-aip 5307 tcp SCO AIP Barrie Cooper Barrie Cooper
sco-aip 5307 udp SCO AIP Barrie Cooper Barrie Cooper
cfengine 5308 tcp CFengine Mark Burgess Mark Burgess
cfengine 5308 udp CFengine Mark Burgess Mark Burgess
jprinter 5309 tcp J Printer Ken Blackwell Ken Blackwell
jprinter 5309 udp J Printer Ken Blackwell Ken Blackwell
outlaws 5310 tcp Outlaws Richard Fife Richard Fife
outlaws 5310 udp Outlaws Richard Fife Richard Fife
5311 Unassigned 2004-05-07
permabit-cs 5312 tcp Permabit Client-Server Jered Floyd Jered Floyd 2004-06
permabit-cs 5312 udp Permabit Client-Server Jered Floyd Jered Floyd 2004-06
rrdp 5313 tcp Real-time & Reliable Data Ted Hoshi Ted Hoshi 2004-06
rrdp 5313 udp Real-time & Reliable Data Ted Hoshi Ted Hoshi 2004-06
opalis-rbt-ipc 5314 tcp opalis-rbt-ipc Laurent Domenech Laurent Domenech
opalis-rbt-ipc 5314 udp opalis-rbt-ipc Laurent Domenech Laurent Domenech
hacl-poll 5315 tcp HA Cluster UDP Polling Hoa Nguyen Hoa Nguyen
hacl-poll 5315 udp HA Cluster UDP Polling Hoa Nguyen Hoa Nguyen
hpbladems 5316 tcp HPBladeSystem Monitor Service Alan Minchew Alan Minchew 2011-05-23 2011-05-16
5316 udp Unassigned 2011-05-16
hpdevms 5317 tcp HP Device Monitor Service Alan Minchew Alan Minchew 2011-05-16
5317 udp Reserved
pkix-cmc 5318 tcp PKIX Certificate Management using CMS (CMC) IESG IETF Chair 2026-02-13 RFC 10003
5318 udp Reserved
roughtime 5319 tcp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
roughtime 5319 udp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
bsfserver-zn 5320 tcp Webservices-based Zn interface of BSF Bert Paul Bert Paul 2008-05-01
5320 udp Reserved
bsfsvr-zn-ssl 5321 tcp Webservices-based Zn interface of BSF over SSL Bert Paul Bert Paul 2008-07-03
5321 udp Reserved
5322-5342 Unassigned
kfserver 5343 tcp Sculptor Database Server Keith Ashman Keith Ashman 2005-12
kfserver 5343 udp Sculptor Database Server Keith Ashman Keith Ashman 2005-12
xkotodrcp 5344 tcp xkoto DRCP Jeff Heisz Jeff Heisz 2006-02
xkotodrcp 5344 udp xkoto DRCP Jeff Heisz Jeff Heisz 2006-02
5345-5348 Unassigned
stuns 5349 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
stuns 5349 udp STUN over DTLS IESG IETF Chair 2014-07-03 RFC 7350 This service name was initially created by RFC 5389.
turns 5349 tcp TURN over TLS 2019-08-02 RFC 8656
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS RFC 5780
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR RFC 5780
5350 tcp Reserved
pcp-multicast 5350 udp Port Control Protocol Multicast IESG IETF Chair RFC 6887
5351 tcp Reserved
pcp 5351 udp Port Control Protocol IESG IETF Chair RFC 6887

Contact Information

Name Organization Contact URI Last Updated
Abhay Rajaram Abhay_Rajaram&3com.com 2003-03
Alan Minchew alan.minchew&hp.com 2011-05-23
Andy Crick acrick&haascnc.com 2007-11-13
Barrie Cooper barrie&sco.com
Bert Paul bert.paul&apertio.com 2008-07-03
Bill Gross william.gross&kohler.com 2010-11-01
Bill Rettig WRettig&efji.com 2010-05-19
Bruce Mackey BAMackey&aol.com
Chris Peel chrispeel.gsi&googlemail.com 2011-03-09
Christof J. Reetz cjr&netplan.de 2011-03-09
Christof J. Reetz Cruse Spezialmaschinen GmbH cjr&crusescanner.com 2014-08-15
Cruse Spezialmaschinen GmbH cjr&crusescanner.com 2014-08-15
Edward Yim eyim&hpmfas4.cup.hp.com
Eric Soderberg seric&hposl102.cup.hp
Glenn Allen gallen&goorooinc.com 2009-08-05
Helmut Giritzer helmut.giritzer&epluse.at 2005-11
Hoa Nguyen hoan&cup.hp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
JaxMP shull&jaxmp.com 2014-08-15
Jeff Heisz jeff.heisz&xkoto.com 2006-02
Jered Floyd jered&permabit.com 2004-06
John Keaveney johnkeaveney&targusinfo.com
John Williams John.H.Williams&hp.com 2007-06
Keith Ashman sciana&sculptor.co.uk 2005-12
Ken Blackwell kenb&bristol.com
Laurent Domenech Opalis ldomenech&opalis.com
Luke Bailey Xycare Ltd luke.bailey&xycare.co.uk 2022-06-06
Mark Burgess mark.burgess&iu.hioslo.no
Michael Andre mandre&gatewayticketing.com 2007-10-04
Michael DeMoney demoney&eng.sun.com
Richard Fife richardf&lucasarts.com
Stephen Hull JaxMP shull&jaxmp.com 2014-08-15
Ted Hoshi tetsuo.hoshi&jp.yokogawa.com 2004-06
Thomas Russell trussell&scte.org 2005-05
Xycare Ltd luke.bailey&xycare.co.uk 2022-06-06