Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
pcp 5351 udp Port Control Protocol IESG IETF Chair RFC 6887
dns-llq 5352 tcp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
dns-llq 5352 udp DNS Long-Lived Queries Stuart Cheshire Stuart Cheshire 2005-08 2019-08-26 RFC 8764
mdns 5353 tcp Multicast DNS IESG IETF Chair RFC 6762
mdns 5353 udp Multicast DNS IESG IETF Chair RFC 6762
mdnsresponder 5354 tcp Multicast DNS Responder IPC Stuart Cheshire Stuart Cheshire 2004-06
mdnsresponder 5354 udp Multicast DNS Responder IPC Stuart Cheshire Stuart Cheshire 2004-06
llmnr 5355 tcp LLMNR Bernard Aboba Bernard Aboba 2004-06
llmnr 5355 udp LLMNR Bernard Aboba Bernard Aboba 2004-06
ms-smlbiz 5356 tcp Microsoft Small Business Gopikrishna Sandra Gopikrishna Sandra 2005-02
ms-smlbiz 5356 udp Microsoft Small Business Gopikrishna Sandra Gopikrishna Sandra 2005-02
wsdapi 5357 tcp Web Services for Devices Henry Rawas Henry Rawas 2005-08
wsdapi 5357 udp Web Services for Devices Henry Rawas Henry Rawas 2005-08
wsdapi-s 5358 tcp WS for Devices Secured Henry Rawas Henry Rawas 2005-08
wsdapi-s 5358 udp WS for Devices Secured Henry Rawas Henry Rawas 2005-08
ms-alerter 5359 tcp Microsoft Alerter Marc McClure Marc McClure 2007-08-07
ms-alerter 5359 udp Microsoft Alerter Marc McClure Marc McClure 2007-08-07
ms-sideshow 5360 tcp Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-sideshow 5360 udp Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-s-sideshow 5361 tcp Secure Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-s-sideshow 5361 udp Secure Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
serverwsd2 5362 tcp Microsoft Windows Server WSD2 Service Erhan Soyer-Osman Erhan Soyer-Osman 2008-03-26
serverwsd2 5362 udp Microsoft Windows Server WSD2 Service Erhan Soyer-Osman Erhan Soyer-Osman 2008-03-26
net-projection 5363 tcp Windows Network Projection Rob Williams Rob Williams 2009-02-17
net-projection 5363 udp Windows Network Projection Rob Williams Rob Williams 2009-02-17
kdnet 5364 udp Microsoft Kernel Debugger Microsoft Corporation Joe Ballantyne 2013-06-16
5364 tcp Reserved
5365-5396 Unassigned
stresstester 5397 tcp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
stresstester 5397 udp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
elektron-admin 5398 tcp Elektron Administration Chris Hawk Chris Hawk 2005-08
elektron-admin 5398 udp Elektron Administration Chris Hawk Chris Hawk 2005-08
securitychase 5399 tcp SecurityChase Daisuke Shinomiya Daisuke Shinomiya 2005-08
securitychase 5399 udp SecurityChase Daisuke Shinomiya Daisuke Shinomiya 2005-08
hpoms-ci-lstn 5403 tcp HPOMS-CI-LSTN Harold Froehling Harold Froehling
hpoms-ci-lstn 5403 udp HPOMS-CI-LSTN Harold Froehling Harold Froehling
wwiotalk 5413 tcp WWIOTALK Roger Knobbe Roger Knobbe
wwiotalk 5413 udp WWIOTALK Roger Knobbe Roger Knobbe
virtualuser 5423 tcp VIRTUALUSER Chad Williams Chad Williams
virtualuser 5423 udp VIRTUALUSER Chad Williams Chad Williams
radec-corp 5430 tcp RADEC CORP David Chell David Chell
radec-corp 5430 udp RADEC CORP David Chell David Chell
park-agent 5431 tcp PARK AGENT John Clifford John Clifford
park-agent 5431 udp PARK AGENT John Clifford John Clifford
postgresql 5432 tcp PostgreSQL Database Tom Lane Tom Lane
postgresql 5432 udp PostgreSQL Database Tom Lane Tom Lane
pyrrho 5433 tcp Pyrrho DBMS Malcolm Crowe Malcolm Crowe 2005-11
pyrrho 5433 udp Pyrrho DBMS Malcolm Crowe Malcolm Crowe 2005-11
sgi-arrayd 5434 tcp SGI Array Services Daemon Karl Feind Karl Feind 2005-10
sgi-arrayd 5434 udp SGI Array Services Daemon Karl Feind Karl Feind 2005-10
sceanics 5435 tcp SCEANICS situation and action notification Richard Olsen Richard Olsen
sceanics 5435 udp SCEANICS situation and action notification Richard Olsen Richard Olsen
5436 tcp Reserved
pmip6-cntl 5436 udp pmip6-cntl RFC 5844
5437 tcp Reserved
pmip6-data 5437 udp pmip6-data RFC 5844
5438-5442 Unassigned
spss 5443 tcp Pearson HTTPS Pearson Pearson 2008-01-17
spss 5443 udp Pearson HTTPS Pearson Pearson 2008-01-17
surebox 5453 tcp SureBox Emin BORU Emin BORU 2004-11
surebox 5453 udp SureBox Emin BORU Emin BORU 2004-11
ttlpriceproxy 5463 tcp TTL Price Proxy Peter Jacobs Peter Jacobs
ttlpriceproxy 5463 udp TTL Price Proxy Peter Jacobs Peter Jacobs
apsolab-tags 5473 tcp The Apsolab company's secure dynamic tag protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5473 udp Reserved
fcp-srvr-inst2 5503 tcp fcp-srvr-inst2 Ken Wittmer Ken Wittmer
fcp-srvr-inst2 5503 udp fcp-srvr-inst2 Ken Wittmer Ken Wittmer
5508-5539 Unassigned
qftest-lic-mcp 5543 tcp QF-Test License Server / QF-Test MCP Server Quality First Software GmbH Gregor Schmid 2024-01-05 2026-09-04
5543 udp Reserved
sgi-eventmond 5553 tcp SGI Eventmond Port Andrei Vilkotski Andrei Vilkotski 2003-06
sgi-eventmond 5553 udp SGI Eventmond Port Andrei Vilkotski Andrei Vilkotski 2003-06
rdmnet-ctrl 5569 tcp PLASA E1.33, Remote Device Management (RDM) controller status notifications PLASA Simon Newton 2012-06-01
rdmnet-device 5569 udp PLASA E1.33, Remote Device Management (RDM) messages PLASA Simon Newton 2012-06-01
sdmmp 5573 tcp SAS Domain Management Messaging Protocol Ron Zuckerman Ron Zuckerman 2007-08-30
sdmmp 5573 udp SAS Domain Management Messaging Protocol Ron Zuckerman Ron Zuckerman 2007-08-30
fac-restore 5582 tcp T-Mobile SMS Protocol Message 3 Jessica Yan Jessica Yan 2008-02-19
fac-restore 5582 udp T-Mobile SMS Protocol Message 3 Jessica Yan Jessica Yan 2008-02-19
tmo-icon-sync 5583 tcp T-Mobile SMS Protocol Message 2 Donghwan Lim Donghwan Lim 2008-01-22
tmo-icon-sync 5583 udp T-Mobile SMS Protocol Message 2 Donghwan Lim Donghwan Lim 2008-01-22
a1-bs 5603 tcp A1-BS Mike Dolan Mike Dolan
a1-bs 5603 udp A1-BS Mike Dolan Mike Dolan
a3-sdunode 5604 tcp A3-SDUNode Mike Dolan Mike Dolan
a3-sdunode 5604 udp A3-SDUNode Mike Dolan Mike Dolan
precise-comm 5630 tcp PreciseCommunication Alon Tamir Alon Tamir 2006-04
precise-comm 5630 udp PreciseCommunication Alon Tamir Alon Tamir 2006-04
pcanywheredata 5631 tcp pcANYWHEREdata Jon Rosarky Jon Rosarky
pcanywheredata 5631 udp pcANYWHEREdata Jon Rosarky Jon Rosarky
pcanywherestat 5632 tcp pcANYWHEREstat Jon Rosarky Jon Rosarky
pcanywherestat 5632 udp pcANYWHEREstat Jon Rosarky Jon Rosarky
beorl 5633 tcp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
beorl 5633 udp BE Operations Request Listener Chirag Desai Chirag Desai 2006-02
xprtld 5634 tcp SF Message Service VR Satish VR Satish 2007-08-16
xprtld 5634 udp SF Message Service VR Satish VR Satish 2007-08-16
sfmsso 5635 tcp SFM Authentication Subsystem De-Chih Chien De-Chih Chien 2008-09-15
5635 udp Reserved
sfm-db-server 5636 tcp SFMdb - SFM DB server De-Chih Chien De-Chih Chien 2008-10-06
5636 udp Reserved
cssc 5637 tcp Symantec CSSC Amol P Tambe Amol P Tambe 2011-02-02
5637 udp Reserved
flcrs 5638 tcp Symantec Fingerprint Lookup and Container Reference Service Symantec Corp Neel A. Bhatt 2012-01-03

Contact Information

Name Organization Contact URI Last Updated
Alon Tamir alon_tamir&symantec.com 2006-04
Amol P Tambe amol_tambe&symantec.com 2011-02-02
Andrei Vilkotski andreiv&sgi.com 2003-06
Apsolab Inc. admin&apsolab.com 2014-11-10
Bernard Aboba bernarda&microsoft.com 2004-06
Chad Williams chad&apple.com
Chirag Desai Chirag_Desai&symantec.com 2006-02
Chris Hawk chris&corriente.net 2005-08
Daisuke Shinomiya shinomiya.daisu&jp.fujitsu.com 2005-08
Dan Polivy dpolivy&microsoft.com 2008-03-12
David Chell david&softlife.co.nz
De-Chih Chien de-chih_chien&symantec.com 2008-10-06
Donghwan Lim donghwan.lim&t-mobile.com 2008-01-22
Emin BORU emin&danismanlik.net 2004-11
Erhan Soyer-Osman erhanso&microsoft.com 2008-03-26
Gopikrishna Sandra v-gosand&microsoft.com 2005-02
Graham Parsons graham.parsons&reflective.com 2005-08
Gregor Schmid gregor.schmid&qfs.de 2024-01-05
Harold Froehling hrf&cup.hp.com
Henry Rawas henryr&microsoft.com 2005-08
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean-Francois Gauthier Apsolab Inc. jfgauthier&apsolab.com 2014-11-10
Jessica Yan jessica.yan2&t-mobile.com 2008-02-19
Joe Ballantyne Microsoft Corporation joeball&microsoft.com 2013-06-16
John Clifford John.Clifford&veritas.com
Jon Rosarky JRosarky&symantec.com
Karl Feind kaf&sgi.com 2005-10
Ken Wittmer kenneth.m.wittmer&accenture.com
Malcolm Crowe malcolm.crowe&paisley.ac.uk 2005-11
Marc McClure marcmcc&microsoft.com 2007-08-07
Microsoft Corporation joeball&microsoft.com 2013-06-16
Mike Dolan MDolan&ihcmail.ih.lucent.com
Neel A. Bhatt Symantec Corp neel_bhatt&symantec.com 2012-01-03
Pearson chad.smith&pearson.com 2008-01-17
Peter Jacobs pjacobs&tullib.com
PLASA standards.na&plasa.org 2012-06-01
Quality First Software GmbH qfs&qfs.de 2024-01-05
Richard Olsen olsen.richard&yahoo.com
Rob Williams rob.williams&microsoft.com 2009-02-17
Roger Knobbe RogerK&wonderware.com
Ron Zuckerman ron.zuckerman&lsi.com 2007-08-30
Simon Newton simon&nomis52.net 2012-06-01
Stuart Cheshire cheshire&apple.com 2022-07-11
Stuart Cheshire mdnsresponder-ipc&multicastdns.org 2004-06
Symantec Corp neel_bhatt&symantec.com 2012-01-03
Tom Lane tgl&sss.pgh.pa.us
VR Satish vr_satish&symantec.com 2007-08-16