Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
flcrs 5638 tcp Symantec Fingerprint Lookup and Container Reference Service Symantec Corp Neel A. Bhatt 2012-01-03
5638 udp Reserved
ics 5639 tcp Symantec Integrity Checking Service Symantec Danzhou Liu 2012-05-07
5639 udp Reserved
zre-disc 5670 udp Local area discovery and messaging over ZeroMQ Pieter Hintjens Pieter Hintjens 2012-12-17
jms 5673 tcp JACL Message Server Stuart Allen Stuart Allen 2002-02
jms 5673 udp JACL Message Server Stuart Allen Stuart Allen 2002-02
v5ua 5675 tcp V5UA application port RFC 3807
v5ua 5675 udp V5UA application port RFC 3807
v5ua 5675 sctp V5UA application port RFC 3807
coap 5683 tcp Constrained Application Protocol (CoAP) IESG IETF Chair 2017-12-22 RFC 8323
coap 5683 udp Constrained Application Protocol IESG IETF Chair 2011-06-13 2013-07-25 RFC 7252
coaps 5684 tcp Constrained Application Protocol (CoAP) IESG IETF Chair 2017-12-22 RFC 7301; RFC 8323
rbsystem 5693 tcp Robert Bosch Data Transfer Syntegon Technology GmbH Klaus Warth 2011-08-01 2020-02-04
5693 udp Reserved
proshareaudio 5713 tcp proshare conf audio gunner gunner
proshareaudio 5713 udp proshare conf audio gunner gunner
omhs 5723 tcp Operations Manager - Health Service Gerardo Dilillo Gerardo Dilillo 2006-08
omhs 5723 udp Operations Manager - Health Service Gerardo Dilillo Gerardo Dilillo 2006-08
unieng 5730 tcp Steltor's calendar access Bernard Desruisseaux Bernard Desruisseaux
unieng 5730 udp Steltor's calendar access Bernard Desruisseaux Bernard Desruisseaux
5731-5740 Unassigned
watchdoc-pod 5743 tcp Watchdoc NetPOD Protocol Christophe Chevalier Christophe Chevalier 2005-08
watchdoc-pod 5743 udp Watchdoc NetPOD Protocol Christophe Chevalier Christophe Chevalier 2005-08
3par-evts 5781 tcp 3PAR Event Reporting Service Sushil Thomas Sushil Thomas 2008-03-10
3par-evts 5781 udp 3PAR Event Reporting Service Sushil Thomas Sushil Thomas 2008-03-10
3par-mgmt 5782 tcp 3PAR Management Service Don Marselle Don Marselle 2008-04-09
3par-mgmt 5782 udp 3PAR Management Service Don Marselle Don Marselle 2008-04-09
3par-mgmt-ssl 5783 tcp 3PAR Management Service with SSL Don Marselle Don Marselle 2008-03-19
3par-mgmt-ssl 5783 udp 3PAR Management Service with SSL Don Marselle Don Marselle 2008-03-19
3par-rcopy 5785 tcp 3PAR Inform Remote Copy Don Marselle Don Marselle 2010-02-03
3par-rcopy 5785 udp 3PAR Inform Remote Copy Don Marselle Don Marselle 2008-04-09
xtreamx 5793 tcp XtreamX Supervised Peer message Ahmad Tajuddin Samsudin Ahmad Tajuddin Samsudin 2007-02
xtreamx 5793 udp XtreamX Supervised Peer message Ahmad Tajuddin Samsudin Ahmad Tajuddin Samsudin 2007-02
icmpd 5813 tcp ICMPD Shane O'Donnell Shane O'Donnell
icmpd 5813 udp ICMPD Shane O'Donnell Shane O'Donnell
5843-5858 Unassigned
ppsuitemsg 5863 tcp PlanetPress Suite Messeng Yannick Fortin Yannick Fortin 2006-02
ppsuitemsg 5863 udp PlanetPress Suite Messeng Yannick Fortin Yannick Fortin 2006-02
diameters 5868 tcp Diameter over TLS/TCP IESG IETF Chair RFC 6733
diameters 5868 sctp Diameter over DTLS/SCTP IESG IETF Chair RFC 6733
jute 5883 tcp Javascript Unit Test Environment Mark Ethan Trostler Mark Ethan Trostler 2011-11-23
rfb 5900 tcp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
rfb 5900 udp Remote Framebuffer Tristan Richardson Tristan Richardson 2006-03 RFC 6143
ff-ice 5903 tcp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 udp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
ff-ice 5903 sctp Flight & Flow Info for Collaborative Env International Civil Aviation Organisation (ICAO) Greg Saccone 2022-06-03 Defined TXT keys: FF-ICE
aoc-acars 5913 tcp Airline operational communications applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
aoc-acars 5913 udp Airline operational communications applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ads-c 5913 sctp Automatic Dependent Surveillance Justin Yu Justin Yu 2011-05-25
indy 5963 tcp Indy Application Server Bjorn Lantz Bjorn Lantz 2004-11
indy 5963 udp Indy Application Server Bjorn Lantz Bjorn Lantz 2004-11
5970-5983 Unassigned
cim-rs 5993 tcp DMTF WBEM CIM REST WS, Inc Jim Davis 2015-04-24
5993 udp Reserved
x11 6000-6063 tcp X Window System Stephen Gildea Stephen Gildea Known Unauthorized Use on port 6003
x11 6000-6063 udp X Window System Stephen Gildea Stephen Gildea Known Unauthorized Use on port 6003
gsmp-ancp 6068 tcp GSMP/ANCP Avri Doria Avri Doria RFC 6320
directplay8 6073 tcp DirectPlay8 John Kane John Kane
directplay8 6073 udp DirectPlay8 John Kane John Kane
6083 tcp Reserved
miami-bcast 6083 udp telecomsoftware miami broadcast Peter Steiner Peter Steiner 2011-02-22
rets 6103 tcp RETS Jeremy Crawford Jeremy Crawford
rets 6103 udp RETS Jeremy Crawford Jeremy Crawford
dayliteserver 6113 tcp Daylite Server Brent Gulanowski Brent Gulanowski 2009-08-26
6113 udp Reserved
backup-express 6123 tcp Backup Express Catalogic Software, Inc. Chi Shih Chang 2008-03-19 2015-02-04
backup-express 6123 udp Backup Express Catalogic Software, Inc. Chi Shih Chang 2008-03-19 2015-02-04
damewaremobgtwy 6130 tcp The DameWare Mobile Gateway Service SolarWinds David Gayler 2013-05-29
6130 udp Reserved
6131-6132 Unassigned
nbt-wol 6133 tcp New Boundary Tech WOL Elizabeth Zilen Elizabeth Zilen 2004-11
nbt-wol 6133 udp New Boundary Tech WOL Elizabeth Zilen Elizabeth Zilen 2004-11
6134-6139 Unassigned
watershed-lm 6143 tcp Watershed License Manager David Ferrero David Ferrero
watershed-lm 6143 udp Watershed License Manager David Ferrero David Ferrero
pscribe 6163 tcp Precision Scribe Cnx Port Robert W Hodges Robert W Hodges 2005-01
pscribe 6163 udp Precision Scribe Cnx Port Robert W Hodges Robert W Hodges 2005-01
6223-6240 Unassigned
jeol-nsdtp-3 6243 tcp JEOL Network Services Data Transport Protocol 3 Kevin Wellwood Kevin Wellwood 2008-04-17
jeol-nsddp-3 6243 udp JEOL Network Services Dynamic Discovery Protocol 3 Kevin Wellwood Kevin Wellwood 2008-04-17
crip 6253 tcp CRIP Mike Rodbell Mike Rodbell
crip 6253 udp CRIP Mike Rodbell Mike Rodbell
bmc-grx 6300 tcp BMC GRX Portnoy Boxman Portnoy Boxman
bmc-grx 6300 udp BMC GRX Portnoy Boxman Portnoy Boxman
bmc-ctd-ldap 6301 tcp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
Portnoy Boxman Portnoy Boxman 2006-09
bmc_ctd_ldap 6301 tcp BMC CONTROL-D LDAP SERVER Portnoy Boxman Portnoy Boxman 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
bmc-ctd-ldap 6301 udp BMC CONTROL-D LDAP SERVER

IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap".
Portnoy Boxman Portnoy Boxman 2006-09
bmc_ctd_ldap 6301 udp BMC CONTROL-D LDAP SERVER Portnoy Boxman Portnoy Boxman 2006-09 This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms.
6302-6305 Unassigned
ufmp 6306 tcp Unified Fabric Management Protocol Mellanox Technologies, Inc. Shachar Dor 2009-12-17 2019-07-02
ufmp 6306 udp Unified Fabric Management Protocol Mellanox Technologies, Inc. Shachar Dor 2009-12-17 2019-07-02
6307-6314 Unassigned
scup 6315 tcp Sensor Control Unit Protocol Sven Kopacz Sven Kopacz 2010-09-01
scup-disc 6315 udp Sensor Control Unit Protocol Discovery Protocol Sven Kopacz Sven Kopacz 2010-09-01
abb-escp 6316 tcp Ethernet Sensor Communications Protocol Jaime Antolin Jaime Antolin 2008-09-25
abb-escp 6316 udp Ethernet Sensor Communications Protocol Jaime Antolin Jaime Antolin 2008-09-25
nav-data-cmd 6317 tcp Navtech Radar Sensor Data Command Navtech Radar Guy Avery 2013-02-20
nav-data 6317 udp Navtech Radar Sensor Data Navtech Radar Guy Avery 2013-02-20
iona-data 6318 tcp IONA Measurement and control data Insphere Ltd Guy Avery 2024-07-01
6318 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Ahmad Tajuddin Samsudin tajuddin&tmrnd.com.my 2007-02
Avri Doria avri.doria&nokia.com
Bernard Desruisseaux bernard&steltor.com
Bjorn Lantz bjorn.lantz&encode.se 2004-11
Brent Gulanowski bgulanowski&marketcircle.com 2009-08-26
Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Chi Shih Chang Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Christophe Chevalier chevalier&archimed.fr 2005-08
Danzhou Liu Symantec Danzhou_Liu&symantec.com 2012-05-07
David Ferrero david&zion.com
David Gayler SolarWinds david.gayler&solarwinds.com 2013-05-29
Don Marselle don.marselle&3par.com 2008-04-09
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Elizabeth Zilen ezilen&newboundary.com 2004-11
Gerardo Dilillo MOMIANA&microsoft.com 2006-08
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
Guy Avery Navtech Radar guy.avery&navtechradar.com 2013-02-20
Guy Avery Insphere Ltd guy&insphereltd.com 2013-02-20
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Insphere Ltd guy&insphereltd.com 2024-07-01
International Civil Aviation Organisation (ICAO) gisinbox&icao.int 2024-11-19
Jaime Antolin jaime.antolin&ie.abb.com 2008-09-25
Jeremy Crawford jeremy&reso.org 2015-09-07
Jim Davis WS, Inc Jim.Davis&ws-inc.com 2015-04-24
John Kane johnkan&microsoft.com
Justin Yu yyu&mitre.org 2011-05-25
Kevin Wellwood wellwood&jeol.com 2008-04-17
Klaus Warth Syntegon Technology GmbH Klaus.Warth&Syntegon.com 2020-02-04
Mark Ethan Trostler mark&zzo.com 2011-11-23
Mellanox Technologies, Inc. info&mellanox.com 2019-07-02
Mike Rodbell mrodbell&ciena.com
Neel A. Bhatt Symantec Corp neel_bhatt&symantec.com 2012-01-03
Peter Steiner steiner&telecomsoftware.com 2011-02-22
Pieter Hintjens ph&imatix.com 2012-12-17
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Portnoy Boxman Portnoy_Boxman&bmc.com 2006-09
Robert W Hodges iana&precdata.com 2005-01
Shachar Dor Mellanox Technologies, Inc. shachard&mellanox.com 2019-07-02
Shane O'Donnell shane&opennms.org
SolarWinds david.gayler&solarwinds.com 2013-05-29
Stephen Gildea gildea&lcs.mit.edu
Stuart Allen stuart&jacl.animats.net 2002-02
Sushil Thomas iana-comm&3par.com 2008-03-10
Sven Kopacz s.kopacz&controllerware.com 2010-09-01
Symantec Corp neel_bhatt&symantec.com 2012-01-03
Symantec info&symantec.com 2012-05-07
Syntegon Technology GmbH Klaus.Warth&syntegon.com 2020-02-04
Tristan Richardson iana&realvnc.com 2006-03
WS, Inc Jim.Davis&ws-inc.com 2015-04-24
Yannick Fortin fortiny&ca.objectiflune.com 2006-02
gunner&ibeam.intel.com