Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
6318 udp Reserved
6319 Unassigned
repsvc 6320 tcp Double-Take Replication Service Carbonite, Inc. James Wilkinson 2006-04 2019-08-23
repsvc 6320 udp Double-Take Replication Service Carbonite, Inc. James Wilkinson 2006-04 2019-08-23
emp-server1 6321 tcp Empress Software Connectivity Server 1 Srdjan Holovac Srdjan Holovac
emp-server1 6321 udp Empress Software Connectivity Server 1 Srdjan Holovac Srdjan Holovac
emp-server2 6322 tcp Empress Software Connectivity Server 2 Srdjan Holovac Srdjan Holovac
emp-server2 6322 udp Empress Software Connectivity Server 2 Srdjan Holovac Srdjan Holovac
6323 Unassigned
hrd-ncs 6324 tcp HR Device Network Configuration Service Hall Research Vishal Dharmadhikari 2011-11-29
hrd-ns-disc 6324 udp HR Device Network service Hall Research Vishal Dharmadhikari 2011-11-29
dt-mgmtsvc 6325 tcp Double-Take Management Service Carbonite, Inc. James Wilkinson 2012-06-06 2019-08-23
6325 udp Reserved
dt-vra 6326 tcp Double-Take Virtual Recovery Assistant Carbonite, Inc. James Wilkinson 2012-10-08 2019-08-23
6326 udp Reserved
6327-6342 Unassigned
sflow 6343 tcp sFlow traffic monitoring Peter Phaal Peter Phaal 2003-06
sflow 6343 udp sFlow traffic monitoring Peter Phaal Peter Phaal 2003-06
streletz 6344 tcp Argus-Spectr security and fire-prevention systems service Argus-Spectr Kirill Marinushkin 2013-10-25
6344 udp Reserved
6345-6345 Unassigned
gnutella-svc 6346 tcp gnutella-svc Serguei Osokine Serguei Osokine
gnutella-svc 6346 udp gnutella-svc Serguei Osokine Serguei Osokine
gnutella-rtr 6347 tcp gnutella-rtr Serguei Osokine Serguei Osokine
gnutella-rtr 6347 udp gnutella-rtr Serguei Osokine Serguei Osokine
6348-6349 Unassigned
adap 6350 tcp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
adap 6350 udp App Discovery and Access Protocol Thomas Kjoernes Thomas Kjoernes 2010-06-22
6351-6354 Unassigned
pmcs 6355 tcp PMCS applications Pavel Mendl Pavel Mendl 2007-03
pmcs 6355 udp PMCS applications Pavel Mendl Pavel Mendl 2007-03
6356-6359 Unassigned
metaedit-mu 6360 tcp MetaEdit+ Multi-User Steven Kelly Steven Kelly 2007-11-12
metaedit-mu 6360 udp MetaEdit+ Multi-User Steven Kelly Steven Kelly 2007-11-12
6361-6362 Unassigned
ndn 6363 udp Named Data Networking Regents of the University of California Jeff Burke 2013-10-30
6363 tcp Reserved
6364-6369 Unassigned
metaedit-se 6370 tcp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
metaedit-se 6370 udp MetaEdit+ Server Administration Steven Kelly Steven Kelly 2007-11-12
6371-6378 Unassigned
redis 6379 tcp An advanced key-value cache and store Salvatore Sanfilippo Itamar Haber 2015-04-23
6379 udp Reserved
6380-6381 Unassigned
metatude-mds 6382 tcp Metatude Dialogue Server Menno Zweistra Menno Zweistra
metatude-mds 6382 udp Metatude Dialogue Server Menno Zweistra Menno Zweistra
6383-6388 Unassigned
clariion-evr01 6389 tcp clariion-evr01 Dave DesRoches Dave DesRoches
clariion-evr01 6389 udp clariion-evr01 Dave DesRoches Dave DesRoches
metaedit-ws 6390 tcp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
metaedit-ws 6390 udp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
6391-6399 Unassigned
boe-cachesvr 6403 boe-cachesvr SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr3 6409 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
6422-6431 Unassigned
pgbouncer 6432 tcp PgBouncer Marko Kreen Marko Kreen 2009-02-13
6432 udp Reserved
6433-6439 Unassigned
sun-sr-https 6443 tcp Service Registry Default HTTPS Domain Paul Sterk Paul Sterk 2006-03
sun-sr-https 6443 udp Service Registry Default HTTPS Domain Paul Sterk Paul Sterk 2006-03
6457-6463 Unassigned
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
SunVTS-RMI 6483 tcp SunVTS RMI Sumit Arora Sumit Arora 2007-06
SunVTS-RMI 6483 udp SunVTS RMI Sumit Arora Sumit Arora 2007-06
boks-clntd 6503 tcp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 tcp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 udp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 udp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
dccp-udp 6511 udp Datagram Congestion Control Protocol Encapsulation for NAT Traversal IESG IETF Chair RFC 6773
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
6513 udp Reserved
lds-distrib 6543 tcp lds_distrib Jack Baker Jack Baker 2003-06
lds-distrib 6543 udp lds_distrib Jack Baker Jack Baker 2003-06
joaJewelSuite 6583 tcp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
joaJewelSuite 6583 udp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
6603-6609 Unassigned
ktelnet 6623 tcp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
ktelnet 6623 udp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
6630 Unassigned
6631 Unassigned 2004-05-28
mxodbc-connect 6632 tcp eGenix mxODBC Connect Marc-Andre Lemburg Marc-Andre Lemburg 2009-11-13 Unauthorized Use Known on port 6632
6632 udp Reserved
6633 tcp Reserved
cisco-vpath-tun 6633 udp Cisco vPath Services Overlay Cisco Surendra Kumar 2012-06-11
mpls-pm 6634 udp MPLS Performance Measurement out-of-band response Cisco Systems Sagar Soni 2014-02-20
6634 tcp Reserved
6635 tcp Reserved
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
6636 tcp Reserved
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
6637-6639 Unassigned
openflow 6653 tcp OpenFlow Open Networking Foundation Puneet Agarwal 2013-07-18
openflow 6653 udp OpenFlow Open Networking Foundation Puneet Agarwal 2013-07-18
vision-elmd 6673 tcp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
Chris Kramer Chris Kramer
vision_elmd 6673 tcp vision_elmd Chris Kramer Chris Kramer This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-elmd 6673 udp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
Chris Kramer Chris Kramer
vision_elmd 6673 udp vision_elmd Chris Kramer Chris Kramer This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
e-design-web 6703 tcp e-Design web Janos Lerch Janos Lerch 2006-02
e-design-web 6703 udp e-Design web Janos Lerch Janos Lerch 2006-02
6707-6713 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Argus-Spectr mail&argus-spectr.ru 2013-10-25
Bob Rundle rundle&rundle.com 2005-11
Carbonite, Inc. jwilkinson&carbonite.com 2019-08-23
Chris Kramer CKramer&gis.shl.com
Cisco smkumar&cisco.com 2012-06-11
Cisco Systems sagsoni&cisco.com 2014-02-20
Dave DesRoches ddesroches&clariion.com
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Hall Research vishal&hallresearch.com 2011-11-29
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Itamar Haber Salvatore Sanfilippo itamar&redislabs.com 2015-04-23
Jack Baker Jack.Baker&l-3com.com 2006-02
James Wilkinson jwilkinson&carbonite.com 2019-08-23
Janos Lerch lerch&softic.hu 2006-02
Jeff Burke Regents of the University of California jburke&remap.ucla.edu 2013-10-30
Kirill Marinushkin Argus-Spectr k.marinushkin&argus-spectr.ru 2013-10-25
Magnus Nystrom magnus&dynas.se
Marc-Andre Lemburg mal&egenix.com 2009-11-13
Marko Kreen markokr&gmail.com 2009-02-13
Menno Zweistra m.zweistra&metatude.com
Open Networking Foundation iana&opennetworking.org 2013-07-18
Paul Sterk paul.sterk&sun.com 2006-03
Pavel Mendl pavel_mendl&centrum.cz 2007-03
Peter Phaal peter.phaal&inmon.com 2003-06
Puneet Agarwal pagarwal&broadcom.com 2013-07-18
Regents of the University of California jburke&remap.ucla.edu 2013-10-30
Robert J. Scott rob&hpcmo.hpc.mil 2005-08
Salvatore Sanfilippo antirez&gmail.com 2015-04-23
Sagar Soni Cisco Systems sagsoni&cisco.com 2014-02-20
SAP Giriraj Harapanahalli 2026-05-27
Serguei Osokine osokin&paragraph.com
Srdjan Holovac srdjan&empress.com
Steven Kelly stevek&metacase.com 2007-11-12
Sumit Arora sumit.arora&sun.com 2007-06
Surendra Kumar Cisco smkumar&cisco.com 2012-06-11
Thomas Kjoernes thomas&ipv.no 2010-06-22
Vishal Dharmadhikari Hall Research vishal&hallresearch.com 2011-11-29