Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
6707-6713 Unassigned
6779-6783 Unassigned
bfd-lag 6784 udp Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces IESG IETF BFD Working Group Chairs 2012-11-08 2014-01-09 RFC 7130
6818-6830 Unassigned
ambit-lm 6831 tcp ambit-lm Don Hejna Don Hejna
ambit-lm 6831 udp ambit-lm Don Hejna Don Hejna
6832-6840 Unassigned
6843-6849 Unassigned
6902-6923 Unassigned
6925-6934 Unassigned
ethoscan 6935 tcp EthoScan Service Marty Campbell Marty Campbell 2011-06-10
ethoscan 6935 udp EthoScan Service Marty Campbell Marty Campbell 2011-06-10
xsmsvc 6936 tcp XenSource Management Service Roger Klorese Roger Klorese 2006-06
xsmsvc 6936 udp XenSource Management Service Roger Klorese Roger Klorese 2006-06
6937-6945 Unassigned
jmact3 6961 tcp JMACT3 Yutaka Ono Yutaka Ono
jmact3 6961 udp JMACT3 Yutaka Ono Yutaka Ono
swismgr1 6963 tcp swismgr1 Yutaka Ono Yutaka Ono
swismgr1 6963 udp swismgr1 Yutaka Ono Yutaka Ono
afs3-fileserver 7000 tcp file server itself
afs3-fileserver 7000 udp file server itself
afs3-callback 7001 tcp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-callback 7001 udp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-prserver 7002 tcp users & groups database Known Unauthorized Use on port 7002
afs3-prserver 7002 udp users & groups database Known Unauthorized Use on port 7002
afs3-vlserver 7003 tcp volume location database
afs3-vlserver 7003 udp volume location database
afs3-kaserver 7004 tcp AFS/Kerberos authentication service
afs3-kaserver 7004 udp AFS/Kerberos authentication service
afs3-volser 7005 tcp volume managment server Known Unauthorized Use on port 7005
afs3-volser 7005 udp volume managment server Known Unauthorized Use on port 7005
afs3-errors 7006 tcp error interpretation service
afs3-errors 7006 udp error interpretation service
afs3-bos 7007 tcp basic overseer process
afs3-bos 7007 udp basic overseer process
afs3-update 7008 tcp server-to-server updater
afs3-update 7008 udp server-to-server updater
afs3-rmtsys 7009 tcp remote cache manager service
afs3-rmtsys 7009 udp remote cache manager service
microtalon-dis 7013 tcp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-dis 7013 udp Microtalon Discovery Jim Thompson Jim Thompson
ct2nmcs 7023 tcp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
ct2nmcs 7023 udp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
op-probe 7030 tcp ObjectPlanet probe Bjorn Jarle Kvande Bjorn Jarle Kvande 2002-04
op-probe 7030 udp ObjectPlanet probe Bjorn Jarle Kvande Bjorn Jarle Kvande 2002-04
iposplanet 7031 tcp IPOSPLANET retailing multi devices protocol Fabrice Paget Fabrice Paget 2012-10-23
7031 udp Reserved
7032-7039 Unassigned
martalk 7073 tcp MarTalk protocol Mahr GmbH Göttingen Kevin Bube 2013-09-02
7073 udp Reserved
snif 7123 tcp SNIF End-to-End TLS Relay Control Connection VESvault Corp Jim Zubov 2021-12-24 2026-07-22 draft-zubov-snif-05, Section 4.3
snif 7123 udp SNIF End-to-End TLS Relay over QUIC VESvault Corp Jim Zubov 2026-07-22 2026-07-22 draft-zubov-snif-05, Section 4.4
7130-7160 Unassigned
cacsambroker 7163 tcp CA Connection Broker David Roberts David Roberts 2005-05
cacsambroker 7163 udp CA Connection Broker David Roberts David Roberts 2005-05
drm-production 7171 tcp Discovery and Retention Mgt Production Micha Ben-Efraim Micha Ben-Efraim 2010-02-18
drm-production 7171 udp Discovery and Retention Mgt Production Micha Ben-Efraim Micha Ben-Efraim 2010-02-18
zsecure 7173 tcp zSecure Server Hans Schoone Hans Schoone 2010-10-01
7173 udp Reserved
pon-ictp 7202 tcp Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems Broadband Forum Broadband Forum 2017-02-22 2019-12-16 TR-352; Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment.
7203-7214 Unassigned
7230-7233 Unassigned
asa-gateways 7234 tcp Traffic forwarding for Okta cloud infra Okta Inc Sam Hu 2020-07-07
7234 udp Reserved
aspcoordination 7235 udp ASP Coordination Protocol Wi-Fi Alliance Mick Conley 2013-12-31
7235 tcp Reserved
display 7236 tcp Wi-Fi Alliance Wi-Fi Display Protocol Wi-Fi Alliance Thomas Sciorilli 2012-04-09 Defined TXT keys: _display.tcp. Display Protocol
7236 udp Reserved
pads 7237 tcp PADS (Public Area Display System) Server Willie Jan Bons Willie Jan Bons 2011-03-10
7237 udp Reserved
7238-7243 Unassigned
7263-7271 Unassigned
oma-rlp 7273 tcp OMA Roaming Location Larry A. Young Larry A. Young 2005-08
oma-rlp 7273 udp OMA Roaming Location Larry A. Young Larry A. Young 2005-08
genstat 7283 tcp General Statistics Rendezvous Protocol VSN International Ltd. Sean D. Sollé 2011-09-28
7283 udp Reserved
swx 7300-7359 The Swiss Exchange Edgar Blum Edgar Blum
7360-7364 Unassigned 2006-02-06
lcm-server 7365 tcp LifeKeeper Communications James Bottomley James Bottomley 2006-02
lcm-server 7365 udp LifeKeeper Communications James Bottomley James Bottomley 2006-02
7366-7390 Unassigned 2006-02-06
mindfilesys 7391 tcp mind-file system server Dave Porter Dave Porter
mindfilesys 7391 udp mind-file system server Dave Porter Dave Porter
mrssrendezvous 7392 tcp mrss-rendezvous server Dave Porter Dave Porter
mrssrendezvous 7392 udp mrss-rendezvous server Dave Porter Dave Porter
nfoldman 7393 tcp nFoldMan Remote Publish Richard McDonald Richard McDonald 2006-01
nfoldman 7393 udp nFoldMan Remote Publish Richard McDonald Richard McDonald 2006-01
fse 7394 tcp File system export of backup images Weibao Wu Weibao Wu 2006-04
fse 7394 udp File system export of backup images Weibao Wu Weibao Wu 2006-04
winqedit 7395 tcp winqedit David Greer David Greer
winqedit 7395 udp winqedit David Greer David Greer
7396 Unassigned
hexarc 7397 tcp Hexarc Command Language George Moromisato George Moromisato 2004-11
hexarc 7397 udp Hexarc Command Language George Moromisato George Moromisato 2004-11
7398-7399 Unassigned
7403-7409 Unassigned
ipluminary 7420 udp Multichannel real-time lighting control Tristan Seifert Tristan Seifert 2018-01-18
xmpv7 7430 tcp OpenView DM xmpv7 api pipe Dave Lamb Dave Lamb
xmpv7 7430 udp OpenView DM xmpv7 api pipe Dave Lamb Dave Lamb
pmd 7431 tcp OpenView DM ovc/xmpv3 api pipe Dave Lamb Dave Lamb
pmd 7431 udp OpenView DM ovc/xmpv3 api pipe Dave Lamb Dave Lamb

Contact Information

Name Organization Contact URI Last Updated
IETF BFD Working Group Chairs bfd-chairs&tools.ietf.org 2014-01-09
Bjorn Jarle Kvande bjorn&objectplanet.com 2002-04
Broadband Forum help&broadband-forum.org 2020-03-17
Bryan Wilcutt bwilcutt&comtechefdata.com 2005-06
Dave Lamb rdl&rdl.cnd.hp.com
Dave Porter porter&mango.com
David Greer david_greer&robelle.com
David Roberts David.Roberts&ca.com 2005-05
Don Hejna djhejna&ambit.com
Edgar Blum edgar.blum&swx.ch
Fabrice Paget onefrench&me.com 2012-10-23
George Moromisato gpm&neurohack.com 2004-11
Hans Schoone Hans.Schoone&nl.ibm.com 2010-10-01
IESG iesg&ietf.org
James Bottomley James.Bottomley&steeleye.com 2006-02
Jim Thompson jim.thompson&powerware.com
Jim Zubov VESvault Corp jz&vesvault.com 2021-12-29
Kevin Bube Mahr GmbH Göttingen kevin.bube&mahr.de 2013-09-02
Larry A. Young Larry.A.Young&mail.sprint.com 2005-08
Mahr GmbH Göttingen info&mahr.de 2013-09-02
Marty Campbell martyc&ethosinfo.com 2011-06-10
Micha Ben-Efraim micha.ben-efraim&ca.com 2010-02-18
Mick Conley Wi-Fi Alliance mconley&wi-fi.org 2013-12-31
Okta Inc asa-tech&okta.com 2020-07-07
Richard McDonald ve3nvm&spamcop.net 2006-01
Roger Klorese roger&xensource.com 2006-06
Sam Hu Okta Inc sam.hu&okta.com 2020-07-07
Sean D. Sollé VSN International Ltd. sean&vsni.co.uk 2011-09-28
Thomas Sciorilli Wi-Fi Alliance tsciorilli&wi-fi.org 2012-04-09
Tristan Seifert t&tseifert.me 2018-01-18
VESvault Corp info&vesvault.com 2021-12-29
VSN International Ltd. sean&vsni.co.uk 2011-09-28
Weibao Wu weibao_wu&symantec.com 2006-04
Wi-Fi Alliance certifications&wi-fi.org 2012-04-09
Wi-Fi Alliance mconley&wi-fi.org 2013-12-31
Willie Jan Bons WillieJan.Bons&nds.eu 2011-03-10
Yutaka Ono ono&saint.nm.fujitsu.co.jp