Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
8232 tcp Reserved
hncp-dtls-port 8232 udp HNCP over DTLS IESG IETF Chair 2016-01-13 RFC 7788
8233-8242 Unassigned
synapse-nhttps 8243 tcp Synapse Non Blocking HTTPS Ruwan Linton Ruwan Linton 2008-07-10
synapse-nhttps 8243 udp Synapse Non Blocking HTTPS Ruwan Linton Ruwan Linton 2008-07-10
8283-8291 Unassigned
blp3 8292 tcp Bloomberg professional Albert Hou Albert Hou 2006-05
blp3 8292 udp Bloomberg professional Albert Hou Albert Hou 2006-05
hiperscan-id 8293 tcp Hiperscan Identification Service Thomas Klose Thomas Klose 2009-12-15
8293 udp Reserved
tmi 8300 tcp Transport Management Interface Steve Kneizys Steve Kneizys 2006-11
tmi 8300 udp Transport Management Interface Steve Kneizys Steve Kneizys 2006-11
amberon 8301 tcp Amberon PPC/PPS Ronald Snyder Ronald Snyder 2006-03
amberon 8301 udp Amberon PPC/PPS Ronald Snyder Ronald Snyder 2006-03
8302-8312 Unassigned
hub-open-net 8313 tcp Hub Open Network Grexie Tim Behrsin 2012-06-13 Defined TXT keys: _hub._tcp.host.example.com
8313 udp Reserved
8314-8319 Unassigned
tnp-discover 8320 tcp Thin(ium) Network Protocol Aly Orady Aly Orady 2007-08-07
tnp-discover 8320 udp Thin(ium) Network Protocol Aly Orady Aly Orady 2007-08-07
tnp 8321 tcp Thin(ium) Network Protocol Aly Orady Aly Orady 2007-08-07
tnp 8321 udp Thin(ium) Network Protocol Aly Orady Aly Orady 2007-08-07
garmin-marine 8322 tcp Garmin Marine Garmin International, Inc." Nathan Karstens 2015-07-23
garmin-marine 8322 udp Garmin Marine Garmin International, Inc." Nathan Karstens 2015-07-23
8323-8350 Unassigned
server-find 8351 tcp Server Find Chris Brown Chris Brown
server-find 8351 udp Server Find Chris Brown Chris Brown
8352-8375 Unassigned
cruise-enum 8376 tcp Cruise ENUM Steve Husak Steve Husak
cruise-enum 8376 udp Cruise ENUM Steve Husak Steve Husak
cruise-swroute 8377 tcp Cruise SWROUTE Steve Husak Steve Husak
cruise-swroute 8377 udp Cruise SWROUTE Steve Husak Steve Husak
cruise-config 8378 tcp Cruise CONFIG Steve Husak Steve Husak
cruise-config 8378 udp Cruise CONFIG Steve Husak Steve Husak
cruise-diags 8379 tcp Cruise DIAGS Steve Husak Steve Husak
cruise-diags 8379 udp Cruise DIAGS Steve Husak Steve Husak
cruise-update 8380 tcp Cruise UPDATE Steve Husak Steve Husak
cruise-update 8380 udp Cruise UPDATE Steve Husak Steve Husak
8381-8382 Unassigned
m2mservices 8383 tcp M2m Services Carlos Arteaga Carlos Arteaga 2004-11
m2mservices 8383 udp M2m Services Carlos Arteaga Carlos Arteaga 2004-11
marathontp 8384 udp Marathon Transport Protocol Inertia Systemes Jasmin Blouin 2015-06-11
8384 tcp Reserved
8385-8399 Unassigned
admind 8403 tcp admind Aaron Bilbrey Aaron Bilbrey
admind 8403 udp admind Aaron Bilbrey Aaron Bilbrey
aritts 8423 tcp Aristech text-to-speech server Aristech GmbH Martin Mende 2017-03-30 2022-02-22
8423 udp Reserved
8424-8431 Unassigned
pgbackrest 8432 tcp PostgreSQL Backup David Steele David Steele 2022-01-26
8432 udp Reserved
8433 tcp Reserved
aws-as2 8433 udp Non Persistent Desktop and Application Streaming Amazon.com Services LLC Ivan O'Mahony 2022-11-07
8434-8441 Unassigned
pcsync-https 8443 tcp PCsync HTTPS
pcsync-https 8443 udp PCsync HTTPS
vp2p 8473 tcp Virtual Point to Point Jerome Grimbert Jerome Grimbert
vp2p 8473 udp Virtual Point to Point Jerome Grimbert Jerome Grimbert
lsp-self-ping 8503 udp MPLS LSP Self-Ping IESG IETF Chair 2015-06-11 2016-02-01 RFC 7746
8503 tcp Reserved
8504-8553 Unassigned
canon-bjnp3 8613 tcp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 udp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
8699 udp Reserved 2004-11 2013-05-24 This entry is being removed on 2013-05-24.
8712-8731 Unassigned
8732 tcp Reserved
dtp-net 8732 udp DASGIP Net Services Dr. Matthias Arnold Dr. Matthias Arnold 2009-03-23
ibus 8733 tcp iBus Silvano Maffeis Silvano Maffeis
ibus 8733 udp iBus Silvano Maffeis Silvano Maffeis
8734-8749 Unassigned
mc-appserver 8763 tcp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
mc-appserver 8763 udp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
acd-pm 8793 tcp Accedian Performance Measurement Marco Mascitto Marco Mascitto
acd-pm 8793 udp Accedian Performance Measurement Marco Mascitto Marco Mascitto
8801-8803 Unassigned Known UNAUTHORIZED USE: Port 8801
3gpp-monp 8809 udp MCPTT Off-Network Protocol (MONP) 3GPP Dongwook Kim 2019-04-15 2026-01-23 3GPP TS 24.379 v13.5.0s
dxspider 8873 tcp dxspider linking protocol Dirk Koopman Dirk Koopman 2005-08
dxspider 8873 udp dxspider linking protocol Dirk Koopman Dirk Koopman 2005-08
secure-mqtt 8883 tcp Secure MQTT OASIS Robin Cover 2008-02-27 2015-03-06
secure-mqtt 8883 udp Secure MQTT OASIS Robin Cover 2008-02-27 2015-03-06
ddi-tcp-3 8890 tcp Desktop Data TCP 2 Fred Yao Fred Yao Known Unauthorized Use on port 8890
ddi-udp-3 8890 udp NewsEDGE client broadcast Fred Yao Fred Yao Known Unauthorized Use on port 8890
ddi-tcp-4 8891 tcp Desktop Data TCP 3: NESS application Fred Yao Fred Yao
ddi-udp-4 8891 udp Desktop Data UDP 3: NESS application Fred Yao Fred Yao
ddi-tcp-6 8893 tcp Desktop Data TCP 5: NewsEDGE/Web application Fred Yao Fred Yao
ddi-udp-6 8893 udp Desktop Data UDP 5: NewsEDGE/Web application Fred Yao Fred Yao
dragonfly 8913 tcp Dragonfly System Service Paul Hodara Paul Hodara 2005-11
dragonfly 8913 udp Dragonfly System Service Paul Hodara Paul Hodara 2005-11
8914-8936 Unassigned
twds 8937 tcp Transaction Warehouse Data Service Lance M. Steenson Lance M. Steenson 2009-09-18
8937 udp Reserved
8938-8952 Unassigned
ub-dns-control 8953 tcp unbound dns nameserver control NLnet Labs Support NLnet Labs Support 2011-05-10 2011-07-11
8953 udp Reserved
9003-9004 Unassigned
swa-1 9023 tcp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-1 9023 udp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-3 9025 tcp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
swa-3 9025 udp Secure Web Access - 3 Tim McGranaghan Tim McGranaghan
emc-pp-mgmtsvc 9083 tcp EMC PowerPath Mgmt Service Jim Perreault Jim Perreault 2010-06-04
9083 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
3GPP dongwook.kim&etsi.org 2026-01-23
Aaron Bilbrey abilbrey&commvault.com
Albert Hou ahou1&bloomberg.com 2006-05
Aly Orady Atto Devices Inc. aly.orady&attodevices.com 2007-08-07
Amazon.com Services LLC aws-iana&amazon.com 2022-11-07
Aristech GmbH aritts&aristech.de 2022-02-22
Atsushi Nakamura nakamura.atsushi318&canon.co.jp 2003-11
Carlos Arteaga carteaga&adelphia.net 2004-11
Chris Brown chrisb&chancery.com
David Steele david&pgbackrest.org 2022-01-26
Dirk Koopman djk&tobit.co.uk 2005-08
Dongwook Kim 3GPP dongwook.kim&etsi.org 2026-01-23
Dr. Matthias Arnold m.arnold&dasgip.de 2009-03-23
Fred Yao Fred_Yao&ddigate2.desktopdata.com
Garmin International, Inc." nettel&garmin.com 2015-07-23
Grexie webmaster&grexie.com 2012-06-15
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Inertia Systemes jasmin.blouin&inertiasystemes.com 2015-06-11
Ivan O'Mahony Amazon.com Services LLC iomahony&amazon.com 2022-11-07
Jasmin Blouin Inertia Systemes jasmin.blouin&inertiasystemes.com 2015-06-11
Jerome Grimbert jerome.grimbert&atosorigin.com
Jim Perreault jim.perreault&emc.com 2010-06-04
Lance M. Steenson lance&transactionwarehouse.net 2009-09-18
Marco Mascitto mmascitto&accedian.com 2011-06-28
Martin Mende Aristech GmbH martin.mende&aristech.de 2022-02-22
NLnet Labs Support NLnet Labs support&nlnetlabs.nl 2011-07-11
Nathan Karstens Garmin International, Inc. nettel&garmin.com 2015-07-23
OASIS robin&oasis-open.org 2015-02-10
Paul Hodara phodara&netwave.com 2005-11
Robin Cover OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Romeo Kasanwidjojo romeo&microcomgroup.com
Ronald Snyder pugaroni&sssnet.com 2006-03
Ruwan Linton ruwan&wso2.com 2008-08-20
Silvano Maffeis maffeis&softwired.ch
Steve Husak portmaster&cruisetech.com
Steve Kneizys skneizys&erpdata.com 2006-11
Thomas Klose thomas.klose&hiperscan.com 2009-12-15
Tim Behrsin tim&behrsin.com 2012-06-15
Tim McGranaghan tim_mcgranaghan&mech.disa.mil