Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| repscmd | 653 | tcp | RepCmd | Scott Dale | Scott Dale | ||||||
| repscmd | 653 | udp | RepCmd | Scott Dale | Scott Dale | ||||||
| purenoise | 663 | tcp | PureNoise | Sam Osa | Sam Osa | ||||||
| purenoise | 663 | udp | PureNoise | Sam Osa | Sam Osa | ||||||
| cimplex | 673 | tcp | CIMPLEX | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| cimplex | 673 | udp | CIMPLEX | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| corba-iiop | 683 | tcp | CORBA IIOP | ||||||||
| corba-iiop | 683 | udp | CORBA IIOP | ||||||||
| connendp | 693 | tcp | almanid Connection Endpoint | Ronny Bremer | Ronny Bremer | ||||||
| connendp | 693 | udp | almanid Connection Endpoint | Ronny Bremer | Ronny Bremer | ||||||
| epp | 700 | tcp | Extensible Provisioning Protocol | RFC 5734 | |||||||
| epp | 700 | udp | EPP running over QUIC | IESG | IETF Chair | 2026-07-23 | RFC 5734; RFC-ietf-regext-epp-quic-12 | ||||
| iris-beep | 702 | tcp | IRIS over BEEP | RFC 3983 | |||||||
| iris-beep | 702 | udp | IRIS over BEEP | RFC 3983 | |||||||
| 703 | Unassigned | ||||||||||
| tbrpf | 712 | tcp | TBRPF | RFC 3684 | |||||||
| tbrpf | 712 | udp | TBRPF | RFC 3684 | |||||||
| iris-xpc | 713 | tcp | IRIS over XPC | ||||||||
| iris-xpc | 713 | udp | IRIS over XPC | ||||||||
| iris-lwz | 715 | tcp | IRIS-LWZ | RFC 4993 | |||||||
| iris-lwz | 715 | udp | IRIS-LWZ | RFC 4993 | |||||||
| netviewdm2 | 730 | tcp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm2 | 730 | udp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm3 | 731 | tcp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet | ||||||
| netviewdm3 | 731 | udp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet | ||||||
| 732-740 | Unassigned | ||||||||||
| 743 | Unassigned | ||||||||||
| rrh | 753 | tcp | |||||||||
| rrh | 753 | udp | |||||||||
| cycleserv | 763 | tcp | |||||||||
| cycleserv | 763 | udp | |||||||||
| submit | 773 | tcp | |||||||||
| notify | 773 | udp | |||||||||
| 803-809 | Unassigned | ||||||||||
| pkix-3-ca-ra | 829 | tcp | PKIX-3 CA/RA | Carlisle Adams | Carlisle Adams | ||||||
| pkix-3-ca-ra | 829 | udp | PKIX-3 CA/RA | Carlisle Adams | Carlisle Adams | ||||||
| netconf-ssh | 830 | tcp | NETCONF over SSH | RFC 6242 | |||||||
| netconf-ssh | 830 | udp | NETCONF over SSH | RFC 6242 | |||||||
| 831 | tcp | Reserved | 2025-09-29 | Previously assigned to NETCONF over BEEP but released by RFC 9900 | |||||||
| 831 | udp | Reserved | 2025-09-29 | Previously assigned to NETCONF over BEEP but released by RFC 9900 | |||||||
| 832 | tcp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 832 | udp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 833 | tcp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 833 | udp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 834-846 | Unassigned | ||||||||||
| gdoi | 848 | tcp | GDOI | RFC 3547 | |||||||
| gdoi | 848 | udp | GDOI | RFC 3547 | |||||||
| domain-s | 853 | tcp | DNS query-response protocol run over TLS | IESG | IETF Chair | 2015-10-08 | 2022-04-11 | RFC 7858 | |||
| domain-s | 853 | udp | DNS query-response protocol run over DTLS or QUIC | IESG | IETF Chair | 2015-10-08 | 2022-04-01 | RFC 7858; RFC 8094; RFC 9250 | |||
| iscsi | 860 | tcp | iSCSI | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi | 860 | udp | iSCSI | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| twamp-control | 862 | tcp | TWAMP-Control | IESG | IETF Chair | RFC 5357 | |||||
| 863-872 | Unassigned | ||||||||||
| rsync | 873 | tcp | rsync | Andrew Tridgell | Andrew Tridgell | ||||||
| rsync | 873 | udp | rsync | Andrew Tridgell | Andrew Tridgell | ||||||
| ideafarm-panic | 903 | tcp | self documenting Telnet Panic Door | Wo'o Ideafarm | Wo'o Ideafarm | ||||||
| ideafarm-panic | 903 | udp | self documenting Panic Door: send 0x00 for info | Wo'o Ideafarm | Wo'o Ideafarm | ||||||
| kink | 910 | tcp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| kink | 910 | udp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| apex-edge | 913 | tcp | APEX endpoint-relay service | RFC 3340 | |||||||
| apex-edge | 913 | udp | APEX endpoint-relay service | RFC 3340 | |||||||
| rndc | 953 | tcp | BIND9 remote name daemon controller | Internet Systems Consortium, Inc. | Ray Bellis | 2017-06-08 | |||||
| 953 | udp | Reserved | |||||||||
| imaps | 993 | tcp | IMAP over TLS protocol | IESG | IETF Chair | 2021-02-22 | RFC 3501; RFC 8314; RFC 9051 | ||||
| 993 | udp | Reserved | 2021-02-22 | RFC 9051 | |||||||
| pop3s | 995 | tcp | POP3 over TLS protocol | IESG | IETF Chair | 2017-12-12 | RFC 8314 | ||||
| pop3s | 995 | udp | pop3 protocol over TLS/SSL (was spop3) | Gordon Mangione | Gordon Mangione | ||||||
| webpush | 1001 | tcp | HTTP Web Push | IESG | IETF Chair | 2016-11-01 | RFC 8030 | ||||
| exp1 | 1021 | tcp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | udp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | sctp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | dccp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | tcp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | udp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | sctp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | dccp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| 1023 | tcp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1023 | udp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1024 | tcp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1024 | udp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1030 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1031 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1032 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| netinfo-local | 1033 | tcp | local netinfo port | Marc Majka | Marc Majka | 2002-08 | |||||
| netinfo-local | 1033 | udp | local netinfo port | Marc Majka | Marc Majka | 2002-08 | |||||
| activesync | 1034 | tcp | ActiveSync Notifications | Sandra Vargas | Sandra Vargas | 2003-03 | |||||
| activesync | 1034 | udp | ActiveSync Notifications | Sandra Vargas | Sandra Vargas | 2003-03 | |||||
| mxxrlogin | 1035 | tcp | MX-XR RPC | Valassis | John Eckert | 2003-04 | 2015-05-05 | ||||
| mxxrlogin | 1035 | udp | MX-XR RPC | Valassis | John Eckert | 2003-04 | 2015-05-05 | ||||
| nsstp | 1036 | tcp | Nebula Secure Segment Transfer Protocol | Steve Ravida | Steve Ravida | ||||||
| nsstp | 1036 | udp | Nebula Secure Segment Transfer Protocol | Steve Ravida | Steve Ravida | ||||||
| ams | 1037 | tcp | AMS | Ronald R. Ohmer | Ronald R. Ohmer | 2004-02 | |||||
| ams | 1037 | udp | AMS | Ronald R. Ohmer | Ronald R. Ohmer | 2004-02 | |||||
| mtqp | 1038 | tcp | Message Tracking Query Protocol | RFC 3887 | |||||||
| mtqp | 1038 | udp | Message Tracking Query Protocol | RFC 3887 | |||||||
| sbl | 1039 | tcp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| sbl | 1039 | udp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| boinc-client | 1043 | tcp | BOINC Client Control | David Anderson | David Anderson | 2004-11 | |||||
| boinc-client | 1043 | udp | BOINC Client Control | David Anderson | David Anderson | 2004-11 | |||||
| remote-as | 1053 | tcp | Remote Assistant (RA) | Roman Kriis | Roman Kriis | Unauthorized Use Known on port 1053 | |||||
| remote-as | 1053 | udp | Remote Assistant (RA) | Roman Kriis | Roman Kriis |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Tridgell | tridge&samba.anu.edu.au | ||
| Carlisle Adams | Cadams&entrust.com | ||
| David Anderson | davea&ssl.berkeley.edu | 2004-11 | |
| Gordon Mangione | gordmµsoft.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Internet Systems Consortium, Inc. | info&isc.org | 2017-06-08 | |
| John Eckert | Valassis | eckertj&valassis.com | 2015-05-05 |
| Jonathan A. Zdziaraski | jonathan&nuclearelephant.com | 2004-11 | |
| Marc Majka | majka&apple.com | 2002-08 | |
| Philippe Binet | phbinet&vnet.ibm.com | ||
| Ray Bellis | ray&isc.org | 2017-06-08 | |
| Roman Kriis | roman&previo.ee | ||
| Ronald R. Ohmer | rohmer&aisconsulting.net | 2004-02 | |
| Ronny Bremer | rbremer&almanid.com | ||
| Sam Osa | pristine&mailcity.com | ||
| Sandra Vargas | Sandramaµsoft.com | 2003-03 | |
| Scott Dale | scott&tioga.com | ||
| Steve Ravida | steve.ravida&nebulaholdings.com | ||
| Ulysses G. Smith Jr. | ugsmith&cesi.com | ||
| Valassis | eckertj&valassis.com | 2015-05-05 | |
| Wo'o Ideafarm | b85f3c23.9ad6f42c&ideafarm.com |