Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rasadv 9753 tcp rasadv Dave Thaler Dave Thaler
rasadv 9753 udp rasadv Dave Thaler Dave Thaler
9763-9799 Unassigned
9803-9874 Unassigned
enrp-sctp 9901 sctp enrp server channel RFC 5353
enrp-sctp-tls 9902 sctp enrp/tls server channel RFC 5353
9903 tcp Reserved
multicast-ping 9903 udp Multicast Ping Protocol 2011-12-09 RFC 6450
acis 9953 tcp 9953 Thomas Guth Thomas Guth 2006-01
acis 9953 udp 9953 Thomas Guth Thomas Guth 2006-01
palace-2 9993 tcp OnLive-2 Douglas Crockford Douglas Crockford
palace-2 9993 udp OnLive-2 Douglas Crockford Douglas Crockford
palace-3 9994 tcp OnLive-3 Douglas Crockford Douglas Crockford
palace-3 9994 udp OnLive-3 Douglas Crockford Douglas Crockford
distinct32 9998 tcp Distinct32 Anoop Tewari Anoop Tewari
distinct32 9998 udp Distinct32 Anoop Tewari Anoop Tewari
documentum-s 10003 tcp EMC-Documentum Content Server Product

IANA assigned this well-formed service name as a replacement for "documentum_s".
Reza Bagherian Reza Bagherian 2007-07-19
documentum_s 10003 tcp EMC-Documentum Content Server Product Reza Bagherian Reza Bagherian 2007-07-19 This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms.
documentum-s 10003 udp EMC-Documentum Content Server Product

IANA assigned this well-formed service name as a replacement for "documentum_s".
Reza Bagherian Reza Bagherian 2007-07-19
documentum_s 10003 udp EMC-Documentum Content Server Product Reza Bagherian Reza Bagherian 2007-07-19 This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms.
cefd-vmp 10023 udp Comtech EF-Data's Vipersat Management Protocol Comtech Nathan Jeffords 2014-01-23
10023 tcp Reserved
ezrelay 10103 tcp eZrelay Albert C. Yang Albert C. Yang 2002-03
ezrelay 10103 udp eZrelay Albert C. Yang Albert C. Yang 2002-03
nmea-0183 10110 tcp NMEA-0183 Navigational Data Meindert Sprang Meindert Sprang 2009-02-18
nmea-0183 10110 udp NMEA-0183 Navigational Data Meindert Sprang Meindert Sprang 2009-02-18
netiq-endpoint 10113 tcp NetIQ Endpoint John Wood John Wood
netiq-endpoint 10113 udp NetIQ Endpoint John Wood John Wood
10130-10159 Unassigned
snmptls 10161 tcp SNMP-TLS RFC 6353
snmpdtls 10161 udp SNMP-DTLS RFC 6353
snmptls-trap 10162 tcp SNMP-Trap-TLS RFC 6353
snmpdtls-trap 10162 udp SNMP-Trap-DTLS RFC 6353
10163-10199 Unassigned
eapol-relay 10253 udp Relay of EAPOL frames Wi-SUN Alliance Phil Beecher 2015-06-26
10253 tcp Reserved
10289-10320 Unassigned
10321 tcp Reserved 2023-12-05 De-Assigned on 2023-12-05.
10321 udp Reserved
10322-10438 Unassigned
bngsync 10439 udp BalanceNG session table synchronization protocol Inlab Software GmbH Thomas G. Obermair 2014-05-02
10439 tcp Reserved
cirrossp 10443 tcp CirrosSP Workstation Communication Cirros Document Solutions Ltd Andy Garratt 2020-02-12
10443 udp Reserved
10501-10539 Unassigned
MOS-soap 10543 tcp MOS SOAP Default Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-soap 10543 udp MOS SOAP Default Port Eric Thorniley Eric Thorniley 2007-09-17
serverdocs 10548 tcp Apple Document Sharing Service Apple Inc. Jason Thorpe 2015-09-29
10549-10630 Unassigned
printopia 10631 tcp Printopia Serve Decisive Tactics, Inc. Chris Kent 2011-10-24 2015-04-09
10631 udp Reserved
10632-10799 Unassigned
10881-10932 Unassigned
octopustentacle 10933 tcp Listen port used by the Octopus Deploy Tentacle deployment agent Octopus Deploy Pty. Ltd. Paul Stovell 2015-01-28
10933 udp Reserved
10934-10989 Unassigned
origo-sync 11103 tcp OrigoDB Server Sync Interface Devrex Labs Robert Friberg 2013-03-29
11103 udp Reserved
11113-11160 Unassigned
suncacao-rmi 11163 tcp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 udp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
t5-straton 11173 tcp Straton Runtime Programing COPALP Jerome FOLLUT 2012-03-01
11173 udp Reserved
11203-11207 Unassigned
11212-11234 Unassigned
xcompute 11235 tcp numerical systems messaging Xplicit Computing Inc Graham J. Orr 2020-10-16
11235 udp Reserved
xcompute 11235 sctp numerical systems messaging Xplicit Computing Inc Graham J. Orr 2020-10-16
11236-11318 Unassigned
imip 11319 tcp IMIP Len Zuvela Len Zuvela
imip 11319 udp IMIP Len Zuvela Len Zuvela
imip-channels 11320 tcp IMIP Channels Port Len Zuvela Len Zuvela
imip-channels 11320 udp IMIP Channels Port Len Zuvela Len Zuvela
arena-server 11321 tcp Arena Server Listen Earl Brannigan Earl Brannigan
arena-server 11321 udp Arena Server Listen Earl Brannigan Earl Brannigan
11322-11366 Unassigned
atm-uhas 11367 tcp ATM UHAS Todd Barker Todd Barker
atm-uhas 11367 udp ATM UHAS Todd Barker Todd Barker
11368-11370 Unassigned
hkp 11371 tcp OpenPGP HTTP Keyserver David Shaw David Shaw 2003-05
hkp 11371 udp OpenPGP HTTP Keyserver David Shaw David Shaw 2003-05
11372-11429 Unassigned
lsdp 11430 udp Lenbrook Service Discovery Protocol Lenbrook Industries Limited Kevin Groeneveld 2014-03-27
11430 tcp Reserved
11431-11433 Unassigned
ollama 11434 tcp Ollama Jesse Gross Jesse Gross 2025-09-26
11434 udp Reserved
11435-11488 Unassigned Known UNAUTHORIZED USE: port 11488
emc-xsw-dconfig 11623 tcp EMC XtremSW distributed config EMC David Erel 2013-09-18
11623 udp Reserved
h323callsigalt 11720 tcp H.323 Call Control Signalling Alternate ITU-T ITU-T TSB 2013-01-31
h323callsigalt 11720 udp H.323 Call Control Signalling Alternate ITU-T ITU-T TSB 2013-01-31
emc-xsw-dcache 11723 tcp EMC XtremSW distributed cache EMC David Erel 2013-09-18
emc-xsw-dcache 11723 udp EMC XtremSW distributed cache EMC David Erel 2013-09-18
entextmed 12003 tcp IBM Enterprise Extender SNA COS Medium Priority Eugene Cox Eugene Cox
entextmed 12003 udp IBM Enterprise Extender SNA COS Medium Priority Eugene Cox Eugene Cox
vipera-ssl 12013 tcp Vipera Messaging Service over SSL Communication Silvano Maffeis Silvano Maffeis 2008-01-16
vipera-ssl 12013 udp Vipera Messaging Service over SSL Communication Silvano Maffeis Silvano Maffeis 2008-01-16
12173-12299 Unassigned
linogridengine 12300 tcp LinoGrid Engine Frans Lundberg Frans Lundberg 2004-11
linogridengine 12300 udp LinoGrid Engine Frans Lundberg Frans Lundberg 2004-11

Contact Information

Name Organization Contact URI Last Updated
Albert C. Yang albert.yang&ezmeeting.com 2002-03
Andy Garratt Cirros Document Solutions Ltd admin&cirros.net 2020-02-12
Anoop Tewari anoop&next.distinct.com
Apple Inc. kazu&apple.com 2015-09-29
Chris Kent Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
Cirros Document Solutions Ltd admin&cirros.net 2020-02-12
Comtech njeffords&comtechefdata.com 2014-01-23
COPALP jf&copalp.com 2012-03-01
Dave Thaler dthaler&microsoft.com
David Erel EMC david.erel&emc.com 2013-09-18
David Shaw dshaw&jabberwocky.com 2003-05
Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
Devrex Labs robert.friberg&devrex.se 2013-03-29
Douglas Crockford douglas&crockford.com
Earl Brannigan earl.brannigan&lindenhous.co.uk
EMC david.erel&emc.com 2013-09-18
Eric Thorniley eric&etcomms.co.uk 2007-09-17
Eugene Cox genecox&raleigh.ibm.com
Frans Lundberg frans&linova.com 2004-11
Graham J. Orr graham&xplicitcomputing.com 2020-10-16
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Inlab Software GmbH info&inlab.de 2014-05-02
Jason Thorpe thorpej&apple.com 2015-09-29
Jerome FOLLUT COPALP jf&copalp.com 2012-03-01
Jesse Gross jesse&ollama.com 2026-02-02
John Wood John.Wood&netiq.com
Kevin Groeneveld Lenbrook Industries Limited kgroeneveld&lenbrook.com 2014-03-27
Len Zuvela IM Unified Coalition imu-comments&egroups.com
Len Zuvela lenz&microsoft.com
Lenbrook Industries Limited tsonderskov&lenbrook.com 2014-03-27
Meindert Sprang ms&customware.nl 2009-02-18
Nathan Jeffords Comtech njeffords&comtechefdata.com 2014-01-23
Nick Stephen nick.stephen&sun.com 2005-08
Octopus Deploy Pty. Ltd. paul&octopusdeploy.com 2015-01-28
Paul Stovell Octopus Deploy Pty. Ltd. paul&octopusdeploy.com 2015-01-28
Phil Beecher Wi-SUN Alliance pbeecher&wi-sun.org 2015-06-26
Reza Bagherian bagherian_reza&emc.com 2007-07-19
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
Silvano Maffeis maffeis&acm.org 2008-01-16
Thomas G. Obermair Inlab Software GmbH thomas.obermair&inlab.de 2014-05-02
Thomas Guth t.guth&zeiss.de 2006-01
Todd Barker toddba&attachmate.com
Wi-SUN Alliance admin&wi-sun.org 2015-06-26
Xplicit Computing Inc info&xplicitcomputing.com 2020-10-16