Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
filenet-tms 32768 tcp Filenet TMS Daniel Whelan Daniel Whelan
filenet-tms 32768 udp Filenet TMS Daniel Whelan Daniel Whelan
filenet-rpc 32769 tcp Filenet RPC Daniel Whelan Daniel Whelan
filenet-rpc 32769 udp Filenet RPC Daniel Whelan Daniel Whelan
filenet-nch 32770 tcp Filenet NCH Daniel Whelan Daniel Whelan
filenet-nch 32770 udp Filenet NCH Daniel Whelan Daniel Whelan
filenet-rmi 32771 tcp FileNET RMI Chris Adkins Chris Adkins
filenet-rmi 32771 udp FileNet RMI Chris Adkins Chris Adkins
filenet-pa 32772 tcp FileNET Process Analyzer Chris Adkins Chris Adkins 2003-01
filenet-pa 32772 udp FileNET Process Analyzer Chris Adkins Chris Adkins 2003-01
filenet-cm 32773 tcp FileNET Component Manager Chris Adkins Chris Adkins 2003-08
filenet-cm 32773 udp FileNET Component Manager Chris Adkins Chris Adkins 2003-08
filenet-re 32774 tcp FileNET Rules Engine Chris Adkins Chris Adkins 2003-08
filenet-re 32774 udp FileNET Rules Engine Chris Adkins Chris Adkins 2003-08
filenet-pch 32775 tcp Performance Clearinghouse Tim Morgan Tim Morgan 2005-11
filenet-pch 32775 udp Performance Clearinghouse Tim Morgan Tim Morgan 2005-11
filenet-peior 32776 tcp FileNET BPM IOR Chris Adkins Chris Adkins 2006-05
filenet-peior 32776 udp FileNET BPM IOR Chris Adkins Chris Adkins 2006-05
filenet-obrok 32777 tcp FileNet BPM CORBA Chris Adkins Chris Adkins 2006-10
filenet-obrok 32777 udp FileNet BPM CORBA Chris Adkins Chris Adkins 2006-10
32778-32800 Unassigned
mlsn 32801 tcp Multiple Listing Service Network Corey Leong Corey Leong 2010-10-11
mlsn 32801 udp Multiple Listing Service Network Corey Leong Corey Leong 2010-10-11
32802-32810 Unassigned
retp 32811 tcp Real Estate Transport Protocol Corey Leong Corey Leong 2010-10-11
32811 udp Reserved
32812-32895 Unassigned
idmgratm 32896 tcp Attachmate ID Manager George Gianelos George Gianelos 2003-03
idmgratm 32896 udp Attachmate ID Manager George Gianelos George Gianelos 2003-03
32897-32999 Unassigned
wg-endpt-comms 33000 tcp WatchGuard Endpoint Communications WatchGuard Technologies, Inc. Anunoy Ghosh 2020-01-16
33000 udp Reserved
33001-33059 Unassigned
mysqlx 33060 tcp MySQL Database Extended Interface Oracle Corp Omer BarNir 2015-08-06
33060 udp Reserved
33061-33122 Unassigned
aurora-balaena 33123 tcp Aurora (Balaena Ltd) Andrew Mather Andrew Mather 2008-02-14
aurora-balaena 33123 udp Aurora (Balaena Ltd) Andrew Mather Andrew Mather 2008-02-14
33124-33330 Unassigned
diamondport 33331 tcp DiamondCentral Interface Edward Browdy Edward Browdy 2002-07
diamondport 33331 udp DiamondCentral Interface Edward Browdy Edward Browdy 2002-07
33332 Unassigned
dgi-serv 33333 tcp Digital Gaslight Service George Flanagin George Flanagin 2010-03-02
33333 udp Reserved
speedtrace 33334 tcp SpeedTrace TraceAgent Holger Heinrich Holger Heinrich 2012-02-01
speedtrace-disc 33334 udp SpeedTrace TraceAgent Discovery Holger Heinrich Holger Heinrich 2012-02-01
33335-33433 Unassigned
traceroute 33434 tcp traceroute use IANA IANA
traceroute 33434 udp traceroute use IANA IANA
33435 tcp Reserved
mtrace 33435 udp IP Multicast Traceroute IESG IETF Chair 2017-12-13 2019-08-09 RFC 8487 Known Unauthorized Use on port 33435
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534
snip-slave 33656 tcp SNIP Slave Dr. Chris Tucker Dr. Chris Tucker 2005-08
snip-slave 33656 udp SNIP Slave Dr. Chris Tucker Dr. Chris Tucker 2005-08
33657-33889 Unassigned
digilent-adept 33890 tcp Adept IP protocol Digilent Inc. Michael T. Alexander 2020-06-25
33890 udp Reserved
33891-34248 Unassigned
turbonote-2 34249 tcp TurboNote Relay Server Default Port Peter Hyde Peter Hyde
turbonote-2 34249 udp TurboNote Relay Server Default Port Peter Hyde Peter Hyde
34250-34377 Unassigned
p-net-local 34378 tcp P-Net on IP local Kurt Nissen Kurt Nissen 2004-02
p-net-local 34378 udp P-Net on IP local Kurt Nissen Kurt Nissen 2004-02
p-net-remote 34379 tcp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
p-net-remote 34379 udp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
34380-34566 Unassigned
dhanalakshmi 34567 tcp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2010-04-20
edi_service 34567 udp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2016-10-26
34568-34961 Unassigned
profinet-rt 34962 tcp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rt 34962 udp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rtm 34963 tcp PROFInet RT Multicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rtm 34963 udp PROFInet RT Multicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm 34964 tcp PROFInet Context Manager PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm 34964 udp PROFInet Context Manager PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-cm-sec 34965 tcp PROFINET secure connection management and key provisioning PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
profinet-cm-sec 34965 udp PROFINET secure connection management and key provisioning PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
34966 tcp Reserved
profinet-rt-sec 34966 udp PROFINET secure real-time data transfer over UDP (unicast and multicast) PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2026-03-10
34967-34979 Unassigned
ethercat 34980 tcp EtherCAT Port Martin Rostan Martin Rostan 2003-11
ethercat 34980 udp EtherCAT Port Martin Rostan Martin Rostan 2003-11
34981-34999 Unassigned
heathview 35000 tcp HeathView Heathwest Systems Limited Andrew Porrer 2013-03-21
35000 udp Reserved
rt-viewer 35001 tcp ReadyTech Viewer ReadyTech Corporation Kevin Woodward 2013-09-13
rt-viewer 35001 udp ReadyTech Viewer ReadyTech Corporation Kevin Woodward 2013-09-13
rt-sound 35002 tcp ReadyTech Sound Server ReadyTech Corporation Kevin Woodward 2013-09-13
35002 udp Reserved
rt-devicemapper 35003 tcp ReadyTech DeviceMapper Server ReadyTech Corporation Kevin Woodward 2013-09-13
35003 udp Reserved
rt-classmanager 35004 tcp ReadyTech ClassManager ReadyTech Corporation Kevin Woodward 2013-09-13
rt-classmanager 35004 udp ReadyTech ClassManager ReadyTech Corporation Kevin Woodward 2013-09-13
rt-labtracker 35005 tcp ReadyTech LabTracker ReadyTech Corporation Kevin Woodward 2013-09-13
35005 udp Reserved
rt-helper 35006 tcp ReadyTech Helper Service ReadyTech Corporation Kevin Woodward 2013-09-13
35006 udp Reserved
35007-35099 Unassigned
axio-disc 35100 tcp Axiomatic discovery protocol Axiomatic Technologies Corporation Oleksandr_Bogush 2016-12-09
axio-disc 35100 udp Axiomatic discovery protocol Axiomatic Technologies Corporation Oleksandr_Bogush 2016-12-09
35101-35353 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Andrew Mather info&balaena.com 2008-02-14
Andrew Porrer Heathwest Systems Limited Andrew.Porrer&heathwest.com 2013-03-21
Anunoy Ghosh anunoy.ghosh&watchguard.com 2020-01-16
Axiomatic Technologies Corporation obogush&axiomatic.com 2016-12-09
Chris Adkins cadkins&filenet.com 2006-10
Corey Leong cleong&gr8c.org 2010-10-11
Daniel Whelan dwhelan&filenet.com
Dietmar Bohn standards.central-office&profibus.com 2026-03-10
Digilent Inc. software&digilent.com 2020-06-25
Dr. Chris Tucker chris.tucker&ioltd.co.uk 2005-08
Edward Browdy ebrowdy&cryptek.com 2002-07
George Flanagin gflanagi&richmond.edu 2010-10-30
George Gianelos GeorgeGi&attachmate.com 2003-03
Girish Gopalakrishnan girish&shankar-software.org 2016-10-26
Heathwest Systems Limited info&heathwest.com 2013-03-21
Holger Heinrich holger2222&googlemail.com 2012-02-01
IANA iana&iana.org
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Kevin Woodward ReadyTech Corporation kwoodward&readytech.com 2013-09-13
Kurt Nissen kn&proces-data.com 2004-02
Martin Rostan m.rostan&beckhoff.com 2003-11
Michael T. Alexander malexander&digilentinc.com 2020-06-25
Oleksandr_Bogush obogush&axiomatic.com 2016-12-09
Omer BarNir omer.barnir&oracle.com
Oracle Corp omer.barnir&oracle.com 2015-08-06
Peter Hyde peter&spis.co.nz
PNO – PROFIBUS Nutzerorganisation e.V. standards.central-office&profibus.com 2026-03-10
ReadyTech Corporation kwoodward&readytech.com 2013-09-13
Tim Morgan tmorgan&filenet.com 2005-11
WatchGuard Technologies, Inc. vendoraccount&watchguard.com 2020-01-16