Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dots-call-home | udp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-data | tcp | DOTS Data Channel Protocol. The service name is used to construct the SRV service name "_dots-data._tcp" for discovering DOTS servers used to establish DOTS data channel. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| edge1 | tcp | Edge1 Base Station | Skycatch, Inc. | Ruben Beltran del Rio | 2018-02-09 | Defined TXT keys: None | |||||
| est | tcp | Enrollment Over Secure Transport | Jack Visoky | Jack Visoky | 2017-10-06 | RFC 7030. Defined TXT keys: None | |||||
| est-coaps | udp | EST over secure CoAP (EST-coaps) | Toerless Eckert | Toerless Eckert | 2022-05-03 | 2022-05-04 | RFC 9148. Defined TXT keys: None | ||||
| ewelink | tcp | eWeLink devices supporting LAN Control | Shenzhen CoolKit Technology Co., Ltd. | Michael Hu | 2019-01-17 | Defined TXT keys: txtvers, id, type, apivers, encrypt, data1, data2, data3, data4, iv | |||||
| fix | Financial Information Exchange (FIX) Protocol | Joakim Johansson | Joakim Johansson | Defined TXT keys: Currently valid enumerated values: FIX Session Protocol Versions (SESSIONVERSION): 1.1 FIX Application Protocol Versions (APPLICATIONVERSION): 2.7, 3.0, 4.0, 4.1, 4.2, 4.3, 4.4, 5.0 Possible TXT records defined and their values (replace uppercase text with enumerations from the list above): txtvers=1 fix=APPLICATIONVERSION fix supported=APPLICATIONVERSION[,APPLICATIONVERSION, ... ,APPLICATIONVERSION] fixt=SESSIONVERSION | |||||||
| h323 | H.323 Real-time audio, video and data communication call setup protocol | Will MacDonald | Will MacDonald | Defined TXT keys: None | |||||||
| home-sharing | iTunes Home Sharing | Amandeep Jawa | Amandeep Jawa | Defined TXT keys: txtvers, hQ, iTSh Version, MID, Database ID, dmb, Version, OSsi, hG, hC, Machine ID | |||||||
| hpr-bldlnx | HP Remote Build System for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| hpr-toollnx | HP Remote System that houses compilers and tools for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| hpr-tstlnx | HP Remote Test System for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| hyperstream | Atempo HyperStream deduplication server | Laurent Charmet | Laurent Charmet | Defined TXT keys: version=x.y.z.w uuid=<36 bytes UUID string> host=<real host name> | |||||||
| iad3 | BBN IAD | 2013-05-24 | This service name is no longer in use. | ||||||||
| im | tcp | Instant Messaging | RFC 3861 | ||||||||
| im | udp | Instant Messaging | RFC 3861 | ||||||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| lobby | Gobby | 0x539 dev group | 0x539 dev group | Defined TXT keys: None | |||||||
| M30S1PT | tcp | Moritz30-Project Standard protocol 1 Plain Text | Moritz30 | Matthias Merkel | 2015-12-07 | Defined TXT keys: None | |||||
| M30S1PT | udp | Moritz30-Project Standard protocol 1 Plain Text | Moritz30 | Matthias Merkel | 2015-12-07 | Defined TXT keys: None | |||||
| mp3sushi | MP3 Sushi | Alexandre Carlhian | Alexandre Carlhian | Defined TXT keys: None | |||||||
| pgpkey-http | PGP Keyserver using HTTP/1.1 | Jeroen Massar | Jeroen Massar | Defined TXT keys: path=<path on the server where the HKP applications reside> normally: "path=/pks/" | |||||||
| pgpkey-https | PGP Keyserver using HTTPS | Jeroen Massar | Jeroen Massar | Defined TXT keys: path=<path on the server where the HKP applications reside> normally: "path=/pks/" | |||||||
| pgpkey-ldap | PGP Keyserver using LDAP | Jeroen Massar | Jeroen Massar | Defined TXT keys: None | |||||||
| pgpkey-mailto | PGP Key submission using SMTP | Jeroen Massar | Jeroen Massar | Defined TXT keys: user=<user portion of the mail address> | |||||||
| pkixrep | Public Key Infrastructure Repository Locator Service | RFC 4386 | |||||||||
| pres | tcp | Presence | RFC 3861 | ||||||||
| pres | udp | Presence | RFC 3861 | ||||||||
| rgb | tcp | RGB Spectrum Device Discovery | RGB Spectrum | Steve Hershey | 2011-10-10 | Defined TXT keys: Keyboard, Mouse, Option1, Option2, Option3, Option4, ModelName | |||||
| rsmp-server | Remote System Management Protocol (Server Instance) | Geoff Back | Geoff Back | Defined TXT keys: apiver=<major.minor> | |||||||
| scpi-raw | IEEE 488.2 (SCPI) Socket | Nick Barendt | Nick Barendt | Defined TXT keys: None | |||||||
| scpi-telnet | IEEE 488.2 (SCPI) Telnet | Nick Barendt | Nick Barendt | Defined TXT keys: None | |||||||
| sessionfs | Session File Sharing | Anthony Williams | Anthony Williams | Defined TXT keys: Text keys are the file extensions of any file the user plans to share, i.e. pdf, doc, mp3. | |||||||
| slimcli | SliMP3 Server Command-Line Interface | Dean Blackketter | Dean Blackketter | Defined TXT keys: None | |||||||
| slimhttp | SliMP3 Server Web Interface | Dean Blackketter | Dean Blackketter | Defined TXT keys: None | |||||||
| slpda | tcp | Remote Service Discovery in the Service Location | RFC 3832 | ||||||||
| slpda | udp | Remote Service Discovery in the Service Location | RFC 3832 | ||||||||
| smartenergy | Smart Energy Profile | Robby Simpson, PhD | Robby Simpson, PhD | 2026-09-01 | Defined TXT keys: See IEEE Std 2030.5 | ||||||
| strobe-sync | tcp | Strobe Synchronization | Jasper Morgal | Richard Morgal | 2019-06-13 | Defined TXT keys: Application will rely upon Bonjour version 3.1.0.1 | |||||
| surveillus | Surveillus Networks Discovery Protocol | Mark Lewis | Mark Lewis | Defined TXT keys: None | |||||||
| timezone | tcp | Time Zone Data Distribution Service - non-TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| timezones | tcp | Time Zone Data Distribution Service - over TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| touch-able | iPhone and iPod touch Remote Controllable | Amandeep Jawa | Amandeep Jawa | Defined TXT keys: txtvers, CtlN, DbId, Ver, DvTy, OSsi, DvSv | |||||||
| touch-remote | iPhone and iPod touch Remote Pairing | Amandeep Jawa | Amandeep Jawa | Defined TXT keys: txtvers, DvNm, Pair, RemV, RemN, DvTy | |||||||
| voalte3 | tcp | Server location via DNS-SD | Voalte, Inc. | John Simpson | 2019-01-22 | Defined TXT keys: txtvers, name, (others not publicly documented) | |||||
| wot | tcp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http. |
||||
| wot | udp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap. |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alexandre Carlhian | alex&appeule.com | ||
| Amandeep Jawa | daap&apple.com | ||
| Anthony Williams | tonydubs&gmail.com | ||
| Dean Blackketter | dean&slimdevices.com | ||
| Geoff Back | geoff&demonlair.co.uk | ||
| 0x539 dev group | http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jack Visoky | jmvisoky&ra.rockwell.com | 2017-10-06 | |
| Jasper Morgal | jpmorgal8&gmail.com | 2019-06-13 | |
| Jeffrey J. Walls | jeff.walls&hp.com | ||
| Jeroen Massar | jeroen&unfix.org | ||
| Joakim Johansson | joakim.johansson&tbricks.com | ||
| John Simpson | Voalte, Inc. | jms1&voalte.com | 2019-01-22 |
| Kazuyuki Ashimura | ashimura&w3.org | 2022-11-22 | |
| Laurent Charmet | laurent.charmet&atempo.com | ||
| Mark Lewis | mark&surveillus.com | ||
| Matthias Merkel | moritz30&moritz30.de | 2015-12-07 | |
| Michael Hu | Shenzhen CoolKit Technology Co., Ltd. | michael.hu&coolkit.cn | 2019-01-17 |
| Moritz30 | moritz30&moritz30.de | 2015-12-07 | |
| Nick Barendt | nbarendt&vxitech.com | ||
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| RGB Spectrum | shershey&rgb.com | 2011-10-10 | |
| Richard Morgal | rmorgal&wildblue.net | 2019-06-13 | |
| Robby Simpson, PhD | rsimpson&gmail.com | ||
| Ruben Beltran del Rio | benb&skycatch.com | 2018-02-09 | |
| Shenzhen CoolKit Technology Co., Ltd. | admin&coolkit.cn | 2019-01-17 | |
| Skycatch, Inc. | dev&skycatch.com | 2018-02-09 | |
| Steve Hershey | RGB Spectrum | shershey&rgb.com | 2011-10-10 |
| Toerless Eckert | tte&cs.fau.de | 2022-05-03 | |
| Voalte, Inc. | engops&voalte.com | 2019-01-22 | |
| W3C Web of Things Working Group | team-wot&w3.org | 2022-11-22 | |
| Will MacDonald | will&codian.com |