Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| remote-as | 1053 | udp | Remote Assistant (RA) | Roman Kriis | Roman Kriis | ||||||
| kyoceranetdev | 1063 | tcp | KyoceraNetDev | Shigenaka Kanemitsu | Shigenaka Kanemitsu | ||||||
| kyoceranetdev | 1063 | udp | KyoceraNetDev | Shigenaka Kanemitsu | Shigenaka Kanemitsu | ||||||
| bridgecontrol | 1073 | tcp | Bridge Control | Andy Heron | Andy Heron | ||||||
| bridgecontrol | 1073 | udp | Bridge Control | Andy Heron | Andy Heron | ||||||
| ansoft-lm-1 | 1083 | tcp | Anasoft License Manager | ||||||||
| ansoft-lm-1 | 1083 | udp | Anasoft License Manager | ||||||||
| proofd | 1093 | tcp | PROOFD | ||||||||
| proofd | 1093 | udp | PROOFD | ||||||||
| adobeserver-2 | 1103 | tcp | ADOBE SERVER 2 | Frank Soetebeer | Frank Soetebeer | ||||||
| adobeserver-2 | 1103 | udp | ADOBE SERVER 2 | Frank Soetebeer | Frank Soetebeer | ||||||
| ltp-deepspace | 1113 | tcp | Licklider Transmission Protocol | RFC 5326 | |||||||
| ltp-deepspace | 1113 | udp | Licklider Transmission Protocol | 2014-02-21 | RFC 5326; RFC 7122 | ||||||
| ltp-deepspace | 1113 | dccp | Licklider Transmission Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 7107696 | ||||
| sacred | 1118 | tcp | SACRED | RFC 3767 | |||||||
| sacred | 1118 | udp | SACRED | RFC 3767 | |||||||
| murray | 1123 | tcp | Murray | Stu Mark | Stu Mark | ||||||
| murray | 1123 | udp | Murray | Stu Mark | Stu Mark | ||||||
| casp | 1130 | tcp | CAC App Service Protocol | ||||||||
| casp | 1130 | udp | CAC App Service Protocol | ||||||||
| caspssl | 1131 | tcp | CAC App Service Protocol Encripted | Enrique Corujo | Enrique Corujo | 2006-02 | |||||
| caspssl | 1131 | udp | CAC App Service Protocol Encripted | Enrique Corujo | Enrique Corujo | 2006-02 | |||||
| kvm-via-ip | 1132 | tcp | KVM-via-IP Management Service | Ian Miller | Ian Miller | 2006-03 | |||||
| kvm-via-ip | 1132 | udp | KVM-via-IP Management Service | Ian Miller | Ian Miller | 2006-03 | |||||
| dfn | 1133 | tcp | Data Flow Network | Mikhailov Center | Anton Mikhailov | 2006-02 | 2021-03-04 | ||||
| dfn | 1133 | udp | Data Flow Network | Mikhailov Center | Anton Mikhailov | 2006-02 | 2021-03-04 | ||||
| aplx | 1134 | tcp | MicroAPL APLX | Richard Nabavi | Richard Nabavi | 2006-02 | |||||
| aplx | 1134 | udp | MicroAPL APLX | Richard Nabavi | Richard Nabavi | 2006-02 | |||||
| omnivision | 1135 | tcp | OmniVision Communication Service | Serge Vacquier | Serge Vacquier | 2006-02 | |||||
| omnivision | 1135 | udp | OmniVision Communication Service | Serge Vacquier | Serge Vacquier | 2006-02 | |||||
| hhb-gateway | 1136 | tcp | HHB Gateway Control | Richard Harwell | Richard Harwell | 2006-02 | |||||
| hhb-gateway | 1136 | udp | HHB Gateway Control | Richard Harwell | Richard Harwell | 2006-02 | |||||
| trim | 1137 | tcp | TRIM Workgroup Service | Siva Poobalasingam | Siva Poobalasingam | 2006-03 | |||||
| trim | 1137 | udp | TRIM Workgroup Service | Siva Poobalasingam | Siva Poobalasingam | 2006-03 | |||||
| encrypted-admin | 1138 | tcp | encrypted admin requests IANA assigned this well-formed service name as a replacement for "encrypted_admin". |
Michael Elizarov | Michael Elizarov | 2007-01 | |||||
| encrypted_admin | 1138 | tcp | encrypted admin requests | Michael Elizarov | Michael Elizarov | 2007-01 | This entry is an alias to "encrypted-admin". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| encrypted-admin | 1138 | udp | encrypted admin requests IANA assigned this well-formed service name as a replacement for "encrypted_admin". |
Michael Elizarov | Michael Elizarov | 2007-01 | |||||
| encrypted_admin | 1138 | udp | encrypted admin requests | Michael Elizarov | Michael Elizarov | 2007-01 | This entry is an alias to "encrypted-admin". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| evm | 1139 | tcp | Enterprise Virtual Manager | Thomas Hennessy | Thomas Hennessy | 2007-10-04 | |||||
| evm | 1139 | udp | Enterprise Virtual Manager | Thomas Hennessy | Thomas Hennessy | 2007-10-04 | |||||
| imyx | 1143 | tcp | Infomatryx Exchange | David Walling | David Walling | 2006-03 | |||||
| imyx | 1143 | udp | Infomatryx Exchange | David Walling | David Walling | 2006-03 | |||||
| c1222-acse | 1153 | tcp | ANSI C12.22 Port | RFC 6142 | |||||||
| c1222-acse | 1153 | udp | ANSI C12.22 Port | RFC 6142 | |||||||
| sddp | 1163 | tcp | SmartDialer Data Protocol | Lee Griffiths | Lee Griffiths | 2004-11 | |||||
| sddp | 1163 | udp | SmartDialer Data Protocol | Lee Griffiths | Lee Griffiths | 2004-11 | |||||
| d-cinema-rrp | 1173 | tcp | D-Cinema Request-Response | Digital Cinema Initiatives, LLC | Digital Cinema Initiatives, LLC | 2004-11 | 2025-08-26 | ||||
| d-cinema-rrp | 1173 | udp | D-Cinema Request-Response | Digital Cinema Initiatives, LLC | Digital Cinema Initiatives, LLC | 2004-11 | 2025-08-26 | ||||
| 3comnetman | 1181 | tcp | 3Com Net Management | Peter White | Peter White | 2004-11 | |||||
| 3comnetman | 1181 | udp | 3Com Net Management | Peter White | Peter White | 2004-11 | |||||
| llsurfup-http | 1183 | tcp | LL Surfup HTTP | ||||||||
| llsurfup-http | 1183 | udp | LL Surfup HTTP | ||||||||
| fiveacross | 1193 | tcp | Five Across Server | Glenn Reid | Glenn Reid | 2004-11 | |||||
| fiveacross | 1193 | udp | Five Across Server | Glenn Reid | Glenn Reid | 2004-11 | |||||
| ssslic-mgr | 1203 | tcp | License Validation | ||||||||
| ssslic-mgr | 1203 | udp | License Validation | ||||||||
| ipcd3 | 1209 | tcp | IPCD3 | Mark Ciskey | Mark Ciskey | ||||||
| ipcd3 | 1209 | udp | IPCD3 | Mark Ciskey | Mark Ciskey | ||||||
| mpc-lifenet | 1213 | tcp | Medtronic/Physio-Control LIFENET | Physio-Control, Inc. | Kevin Drew | 2014-02-14 | |||||
| mpc-lifenet | 1213 | udp | Medtronic/Physio-Control LIFENET | Physio-Control, Inc. | Kevin Drew | 2014-02-14 | |||||
| tgp | 1223 | tcp | TrulyGlobal Protocol | Gur Kimchi | Gur Kimchi | 2008-05-20 | |||||
| tgp | 1223 | udp | TrulyGlobal Protocol | Gur Kimchi | Gur Kimchi | 2008-05-20 | |||||
| periscope | 1230 | tcp | Periscope | Kevin Madden | Kevin Madden | ||||||
| periscope | 1230 | udp | Periscope | Kevin Madden | Kevin Madden | ||||||
| menandmice-lpm | 1231 | tcp | menandmice-lpm | Sigfus Magnusson | Sigfus Magnusson | ||||||
| menandmice-lpm | 1231 | udp | menandmice-lpm | Sigfus Magnusson | Sigfus Magnusson | ||||||
| first-defense | 1232 | tcp | Remote systems monitoring | Nexum, Inc. | Michael Fread | 2012-09-21 | Microsoft (unoffically) using 1232 | ||||
| first-defense | 1232 | udp | Remote systems monitoring | Nexum, Inc. | Michael Fread | 2012-09-21 | Microsoft (unoffically) using 1232 | ||||
| univ-appserver | 1233 | tcp | Universal App Server | Tim Sent | Tim Sent | ||||||
| univ-appserver | 1233 | udp | Universal App Server | Tim Sent | Tim Sent | ||||||
| search-agent | 1234 | tcp | Infoseek Search Agent | Jackie Wu | Jackie Wu | ||||||
| search-agent | 1234 | udp | Infoseek Search Agent | Jackie Wu | Jackie Wu | ||||||
| mosaicsyssvc1 | 1235 | tcp | mosaicsyssvc1 | Brian Matthews | Brian Matthews | ||||||
| mosaicsyssvc1 | 1235 | udp | mosaicsyssvc1 | Brian Matthews | Brian Matthews | ||||||
| bvcontrol | 1236 | tcp | bvcontrol | Daniel J Walsh | Daniel J Walsh | ||||||
| bvcontrol | 1236 | udp | bvcontrol | Daniel J Walsh | Daniel J Walsh | ||||||
| tsdos390 | 1237 | tcp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| tsdos390 | 1237 | udp | tsdos390 | Ben Pracht | Ben Pracht | ||||||
| hacl-qs | 1238 | tcp | hacl-qs | Farid Faez | Farid Faez | ||||||
| hacl-qs | 1238 | udp | hacl-qs | Farid Faez | Farid Faez | ||||||
| nmsd | 1239 | tcp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| nmsd | 1239 | udp | NMSD | Yuri Machkasov | Yuri Machkasov | ||||||
| serialgateway | 1243 | tcp | SerialGateway | Stephen LaValley | Stephen LaValley | ||||||
| serialgateway | 1243 | udp | SerialGateway | Stephen LaValley | Stephen LaValley | ||||||
| q55-pcc | 1253 | tcp | q55-pcc | Prem Tirilok | Prem Tirilok | ||||||
| q55-pcc | 1253 | udp | q55-pcc | Prem Tirilok | Prem Tirilok | ||||||
| dka | 1263 | tcp | dka | Chris Griffin | Chris Griffin | ||||||
| dka | 1263 | udp | dka | Chris Griffin | Chris Griffin | ||||||
| emc-gateway | 1273 | tcp | EMC-Gateway | Rene Fontaine | Rene Fontaine | ||||||
| emc-gateway | 1273 | udp | EMC-Gateway | Rene Fontaine | Rene Fontaine | ||||||
| 1276 | tcp | Reserved | 2014-05-23 | This entry has been removed on 2014-05-23. | |||||||
| 1276 | udp | Reserved | 2014-05-23 | This entry has been removed on 2014-05-23. | |||||||
| productinfo | 1283 | tcp | Product Information | ||||||||
| productinfo | 1283 | udp | Product Information | ||||||||
| pkt-krb-ipsec | 1293 | tcp | PKT-KRB-IPSec | Nancy Davoust | Nancy Davoust | ||||||
| pkt-krb-ipsec | 1293 | udp | PKT-KRB-IPSec | Nancy Davoust | Nancy Davoust | ||||||
| h323hostcallsc | 1300 | tcp | H.323 Secure Call Control Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323hostcallsc | 1300 | udp | H.323 Secure Call Control Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| 1301 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1301 | udp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1302 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andy Heron | btexact.ports&bt.com | ||
| Anton Mikhailov | Mikhailov Center | anton&mikhailov.center | 2021-03-04 |
| Ben Pracht | ben.pracht&tivoli.com | ||
| Brian Matthews | bmatthews&mosaicsystems.com | ||
| Chris Griffin | cgriffin&dka.com | ||
| Daniel J Walsh | dwalsh&bindview.com | ||
| David Walling | sylvanhollow&yahoo.com | 2006-03 | |
| Digital Cinema Initiatives, LLC | dci.info&dcimovies.com | 2025-08-26 | |
| Enrique Corujo | enrique&caclearing.com | 2006-02 | |
| Farid Faez | farid_faez&hp.com | ||
| Frank Soetebeer | frsoeteb&adobe.com | 2003-01 | |
| Glenn Reid | port-reg&fiveacross.com | 2004-11 | |
| Gur Kimchi | gkimchiµsoft.com | 2008-05-20 | |
| ITU-T | tsbsg16&itu.int | 2013-01-31 | |
| ITU-T TSB | ITU-T | tsbsg16&itu.int | 2013-01-31 |
| Ian Miller | IANA-reg&adder.com | 2006-03 | |
| Jackie Wu | jackiew&infoseek.com | ||
| Kevin Drew | Physio-Control, Inc. | kevin.c.drew&physio-control.com | 2014-02-14 |
| Kevin Madden | Kevin&emailxtras.com | ||
| Lee Griffiths | lg&dataconnection.com | 2004-11 | |
| Mark Ciskey | mlciskey&plato.com | ||
| Michael Elizarov | Michael.Elizarovµsoft.com | 2007-01 | |
| Michael Fread | Nexum, Inc. | mfread&nexuminc.com | 2012-09-21 |
| Mikhailov Center | pulse.cc&mail.ru | 2021-03-04 | |
| Nancy Davoust | n.davoust&cablelabs.com | ||
| Nexum, Inc. | mfread&nexuminc.com | 2012-09-21 | |
| Peter White | peter_white&3com.com | 2004-11 | |
| Physio-Control, Inc. | kevin.c.drew&physio-control.com | 2014-02-14 | |
| Prem Tirilok | Prem.Tirilok&tellabs.com | ||
| Rene Fontaine | fontaine_rene&emc.com | ||
| Richard Harwell | richardcharwell&eaton.com | 2006-02 | |
| Richard Nabavi | nabaviµapl.co.uk | 2006-02 | |
| Roman Kriis | roman&previo.ee | ||
| Serge Vacquier | svacquier&axway.com | 2019-03-29 | |
| Shigenaka Kanemitsu | Shigenaka_Kanemitsu&ypd.kyocera.co.jp | ||
| Sigfus Magnusson | sigfusm&menandmice.com | ||
| Siva Poobalasingam | siva&towersoft.com.au | 2006-03 | |
| Stephen LaValley | lavalley&lucent.com | ||
| Stu Mark | fordii&j51.com | ||
| Thomas Hennessy | thennessy&manageiq.com | 2007-10-04 | |
| Tim Sent | tim.sent&systemsarchitects.com | ||
| Yuri Machkasov | yuri&ptc.com |