Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
31017-31019 Unassigned
31021-31028 Unassigned
31030-31336 Unassigned
31338-31399 Unassigned
31401-31415 Unassigned
31417-31456 Unassigned
31458-31619 Unassigned
31621-31684 Unassigned
31686-31764 Unassigned
31766-31947 Unassigned
31950-32033 Unassigned
32035-32248 Unassigned
32250-32399 Unassigned
32401-32482 Unassigned
32484-32634 Unassigned
32637-32766 Unassigned
32778-32800 Unassigned
32802-32810 Unassigned
32812-32895 Unassigned
32897-32999 Unassigned
33001-33059 Unassigned
33061-33122 Unassigned
33124-33330 Unassigned
33332 Unassigned
33335-33433 Unassigned
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534
33657-33889 Unassigned
33891-34248 Unassigned
34250-34377 Unassigned
34380-34566 Unassigned
34568-34961 Unassigned
34967-34979 Unassigned
34981-34999 Unassigned
35007-35099 Unassigned
35101-35353 Unassigned
35358-36000 Unassigned
36002-36410 Unassigned
36413-36421 Unassigned
36425-36442 Unassigned
36445-36461 Unassigned
36463-36523 Unassigned
36525-36601 Unassigned
36603-36699 Unassigned
36701-36864 Unassigned
36866-37471 Unassigned
37473-37474 Unassigned
37476-37482 Unassigned
37484-37600 Unassigned
37602-37653 Unassigned
37655-37999 Unassigned
38003-38200 Unassigned
38204-38411 Unassigned
38413-38421 Unassigned
38423-38461 Unassigned
38463-38471 Unassigned
38473-38637 Unassigned
38639-38799 Unassigned
38801-38864 Unassigned
38866-39062 Unassigned
39064-39680 Unassigned
39682-39999 Unassigned
40001-40022 Unassigned
40024-40403 Unassigned
40405-40840 Unassigned
40844-40852 Unassigned
40854-41110 Unassigned
41112-41120 Unassigned
41122-41229 Unassigned
41231-41793 Unassigned
41798-42507 Unassigned Unauthorized Use Known on port 42000
42511-42998 Unassigned
43001-43187 Unassigned
43192-43209 Unassigned
43211-43437 Unassigned
43442-44122 Unassigned
44124-44320 Unassigned
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC 6887
44324-44443 Unassigned
44446-44543 Unassigned Known UNAUTHORIZED USE: Ports 44515 & 44516
44545-44552 Unassigned
44554-44599 Unassigned
44601-44817 Unassigned
44819-44899 Unassigned
44901-44999 Unassigned
45003-45044 Unassigned
45046-45053 Unassigned
45055-45184 Unassigned
45186-45513 Unassigned
45515-45677 Unassigned
45679-45823 Unassigned
45826-45965 Unassigned
45967-46335 Unassigned
46337-46997 Unassigned
47002-47099 Unassigned
47101-47556 Unassigned
47558-47623 Unassigned
47625-47805 Unassigned
47807 Unassigned
47810-47999 Unassigned
48006-48047 Unassigned
48051-48127 Unassigned