Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rtsps 322 tcp RTSPS Anders Klemets Anders Klemets
rtsps 322 udp RTSPS Anders Klemets Anders Klemets
rtsp 554 tcp Real Time Streaming Protocol (RTSP) Rob Lanphier Rob Lanphier
rtsp 554 udp Real Time Streaming Protocol (RTSP) Rob Lanphier Rob Lanphier
bitspeer 2178 tcp Peer Services for BITS Jeff Roberts Jeff Roberts 2005-11
bitspeer 2178 udp Peer Services for BITS Jeff Roberts Jeff Roberts 2005-11
ttntspauto 3474 tcp TSP Automation Arnie Koster Arnie Koster 2002-04
ttntspauto 3474 udp TSP Automation Arnie Koster Arnie Koster 2002-04
hlibmgr 3634 tcp hNTSP Library Manager Kenji Tetsuyama Kenji Tetsuyama 2002-11
hlibmgr 3634 udp hNTSP Library Manager Kenji Tetsuyama Kenji Tetsuyama 2002-11
tsp 3653 tcp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
tsp 3653 udp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
intecom-ps1 5056 tcp Intecom Pointspan 1 David Meermans David Meermans
intecom-ps1 5056 udp Intecom Pointspan 1 David Meermans David Meermans
intecom-ps2 5057 tcp Intecom Pointspan 2 David Meermans David Meermans
intecom-ps2 5057 udp Intecom Pointspan 2 David Meermans David Meermans
ewctsp 6066 tcp EWCTSP Mark Bailon Mark Bailon
ewctsp 6066 udp EWCTSP Mark Bailon Mark Bailon
dtspcd 6112 tcp Desk-Top Sub-Process Control Daemon Doug Royer Doug Royer 2010-12-08
dtspcd 6112 udp Desk-Top Sub-Process Control Daemon Doug Royer Doug Royer 2010-12-08
rtsp-alt 8554 tcp RTSP Alternate (see port 554) Stephen Casner Stephen Casner
rtsp-alt 8554 udp RTSP Alternate (see port 554) Stephen Casner Stephen Casner
ssports-bcast 8808 udp STATSports Broadcast Service Statsports_International Catalin Caranfil 2016-12-22
netspeak-is 21846 tcp NetSpeak Corp. Directory Services Toby Hosterman Toby Hosterman
netspeak-is 21846 udp NetSpeak Corp. Directory Services Toby Hosterman Toby Hosterman
netspeak-cs 21847 tcp NetSpeak Corp. Connection Services Toby Hosterman Toby Hosterman
netspeak-cs 21847 udp NetSpeak Corp. Connection Services Toby Hosterman Toby Hosterman
netspeak-acd 21848 tcp NetSpeak Corp. Automatic Call Distribution Toby Hosterman Toby Hosterman
netspeak-acd 21848 udp NetSpeak Corp. Automatic Call Distribution Toby Hosterman Toby Hosterman
netspeak-cps 21849 tcp NetSpeak Corp. Credit Processing System Toby Hosterman Toby Hosterman
netspeak-cps 21849 udp NetSpeak Corp. Credit Processing System Toby Hosterman Toby Hosterman
htsp Home Tv Streaming Protocol Andreas Öman Andreas Öman Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Anders Klemets anderskl&microsoft.com
Andreas Öman andreas&lonelycoder.com
Arnie Koster akoster&teltone.com 2002-04
Catalin Caranfil c.caranfil&statsports.com 2016-12-22
David Meermans david.meermans&aastra.com
Doug Royer DouglasRoyer&gmail.com 2010-12-09
Jeff Roberts jroberts&microsoft.com 2005-11
Kenji Tetsuyama kenji&onkyo.co.jp 2002-11
Marc Blanchet marc.blanchet&viagenie.ca 2003-01
Mark Bailon mark.bailon&ericsson.com
Rob Lanphier robla&prognet.com
Statsports_International iana_liaison&statsports.com 2016-12-22
Stephen Casner casner&precept.com
Toby Hosterman root&netspeak.com