Content-Centric Networking (CCNx)
Created
- 2019-02-11
Last Updated
- 2024-04-19
Available Formats
CCNx Packet Types
Registration Procedure(s)
- RFC Required
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x00 | PT_INTEREST | RFC 8609, Section 3.2 |
| 0x01 | PT_CONTENT | RFC 8609, Section 3.2 |
| 0x02 | PT_RETURN | RFC 8609, Section 3.2 |
| 0x03 | PT_CCNINFO_REQUEST | RFC 9344 |
| 0x04 | PT_CCNINFO_REPLY | RFC 9344 |
| 0x05 | PT_ECHO_REQUEST | RFC 9508 |
| 0x06 | PT_ECHO_REPLY | RFC 9508 |
| 0x07 | PT_TR_REQUEST | RFC 9507 |
| 0x08 | PT_TR_REPLY | RFC 9507 |
| 0x09-0xFF | Unassigned |
CCNx Interest Return Code Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Dave Oran, Hitoshi Asaeda
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x00 | Reserved | RFC 8609 |
| 0x01 | T_RETURN_NO_ROUTE | RFC 8609, Section 3.2.3.3 |
| 0x02 | T_RETURN_LIMIT_EXCEEDED | RFC 8609, Section 3.2.3.3 |
| 0x03 | T_RETURN_NO_RESOURCES | RFC 8609, Section 3.2.3.3 |
| 0x04 | T_RETURN_PATH_ERROR | RFC 8609, Section 3.2.3.3 |
| 0x05 | T_RETURN_PROHIBITED | RFC 8609, Section 3.2.3.3 |
| 0x06 | T_RETURN_CONGESTED | RFC 8609, Section 3.2.3.3 |
| 0x07 | T_RETURN_MTU_TOO_LARGE | RFC 8609, Section 3.2.3.3 |
| 0x08 | T_RETURN_UNSUPPORTED_HASH_RESTRICTION | RFC 8609, Section 3.2.3.3 |
| 0x09 | T_RETURN_MALFORMED_INTEREST | RFC 8609, Section 3.2.3.3 |
| 0x0A | T_RETURN_INVALID_PATH_LABEL | RFC 9531 |
| 0x0B-0xFF | Unassigned |
CCNx Hop-by-Hop Types
Registration Procedure(s)
- RFC Required
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x0000 | Reserved | RFC 8609 |
| 0x0001 | T_INTLIFE | RFC 8609, Section 3.4 |
| 0x0002 | T_CACHETIME | RFC 8609, Section 3.4 |
| 0x0003 | T_MSGHASH | RFC 8609, Section 3.4 |
| 0x0004-0x0007 | Reserved | RFC 8609 |
| 0x0008 | T_DISC_REQHDR | RFC 9344 |
| 0x0009 | T_DISC_REPORT | RFC 9344 |
| 0x000A | T_PATH_LABEL | RFC 9531 |
| 0x000B-0x0FFD | Unassigned | |
| 0x0FFE | T_PAD | RFC 8609, Section 3.3.1 |
| 0x0FFF | T_ORG | RFC 8609, Section 3.3.2 |
| 0x1000-0x1FFF | Reserved for Experimental Use | RFC 8609, Section 3 |
| 0x2000-0xFFFF | Unassigned |
CCNx Top-Level Types
Registration Procedure(s)
- RFC Required
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x0000 | Reserved | RFC 8609 |
| 0x0001 | T_INTEREST | RFC 8609, Section 3.5 |
| 0x0002 | T_OBJECT | RFC 8609, Section 3.5 |
| 0x0003 | T_VALIDATION_ALG | RFC 8609, Section 3.5 |
| 0x0004 | T_VALIDATION_PAYLOAD | RFC 8609, Section 3.5 |
| 0x0005 | T_DISCOVERY | RFC 9344 |
| 0x0006-0xFFFF | Unassigned |
CCNx Name Segment Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Dave Oran, Hitoshi Asaeda
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x0000 | Reserved | RFC 8609 |
| 0x0001 | T_NAMESEGMENT | RFC 8609, Section 3.6.1 |
| 0x0002 | T_IPID | RFC 8609, Section 3.6.1 |
| 0x0003 | T_NONCE | RFC 9508 |
| 0x0004-0x000F | Unassigned | |
| 0x0010-0x0013 | Reserved | RFC 8609 |
| 0x0014-0x0FFE | Unassigned | |
| 0x0FFF | T_ORG | RFC 8609, Section 3.3.2 |
| 0x1000-0x1FFF | T_APP:00 - T_APP:4096 | RFC 8609, Section 3.6.1 |
| 0x2000-0xFFFF | Unassigned |
CCNx Message Types
Registration Procedure(s)
- RFC Required
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x0000 | T_NAME | RFC 8609, Section 3.6 |
| 0x0001 | T_PAYLOAD | RFC 8609, Section 3.6 |
| 0x0002 | T_KEYIDRESTR | RFC 8609, Section 3.6 |
| 0x0003 | T_OBJHASHRESTR | RFC 8609, Section 3.6 |
| 0x0004 | Unassigned | |
| 0x0005 | T_PAYLDTYPE | RFC 8609, Section 3.6.2.2 |
| 0x0006 | T_EXPIRY | RFC 8609, Section 3.6.2.2 |
| 0x0007-0x000C | Reserved | RFC 8609 |
| 0x000D | T_DISC_REQ | RFC 9344 |
| 0x000E | T_DISC_REPLY | RFC 9344 |
| 0x000F-0x0FFD | Unassigned | |
| 0x0FFE | T_PAD | RFC 8609, Section 3.3.1 |
| 0x0FFF | T_ORG | RFC 8609, Section 3.3.2 |
| 0x1000-0x1FFF | Reserved for Experimental Use | RFC 8609, Section 3 |
| 0x2000-0xFFFF | Unassigned |
CCNx Payload Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Dave Oran, Hitoshi Asaeda
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x00 | T_PAYLOADTYPE_DATA | RFC 8609, Section 3.6.2.2.1 |
| 0x01 | T_PAYLOADTYPE_KEY | RFC 8609, Section 3.6.2.2.1 |
| 0x02 | T_PAYLOADTYPE_LINK | RFC 8609, Section 3.6.2.2.1 |
| 0x03-0xFF | Unassigned |
CCNx Validation Algorithm Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Dave Oran, Hitoshi Asaeda
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x0000 | Reserved | RFC 8609 |
| 0x0001 | Unassigned | |
| 0x0002 | T_CRC32C | RFC 8609, Section 3.6.4.1 |
| 0x0003 | Unassigned | |
| 0x0004 | T_HMAC-SHA256 | RFC 8609, Section 3.6.4.1 |
| 0x0005 | T_RSA-SHA256 | RFC 8609, Section 3.6.4.1 |
| 0x0006 | T_EC-SECP-256K1 | RFC 8609, Section 3.6.4.1 |
| 0x0007 | T_EC-SECP-384R1 | RFC 8609, Section 3.6.4.1 |
| 0x0008-0x0FFD | Unassigned | |
| 0x0FFE | T_PAD | RFC 8609, Section 3.3.1 |
| 0x0FFF | T_ORG | RFC 8609, Section 3.3.2 |
| 0x1000-0x1FFF | Reserved for Experimental Use | RFC 8609, Section 3 |
| 0x2000-0xFFFF | Unassigned |
CCNx Validation-Dependent Data Types
Registration Procedure(s)
- RFC Required
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x0000 | Reserved | RFC 8609 |
| 0x0001-0x0008 | Unassigned | |
| 0x0009 | T_KEYID | RFC 8609, Section 3.6.4.1.4 |
| 0x000A | T_PUBLICKEYLOC | RFC 8609, Section 3.6.4.1.4 |
| 0x000B | T_PUBLICKEY | RFC 8609, Section 3.6.4.1.4 |
| 0x000C | T_CERT | RFC 8609, Section 3.6.4.1.4 |
| 0x000D | T_LINK | RFC 8609, Section 3.6.4.1.4 |
| 0x000E | T_KEYLINK | RFC 8609, Section 3.6.4.1.4 |
| 0x000F | T_SIGTIME | RFC 8609, Section 3.6.4.1.4 |
| 0x0010-0x0FFE | Unassigned | |
| 0x0FFF | T_ORG | RFC 8609, Section 3.3.2 |
| 0x1000-0x1FFF | Reserved for Experimental Use | RFC 8609, Section 3 |
| 0x2000-0xFFFF | Unassigned |
CCNx Hash Function Types
Registration Procedure(s)
- Specification Required
Expert(s)
- Dave Oran, Hitoshi Asaeda
Reference
- RFC 8609: Content-Centric Networking (CCNx) Messages in TLV Format
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x0000 | Reserved | RFC 8609 |
| 0x0001 | T_SHA-256 | RFC 8609, Section 3.3.3 |
| 0x0002 | T_SHA-512 | RFC 8609, Section 3.3.3 |
| 0x0003-0x0FFE | Unassigned | |
| 0x0FFF | T_ORG | RFC 8609, Section 3.3.2 |
| 0x1000-0x1FFF | Reserved for Experimental Use | RFC 8609, Section 3 |
| 0x2000-0xFFFF | Unassigned |
CCNx Reply Types
Registration Procedure(s)
- RFC Required
Reference
- RFC 9344: CCNinfo: Discovering Content and Network Information in Content-Centric Networks
Available Formats
CCNx Echo Reply Codes
Registration Procedure(s)
- Specification Required
Expert(s)
- Dave Oran, Hitoshi Asaeda
Reference
- RFC 9508: Information-Centric Networking (ICN) Ping Protocol Specification
Available Formats
| Type | Name | Reference |
|---|---|---|
| 0x00 | Reserved | RFC 9508 |
| 0x01 | T_ECHO_RETURN_FORWARDER | RFC 9508, Section 4.2 |
| 0x02 | T_ECHO_RETURN_APPLICATION | RFC 9508, Section 4.2 |
| 0x03 | T_ECHO_RETURN_OBJECT | RFC 9508, Section 4.2 |
| 0x04-0xFF | Unassigned |