Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| mdqs | 666 | tcp | |||||||||
| mdqs | 666 | udp | |||||||||
| doom | 666 | tcp | doom Id Software | ddt | ddt | ||||||
| doom | 666 | udp | doom Id Software | ddt | ddt | ||||||
| netview-aix-6 | 1666 | tcp | netview-aix-6 | ||||||||
| netview-aix-6 | 1666 | udp | netview-aix-6 | ||||||||
| extensis | 2666 | tcp | extensis | Milton Sagen | Milton Sagen | ||||||
| extensis | 2666 | udp | extensis | Milton Sagen | Milton Sagen | ||||||
| m3ua | 2905 | tcp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| m3ua | 2905 | sctp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| eserver-pap | 3666 | tcp | IBM eServer PAP | Dave Gimpl | Dave Gimpl | 2003-01 | |||||
| eserver-pap | 3666 | udp | IBM EServer PAP | Dave Gimpl | Dave Gimpl | 2003-01 | |||||
| eportcomm | 4666 | tcp | E-Port Message Service | ||||||||
| eportcomm | 4666 | udp | E-Port Message Service | ||||||||
| nrpe | 5666 | tcp | Nagios Remote Plugin Executor | Nagios Enterprises, LLC | Bryan Heden | 2017-09-06 | |||||
| 5666 | udp | Reserved | |||||||||
| 6658-6664 | Unassigned | Unauthorized Use Known on Port 6659 | |||||||||
| ircu | 6665-6669 | tcp | IRCU | Brian Tackett | Brian Tackett | ||||||
| 6665-6669 | udp | Reserved | |||||||||
| monetra-admin | 8666 | tcp | Monetra Administrative Access | Main Street Softworks Inc | Brad House | 2013-04-02 | |||||
| 8666 | udp | Reserved | |||||||||
| zoomcp | 9666 | tcp | Zoom Control Panel Game Server Management | Zoom Control Panel | Joshua Pedroza | 2014-02-26 | |||||
| 9666 | udp | Reserved | |||||||||
| 16620-16664 | Unassigned | ||||||||||
| axon-tunnel | 16665 | tcp | Reliable multipath data transport for high latencies | Bridgeworks | Mihai Popa | 2014-09-26 | 2026-09-11 | ||||
| 16665 | udp | Reserved | |||||||||
| 16666 | tcp | Reserved | |||||||||
| vtp | 16666 | udp | Vidder Tunnel Protocol | Vidder, Inc. | Ted Schroeder | 2011-10-24 | |||||
| 16667-16788 | Unassigned | ||||||||||
| sdtvwcam | 24666 | tcp | Service used by SmarDTV to communicate between a CAM and a second screen application | SmarDTV | Vincent Demortier | 2015-03-04 | |||||
| 24666 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Brad House | Main Street Softworks Inc | brad&mainstreetsoftworks.com | 2013-04-02 |
| Brian Tackett | cym&acrux.net | ||
| Bridgeworks | mihai.popa&4bridgeworks.com | 2026-09-11 | |
| Bryan Heden | bheden&nagios.com | 2017-09-06 | |
| Dave Gimpl | gimpl&us.ibm.com | 2003-01 | |
| Joshua Pedroza | Zoom Control Panel | info&zoomcp.com | 2014-02-26 |
| Lyndon Ong | LyOng&ciena.com | ||
| Main Street Softworks Inc | info&mainstreetsoftworks.com | 2013-04-02 | |
| Mihai Popa | mihai.popa&4bridgeworks.com | 2026-09-11 | |
| Milton Sagen | msagen&extensis.com | ||
| Nagios Enterprises, LLC | techteam&nagios.com | 2017-09-06 | |
| SmarDTV | vincent.demortier&smardtv.com | 2015-03-04 | |
| Ted Schroeder | Vidder, Inc. | ted&vidder.com | 2011-10-24 |
| Vidder, Inc. | ted&vidder.com | 2011-10-24 | |
| Vincent Demortier | SmarDTV | vincent.demortier&smardtv.com | 2015-03-04 |
| Zoom Control Panel | ianaport&zoomcp.com | 2014-02-26 | |
| ddt&idcube.idsoftware.com |