Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www-http 80 tcp World Wide Web HTTP Tim Berners-Lee Tim Berners-Lee This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
www-http 80 udp World Wide Web HTTP Tim Berners-Lee Tim Berners-Lee This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
http 80 sctp HTTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path to document>
ris 180 tcp Intergraph Dave Buehmann Dave Buehmann
ris 180 udp Intergraph Dave Buehmann Dave Buehmann
http-mgmt 280 tcp http-mgmt Adrian Pell Adrian Pell
http-mgmt 280 udp http-mgmt Adrian Pell Adrian Pell
is99s 380 tcp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
is99s 380 udp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
iafdbase 480 tcp iafdbase Rick Yazwinski Rick Yazwinski
iafdbase 480 udp iafdbase Rick Yazwinski Rick Yazwinski
sntp-heartbeat 580 tcp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
sntp-heartbeat 580 udp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
http-alt 591 tcp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
http-alt 591 udp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
ipp 631 tcp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipp 631 udp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipps 631 tcp Internet Printing Protocol over HTTPS IESG IETF Chair 2018-07-06 RFC 8011
entrust-aaas 680 tcp entrust-aaas
entrust-aaas 680 udp entrust-aaas
wpgs 780 tcp Josyula R. Rao Josyula R. Rao
wpgs 780 udp Josyula R. Rao Josyula R. Rao
mdbs-daemon 800 tcp IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 tcp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
mdbs-daemon 800 udp IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 udp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
device 801 tcp
device 801 udp
mbap-s 802 tcp Modbus Application Protocol Secure modbus.org Dennis Dube 2014-06-10
mbap-s 802 udp Modbus Application Protocol Secure modbus.org Dennis Dube 2014-06-10
803-809 Unassigned
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
webpush 1001 tcp HTTP Web Push IESG IETF Chair 2016-11-01 RFC 8030
socks 1080 tcp Socks Ying-Da Lee Ying-Da Lee
socks 1080 udp Socks Ying-Da Lee Ying-Da Lee
mc-client 1180 tcp Millicent Client Proxy Steve Glassman Steve Glassman
mc-client 1180 udp Millicent Client Proxy Steve Glassman Steve Glassman
pictrography 1280 tcp Pictrography Takashi Hoshino Takashi Hoshino
pictrography 1280 udp Pictrography Takashi Hoshino Takashi Hoshino
telesis-licman 1380 tcp Telesis Network License Manager Karl Schendel, Jr. Karl Schendel, Jr.
telesis-licman 1380 udp Telesis Network License Manager Karl Schendel, Jr. Karl Schendel, Jr.
pacerforum 1480 tcp PacerForum Peter Caswell Peter Caswell
pacerforum 1480 udp PacerForum Peter Caswell Peter Caswell
tn-tl-r1 1580 tcp tn-tl-r1
tn-tl-r2 1580 udp tn-tl-r2 Ed Kress Ed Kress
microcom-sbp 1680 tcp microcom-sbp Boris B. Maiden Boris B. Maiden
microcom-sbp 1680 udp microcom-sbp Boris B. Maiden Boris B. Maiden
dpkeyserv 1780 tcp dpkeyserv Yasunari Gon Yamasita Yasunari Gon Yamasita
dpkeyserv 1780 udp dpkeyserv Yasunari Gon Yamasita Yasunari Gon Yamasita
ansys-lm 1800 tcp ANSYS-License manager Suzanne Lorrin Suzanne Lorrin
ansys-lm 1800 udp ANSYS-License manager Suzanne Lorrin Suzanne Lorrin
msmq 1801 tcp Microsoft Message Que Amnon Horowitz Amnon Horowitz
msmq 1801 udp Microsoft Message Que Amnon Horowitz Amnon Horowitz
concomp1 1802 tcp ConComp1 Ed Vincent Ed Vincent
concomp1 1802 udp ConComp1 Ed Vincent Ed Vincent
hp-hcip-gwy 1803 tcp HP-HCIP-GWY Allen Baker Allen Baker
hp-hcip-gwy 1803 udp HP-HCIP-GWY Allen Baker Allen Baker
enl 1804 tcp ENL Brian Olson Brian Olson
enl 1804 udp ENL Brian Olson Brian Olson
enl-name 1805 tcp ENL-Name Brian Olson Brian Olson
enl-name 1805 udp ENL-Name Brian Olson Brian Olson
musiconline 1806 tcp Musiconline Craig Weeks Craig Weeks
musiconline 1806 udp Musiconline Craig Weeks Craig Weeks
fhsp 1807 tcp Fujitsu Hot Standby Protocol Eiki Iwata Eiki Iwata
fhsp 1807 udp Fujitsu Hot Standby Protocol Eiki Iwata Eiki Iwata
oracle-vp2 1808 tcp Oracle-VP2 Craig Fowler Craig Fowler
oracle-vp2 1808 udp Oracle-VP2 Craig Fowler Craig Fowler
oracle-vp1 1809 tcp Oracle-VP1 Craig Fowler Craig Fowler
oracle-vp1 1809 udp Oracle-VP1 Craig Fowler Craig Fowler
vsat-control 1880 tcp Gilat VSAT Control Yariv Kaplan Yariv Kaplan
vsat-control 1880 udp Gilat VSAT Control Yariv Kaplan Yariv Kaplan
panquest-xact 1980 tcp PanQuest XACT Chris Vertonghen Chris Vertonghen 2025-11-20
panquest-xact 1980 udp PanQuest XACT Chris Vertonghen Chris Vertonghen 2025-11-20
autodesk-nlm 2080 tcp Autodesk NLM (FLEXlm) Greg Suppes Greg Suppes
autodesk-nlm 2080 udp Autodesk NLM (FLEXlm) Greg Suppes Greg Suppes
mc-gt-srv 2180 tcp Millicent Vendor Gateway Server Steve Glassman Steve Glassman
mc-gt-srv 2180 udp Millicent Vendor Gateway Server Steve Glassman Steve Glassman
lnvpoller 2280 tcp LNVPOLLER
lnvpoller 2280 udp LNVPOLLER
etcd-server 2380 tcp etcd server to server communication CoreOS Brian Harrington 2014-07-09
2380 udp Reserved
powerexchange 2480 tcp Informatica PowerExchange Listener Informatica Philip Line 2023-03-13
powerexchange 2480 udp Informatica PowerExchange Listener Informatica Philip Line 2023-03-13
tributary 2580 tcp Tributary Louis Lu Louis Lu
tributary 2580 udp Tributary Louis Lu Louis Lu
pxc-sapxom 2680 tcp pxc-sapxom Hideki Kiriyama Hideki Kiriyama
pxc-sapxom 2680 udp pxc-sapxom Hideki Kiriyama Hideki Kiriyama
lbc-control 2780 tcp LBC Control Keiji Michine Keiji Michine
lbc-control 2780 udp LBC Control Keiji Michine Keiji Michine
acc-raid 2800 tcp ACC RAID Scott St. Clair Scott St. Clair
acc-raid 2800 udp ACC RAID Scott St. Clair Scott St. Clair
igcp 2801 tcp IGCP David Hampson David Hampson
igcp 2801 udp IGCP David Hampson David Hampson
veritas-tcp1 2802 tcp Veritas TCP1
veritas-udp1 2802 udp Veritas UDP1 Russ Thrasher Russ Thrasher
btprjctrl 2803 tcp btprjctrl Huw Thomas Huw Thomas

Contact Information

Name Organization Contact URI Last Updated
Adrian Pell PELL_ADRIAN/HP-UnitedKingdom_om6@hplb.hpl.hp.com
Allen Baker abaker&boi.hp.com
Amnon Horowitz amnonh&microsoft.com
Boris B. Maiden Boris_Maiden&smtp.microcom.com
Brian Harrington CoreOS brian.harrington&coreos.com 2014-07-09
Brian Olson briolson&pacbell.net
Chris Vertonghen chris&panquest.com 2025-11-20
Clay Maeckel clay&claris.com 2023-09-12
CoreOS brian.harrington&coreos.com 2014-07-09
Craig Fowler cfowler&us.oracle.com
Craig Weeks cweeks&syspace.co.uk
Dave Buehmann ingr!daveb&uunet.uu.net
David Hampson davidha&codemasters.com
Dennis Dube dennis.dube&schneider-electric.com 2014-06-10
Ed Kress eskress&thinknet.com
Ed Vincent edv&concomp.com
Eiki Iwata eiki&nd.net.fujitsu.co.jp
Frank Quick fquick&qualcomm.com
Greg Suppes greg.suppes&autodesk.com
Hideki Kiriyama kiriyama&cp10.es.xerox.com
Huw Thomas huw.thomas&bt.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Informatica DLEnterpriseSupport&informatica.com 2023-03-13
Josyula R. Rao jrrao&watson.ibm.com
Karl Schendel, Jr. wiz&telesis.com
Keiji Michine michine&net.paso.fujitsu.co.jp
Louis Lu LouisL&bristol.com
Louis Mamakos louie&uu.net
modbus.org rbelliardi&modbus.org 2014-06-10
Peter Caswell pfc&pacvax.pacersoft.com
Philip Line Informatica pline&informatica.com 2023-03-13
Randall Stewart IETF TSVWG rrs&lakerest.net
Rick Yazwinski ricky&solect.com
Russ Thrasher Russell.Thrasher&veritas.com
Scott St. Clair stclair&ntc.adaptec.com
Steve Glassman steveg&pa.dec.com
Suzanne Lorrin sml&ansyspo.ansys.com
Takashi Hoshino hoshino&miya.fujifilm.co.jp
Tim Berners-Lee timbl&w3.org
Yariv Kaplan yarivk&gilat.com
Yasunari Gon Yamasita yamasita&omronsoft.co.jp
Ying-Da Lee ylee&syl.dl.nec.com