Address Family Numbers
- RFC 2453: RIP Version 2
- RFC 2677: Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP)
- RFC 2858: Multiprotocol Extensions for BGP-4
Registrations also appear in ianaaddressfamilynumbers-mib.
When this registry is modified, the YANG module iana-routing-types
must be updated as defined in RFC 8294.
| Range |
Registration Procedures |
| 1-16383 |
Standards Action |
| 16384-32767 |
First Come First Served |
| Number |
Description |
Reference |
Registration Date |
| 0 |
Reserved |
|
|
| 1 |
IP (IP version 4) |
|
|
| 2 |
IP6 (IP version 6) |
|
|
| 3 |
NSAP |
|
|
| 4 |
HDLC (8-bit multidrop) |
|
|
| 5 |
BBN 1822 |
|
|
| 6 |
802 (includes all 802 media plus Ethernet "canonical format") |
|
|
| 7 |
E.163 |
|
|
| 8 |
E.164 (SMDS, Frame Relay, ATM) |
|
|
| 9 |
F.69 (Telex) |
|
|
| 10 |
X.121 (X.25, Frame Relay) |
|
|
| 11 |
IPX |
|
|
| 12 |
Appletalk |
|
|
| 13 |
Decnet IV |
|
|
| 14 |
Banyan Vines |
|
|
| 15 |
E.164 with NSAP format subaddress |
ATM Forum UNI 3.1. October 1995.; Andy Malis |
|
| 16 |
DNS (Domain Name System) |
|
|
| 17 |
Distinguished Name |
Charles Lynn |
|
| 18 |
AS Number |
Charles Lynn |
|
| 19 |
XTP over IP version 4 |
Mike Saul |
|
| 20 |
XTP over IP version 6 |
Mike Saul |
|
| 21 |
XTP native mode XTP |
Mike Saul |
|
| 22 |
Fibre Channel World-Wide Port Name |
Mark Bakke |
|
| 23 |
Fibre Channel World-Wide Node Name |
Mark Bakke |
|
| 24 |
GWID |
Subra Hegde |
|
| 25 |
AFI for L2VPN information |
RFC 4761; RFC 6074 |
|
| 26 |
MPLS-TP Section Endpoint Identifier |
RFC 7212 |
|
| 27 |
MPLS-TP LSP Endpoint Identifier |
RFC 7212 |
|
| 28 |
MPLS-TP Pseudowire Endpoint Identifier |
RFC 7212 |
|
| 29 |
MT IP: Multi-Topology IP version 4 |
RFC 7307 |
|
| 30 |
MT IPv6: Multi-Topology IP version 6 |
RFC 7307 |
|
| 31 |
BGP SFC |
RFC 9015 |
|
| 32-16383 |
Unassigned |
|
|
| 16384 |
EIGRP Common Service Family |
Donnie Savage |
2008-05-13 |
| 16385 |
EIGRP IPv4 Service Family |
Donnie Savage |
2008-05-13 |
| 16386 |
EIGRP IPv6 Service Family |
Donnie Savage |
2008-05-13 |
| 16387 |
LISP Canonical Address Format (LCAF) |
David Meyer |
2009-11-12 |
| 16388 |
BGP-LS |
RFC 9552 |
2013-03-20 |
| 16389 |
48-bit MAC |
RFC 7042 |
2013-05-06 |
| 16390 |
64-bit MAC |
RFC 7042 |
2013-05-06 |
| 16391 |
OUI |
RFC 7961 |
2013-09-25 |
| 16392 |
MAC/24 |
RFC 7961 |
2013-09-25 |
| 16393 |
MAC/40 |
RFC 7961 |
2013-09-25 |
| 16394 |
IPv6/64 |
RFC 7961 |
2013-09-25 |
| 16395 |
RBridge Port ID |
RFC 7961 |
2013-09-25 |
| 16396 |
TRILL Nickname |
RFC 7455 |
2014-09-02 |
| 16397 |
Universally Unique Identifier (UUID) |
Nischal Sheth |
2019-11-04 |
| 16398 |
Routing Policy AFI |
draft-ietf-idr-rpd-02 |
2020-05-12 |
| 16399 |
MPLS Namespaces |
draft-kaliraj-bess-bgp-sig-private-mpls-labels-03 |
2021-10-19 |
| 16400-65534 |
Unassigned |
|
|
| 65535 |
Reserved |
|
|
Contact Information