Border Gateway Protocol - Link State (BGP-LS) Parameters

Created

  • 2015-11-03

Last Updated

  • 2026-10-12

Available Formats


BGP-LS NLRI Types

Expert(s)

  • Hannes Gredler (primary), Adrian Farrel (secondary)

Reference

  • RFC 9552: Distribution of Link-State and Traffic Engineering Information Using BGP

Available Formats

Range Registration Procedures
1-64999 Expert Review
65000-65535 Private Use
Type NLRI Type Reference
0 Reserved RFC 9552
1 Node NLRI RFC 9552
2 Link NLRI RFC 9552
3 IPv4 Topology Prefix NLRI RFC 9552
4 IPv6 Topology Prefix NLRI RFC 9552
5 SR Policy Candidate Path NLRI RFC 9857
6 SRv6 SID NLRI RFC 9514
7 Inter-AS Link NLRI RFC-ietf-idr-bgpls-inter-as-topology-ext-46
8-1100 Unassigned
1101 Not to be allocated
1102-64999 Unassigned
65000-65535 Private Use RFC 9552

BGP-LS Protocol-IDs

Expert(s)

  • Hannes Gredler (primary), Adrian Farrel (secondary)

Reference

  • RFC 9552: Distribution of Link-State and Traffic Engineering Information Using BGP

Available Formats

Range Registration Procedures
1-199 Expert Review
200-255 Private Use
Protocol-ID NLRI information source protocol Reference
0 Reserved RFC 9552
1 IS-IS Level 1 RFC 9552
2 IS-IS Level 2 RFC 9552
3 OSPFv2 RFC 9552
4 Direct RFC 9552
5 Static configuration RFC 9552
6 OSPFv3 RFC 9552
7 BGP RFC 9086
8 RSVP-TE draft-ietf-idr-bgp-ls-te-path-01
9 Segment Routing RFC 9857
10-199 Unassigned
200-255 Private Use RFC 9552

BGP-LS Well-Known Instance-IDs (OBSOLETE)

Registration Procedure(s)

  • Registry closed

Reference

  • RFC 9552: Distribution of Link-State and Traffic Engineering Information Using BGP

Available Formats

Identifier Routing Universe Reference
0 Default Layer 3 Routing topology RFC 9552
1-31 Unassigned
32 - 2^64-1 Private use - not recorded RFC 9552


SRv6 BGP EPE SID Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9514: Border Gateway Protocol - Link State (BGP-LS) Extensions for Segment Routing over IPv6 (SRv6)

Available Formats

Bit Description Reference
0 Backup Flag (B-Flag) RFC 9514
1 Set Flag (S-Flag) RFC 9514
2 Persistent Flag (P-Flag) RFC 9514
3-7 Unassigned

BGP-LS Node Flags

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Adrian Farrel, Hannes Gredler

Reference

  • RFC 9552: Distribution of Link-State and Traffic Engineering Information Using BGP

Available Formats

Bit Description Reference
0 Overload Bit (O-bit) RFC 9552
1 Attached Bit (A-bit) RFC 9552
2 External Bit (E-bit) RFC 9552
3 ABR Bit (B-bit) RFC 9552
4 Router Bit (R-bit) RFC 9552
5 V6 Bit (V-bit) RFC 9552
6-7 Unassigned

BGP-LS MPLS Protocol Mask

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Adrian Farrel, Hannes Gredler

Reference

  • RFC 9552: Distribution of Link-State and Traffic Engineering Information Using BGP

Available Formats

Bit Description Reference
0 Label Distribution Protocol (L-bit) RFC 9552
1 Extension to RSVP for LSP Tunnels (R-bit) RFC 9552
2-7 Unassigned

BGP-LS IGP Prefix Flags

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Adrian Farrel, Hannes Gredler

Reference

  • RFC 9552: Distribution of Link-State and Traffic Engineering Information Using BGP

Available Formats

Bit Description Reference
0 IS-IS Up/Down Bit (D-bit) RFC 9552
1 OSPF "no unicast" Bit (N-bit) RFC 9552
2 OSPF "local address" Bit (L-bit) RFC 9552
3 OSPF "propagate NSSA" Bit (P-bit) RFC 9552
4-7 Unassigned

BGP-LS SR Segment Descriptor Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Matthew Bocci, Zafar Ali

Reference

  • RFC 9857: Advertisement of Segment Routing Policies Using BGP - Link State

Available Formats

Code Point Segment Descriptor Reference Change Controller
0 Reserved RFC 9857 IETF
1 Type A Segment RFC 9857 IETF
2 Type B Segment RFC 9857 IETF
3 Type C Segment RFC 9857 IETF
4 Type D Segment RFC 9857 IETF
5 Type E Segment RFC 9857 IETF
6 Type F Segment RFC 9857 IETF
7 Type G Segment RFC 9857 IETF
8 Type H Segment RFC 9857 IETF
9 Type I Segment RFC 9857 IETF
10 Type J Segment RFC 9857 IETF
11 Type K Segment RFC 9857 IETF
12-255 Unassigned

BGP-LS SR Policy Metric Types

Registration Procedure(s)

  • Expert Review

Expert(s)

  • Stephane Litkowski, Jie Dong

Reference

  • RFC 9857: Advertisement of Segment Routing Policies Using BGP - Link State

Available Formats

Code Point Metric Type Reference Change Controller
0 IGP RFC 9857 IETF
1 Min Unidirectional Delay RFC 9857 IETF
2 TE RFC 9857 IETF
3 Hop Count RFC 9857 IETF
4 SID List Length RFC 9857 IETF
5 Bandwidth RFC 9857 IETF
6 Avg Unidirectional Delay RFC 9857 IETF
7 Unidirectional Delay Variation RFC 9857 IETF
8 Loss RFC 9857 IETF
9-127 Unassigned
128-255 User Defined RFC 9857 IETF