Border Gateway Protocol (BGP) Tunnel Encapsulation

Last Updated

  • 2026-09-03

Available Formats


BGP Tunnel Encapsulation Attribute Tunnel Types

Registration Procedure(s)

  • First Come First Served

Reference

  • RFC 9012: The BGP Tunnel Encapsulation Attribute

Available Formats

Value Description Reference Change Controller
0 Reserved RFC 9012
1 L2TPv3 over IP RFC 9012 IETF
2 GRE RFC 9012 IETF
3 Transmit tunnel endpoint (DEPRECATED) RFC 9012 IETF
4 IPsec in Tunnel-mode (DEPRECATED) RFC 9012 IETF
5 IP in IP tunnel with IPsec Transport Mode (DEPRECATED) RFC 9012 IETF
6 MPLS-in-IP tunnel with IPsec Transport Mode (DEPRECATED) RFC 9012 IETF
7 IP in IP RFC 9012 IETF
8 VXLAN Encapsulation RFC 8365 IETF
9 NVGRE Encapsulation RFC 8365 IETF
10 MPLS Encapsulation RFC 8365 IETF
11 MPLS in GRE Encapsulation RFC 8365 IETF
12 VXLAN GPE Encapsulation RFC 8365 IETF
13 MPLS in UDP Encapsulation RFC 7510; RFC Errata 4350 IETF
14 IPv6 Tunnel Martin Djernaes
15 SR Policy RFC 9830 IETF
16 Bare Nischal Sheth
17 SR Tunnel (DEPRECATED) RFC 9125 IETF
18 Cloud Security Ramesh Babu Yakkala
19 Geneve Encapsulation RFC 8926 IETF
20 Any-Encapsulation draft-ietf-bess-bgp-multicast-controller-06
21 GTP Tunnel Type Keyur Patel; Tetsuya Murakami
22 Dynamic Path Selection (DPS) Tunnel Encapsulation Venkit Kasiviswanathan
23 Originating PE (OPE) draft-heitz-bess-evpn-option-b-01
24 Dynamic Path Selection (DPS) Policy https://eos.arista.com/eos-4-26-2f/dps-vpn-scaling-using-bgp; Sarah Chen
25 SDWAN-Hybrid draft-ietf-idr-sdwan-edge-discovery-04
26 X-over-UDP Jeffrey Haas
27 Distributed Etherlink Switch (DES) Tunnel Encapsulation David Cronin Arista Networks
28 ESP-Protected-Payload draft-wdh-srv6ops-secservice-00
29-65535 Unassigned

BGP Tunnel Encapsulation Attribute Sub-TLVs

Reference

  • RFC 9012: The BGP Tunnel Encapsulation Attribute

Note

If the Sub-TLV Type is in the range from 0 to 127 (inclusive), the Sub-TLV Length field contains one octet. If the Sub-TLV Type is in the range from 128 to 255 (inclusive), the Sub-TLV Length field contains two octets.

Available Formats

Range Registration Procedures
1-63 Standards Action
64-125 First Come First Served
126-127 Experimental Use
128-191 Standards Action
192-252 First Come First Served
253-254 Experimental Use
Value Description Reference Change Controller
0 Reserved RFC 9012 IETF
1 Encapsulation RFC 9012 IETF
2 Protocol Type RFC 9012 IETF
3 IPsec Tunnel Authenticator (DEPRECATED) RFC 9012 IETF
4 Color RFC 9012 IETF
5 Load-Balancing Block RFC 5640 IETF
6 Tunnel Egress Endpoint RFC 9012 IETF
7 DS Field RFC 9012 IETF
8 UDP Destination Port RFC 9012 IETF
9 Embedded Label Handling RFC 9012 IETF
10 MPLS Label Stack RFC 9012 IETF
11 Prefix-SID RFC 9012 IETF
12 Preference sub-TLV RFC 9830 IETF
13 Binding SID sub-TLV RFC 9830 IETF
14 ENLP sub-TLV RFC 9830 IETF
15 Priority sub-TLV RFC 9830 IETF
16 SPI/SI Representation Sub-TLV RFC 9015 IETF
17-19 Unassigned
20 SRv6 Binding SID sub-TLV RFC 9830 IETF
21-63 Unassigned
64 IPSEC-SA-ID draft-ietf-idr-sdwan-edge-discovery-04, Section 6.3
65 Extended Port Property draft-ietf-idr-sdwan-edge-discovery-04, Section 6.4
66 Underlay ISP Properties draft-ietf-idr-sdwan-edge-discovery-04, Section 6.5
67 IPsec SA Nonce draft-ietf-idr-sdwan-edge-discovery-04, Section 7.1
68 IPsec Public Key draft-ietf-idr-sdwan-edge-discovery-04, Section 7.2
69 IPsec SA Proposal draft-ietf-idr-sdwan-edge-discovery-04, Section 7.3
70 Simplified IPsec SA draft-ietf-idr-sdwan-edge-discovery-04, Section 7.4
71 IPsec Version Priyesh Vakayil Palakandy
72-122 Unassigned
123 NRP ID RFC-ietf-idr-sr-policy-nrp-13
124 RPF draft-ietf-bess-bgp-multicast-controller-06
125 Tree Label Stack draft-ietf-bess-bgp-multicast-controller-06
126-127 Reserved for Experimental Use RFC 9012 IETF
128 Segment List sub-TLV RFC 9830 IETF
129 SR Policy Candidate Path Name sub-TLV RFC 9830 IETF
130 SR Policy Name sub-TLV RFC 9830 IETF
131 Reverse Segment List sub-TLV (TEMPORARY - registered 2026-07-13, expires 2027-07-13) draft-ietf-idr-sr-policy-path-segment-16 IETF
132-191 Unassigned
192 The WAN ID Sub-TLV Venkit Kasiviswanathan
193 The Bytes Sub-TLV Venkit Kasiviswanathan
194 IPSEC DIM sub-TLV Venkit Kasiviswanathan
195 IPSEC Key Exchange sub-TLV Venkit Kasiviswanathan
196 IPSEC SA Proposals sub-TLV Venkit Kasiviswanathan
197 Service Segment List Hongda Huang
198 Service Vtep Hongda Huang
199 Distributed Etherlink Switch (DES) Adjacency David Cronin Arista Networks
200-252 Unassigned
253-254 Reserved for Experimental Use RFC 9012 IETF
255 Reserved RFC 9012 IETF

Flags Field of VXLAN Encapsulation Sub-TLVs

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9012: The BGP Tunnel Encapsulation Attribute

Available Formats

Bit Position Description Reference
0 V (VN-ID) RFC 9012
1 M (MAC Address) RFC 9012
2-7 Unassigned

Flags Field of NVGRE Encapsulation Sub-TLVs

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9012: The BGP Tunnel Encapsulation Attribute

Available Formats

Bit Position Description Reference
0 V (VN-ID) RFC 9012
1 M (MAC Address) RFC 9012
2-7 Unassigned

Embedded Label Handling Sub-TLVs

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9012: The BGP Tunnel Encapsulation Attribute

Available Formats

Value Description Reference
0 Reserved RFC 9012
1 Payload of MPLS with embedded label RFC 9012
2 No embedded label in payload RFC 9012
3-255 Unassigned

Color Extended Community Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9012: The BGP Tunnel Encapsulation Attribute

Available Formats

Bit Position Description Reference
0-1 Color-only Types Field RFC 9830
2-15 Unassigned

SR Policy Segment List Sub-TLVs

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9830: Advertising Segment Routing Policies in BGP

Available Formats

Value Description Reference
0 Reserved RFC 9830
1 Type A Segment sub-TLV RFC 9830
2 Deprecated RFC 9830
3 Type C Segment sub-TLV RFC 9831
4 Type D Segment sub-TLV RFC 9831
5 Type E Segment sub-TLV RFC 9831
6 Type F Segment sub-TLV RFC 9831
7 Type G Segment sub-TLV RFC 9831
8 Type H Segment sub-TLV RFC 9831
9 Weight sub-TLV RFC 9830
10 Deprecated RFC 9830
11 Deprecated RFC 9830
12 Deprecated RFC 9830
13 Type B Segment sub-TLV RFC 9830
14 Type I Segment sub-TLV RFC 9831
15 Type J Segment sub-TLV RFC 9831
16 Type K Segment sub-TLV RFC 9831
17 ELP (TEMPORARY - registered 2026-01-06, expires 2026-01-06) draft-ietf-idr-bgp-sr-mpls-elp-00
18 Path MTU sub-TLV (TEMPORARY - registered 2026-06-08, expires 2027-06-08) draft-ietf-idr-sr-policy-path-mtu-14
19 Segment List ID sub-TLV RFC-ietf-idr-sr-policy-seglist-id-14
20 Segment Type L sub-TLV (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05
21 Segment Type M sub-TLV (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05
22 Segment Type N sub-TLV (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05
23 Segment Type O sub-TLV (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-te-policy-attr-05
24 Path Segment sub-TLV (TEMPORARY - registered 2026-07-13, expires 2027-07-13) draft-ietf-idr-sr-policy-path-segment-16
25-220 Unassigned
221 Metric (TEMPORARY - registered 2026-07-02, expires 2027-07-02) draft-ietf-idr-sr-policy-metric-05
222-255 Unassigned

SR Policy Binding SID Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9830: Advertising Segment Routing Policies in BGP

Available Formats

Bit Description Reference
0 Specified-BSID-Only Flag (S-Flag) RFC 9830
1 Drop-Upon-Invalid Flag (I-Flag) RFC 9830
2-7 Unassigned

SR Policy SRv6 Binding SID Flags

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9830: Advertising Segment Routing Policies in BGP

Available Formats

Bit Description Reference
0 Specified-BSID-Only Flag (S-Flag) RFC 9830
1 Drop-Upon-Invalid Flag (I-Flag) RFC 9830
2 SRv6 Endpoint Behavior & SID Structure Flag (B-Flag) RFC 9830
3-7 Unassigned

SR Policy Segment Flags

Registration Procedure(s)

  • IETF Review

Reference

  • RFC 9830: Advertising Segment Routing Policies in BGP

Available Formats

Bit Description Reference
0 Segment Verification Flag (V-Flag) RFC 9830
1 SR Algorithm Flag (A-Flag) RFC 9831
2 SID Specified Flag (S-Flag) RFC 9831
3 SRv6 Endpoint Behavior & SID Structure Flag (B-Flag) RFC 9830
4-7 Unassigned

Color Extended Community Color-Only Types

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9830: Advertising Segment Routing Policies in BGP

Available Formats

Type Description Reference
0 Specific Endpoint Match RFC 9830
1 Specific or Null Endpoint Match RFC 9830
2 Specific, Null, or Any Endpoint Match RFC 9830
3 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Arista Networks dsf-dev&arista.com 2024-06-13
David Cronin Arista Networks davidcronin&arista.com 2024-06-12
Hongda Huang hongda&arista.com 2023-07-19
Jeffrey Haas jhaas&juniper.net 2023-03-22
Keyur Patel keyur&arrcus.com 2021-05-14
Martin Djernaes mdjernaes&juniper.net 2016-03-30
Nischal Sheth nsheth&juniper.net 2017-08-16
Priyesh Vakayil Palakandy priyesh&arista.com 2024-10-08
Ramesh Babu Yakkala ryakkala&cisco.com 2020-02-18
Sarah Chen sarahchen&arista.com 2022-02-01
Tetsuya Murakami tetsuya&arrcus.com 2021-05-14
Venkit Kasiviswanathan venkit&arista.com 2021-09-10