BGP Monitoring Protocol (BMP) Parameters

Created

  • 2016-04-14

Last Updated

  • 2026-05-22

Available Formats


BMP Message Types

Expert(s)

  • John G. Scudder, Rex Fernando (rex), Paolo Lucente

Reference

Available Formats

Range Registration Procedures
0-127 Standards Action
128-250 Specification Required
251-254 Experimental Use
Type Description Reference
0 Route Monitoring RFC 7854
1 Statistics Report RFC 7854
2 Peer Down Notification RFC 7854
3 Peer Up Notification RFC 7854
4 Initiation RFC 7854
5 Termination RFC 7854
6 Route Mirroring RFC 7854
7-250 Unassigned
251-254 Experimental RFC 7854
255 Reserved RFC 7854

BMP Peer Types

Expert(s)

  • John G. Scudder, Rex Fernando (rex), Paolo Lucente

Reference

Available Formats

Range Registration Procedures
0-127 Standards Action
128-250 Specification Required
251-254 Experimental Use
Peer Type Description Reference
0 Global Instance Peer RFC 7854
1 RD Instance Peer RFC 7854
2 Local Instance Peer RFC 7854
3 Loc-RIB Instance Peer RFC 9069
4-250 Unassigned
251-254 Experimental RFC 7854
255 Reserved RFC 7854

BMP Peer Flags for Peer Types 0 through 2

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 7854: BGP Monitoring Protocol (BMP)
  • RFC 9069: Support for Local RIB in the BGP Monitoring Protocol (BMP)

Available Formats

Flag Description Reference
0 V flag RFC 7854
1 L flag RFC 7854; RFC Errata 7703
2 A flag RFC 7854
3 O flag RFC 8671
4 F flag (DEPRECATED) RFC 9069
5-7 Unassigned

BMP Peer Flags for Loc-RIB Instance Peer Type 3

Registration Procedure(s)

  • Standards Action

Reference

  • RFC 9069: Support for Local RIB in the BGP Monitoring Protocol (BMP)

Available Formats

Flag Description Reference
0 F flag RFC 9069
1-7 Unassigned

BMP Statistics Types

Reference

  • RFC 7854: BGP Monitoring Protocol (BMP)
  • RFC 9515: Revision to Registration Procedures for Multiple BMP Registries

Available Formats

Range Registration Procedures
0-32767 Standards Action
32768-65530 First Come First Served
65531-65534 Experimental Use
Stat Type Description Reference
0 Number of prefixes rejected by inbound policy RFC 7854
1 Number of (known) duplicate prefix advertisements RFC 7854
2 Number of (known) duplicate withdraws RFC 7854
3 Number of updates invalidated due to CLUSTER_LIST loop RFC 7854
4 Number of updates invalidated due to AS_PATH loop RFC 7854
5 Number of updates invalidated due to ORIGINATOR_ID RFC 7854
6 Number of updates invalidated due to a loop found in AS_CONFED_SEQUENCE or AS_CONFED_SET RFC 7854
7 Number of routes in Adj-RIBs-In RFC 7854
8 Number of routes in Loc-RIB RFC 7854
9 Number of routes in per-AFI/SAFI Adj-RIB-In RFC 7854
10 Number of routes in per-AFI/SAFI Loc-RIB RFC 7854
11 Number of updates subjected to treat-as-withdraw RFC 7854
12 Number of prefixes subjected to treat-as-withdraw RFC 7854
13 Number of duplicate update messages received RFC 7854
14 Number of routes in pre-policy Adj-RIB-Out RFC 8671
15 Number of routes in post-policy Adj-RIB-Outy RFC 8671
16 Number of routes in per-AFI/SAFI pre-policy Adj-RIB-Out RFC 8671
17 Number of routes in per-AFI/SAFI post-policy Adj-RIB-Out RFC 8671
18 Number of routes currently in the pre-policy Adj-RIB-In. RFC 9972
19 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-In. RFC 9972
20 Number of routes currently in the post-policy Adj-RIB-In. RFC 9972
21 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In. RFC 9972
22 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-In rejected by an inbound policy. RFC 9972
23 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In accepted by an inbound policy. RFC 9972
24 Number of routes currently in per-AFI/SAFI selected as primary route. (TEMPORARY - registered 2024-10-18, extension registered 2025-09-23, expires 2026-10-18) draft-ietf-grow-bmp-bgp-rib-stats-16
25 Number of routes currently in per-AFI/SAFI selected as a backup route. (TEMPORARY - registered 2024-10-18, extension registered 2025-09-23, expires 2026-10-18) draft-ietf-grow-bmp-bgp-rib-stats-16
26 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB suppressed by a configured route-damping policy. RFC 9972
27 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB marked as stale by GR events. RFC 9972
28 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB marked as stale by LLGR. RFC 9972
29 Number of routes currently in the post-policy Adj-RIB-In left before exceeding the received-route threshold. RFC 9972
30 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In left before exceeding the received-route threshold. RFC 9972
31 Number of routes currently in the post-policy Adj-RIB-In or Loc-RIB left before exceeding a license-customized route threshold. RFC 9972
32 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In or Loc-RIB left before exceeding a license-customized route threshold. RFC 9972
33 Number of routes currently in the pre-policy Adj-RIB-In rejected due to exceeding the locally configured maximum AS_PATH length. RFC 9972
34 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-In rejected due to exceeding the locally configured maximum AS_PATH length. RFC 9972
35 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In invalidated after verifying the route origin ASN through the ROA of the RPKI and mismatch of prefix length. RFC 9972
36 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In validated after verifying the route origin ASN through the ROA of the RPKI. RFC 9972
37 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-In whose RPKI route origin validation state is NotFound. RFC 9972
38 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-Out rejected by an outbound policy. RFC 9972
39 Number of routes currently in the pre-policy Adj-RIB-Out filtered due to AS_PATH length exceeding the locally configured maximum. RFC 9972
40 Number of routes currently in the per-AFI/SAFI pre-policy Adj-RIB-Out filtered due to AS_PATH length exceeding the locally configured maximum. RFC 9972
41 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-Out invalidated after verifying the route origin ASN through the ROA of the RPKI and mismatch of prefix length. RFC 9972
42 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-Out validated after verifying the route origin ASN through the ROA of the RPKI. RFC 9972
43 Number of routes currently in the per-AFI/SAFI post-policy Adj-RIB-Out whose RPKI route origin validation state is NotFound. RFC 9972
44-65530 Unassigned
65531-65534 Experimental RFC 7854
65535 Reserved RFC 7854

BMP Initiation Information TLVs

Reference

  • RFC 7854: BGP Monitoring Protocol (BMP)
  • RFC 9069: Support for Local RIB in the BGP Monitoring Protocol (BMP)
  • RFC 9515: Revision to Registration Procedures for Multiple BMP Registries
  • RFC 9736: The BGP Monitoring Protocol (BMP) Peer Up Message Namespace

Available Formats

Range Registration Procedures
0-32767 Standards Action
32768-65530 First Come First Served
65531-65534 Experimental Use
Type Description Reference
0 String RFC 9736
1 sysDescr RFC 9736
2 sysName RFC 9736
3 Reserved RFC 9736
4 Reserved RFC 9736
5-65530 Unassigned
65531-65534 Experimental RFC 7854
65535 Reserved RFC 9736

BMP Termination Message TLVs

Reference

  • RFC 7854: BGP Monitoring Protocol (BMP)
  • RFC 9515: Revision to Registration Procedures for Multiple BMP Registries

Available Formats

Range Registration Procedures
0-32767 Standards Action
32768-65530 First Come First Served
65531-65534 Experimental Use
Type Description Reference
0 String RFC 7854
1 Reason RFC 7854
2-65530 Unassigned
65531-65534 Experimental RFC 7854
65535 Reserved RFC 7854

BMP Termination Message Reason Codes

Reference

  • RFC 7854: BGP Monitoring Protocol (BMP)
  • RFC 9515: Revision to Registration Procedures for Multiple BMP Registries

Available Formats

Range Registration Procedures
0-32767 Standards Action
32768-65530 First Come First Served
65531-65534 Experimental Use
Type Description Reference
0 Administratively closed RFC 7854
1 Unspecified reason RFC 7854
2 Out of resources RFC 7854
3 Redundant connection RFC 7854
4 Permanently administratively closed RFC 7854
5-65530 Unassigned
65531-65534 Experimental RFC 7854
65535 Reserved RFC 7854

BMP Peer Down Reason Codes

Expert(s)

  • John G. Scudder, Rex Fernando (rex), Paolo Lucente

Reference

Available Formats

Range Registration Procedures
0-127 Standards Action
128-250 Specification Required
251-254 Experimental Use
Type Description Reference
0 Reserved RFC 7854
1 Local system closed, NOTIFICATION PDU follows RFC 7854
2 Local system closed, FSM Event follows RFC 7854
3 Remote system closed, NOTIFICATION PDU follows RFC 7854
4 Remote system closed, no data RFC 7854
5 Peer de-configured RFC 7854
6 Local system closed, TLV data follows RFC 9069
7-250 Unassigned
251-254 Experimental RFC 7854; RFC Errata 7194
255 Reserved RFC 7854; RFC Errata 7194

BMP Route Mirroring TLVs

Reference

  • RFC 7854: BGP Monitoring Protocol (BMP)
  • RFC 9515: Revision to Registration Procedures for Multiple BMP Registries

Available Formats

Range Registration Procedures
0-32767 Standards Action
32768-65530 First Come First Served
65531-65534 Experimental Use
Type Description Reference
0 BGP Message RFC 7854
1 Information RFC 7854
2-65530 Unassigned
65531-65534 Experimental RFC 7854
65535 Reserved RFC 7854

BMP Route Mirroring Information Codes

Reference

  • RFC 7854: BGP Monitoring Protocol (BMP)
  • RFC 9515: Revision to Registration Procedures for Multiple BMP Registries

Available Formats

Range Registration Procedures
0-32767 Standards Action
32768-65530 First Come First Served
65531-65534 Experimental Use
Type Description Reference
0 Errored PDU RFC 7854
1 Messages Lost RFC 7854
2-65530 Unassigned
65531-65534 Experimental RFC 7854
65535 Reserved RFC 7854

BMP Peer Up Message TLVs

Reference

  • RFC 9736: The BGP Monitoring Protocol (BMP) Peer Up Message Namespace

Available Formats

Range Registration Procedures
0, 3-32767 Standards Action
32768-65530 First Come First Served
65531-65534 Experimental Use
Type Description Reference
0 String RFC 9736
1 Reserved RFC 9736
2 Reserved RFC 9736
3 VRF/Table Name RFC 9736
4 Admin Label RFC 9736
5-65530 Unassigned
65531-65534 Experimental RFC 9736
65535 Reserved RFC 9736